No puedo instalar un archivo tar.gz con las fórmulas tradicionales.

Imagen de oniro
0 puntos

Hola, me he bajado el rpm package management, sudo tar rpm-5.1.9.tar.gz, pero al applicar la fórmula de instalación de archivos tar.gz

sudo tar -zxvf archivo.tar.gz

sudo tar -zxvf rpm-5.1.9.tar.gz

me dice que no existe.

He ido con el terminal hacia la carpeta descomprimida y he ejecutado ./configure, y después de mucho cheking no me deja hacer make, dice que no hay regla para construir el objeto install.

He intentado ejecutar un archivo llamado install.sh, pero dice que no se puede instalar.

¿Qué se puede hacer?

Gracias.

Imagen de CHuLoYo
+1
0
-1

rpm package management?
Sabes que ubuntu está basada en debian?

Si te dice que no existe, es que no estás poniendo su ruta. Entra al directorio con el comando cd

---------
Marcos Pérez
Grupo de aprendizaje de programación

+1
0
-1
Imagen de oniro
+1
0
-1

Lo sé, pero en la página de descarga decía que valía para otras distribuciones.

Entré en el directorio bien, cd Escritorio/rpf/rpm-5.1.9, ejecuté el ./configure, hizo muchísimo cheking con los archivos, pero dijo que no se podía crear el objeto de instalación.

*rpf es la carpeta que yo he inventado en el escritorio donde para meter el archivo tar.gz con forma de caja y lo he descomprimido ahí.

+1
0
-1
Imagen de oniro
+1
0
-1

Ah ya te entiendo, espera.

+1
0
-1
Imagen de oniro
+1
0
-1

No me deja, he hecho

oniro@oniro-team:~$ cd Escritorio/rpf
oniro@oniro-team:~/Escritorio/rpf$ sudo tar -zxvf archivo.tar.gz

y dice que no existe elo fichero o directorio.

+1
0
-1
Imagen de oniro
+1
0
-1

Joer que burra, lo había hecho mal, ahora sí, he hecho dentro de la carpeta

sudo tar -zxvf rpm-5.1.9.tar.gz

y ha hecho una ristra muy grande de archivos rpm, voy a ver si ahora puedo hacer algo.

+1
0
-1
Imagen de oniro
+1
0
-1

Después de esto, me he situado en el terminal en la carpeta al nivel siguiente

cd nombre-del-paquete, o sea cd rpm-5.1.9.

oniro@oniro-team:~/Escritorio/rpf/rpm-5.1.9$

./configure y hace la lectura de archivos otra vez,

make y ahora me dice que no se especificó ningún objeto y no se encontró makefile...

+1
0
-1
Imagen de CHuLoYo
+1
0
-1

pon el comando

ls

en el directorio para ver todo lo que tiene.
puedes hacer

ls | grep makefile

para ver si hay algún fichero con ese nombre.

---------
Marcos Pérez
Grupo de aprendizaje de programación

+1
0
-1
Imagen de jericozorn1
+1
0
-1

Hola a tod@s.

Has mirado, el formato de los archivos que has descomprimido???

A lo mejor te sirve esto de algo:
http://doc.ubuntu-es.org/Alien

Saludos.

+1
0
-1
Imagen de oniro
+1
0
-1

Hay Makefile.am y .in, pero grep makefile ninguno.

+1
0
-1
Imagen de CHuLoYo
+1
0
-1

grep sirve para filtrar:

lspci | grep network

filtra los resultados del comando lspci que contengan "network"

ls -lisa | grep makefile

Muestra el contenido de un directorio con todas las propiedades y permisos filtrando por makefile

---------
Marcos Pérez
Grupo de aprendizaje de programación

+1
0
-1
Imagen de oniro
+1
0
-1

He intentado ejecutar alien en la carpeta, ya que el terminal sacó una lista inmensa de archivos rpm

sudo alien-d-v-c*.rpm

pero dice que el comando no se encuentra.

+1
0
-1
Imagen de oniro
+1
0
-1

He probado a hacer

oniro@oniro-team:~/Escritorio/rpf$ sudo alien -div rpm-5.1.9.tar.gz
ls -l rpm-5.1.9.tar.gz
tar Oxf rpm-5.1.9.tar.gz install/predoinst.sh 2>/dev/null
tar Oxf rpm-5.1.9.tar.gz install/delete.sh 2>/dev/null
tar Oxf rpm-5.1.9.tar.gz install/doinst.sh 2>/dev/null
tar Oxf rpm-5.1.9.tar.gz install/predelete.sh 2>/dev/null
mkdir rpm-5.1.9
mkdir: no se puede crear el directorio «rpm-5.1.9»: El archivo ya existe
unable to mkdir rpm-5.1.9: at /usr/share/perl5/Alien/Package.pm line 257, line 5408.
oniro@oniro-team:~/Escritorio/rpf$ sudo alien -d
You must specify a file to convert.

entonces me he metido en la carpeta

oniro@oniro-team:~$ cd Escritorio/rpf/rpm-5.1.9
oniro@oniro-team:~/Escritorio/rpf/rpm-5.1.9$

he ejecutado

sudo alien -dv *.*.rpm

y me dice que rpm no se encuentra, pues antes yo había visto que le terminal leyó unos cuantos, no lo entiendo.

+1
0
-1
Imagen de CHuLoYo
+1
0
-1

sudo alien -dv *.*.rpm

Más bien

sudo alien -dv *.rpm

No puedo ayudarte mucho más ya que no conozco bien las opciones de alien.
Saludos.

---------
Marcos Pérez
Grupo de aprendizaje de programación

+1
0
-1
Imagen de oniro
+1
0
-1

Soy imbécil, no leyó ningun archivo rpm, sino archuvos del tipo "rpm-5.1.9/po/sl.po", era el nombre de la carpeta...será le dolor de ojos, levo tres días pegada a la pantalla.

+1
0
-1
Imagen de jericozorn1
+1
0
-1

Hola a tod@s.

Oniro, a ver si lo entiendo, tu quieres instalar el gestor de paquetes de rpm, ¿en un sistema ubuntu?

Según la wikipedia, esto es lo que quieres ???
http://es.wikipedia.org/wiki/RPM_Package_Manager

Si es así, te he de comentar, que el sistema ubuntu, lleva su propio gestor de paquetes, y como te han comentado antes, ubuntu deriva de debian, y sus paquetes son del tipo .deb, no del tipo .rpm.

El uso de "alien" esta pensado para poder portar los paquetes .rpm, a .deb, pero solo aquellos paquetes que no esten en la versión .deb, que suelen ser muy poquitos paquetes.

Resumiendo, no necesitas instalar, el gestor de paquetes .rpm.

Saludos.

+1
0
-1
Imagen de oniro
+1
0
-1

Gracias jericozorn.

El caso, es que en esta página web, hay un usuario de ubuntu que ha tenido exactamente el mismo problema que yo para instalar Staroffice, y lo solucionó instalando el pakage manager.

http://www.comunidadp2p.net/showthread.php?3184-Problema-instalar-starof...

+1
0
-1
Imagen de CHuLoYo
+1
0
-1

Usuario de ubuntu? Dónde ves tú eso? Distribuciones de Linux hay millones, ubuntu sólo es una cagadita en este mundo.
El usuario dijo claramente:

He intentado instalar Staroffice, he descargado la versión para linux, inicia la instalación pero al procesar los paquetes rpm sucede lo siguiente:

Te dijimos todo el post que ubuntu está basada en DEBIAN (otra de las muchas "versiones" de linux) y utiliza el sistema de paquetes .deb . Los RPM son propios de RedHat, Mandriva, Fedora u openSuse, entre muchos otros que se basan en RedHat.

Así que una de tres:

  1. O intentas conseguir el programa en .deb
  2. O intentas convertir el .rpm en .deb con alien
  3. O te bajas el código fuente y lo compilas

Y sino... qué tiene de malo OpenOffice.org?

---------
Marcos Pérez
Grupo de aprendizaje de programación

+1
0
-1
Imagen de oniro
+1
0
-1

Debajo del cuadro de error el usuario dice "estoy en ubuntu, que me falta?".

Openoffice ahora mismo me está planteando un problema estético para el currículum, que a otros les podrá parecer banal, pero cuando se trata de nuestro currículum y buscar trabajo nos volvemos más exigentes, hasta ahora solventaba el problema bajando al cíber, pero estoy intentando probar Staroffice para ver si me sirve y cortar esa dependencia con Microsoft.

Por cierto, hay un mensaje tuyo que no había visto, el que va después de makefile.in, voy a hacer la prueba.

+1
0
-1
Imagen de CHuLoYo
+1
0
-1

Qué problema estético?
Porque yo hago todos mis documentos (incluido el currículum, que por cierto lo tengo muy chulo xD) con openOffice.org y te digo que salen cojonudos.
Otra cosa es si intentas modificar un .doc hecho con mocosol guor. Ahí sí te recomendaría hacerlo desde cero en openoffice.

---------
Marcos Pérez
Grupo de aprendizaje de programación

+1
0
-1
Imagen de oniro
+1
0
-1

No, en los filtros no me ha salido nada.

+1
0
-1
Imagen de CHuLoYo
+1
0
-1

PEro hay un Makefile.am ?
Ejecuta ese

---------
Marcos Pérez
Grupo de aprendizaje de programación

+1
0
-1
Imagen de oniro
+1
0
-1

Lo hay, pero al ejecutar "make", o "make makefile.am", dice que no hay ninguna regla para construir el objeto.

Señalar que en el paso anterior, el de ./configure, al final del todos decía "configure: error: mandatory POPT library not found".

+1
0
-1
Imagen de CHuLoYo
+1
0
-1

Te faltan librerías para configurar la compilación.
Vamos, que estás jodida.....
PD: Buscando un poco encontré una solución que no es rpm, pero mirando mejor, hace tiempo que quitaron la forma gratuita. ASí que no sé cómo puedo ayudarte. Hay una solución en la página de ubuntu, pero necesitas el CD original (o por lo menos una copia, pero aquí en este foro esos temas no se tratan)

Saludos.

---------
Marcos Pérez
Grupo de aprendizaje de programación

+1
0
-1
Imagen de jericozorn1
+1
0
-1

Hola a tod@s.

Oniro, que quieres instalar staroffice, por que openoffice no te sirve???

Volvamos a la wikipedia a ver que dice de staroffice: http://es.wikipedia.org/wiki/StarOffice

Y si vamos a la portada de la pagina de staroffice ( Sun): http://www.sun.com/software/staroffice/index.jsp

Se puede ver claramente que la versión de staroffice, la 9.0 es de pago, y que al mismo tiempo te dan la opción libre que es openoffice.

Por que no preguntas mejor, por el problema que tienes haciendo el curriculum, a ver si se te puede ayudar en eso otro???

Por que el tema del staroffice, es sencillo, lo pagas, lo bajas, lo instalas.

El de openoffice es mas sencillo, lo buscas en el gestor de paquetes, y lo instalas.

Me parece muy raro, que no puedas hacer "algo" con openoffice y si con staroffice.

Saludos.

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola oni....:

1- StarOffice es OpenOffice, lo que puedes hacer con StarOffice
lo puedes hacer con OpenOffice.

2- Si quieres algo con distintas prestaciones, puedes instalar
desde los repositorios symphony, es la versión para Karmic de
Ibm Lotus Symphony, basada en el código de OpenOffice, pero muy
distinta.

Saludos.
Gabriel.



Solo doy soporte para Ubuntu - Existen muchas soluciones - Las erróneas y la mia.
+1
0
-1
Imagen de oniro
+1
0
-1

Muchas gracias a todos.

+1
0
-1