2010-4-3 Problema: Bloqueos de equipo aleatorios relacionados con la tarjeta grafica NVIDIA

Imagen de Andurino
0 puntos

Sabado 3-4-2010
Después de leer mucho , goglear y forear, probar y probar durante aproximadamente 1 año no he conseguido averiguar dos cosas:
1.-Que narices le pasa a la gráfica.
2.-Cómo solucionarlo

Mi Harware
-ADM 2100 xp , 1,5 GB RAM, nvia 6800 (sin letra)
Mi SO actual UBUNTU 9.10 karmic koala con nucleo linux 2.6.31-20 generic y Gnome 2.28.1

¿Que me ocurre?
Pongo esto en primer lugar porque posteriormente enunciare los procesos que he realizado, sin obtener ningun resultado significativo.

1-El equipo se bloquea cuando le da la gana y si quiero forzar el cuelque lanzar cualquier cosa que requiera algo de tarjeta grafica.

COMO HE INTENTADO SOLUCIONARLO

1-Aceleracion 3d no habilitada, se verificaron los 3 controladores que vienen con la distribucion.
2 DESINTALACION DE TODOS LO PAQUETES nvdia* he instalacion del driver propietario y oficial de nvidia NVIDIA-Linux-x86-195.36.15-pkg1.run con esto yo he consegido tener aceleracion 3d no funcional es decir al acceder a glxinfo o procesos graficos (aplicaciones no necesariamente 3d) se sigue bloqueando.
3. Desinstalacion de todos los drives y del servidor X y reinstalar todo con driver oficial nvidia.
4. Desinstalacion de todos los drivers y del servidor X y instalar el paquete nvidia-190.
5. Desinstalacion de todos los drivers y servidor x, instalar ENVY.

Como ya he dicho en todos estos metodos bastante simplificados puesto que cada uno de ellos me ha dado bastante guerra, que si faltaban header, que si los permisos del ejecucion no eran los adecuados etc. etc.

He consultado este problema y en la mayoria de casos todos me indican "mira los logs" y les replico que los logs no continen informacion sobre ningun error porque el equipo se bloquea y aparentemente no permite escribir el log.

Dicho esto ¿se te ocurre algo?

Yo sospecho despues de haber trasteado que tiene que ser algo del GDM (error en el driver glx por inapropiado) y del fichero xorg.conf (alguna option con algun valor)

Muchas gracias.

Imagen de juanramon
+1
0
-1

Prueba a ver con el nuevo driver nouveau ( aun en desarrollo) desde sinaptic
De todos modos, mira que no sean los efectos de escritorio de compiz.

 

 

Salud y alegria

------------------------------------------------------------------------------------

Juanramon

--------------------------------------------------------------------------------

+1
0
-1

 

 

Salud y alegria

------------------------------------------------------------------------------------

Juanramon

--------------------------------------------------------------------------------

Imagen de Andurino
+1
0
-1

Ese driver solo me permite acceder a entorno grafico de baja resolucion

+1
0
-1
Imagen de Andurino
+1
0
-1

No se le ocurre a nadie nada?

+1
0
-1
Imagen de JhonQ
+1
0
-1

Hola, te sugiero intentes:
Entra en "modo seguro"
elimina o renombra el xorg. conf (karmic no lo usa por defecto)
desinstala todos los drivers nvidia (y todo lo que diga nvidia)
ejecuta
dpkg --reconfigure -a
reinicia
Te dira que hay controladores disponible de tu tarjeta.
instala el 173 (es el "más viejo" para karmic, por lo que el más depurado)
Suerte

+1
0
-1
Imagen de Andurino
+1
0
-1

Pues nada, sigue sin ir

¿Alguna idea más?

Gracias

+1
0
-1
Imagen de jlas9
+1
0
-1

Andurino, me pasa lo mismo que a tí.

Mi equipo es AMD X2 (64 bits) 4200 con GeForce 8500 GT. Empecé "achacando" los malditos cuelgues al uso de Adobe Flash, pero para nada, como tu bien dices son totalmente aleatorios. A las "soluciones" que tu has intentado yo añado que he descargado de la página oficial de Nvidia el driver beta 256.25, pero nada, no es una solución.

Ahora mismo usando driver "nouveau", los cuelgues del sistema han desaparecido por completo, mi máquina es una fiera... llegué a pensar que se había roto, pero afortunadamente, para nada. Es un problema de mala conjugación driver + kernel. Como todo en esta vida, tendrá una solución, pero hasta entonces... jodido sin aceleración gráfica.

Saludos muy solidarios.

+1
0
-1
Imagen de negrodem
+1
0
-1

bien muchachos, otro mas con los benditos problemas ubuntu + nvidia. Pero vale aclarar me ocurrió con lucid linx y pcs con configuracion de nvidia onboard (6150 para amd y 7100 o 7050 para intel. Con noveau van un balazo pero con los driver privativos ocurren cuelgues o no me permiten apagar el equipo etc. Con ubuntu 8.04 lts van la mar de bien pero con lucid tuve mas de un problema y eso que probe con linux mint también. Debo reconocer que con fedora y open suse por ahora en sus últimos kernel si bien incorporan noveau pude correr con los drivers privativos sin dramas. Pero ostia!! quiero mi ubuntu 10 andando asi!!!!..Por ahora nadie me a dado una explicación concreta ni solución y intente casi todo.

+1
0
-1