Por fin pude instalar ubuntu en clevo m73sr

Imagen de capachecoc
0 puntos

Instalando Linux en clevo M73sr

Por fin he logrado instalar un Linux en un Compumax Liberty Education 2008 (clevo M73sr) con un resultado satisfactorio

. Probé:

Ubuntu 10.04 de 64
Ubuntu 10.04 de 32
Ubuntu 9.10 de 64
Ubuntu 8.04 de 64
Ubuntu 8.04 de 32
Fedora 12 de 64

Con las tres versiones mas recientes de ubuntu (10.04 de 64, 10.04 de 32 y 9.10 de 64) no tuve éxito y ni siquiera logré crear particiones, ya que al parecer se presenta un problema de sincronia y se pierde el video, incluí los parametros noapic, nolapic, apci=off y vga=771. Pero no logré arrancar la instalación sin perder el video.

Con Fedora 12 de 64 logré terminar la instalación pero la resolución que daba era solo de 800X600 y no pude encontrar un controlador correcto, o que al menos me pudiera mejorar la resolución, pero dicho sea de paso fue el único sistema donde logré usar la red, al menos temporalmente, y realizar las tareas mas comunes de ofimática, navegar por Internet ver videos etc, pero luego de algunas horas la tarjeta de red inalambrica se caía y empezaba a solicitar autenticación, y solo podía arrancar nuevamente reiniciando o conectando el cable de red.

Con ubuntu 8.04 de 64 logré terminar la instalación, al iniciar el sistema cargaba el kernel pero se congelaba antes de recibir la contraseña, al iniciar en modo a prueba de fallos como root y ejecutar satartx podía iniciar el modo gráfico sin red y con limitaciones de montaje de medios, ensayé el siguiente tutorial http://www.elamaule.cl/admin/render/noticia/17779 debido a que el chip de video es el SISM672, el mismo de la maquina con que estoy trabajando, pero no logré arrancar el sistema aún editando el Grub desde root en modo a prueba de fallos.

Finalmente con ubuntu 8.04 de 32 logré instalar y arrancar el sistema. El procedimiento fue el siguiente:

Encender la máquina
F2 para poner la bios en sistema operativo linux en el menú advanced, salvar cambios y reiniciar
Seleccionar idioma
F6 para dar el parametro vga=771, no recuerdo si es mayuscula o minuscula pero se puede verificar con la ayuda (F1 y F3)
F6 para dar los parámetros noapic, nolapic, apci=off
Enter para iniciar la instalación, seguir los cuadros de diálogos, (ojo poner el cable de red porque aun no hay wi-fi)
particionar a conveniencia, en mi caso dejé libre 100 GB de mi partición NTFS y luego usar todo el espacio libre. esperar, esperar y por fin: retire el cd y de Enter para reiniciar.

Bien otra vez 800x600, para entonces ya había conseguido los controladores del dichoso SIS M672
para ubuntu 10.04 y viene la pregunta del millón ¿que pasará si actualizo a 10.04 desde 8.04?. respuesta: el sistema se bloquea y no hay reversa, volver a instalar.

Ensayé algunos controladores para el famoso SIS M672:

Model: Clevo M740S/M760S
OS: Linux
Distribution: Ubuntu 8.10 32bit Desktop
Kernel: 2.6.27-7-generic
Driver Rev.: 1.0

nada, no satisface las dependecias.

xorg-driver-sis671_0.9_i386.deb

Nada

sisctrl_0.0.20051202-1_i386.deb

Ese si se instaló, pero no soporta el tal SIS M672

y por fin: xorg-driver-sisimedia_0.9-1_i386.deb

lo descargo:
http://nacho.larrateguy.com.ar/wp-content/uploads/2009/07/xorg-driver-si...

Acá dice como instalarlo:
http://nacho.larrateguy.com.ar/2009/07/11/drivers-de-sis-771671-para-xor...

sin embargo prefiero darle doble clik para abrirlo con instalador de paquetes, doy contraseña y finalmente me pregunta si reemplaza xorg.conf (no está demás guardar una copia por si no funciona) acepto y reinicio.

Me detecta un problema de video y me da la opción de configurar y por primera vez veo resoluciones mayores a 800X600 arranca el modo gráfico y...... otra vez ¡¡¡¡800x600!!! voy a sitema> preferencias > resolución de pantalla y de nuevo la máxima es 800x600 verifico el xorg.conf y sí tiene las lineas:

Section "Device"
Driver "sisimedia"
EndSection
reinicio de nuevo y magia 1280x1024

Con todo el dolor de cabeza que me dio el tal SIS M672 estoy satisfecho, pero aún no se si tengo aceleración de video, si tengo 2D o 3D y además sé que habiendose lanzado Ubuntu 10.04, los días de Hardy Heron están contados. Sin embargo creo que habrá alguna solución para cuando ya no haya soporte para Hardy Heron, por lo pronto puedo decir que si se puede instalar ubuntu en un Clevo M73sr (Compumax liberty education en Colombia, creo que algún modelo Bangho en Argentina).

Este es mi primer aporte y espero que le sirva a álguien

Imagen de capachecoc
+1
0
-1

El único sistema de 64 que me permitió instalarlo etc fue Fedora 12, pero todo lo que pude en fedora lo pude en Hardy Heron 32 y me parece que con mejores resultados.

+1
0
-1
Imagen de mozart_ar
+1
0
-1

según este post http://jose.vazquez.be/instalando-ubuntu-notebook-bangho/ funciona en 9.04 , veo que vos no lo mencionas.
Voy a hacer la prueba y te cuento.

+1
0
-1
Imagen de mozart_ar
+1
0
-1

no funciono :-/ tanto 9.04 como 10.04 , probé cambiando varios parámetros del arranque del kernel, pero nada.

+1
0
-1
Imagen de mozart_ar
+1
0
-1

puse windows 7 :-)

+1
0
-1
Imagen de capachecoc
+1
0
-1

Pido disculpas por no atender los comentarios a tiempo. Sin embargo si aún quisieras ensayar ubuntu hay buenas noticias (al menos funcionó en mi M73sr)

+1
0
-1
Imagen de capachecoc
+1
0
-1

Estaba por pensar que el clevo m730sr (m73sr, compumax liberty education, bangho, etc, etc) se iba a quedar con el Ubuntu 8.04, hasta que me decidí a probar las nuevas versiones

Con 10.04 no pude con la de 32 ni 64 ni siquiera la server

Casi convencido de que la única ruta era instalar primero la versión server, para luego instalar escritorio y aplicaciones, descargué la iso y mandé la instalación, por error olvidé dar los parámetros vga=771, noapic, nolapic, apci=of. Para mi sorpresa la instalación terminó sin novedad, instalé gnome básico y startx me dió el entorno gráfico, como era de esperarse gnome básico era algo así como una consola mas ratón y unas escasísimas aplicaciones, y se vislumbraba que poner a tono la máquina iba a ser un trabajo largo.

Me quede pensando que si la instalación se había completado sin parámetros especiales tal vez, se podía hacer una instalación completa. Lo obvio es que tratara con la versión alternate, sin embargo descargué la desktop, cree el cd instalador y arranqué, el live de prueba cargó y le dí instalar, seleccioné extras y actualizar durante la instalación, para mi sorpresa todo concluyó normalmente, con el único lío ya conocido de la baja resolución.

Actualicé el sistema y reinicié

Una googleada por si había algo nuevo y encontré este post:
Driver SiS671/672 para Ubuntu 10.10 o Linux Mint 10
http://www.taringa.net/posts/linux/7941232/Driver-SiS671_672-para-Ubuntu...

donde hay un enlace a un controlador para ubuntu 10.10
http://dl.dropbox.com/u/11893371/10.10/sis671.tar.gz

el archivo se descomprime y se copia en:

/usr/lib/xorg/modules/drivers

En mi caso el archivo xorg.conf no existía
así que descargué este:

http://dl.dropbox.com/u/11893371/10.10/xorg.conf

Y lo pegué en el:
/etc/X11/

Reinicié y ya tengo 1280 x 800

para probar si era 3D intenté habilitar los efectos y no se pudo, así que el controlador debe ser el 2D.

Saludos y espero ayudar a que algunas máquinas puedan tener linux

+1
0
-1