No puedo ejecutar con pascal

Imagen de kOz
kOz
0 puntos

Hola,

Os cuento mi problema. He instalado free pascal porque lo necesito para la uni. Al principio no me compilaba, me daba el error: "util ld not found, switching to external linking"
Despues de pelearme y buscar, encontre que le faltaba una libreria o algo asi, busque en el gestor de paquetes synaptic "pascal" y me salio una libreria que ponia en la descripcion "GNU pascal compiler", la instale, y al compilar en free pascal mi programa me daba 3 nuevos errores, entonces puse en aptitude la libreria que sabia que me faltaba (que curiosamente no era la misma que habia instalado con synaptic), en la linea de comandos: "aptitude install glibc" (no habia hecho esto antes xq no me dejaba, y curiosamente despues mirando otra cosa me salio un mensaje "no se ha podido bloquear el raton, puede que alguien este monitorizando su sesion" o algo de un intruso, le di a un boton aceptar y me salio otro mensaje iwal pero con el teclado,desconecte el cable de internet y no me ha vuelto a salir no se si alguien sabra algo...) y me salio que no lo habia encontrado y los resultados mas parecidos, instale las dos librerias que salieron con los resultados mas parecidos y ya me compilaba bien los programas, pero ahora no ejecuta, bueno, le doy a Run en el menu run del free pascal (el free pascal lo ejecuto desde la linea de comandos poniendo "fp" no se si se hara asi... (soy novato)) y se quita la pantalla azul, vuelve a la blanca de la linea de comandos y una especie de mensaje pulse una tecla para volver, no deja hacer nada mas, ni aparece mi programa, ni nada, no se que hacer, o si he hecho algo mal al instalar esas librerias con synaptic, no se... si alguien puede ayudarme, muchas gracias.

Gracias otra vez y perdon x la parrafada.

Un saludo.

Imagen de Anónimo
+1
0
-1

Hola,

he tenido un problema similar en cuanto a no poder ejecutar los programas que se compilan correctamente. Parece una tontería, pero resulta que intentaba hacer todo esto en la partición compartida y no en mi "home". Si pasas el ejecutable a tu "home", te permite ejecutarlo, pero en la partición compartida no.

Será un "bug" de Ubuntu?

Saludos.

Héctor.

+1
0
-1