configuracion de jack para tarjeta fast track m-audio

Imagen de tanzak
0 puntos

Hola,

estoy usando ubuntu studio v10 y quiero instalar rosegarden. Despues de mirar en varios foros he conseguido configurar jack para reproducir sonido, pero no consigo grabar nada. La configuracion que tengo ahora es:

ruta del servidor: jackd
Tiempo real activado
monitoreo h/w: activado

cuadros/periodo: 128
frecuencia muestreo: 44100
periodos/buffer: 4

interfaz: hw1 (fast track)
Dispositivo de entrada: aqui he probado default, hw1 (fast track), y hw1,0 (usb audio)

todo lo demas esta en default
y al final me sale una latencia de 11,6 mseg

Entonces, ejecuto el jack y parece que mas o menos funciona, aunque me sale un error cada dos por tres de:

delay of 5057.000 usecs exceeds estimated spare time of 2880.000; restart ...

Entonces he probado de reproducir con el hydrogen y funciona bien, al probar de grabar con ardour o con grabador de sonido no me detecta entrada de audio. Por otro lado, en rosegarden no consigo que me reproduzca o grabe sonido alguno...

Alguien sabe como puedo corregir esto?

muchas gracias

Imagen de Pablo_F
+1
0
-1

Hola tanzak.

Debes aclarar algunas cosas. A parte del problema de no ver las entradas, jack no está funcionando de forma estable

¿Cuál es modelo exacto de tu tarjeta?

Que yo sepa hay al menos dos "fast track" de m-audio, la pro y la ultra. Además, da la salida de estos comandos informativos:

lsusb

(sólo la línea que se refiere a tu tarjeta)

cat /proc/asound/cards
aplay -l
ulimit -l
ulimit -r
groups

Saludos, Pablo

+1
0
-1

"Los analfabetos del siglo XXI no serán aquellos que no sepan leer y escribir, sino aquellos que no sean capaces de aprender, olvidar lo aprendido y aprender de nuevo" (Alvin Toffler)

Imagen de juanramon
+1
0
-1

el hecho de que no te "Capture" sonido es porque quizas debas hacer las conexiones pertinentes ( en jack ) para que la señal de entrada vaya al puerto de la aplicacion que deseas.
Vamos me imagino que es eso, por que las conexiones de salida se suelen "autoconectar" pero no las de entrada. Y si jack esta en modo duplex ( y por defecto es así) y funciona la salida, la entrada deberia funcionar.

Respecto a los buffers y sus muestras: procura poner 2 o, maximo, 3 a 128 o 512 muestras por buffer(si fuera necesario a 1024) . No se por que pero suele ser mas inestable cuantos mas buffers le pones. Normalmente es mejor aumentar la cantidad de muestras que los buffers.

+1
0
-1

 

 

Salud y alegria

------------------------------------------------------------------------------------

Juanramon

--------------------------------------------------------------------------------