Mis ventanas aparecen incompletas como si estuvieran recortadas y tengo 1 escritorio en vez de 4 Algo desinstale (SOLUCIONADO)

Imagen de moji star
0 puntos

hola a todos. Espero me puedan ayudar. Tengo Ubuntu 10.04 lts.

Yo no sé que desinstale, ya que me puse a eliminar paquetes que nunca he usado y liberar espacio en mi maquina y sucede lo siguiente:

en todas mis ventanas aparecen como si estuvieran recortadas, es decir solo aparecen los menús, ejemplo en Firefox(Archivo editar etc etc...) si se muestran los menús y lo de arriba lo que seria la barra de titulo, no aparece, junto con todo el marco por así decirlo. Aparte me aparece mi navegador esquinado hacia la parte superior derecha.

si le doy Alt-F4 no funciona no cierra, solamente usando el menú "archivo-salir". Si quiero maximizar tampoco me lo permite.

si quiero saltar a otra ventana no me lo permite. Es decir, si abrí una terminal antes que el firefox no me deja acceder a ella hasta que cierre el navegador.

otra cosa, aparecen todas mis ventanas sin estar maximisadas. No completas las pantallas solo la mitad o menos. como una ventana cualquiera de navegación.

solamente tengo un escritorio y tenia los cuatro escritorios con los que viene por default ubuntu. Cabe mencionar que si le doy en "Gnome Shell" ubicado en accesorios si no mal recuerdo me abre otro entorno y ahi si me aparecen mis ventanas correctamente... pero otras se me deshabilitan.

en mi barra de tareas no me aparece tampoco ninguna ventana... es decir como ejemplo tomo de nuevo firefox.. al abrirlo se muestra en la barra de tareas pero una vez que termina de cargar desaparece.

He estado dandole vueltas y he encontrado que no tengo instalado "Gnome desktop environment with extra components", lo quiero instalar pero me muestra un conflicto, que es el siguiente:
me pide que instale "epiphany-extensions". lo he instalado pero me desintala "swfdec-mozilla", y al querer instalar de nuevo Gnome desktop me pide que instale swfdec-mozilla..
y pues como ven es un juego de nunca acabar con instalar y desinstalar.

por favor ayuda...

de verdad no puedo trabajar de esta forma como mi maquina...

gracias., de nuevo...

Imagen de moji star
+1
0
-1

Hola de nuevo... pues bien...
en Aplicaciones-Otras existe una aplicación que se llama Mutter...

pues bien le he dado clic y me reinicia (por así decirlo) mi escritorio. Y ya me funciona correctamente, sin ningún problema hasta mis 4 escritorios han aparecido de nuevo, pero el detalle esta, que cuando reinicio sesión otra vez vuelve a suceder lo mismo con mi escritorio.

Otro detalle es que cuando quiero cambiar los efectos visuales me marca el siguiente mensaje "El silenciador esta ejecutándose, no se pueden cambiar los efectos"

cosas extrañas por favor ayuda... gracias...

+1
0
-1

Moji Star

Imagen de arraclan
+1
0
-1

posiblemente hayas desistalado compiz, en un terminal ejecuta:

sudo apt-get install compiz compiz-gnome emerald

sal de la sesión y vuelve a entrar..

salu2

+1
0
-1

--
arraclan(@)gmail.com
"I'm not anti-social; I'm just not user friendly"
Arraclan, registered Linux user #378069, Ubuntu User #1422

Imagen de moji star
+1
0
-1

muchas gracias Arraclan...

tenias mucha razón...

hice lo que me indicaste... con la excepción que cuando reinicie todo estaba igual, y lo único que hice de mas, fue ir a "Efectos visuales" en "Cambiar fondo de escritorio" (clic derecho) y le di normal ya que estaba activado en Ninguno y me apareció una ventana que decía buscando codecs y bualaaa!!!! ya todo volvió a la normalidad...

muchas gracias., jeje te debo una.,.,.

cuídate bonito día...

+1
0
-1

Moji Star

Imagen de moji star
+1
0
-1

Hola de nuevo.,. Arraclan...
y pues con la novedad., que no se soluciono del todo., es decir..
que cierro sesión.. y vuelvo a iniciar., y me vuelve a aparecer el mismo problema..

y al darle en activar efectos..

muestra "buscando controladores faltantes"

que controladores., me pueden faltar.. o que mas puedo hacerr..
sin mas espero tu respuesta...
gracias...

+1
0
-1

Moji Star

Imagen de arraclan
+1
0
-1

¿que tarjeta de video tienes? lo que te pide es el driver para habilitar el 3d, en el modo normal no te hace falta, por eso falla compiz.

+1
0
-1

--
arraclan(@)gmail.com
"I'm not anti-social; I'm just not user friendly"
Arraclan, registered Linux user #378069, Ubuntu User #1422

Imagen de moji star
+1
0
-1

pues esta raro... porque antes que desinstalara lo que me causo el problema...

si me funcionaba todo correctamente... sin ninguna falla...

asi que yo opino que no es problema de la tarjeta...

por favor ayuda... por que cada vez que inicio sesión es la misma cantaleta...
tengo que dar clic derecho y "cambiar fondo de escritorio-efectos visuales-normal o extra" y busca los controladores.. y ya todo vuelve a la normalidad...

como la vezz.,???

+1
0
-1

Moji Star

Imagen de arraclan
+1
0
-1

entra en el equipo, ponlo en modo normal para que funcione todo, abre un terminal, ejecuta:

compiz --replace

que mensaje de error te da?

+1
0
-1

--
arraclan(@)gmail.com
"I'm not anti-social; I'm just not user friendly"
Arraclan, registered Linux user #378069, Ubuntu User #1422

Imagen de moji star
+1
0
-1

hola hola arraclan pues mira... hice lo que me pediste...

y esto es lo que me muestra:::

WARNING: Application calling GLX 1.3 function "glXCreatePixmap" when GLX 1.3 is not supported! This is an application bug!
WARNING: Application calling GLX 1.3 function "glXDestroyPixmap" when GLX 1.3 is not supported! This is an application bug!

bueno eso que??? me dice que me indica...???

estoy pendiente de tu respuesta gracias.,

+1
0
-1

Moji Star

Imagen de arraclan
+1
0
-1

pues eso es que está funcionando bien, creo que lo único que te falta es el decorador de ventanas que no se ejecuta. Prueba a poner el escritorio sin efectos, abrir un terminal, luego le activas los efectos y perderas los bordes de ventanas. En el terminal ejecuta:

gtk-window-decorator --replace

deben de salirte los bordes y todo estaría normal.... si te sale algún error pegamelo aquí...

salu2

+1
0
-1

--
arraclan(@)gmail.com
"I'm not anti-social; I'm just not user friendly"
Arraclan, registered Linux user #378069, Ubuntu User #1422

Imagen de moji star
+1
0
-1

hola hola.,.

pùes hice lo que me indicaste.,
y sii., todo lo que dijiste era cierto., excepto el final
ya que esto es lo que me arrojo la terminal.,

/usr/share/themes/tropical/gtk-2.0/gtkrc:66: Invalid symbolic color 'selected_bg_color'
/usr/share/themes/tropical/gtk-2.0/gtkrc:66: error: invalid identifier `selected_bg_color', expected valid identifier

y lo peor es que no termina., el proceso., mmm es decir., que se queda parpadeando el indicador., y no sale el
nompc@nompc-laptop:$ (como ejemplo)
y si cierro la terminal., se desaparecen los marcos.,
como si la acabara de iniciar.,

eso eso loq ue ha sucedido., saludos.,

+1
0
-1

Moji Star

Imagen de arraclan
+1
0
-1

todo bien entonces, lo de los mensajes es normal. Pues yo te diría que te instalaras fusion-icon y actives los efectos desde allí, lo que te está fallando es el programa de gnome que te activa los efectos, así que usamos otro y todo listo.

Instala fusion-icon:

sudo apt-get install fusion-icon

ejecutalo con alt-f2 o un terminal, te sale un nuevo icono en la barra con forma de diamante, desde allí puedes arrancar compiz con el decorador correcto y cambiarlo fácilmente.

pruebalo a ver como te va...

salu2

+1
0
-1

--
arraclan(@)gmail.com
"I'm not anti-social; I'm just not user friendly"
Arraclan, registered Linux user #378069, Ubuntu User #1422

Imagen de moji star
+1
0
-1

hola Arraclan... ha sucedido lo siguiente...:

hice todo lo que me indicaste... y pues., el diamante no es diamante.. jeje me apareció un icono en forma de cubo azul... y bueno al darle clic en "Select Window Manager" me carga mis preferencias en mis ventanas.,.

osea que cuando inicio mi sesión sigue igual, aparece mi ventana sin bordes. Y otro detalle... cuando inicio sesión se abre tambien la ventana de la terminal... y siempre es lo mismo...

eso ha sucedido... saludos...

+1
0
-1

Moji Star

Imagen de arraclan
+1
0
-1

bueno, vamos a terminar con esto, primero abres la sesion, ejecutas fusion-icon y te aseguras que tienes bordes y todo va bien... si habres alguna ventana para comprobar luego la cierras (cierra el terminal ese que te sale), luego le das a alt-f2 y ejecutas: gnome-session-properties

en la segunda pestaña hay un botón para salvar lo programas que se están ejecutando en este momento, le das, cierras y cuando salgas y entres todo estará en su sitio...

salu2

+1
0
-1

--
arraclan(@)gmail.com
"I'm not anti-social; I'm just not user friendly"
Arraclan, registered Linux user #378069, Ubuntu User #1422

Imagen de moji star
+1
0
-1

Hola Arraclan, casi un mes despues de tu último mensaje... Sucede que por cuestiones de falta de internet, no habia podido contactarte...

sucede lo siguiente hice lo que me indicaste y sigue pasando lo mismo...

Inicio sesión y me aparece abierta una terminal y no se muestran los bordes de mis ventanas, aunado a que solo me muestra un escritorio, en lugar de los 4 que tiene por default el sistema...

Todo vuelve a la normalidad, cuando selecciono en ""clic derecho-cambiar el fondo del escritorio-efectos visuales-" y seleccionar normal, extra, personalizado...

y bueno disculpa tantas molestias... espero me puedas ayudar, gracias., saludos.,.

+1
0
-1

Moji Star

Imagen de fjcchfer
+1
0
-1

METACITY que es el decorador de ventanas por defecto en gnome, o instalaste Emerald, pero compiz no lo carga como decorador de ventanas, y al final tu sistema no trabaja ni con uno ni con otro, intenta reinstalar metacity (sudo apt-get install metacity -y)

+1
0
-1
Imagen de moji star
+1
0
-1

hola fgcchfer

ya hice lo que me indicaste y resulta que si lo tengo instalado (lo tengo en la versión mas reciente)

entonces que mas puedo hacer???
gracias por tu aporte...

+1
0
-1

Moji Star

Imagen de fjcchfer
+1
0
-1

nunca he probado gnome shell pero me parece que es el que te esta dando lata, si tienes compiz y emerald prueba intentar en alt-f2 "emerald --replace" o intenta desinstalar gnome shell

+1
0
-1
Imagen de moji star
+1
0
-1

Hola fgcchfer, sucede lo siguiente ya tengo desinstalado Gnome Shell desde antes que me enviaras tu primer aporte...

e hice lo que me indicaste,,, voy a reiniciar mi sistema y e cuento que ha sucedido...

ok

muchas gracias por tus aportes...

Cabe mencionar tambien que he revisado y no tengo instalado Gnome... y al querer instalarlo me pide que instale Epiphany extentions... y le doy en instalar este y me dice que desinstale swfdec-mozilla
y si lo hago vuelvo a querer instalar Gnome y me dice que me hace falta swfdec-mozilla y de nuevo hago lo que me pide y me dice que tengo que desinstalar Epiphany-extentions y
como te daras cuenta es cuento de nunca acabar...

entonces que puedo hacer...??? gracias muchas gracias.,.,

+1
0
-1

Moji Star

Imagen de moji star
+1
0
-1

hola., pues la cosa sigue igual.,.

estoy pensando si reinstalo ubuntu 10.04., podre solucionar mi problema.,.???

ojala sii., porque ya estoy descargando ubuntu 10.04 y crear un CD live... ojala sirva.,
gracias., espero su respuesta...

+1
0
-1

Moji Star

Imagen de fjcchfer
+1
0
-1

una reinstalacion, pero se me ocurre que antes podrías ejecutar en terminal un

sudo apt-get remove --purge firefox* epiphany* -y

y luego un

sudo apt-get install ubuntu-desktop -y

eso borra los paquetes que creo que te dan conflictos y lo segundo reinstala el escritorio de ubuntu con sus dependencias, obviamente instalara solo lo que te haga falta sin tocar lo que ya tienes, es como un equivalente a reinstalacion limpia....ojo es un "mas o menos equivalente"

+1
0
-1
Imagen de moji star
+1
0
-1

hola a todos., mi solución al problema es meramente reinstalar ubuntu...

no hay otra solución más comoda...

ya que las que amablemente me han indicado simplemente no surtieron efectos...

eso si aconsejo que hay que respaldar toda nuestra información.,.,

gracias., a todos los que me apoyaron...

todos aprendimos que fue lo bueno...

+1
0
-1

Moji Star

Imagen de Pan0ramix
+1
0
-1

Buscando una solución al problema del Mutter me vengo a encontrar el problema que tuve con Lucid en mi netbook Inspiron Mini 10.

Tal cual lo describe moji star que dió la vuelta al mundo con su problema ayudado por foristas amigos que intentaron lo mejor pero... no se solucionó. Hubo que reinstalar Ubuntu nuevamente. Si, confieso que hice exactamente lo mismo, pero esta vez aproveché el lanzamiento de Maverick Meerkat 10.10 para arreglar el pastel.

Total que ahora tengo instalado 10.10 y sigo con el problema del mutter! Ahora no me deja personalizar los efecto visuales pues me dice que "El silenciador esta ejecutándose,no se puede cambiar a otros efectos". Tengo un post al respecto con una solución propuesta que no me convence mucho, voy a darle una vuelta mas al tema.

Para colmo de males, lo que tenía mal en Lucid era la Cam Eye312 de Genius que me invertía la imagen, pero gracias a 10.10 y que Skype viene como asociado con Canonical el problema se resolvió, mientras persiste en Lucid quien sabe hasta cuando...

No sé qué ocurre con Metacity, el Mutter, el Gnome y la p..ta que los ...rió pero seguro que algo nuevo vamos a aprender.

Habrá más novedades para este boletín!

+1
0
-1

--------------------
Saludos
Pan0ramix

Imagen de moji star
+1
0
-1

hola panoramix...

espero estés bien... pues te hago una pregunta...

reinstalaste o instalaste el ubuntu 10.10???

es que si reinstalaste te jalo todos tus problemas, ya que el sistema lo reconoce como tus personalizaciones...

y creo que es lo que hiciste..

espero no equivocarme...

por eso se tiene que mandar a la goma con una instalación limpia.. osea completita como si fuera la primera vez....

y bueno espero tu respuesta.. para poder apoyarte.... saludos...

+1
0
-1

Moji Star

Imagen de cescman
+1
0
-1

+1
0
-1
Imagen de cesc1989
+1
0
-1

Me lo lei todo!! Y lo unico que me funciono fue el activar los graficos. Y a diferencia de moji star este problema me pasa en ubuntu 10.10 !!! Sigo buscando...

+1
0
-1

Lo unico que extraño de Windows son dos cosas: 1-Los juegos 2-El ConvertXtoDVD