Instalar aplicaciones Ubuntu 10.4 sobre MAC G5

Imagen de bego131
0 puntos

Hola.
Por motivos de trabajo me veo obligada a utilizar un MAC G5, al que le he instalado hace unos días Ubuntu 10.4. El problema es que al intentar instalar distintas aplicaciones (como Skype o Flash para Mozilla) me dice que "la arquitectura es incorrecta", ya lo baje para 64 o para 32 bits. Si intento instalarlas a través del Gestor de Software de Ubuntu me dice que "Flash no está disponible para powerpc". Como es de suponer, si me las intento descargar para MAC Ubuntu no las reconoce y no me deja instalarlas. Estoy desesperada!!! ya que no quiero volver al MAC OS!!

¿Alguna idea?

Por si acaso, la respuesta a uname -a es: 'Linux "nombreusuario" 2.6.32-22-powerpc64-smp #36-Ubuntu SMP "fecha" ppc64 GNU/Linux'

Un saludo y gracias de antemano!

Imagen de c0kit0_2oo7
+1
0
-1

Me suena raro ubuntu para mac... creo que la última versión de ubuntu disponible para mac ppc fue la 6.06 (corrijanme si me equivoco).. Estaré mirando cosas sobre ubuntu 10.04 en mac pero en principio me parece que no existe (o sí pero no oficialmente...) tengo entendido que ubuntu para mac está en versiones x86 y x64 para pc... (Ahora vengo!!! voy a 'googlear')...

+1
0
-1

---------------------------------------------------------------------------
lestat@esdebian.org

Imagen de c0kit0_2oo7
+1
0
-1

He vuelto... encontré esto:

http://en.wikipedia.org/wiki/Ubuntu_(operating_system)

Cito:
"System requirements
The desktop version of Ubuntu currently supports the Intel x86, AMD64, and ARM[64] architectures. Some server releases also support the SPARC architecture.[65][66] Unofficial support is available for the PowerPC,[67] IA-64 (Itanium) and PlayStation 3 architectures (note however that Sony officially removed support for OtherOS on the PS3 with firmware 3.21, released on April 1, 2010[68])."

Con lo cual, ppc no está oficialmente soportada, supongo que por eso te da problemas, a mi entender los paquetes que intentas instalar para mac, son paquetes para macintels... (los nuevos macbook por ejemplo), de la misma manera que en mac o s x no puedes instalar apps para ppc en intel sin usar rosetta.. y en ppc es imposible instalar apps para mac intel, pues en ubuntu habrán apps para macintel y otras para mac ppc... Yo que tú buscaría por google para ver si la aplicación que buscas está para ppc o no, porque el problema es ese.. no lo de 32 o 64 bits.

Al ser no oficial quizás encuentres soporte en los repositorios que se encuentran descomentados en tu sources.list.. (existe eso aun?? es que hace mucho que no uso ubuntu :D).

Tal vez podrías buscar ayuda en foros de mac también... Si dejas escrito qué programa quieres instalar igual te echo una mano.

PD: Encontre esto tambien http://cdimage.ubuntu.com/ports/daily-live/current/
La version 10.10 supongo que en estado alfa... veo que hay soporte para ppc, asi que igual con paciencia en unos meses el soporte para ppc se mejora :P.

PD2: Has probado a compilar a mano?

(Cuentame cositas que volveré)

+1
0
-1

---------------------------------------------------------------------------
lestat@esdebian.org