Aceleracion 3d con ati xpress 200M

Estoy intentando obtener la aceleración en mi ati radeon xpress 200M. En un primer momento instalé Ubuntu 5.10 para amd64 bits y no lo conseguí después de probar varias "recetas". Depués me pasé a 32 bits pensando que sería más fácil pero tampoco lo consigo.
Siguiendo esta "receta":
#########
Instalar Drivers de ATI del propietario:

(Por si acaso instala linux-restricted-modules de tu kernel y los linux-headers)
Esto me costo tela pero es más fácil de lo q parece.

1. Debeis de bajar los drivers RADEON de la pagina de ATI:
https://support.ati.com/ics/support/default.asp?deptID=894&task=knowledg...
2. Bajaros el instalador .RUN en mi caso x86:
http://www2.ati.com/drivers/linux/ati-driver-installer-8.16.20-i386.run
3. Abre un terminal y escribe lo siguiente:
$sudo chmod +x ati-driver-installer-8.16.20-i386.run
$sudo ./ati-driver-installer-8.16.20-i386.run
4. Le das a instalación automática sigues los pasos (No ejecutes fglrxconfig)
5. Entramos en el directorio /lib/modules/fglrx/build_mod y ejecutamos:
$./make.sh
$cd ..
$./make_install.sh
6. En teoria estan instalados con el modulo y todo pero aqui viene lo que tantos quebraderos de
cabeza me ha dado (por lo q no le funcionan a la gente en general)
Debes copiar el archivo (weno link Sticking out tongue) fglrx.ko a el directorio de modulos de tu kernel. ejemplo de
mi caso:
$sudo cp fglrx.ko /lib/modules/2.6.10-5-686-smp/kernel/drivers/video
Donde pone 2.6.10-5-686-smp poner el que os corresponda y listo. AHORA SI FUNCIONA la aceleración
en tu ATI RADEON.
NOTA: Este modo de instalación lo he probado con una ATI 9200SE y con una 9500 y en ambos funciona.
##########
todo me sale hasta llegar a la ejecución de las órdenes del paso 5. Es en este preciso momento cuando me he empezado a plantear si me estoy haciendo un lio con el kernel, la arquitectura, etc, etc.

Ah, por cierto, al final de la corrida me quedo con ubuntu 32 bits porque me reconoce la red que tengo montada en casa sin problemas (no tengo ni idea por què no lo hace el 64 bits), ¿Podríais ayudarme a resolver mi problema con la ati sobre ubuntu 5.10 32 bits?. También me interesa el tema wifi (Broadcom 802.1b/g WLAN).
Gracias por adelantado. Salu2.

Imagen de Morpheus 0
+1
0
-1

Hardware de video soportado:

https://wiki.ubuntu.com/HardwareSupportComponentsVideoCards

No quiere decir que no funcione, lo que pasa es que tienes que investigar un poco como hacerla funcionar.

http://www.ubuntu-es.org/node/10627

http://www.ubuntu-es.org/node/5571

http://www.ubuntu-es.org/node/7987

Hardware 100 % funcional en ubuntu por ahora, en abril liberan la siguiente versión estable de ubuntu dapper, espero que tenga soporte para tu tarjeta:

http://www.ubuntu-es.org/node/13840#comment-29854

Prueba si esta solución hace funcionar la aceleración 3d en tu ati:
http://www.ubuntu-es.org/node/3674

+1
0
-1