Detectar redes WiFi en Lucid Lynx

Imagen de Anarcho Dani
0 puntos

Buenas!!

Hace unos días me compré un portátil Toshiba con Windows 7 preinstalado, que no me ha dado ningún problema con Internet.

En cambio, después de instalar sin problemas Ubuntu 10.04 no logro conectarme a Internet. Voy a conexiones inalámbricas, y no me detecta nada, me pide que las cree yo o algo así, introduciendo un montón de datos extraños.

Mi duda es si lo lógico no sería que Ubuntu detecte las redes WiFi cercanas (tal y como lo hace Windows), permitiéndote elegir a cual conectarte. Pero en mi caso, sencillamente no muestra nada, ni da indicios de que esté rastreando en busca de conexiones.

He buscado por Gúgel, pero no he encontrado nada. Agradecería cualquier ayuda, y si necesitáis que de más datos decidlo.

Saludos!

Imagen de Anarcho Dani
+1
0
-1

He conseguido añadir una conexión inalámbrica introduciendo el SSID, la clave y otros datos que me exigía, pero continúa sin conectarse :S

No logro entender qué es lo que va mal, cualquier cosa que me podáis decir os la aggradecería enormemente, que ardo en deseos de mandar a tomar por culo Windows 7 de una vez xD

+1
0
-1
Imagen de DOA1
+1
0
-1

Al igual que Windows, Ubuntu las detecta solo. Al lado del dibujo del parlante arriba a la derecha. Tenes un menú que al bajarlo entre "red Cableada" y "VPN" te muestra todas las redes disponibles con su nombre. Haces click sobre una y sí necesita clave te la pide y te conectas. El problema es que no esta funcionando el Driver para que funcione la placa WiFi.
Soluciones: 1 Averigua que placa de WiFi tiene.
Como este problema lo tenemos muchos y tiene su complejidad resolverlo, justamente en este momento están trabajando en mejorar y hacer todos los driver para todas las placas posibles. Con lo cual para octubre se solucionaría simplemente actualizando el soft.
Lo primero es conectando la Compu por cable y menú Sistema/ Administración / Gestor de actualizaciones. Actualiza la CPU. Después Sistema/ Administración / Gestor de hardware y puede que este en el listado el Driver que estas necesitando. Aprovecha e instala los demás.
Sí sigue sin funcionar menú lugares/Equipo Sistema de archivos/etc/modprobe.d/blacklist.conf
Abre el archivo blacklist.conf es como un .txt y buscas el texto siguiente (esta último)
# really needed.
#blacklist amd76x_edac (el símbolo # adelante en este renglón lo agregue yo)
Con esto le decís a al sistema que no deshabilite "amd76x_edac "
En mi caso se solucionó agregando este símbolo delante del renglón. Veraz que en ingles dice que solo "really needed" "realmente necesario" hacer esto.
Si con todo esto no funciona hay que buscar e instalar los driver manualmente.
Espero tu respuesta.

+1
0
-1
Imagen de Anarcho Dani
+1
0
-1

Gracias por la respuesta!

El problema es que no me funciona el Gestor de actualizaciones, ya que al no estar conectado a inernet no encuentra nada xD

El Gestor de hardware tampoco me encuentra nada.

El archivo blacklist.conf no me deja modificarlo, y eso que soy usuario root.

No hay forma de descargarlo como archivo? Quiero decir, descargar los drivers para Linux en Windows 7 (que tiene internet) como archivos, y abrirlos después en Ubuntu para instalarlos.

Saludos y gracias de nuevo por responder!

+1
0
-1
Imagen de DOA1
+1
0
-1

Lo primero buscar que placa WiFi tienes, y como seguro estas leyendo esto con W7 tienes que ir al "panel de control" "Hardware y sonido" después no me acuerdo bien el titulo, no hay muchas opciones, Dentro de la anterior la primera solapa es "general" la segunda "dispositivos" o algo así y tiene una larga lista con todos los mismos y en ella el nombre de WiFi.
Después puedes buscar el Driver y también bajar los de W98 Win XP Vista 7 y sí instalaste la versión de 64bit también baja esos.
Después veremos sí tiene uno para Linux o con el programa Ndiswrapper que esta en el CD de instalación funciona uno de Windows.

+1
0
-1
Imagen de joselms02
+1
0
-1

Escribe en terminal ifconfig y nos muestras que aparece

+1
0
-1
Imagen de Anarcho Dani
+1
0
-1

En Administrador de dispositivos --> Adaptadores de red, me aparece "Atheros AR8152 Fast Ethernet Controller" y "Adaptador de red Broadcom 802.11n"

Supongo que la placa WiFi es la Atheros. He buscado por Gugel los drivers y he dado con la web opendrivers.com, de la que me he descargado y he instalado sin problemas un driver para mi mismo modelo y válido tanto para W7 como para Vista, XP y demás. Concretamente la versión 1.0.0.41
Aun así, no se si este driver servirá de algo para Ubuntu.

Además hay un driver del mismo modelo para Linux, el 1.0.1.9
Lo he descargado y he intentado abrirlo en Ubuntu, pero me da un error cuando lo abro. Concretamente sale esto:

gzip: stdin: decompression OK, trailing garbage ignored
tar: Child returned status 2
tar: Exiting with failure status due to previous errors

De todas formas, si elijo otra forma de abrirlo (ahora no recuerdo cual exactamente, era haciendo click derecho) se me abre una carpeta con varios archivos, y no se cómo instalar eso.

En cuanto a Ndswraper, no logro instalarlo xD

Esto aparece si tecleo ifconfig:

Link encap:Bucle local
Direc. inet:xxx.x.x.x Másc:xxx.x.x.x
Dirección inet6: ::1/128 Alcance:Anfitrión
ACTIVO BUCLE FUNCIONANDO MTU:16436 Métrica:1
Paquetes RX:76 errores:0 perdidos:0 overruns:0 frame:0
Paquetes TX:76 errores:0 perdidos:0 overruns:0 carrier:0
colisiones:0 long.colaTX:0
Bytes RX:5840 (5.8 KB) TX bytes:5840 (5.8 KB)

Siento el tostón, y agradezco de verdad la ayuda ;)
Saludos!

+1
0
-1
Imagen de DOA1
+1
0
-1

No, atheros es tu placa de red por cable y la Broadcom es tu placa WiFi.La norma WiFi 802.11n es la más moderna. Al problema: si buscas en la red esta lleno de tutoriales con varias formas de resolverlo. Yo no puedo probarlo porque no tengo esa placa, pero te paso la mas facil que he visto. En el terminal escribes lo siguiente (después del signo $)

:~$ sudo aptitude install bcmwl-kernel-source
y reinicia

y en el link de abajo tienes la explicación.

Por otra parte en disco de instalación tienes varios paquetes con varios modelos para esa marca. Sí lo anterior no funciona en "Sistema/administracion/origenes del Software" tilda el CD y después en "Aplicaciones/centro de Sofware ubuntu" busca "bc" y los veras.

http://www.guatewireless.org/os/linux/distros/debian/ubuntu/como-instala...

Aguardo respuesta y si arranca te digo los pasos para ponerlo a punto al sistema.

+1
0
-1
Imagen de DOA1
+1
0
-1

Imagen de Anarcho Dani
+1
0
-1

Siguiendo el primer tutorial:

sudo aptitude install bcmwl-kernel-source
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Leyendo la información de estado extendido
Inicializando el estado de los paquetes... Hecho
No se pudo encontrar ningún paquete cuyo nombre o descripción coincida con «bcmwl-kernel-source»
No se pudo encontrar ningún paquete cuyo nombre o descripción coincida con «bcmwl-kernel-source»
No se instalará, actualizará o eliminará ningún paquete.
0 paquetes actualizados, 0 nuevos instalados, 0 para eliminar y 0 sin actualizar.
Necesito descargar 0B de ficheros. Después de desempaquetar se usarán 0B.
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Leyendo la información de estado extendido
Inicializando el estado de los paquetes... Hecho

En cuanto a lo de tildar el CD en Orígenes del software no sé a que te refieres exactamente, pero en Centro de software tecleo bc y me sale, entre otros paquetes, bcmwl-modaliases, que me aparece como ya instalado y supongo que es al que te refieres.

Cuando intento el método del segundo tutorial me sale esto:

apt-get install b43-fwcutter
E: No se pudo abrir el fichero de bloqueo '/var/lib/dpkg/lock' - open (13: Permiso denegado)
E: Imposible bloquear el directorio de administración (/var/lib/dpkg/), ¿es superusuario?

Muchas gracias de nuevo por responder, porque esto es realmente desesperante xD

+1
0
-1
Imagen de DOA1
+1
0
-1

Te sale lo siguiente porque no puede encontrar los paquetes ni en la red porque no estas conectado, ni en el CD porque por defecto no está tildada esa opción.

"No se pudo encontrar ningún paquete cuyo nombre o descripción coincida con «bcmwl-kernel-source»"

Apenas arrancas la maquina hay 3 menus a la izquierda Aplicaciones, Lugares y Sistema. Dentro de SISTEMA esta Administración y dentro del anterior encontraras ORIGENES DE SOFTWARE. Incerta el CD de instalación y tilda la opción. Despues puedes ejecutar el comando nuevamente, "sudo aptitude install bcmwl-kernel-source" o también desde Gestor de Software.

+1
0
-1
Imagen de Anarcho Dani
+1
0
-1

De acuerdo. El problema es que instalé Ubuntu 10.04 por medio de un pendrive USB, y no detecta eso como CD de instalación cuando lo conecto y voy a Origenes de Software. He intentado de nuevo el comando con el pendrive, pero da el mismo mensaje, parece que no busca en los dispositivos USB.

+1
0
-1
Imagen de DOA1
+1
0
-1

Con USB nunca probé, pero la solución es ejecutar ese comando o con un CD de instalación o conectado a internet por cable. y todo puede tardar 3 minutos.

+1
0
-1
Imagen de Anarcho Dani
+1
0
-1

¿Y no hay alguna otra forma? Porque sólo tengo la versión 7.10 en CD y dudo que tenga esos drivers. Y sólo tengo internet inalámbrico xD

He buscado en el USB de instalación el archivo manualmente y lo he encontrado. Si no recuerdo mal está como paquete Debian (.deb). He probado a ejecutarlo haciendo doble click pero me da un error. ¿Se supone que hago algo mal? Copio el texto de error y en breves lo pongo aquí.

De nuevo, mil gracias por la paciencia! :D

+1
0
-1
Imagen de Anarcho Dani
+1
0
-1

Abro el archivo bcmwl-kernel-source_5.60.48.36+bdcom-0ubuntu3_amd64.deb con el instalador de paquetes y sale:

Error: La dependencia no se puede satisfacer: dkms

He buscado por Gugel y parece que DKMS es algo que debería venir ya con Ubuntu.

Voy a intentar instalar DKMS a ver si funciona, y luego comento.

+1
0
-1
Imagen de Anarcho Dani
+1
0
-1

Veamos, he instalado con éxito DKMS. Después he ejecutado el paquete .deb con el Instalador de paquetes y se instala en principio sin problemas, pero da algún error. Lo reintento y me avisa de que hay un paquete idéntico ya instalado.

Entonces en la terminal escribo de nuevo, pero ahora da un error que no logro descifrar:

sudo aptitude install bcmwl-kernel-source
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Leyendo la información de estado extendido
Inicializando el estado de los paquetes... Hecho
Se configurarán los siguientes paquetes que están ahora parcialmente instalados:
bcmwl-kernel-source
0 paquetes actualizados, 0 nuevos instalados, 0 para eliminar y 0 sin actualizar.
Necesito descargar 0B de ficheros. Después de desempaquetar se usarán 0B.
Escribiendo información de estado extendido... Hecho
Configurando bcmwl-kernel-source (5.60.48.36+bdcom-0ubuntu3) ...
Removing old bcmwl-5.60.48.36+bdcom DKMS files...

------------------------------
Deleting module version: 5.60.48.36+bdcom
completely from the DKMS tree.

------------------------------
Done.
Loading new bcmwl-5.60.48.36+bdcom DKMS files...
First Installation: checking all kernels...
Building only for 2.6.32-21-generic
Building for architecture x86_64
Building initial module for 2.6.32-21-generic
/usr/sbin/dkms: línea 35: patch: orden no encontrada

Error! Application of patch 0001-MODULE_LICENSE.patch failed.
Check /var/lib/dkms/bcmwl/5.60.48.36+bdcom/build/ for more information.
dpkg: error al procesar bcmwl-kernel-source (--configure):
el subproceso script post-installation instalado devolvió el código de salida de error 6
Se encontraron errores al procesar:
bcmwl-kernel-source
E: Sub-process /usr/bin/dpkg returned an error code (1)
Un paquete no se pudo instalar. Intentado recuperarse:
Configurando bcmwl-kernel-source (5.60.48.36+bdcom-0ubuntu3) ...
Removing old bcmwl-5.60.48.36+bdcom DKMS files...

------------------------------
Deleting module version: 5.60.48.36+bdcom
completely from the DKMS tree.

------------------------------
Done.
Loading new bcmwl-5.60.48.36+bdcom DKMS files...
First Installation: checking all kernels...
Building only for 2.6.32-21-generic
Building for architecture x86_64
Building initial module for 2.6.32-21-generic
/usr/sbin/dkms: línea 35: patch: orden no encontrada

Error! Application of patch 0001-MODULE_LICENSE.patch failed.
Check /var/lib/dkms/bcmwl/5.60.48.36+bdcom/build/ for more information.
dpkg: error al procesar bcmwl-kernel-source (--configure):
el subproceso script post-installation instalado devolvió el código de salida de error 6
Se encontraron errores al procesar:
bcmwl-kernel-source
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Leyendo la información de estado extendido
Inicializando el estado de los paquetes... Hecho

Por un momento parecía que lo había conseguido, pero ahora sale esto... ¡¿por qué a mí?! xD

+1
0
-1
Imagen de DOA1
+1
0
-1

Jamas he intentado hacerlo de esa forma, yo le pediría a un amigo que me deje conectarme 3 minutos y listo.

+1
0
-1
Imagen de Anarcho Dani
+1
0
-1

No entiendo a que te refieres exactamente xD

Yo quiero que Ubuntu tenga una conexión a internet por la enorme utilidad y mejoría que esto supone para cualquier sistema operativo. Si sólo quisiera conectarme a internet, lo haría desde Windows...

De todos modos, muchas gracias por tu ayuda, he buscado un poco y parece que el error que me sale es algo reciente de lo que apenas hay información :S

+1
0
-1
Imagen de Efrainek
+1
0
-1

No he leído todos los comentarios por eso no se si has hecho esto, una solución sencilla,

1. conecta tu pc a internet mediante el cable eternet
2. inicia la aplicación que esta en sistema/administracion/controladores de hardaware
3. Ponle buscar controladores
4. Aparecerán los broadcom
5. activalo

y listo así me paso a mi y así lo solucione, espero sirva

+1
0
-1

El conocimiento es la raíz del valor, la ignorancia es la raíz del miedo -Efrainek-

http://efrainek.wordpress.com/
Caminando con Xubuntu, SliTaz y algo más

Imagen de DOA1
+1
0
-1

Yo no me expresé bien pero Efrainek sí, la solución es que te conectes por Cable de Red 3 minutos, hagas la instalación de forma normal y después te funcionará bien el WiFI. No le puedes pedir a un amigo o familiar que te deje usa la conexión por unos minutos? lo arreglas de forma normal y listo.

+1
0
-1
Imagen de Anarcho Dani
+1
0
-1

Gracias por las respuestas, y mis disculpas por no haberte entendido bien, DOA1 ;)

He probado a conectar el cable, pero me continúa dando errores. No muestra tampoco que exista ninguna conexión por cable y no funciona Internet.

Recibí hace unos días el CD oficial de instalación de Lucid Lynx, y probé a insertarlo y a repetir los pasos anteriores (cuando me conecto por cable Ethernet, aun sin Internet, me pide que introduzca el CD de instalación para instalar los paquetes), pero tampoco funcionó. Cuando trato que Ubuntu lea el CD me dice que la arquitectura no es la correcta, por lo que imagino que es porque el CD que me enviaron es de 32bits, y yo instalé la versión de 64bits (el portátil la soporta).

Es posible que este sea el fondo del problema. Instalé la de 64bits pensando que sería mejor, pero por lo que veo no da más que problemas.
¿Es posible que el paquete bcmwl-kernel-source_5.60.48.36+bdcom-0ubuntu3_amd64.deb, es decir, el paquete con los drivers que necesito, sólo sirva para 32bits?

Si creéis que sí, reinstalaré Ubuntu en la versión de 32bits.

Muchas gracias de nuevo!

+1
0
-1
Imagen de Anarcho Dani
+1
0
-1

Por cierto, al instalar Ubuntu lo hice realizando 3 particiones: /, /home y otra más.

Si quiero reinstalar el sistema para cambiarlo a 32bits y evitar que me de errores es necesario que borre y vuelva a crear de nuevo las 3? O es suficiente con reinstalar sólo la partición /?

Apenas tengo datos personales guardados en /home, por lo que si tengo que eliminar las 3 particiones no me supone un gran problema.

Gracias!

+1
0
-1
Imagen de DOA1
+1
0
-1

No estoy seguro, pero me parece que la /home no hace falta que la borres, de hecho creo que está hecha justo para esto, para que cuando reinstales no tengas problemas con los archivos personales. Yo probaría solo con la partición / (root).

+1
0
-1