wifi pci 802.11g, me esta volviendo loco

Hola a todos:
Como se que vuestro tiempo es importante, antes de poner este post he buscado , rebuscado, y vuelto a buscar y no he encontrado nada, os detallo mi problema:
Estoy en un centro educativo con mas de 10 ordenadores todos iguales, he montado una ubuntu en uno de ellos, con la idea de pasar todo el centro a linux, todo perfecto salvo la tarjeta wifi, es una SMC networks, una 2.4 Ghz 54 Mbps Wireless PCI
CARD, pero como lo q nos interesa es lo q nos saca el lspci:
0000:00:0a.0 Network controller: Intersil Corporation Intersil ISL3890 [Prism GT/Prism Duettel (rev 01)
Bueno, pues parece si hago un lsmod veo q si q me ha cargado el prism54, pero aki el problema
si hago un iwconfig me aparece eth0 NOT READY! ESSID:off/any Mode; MAnaged...... ya sigue todo lo normal.
El iwconfig parece normal salvo el NOT READY, no se, lo raro es q si hago un ifconfig eth0 172.26.0.2 por ejemplo, sale por pantall eth0: device soft reset timed out, en el ifconfig el eth0 se levanta pero en el iwconfig aparece eth0 no wireless extensions.

Uff , ayuda por favor, es lo q me falta para poder pasar 10 ordenadores a linux.
Muchas gracias

Imagen de Anónimo
+1
0
-1

Se me ha olvidado decir q en una debian si q funciona, pero la idea es usar ubuntu.

+1
0
-1
Imagen de cjgbgonzalez
+1
0
-1

HOla solo un comentario yo probaria esto si con la maquina debian funciona veria en less /etc/network/interfaces aver que esta haciendo el debian que ubuntu no por que segun dice lspci la ve y lsmod la monta y esta tengo la idea de que ubuntu no te la esta montando como deberia pero no soy un experto solo es un comentario que derepente te da luz y terminas por hacerla funcionar

Solo una cosa mas recuerda que con tiempo y trabajo todo se puede jajaja mucha suerte

+1
0
-1
Imagen de Anónimo
+1
0
-1

ese archivo es el mismo q puse en la ubuntu, la configuración de la red etc, pero el problema no viene de ahi, no se intentare usar ndiswrapeer q opinais?

+1
0
-1