Problema de arranque y consabido "Grub Rescue"

Imagen de Jose Magno
0 puntos

Buenas noches.
He buscado por bastantes sitios sin éxito una solución a mi pequeño problema.
He intentado crear un Live USB desde el Live CD. Pero lo hice desde la aplicación "Instalar Ubuntu" y una vez en ella, dirigiendo la instalación a una partición en mi USB. La verdad es que lo que había leído me indicaba hacerlo así, pero he detectado que no cuando he arrancado el PC sin la memoria enchufada y me daba el error "Error: no such device xxxxxxxxx. Grub rescue:". (¿Me he equivocado?¿Lo he hecho mal?)
A partir de ahí, la única forma de acceder tanto a esa instalación como a la que ya tenía de Vista es con la memoria enchufada y eligiendo en el menú de arranque la opción que quieres (así, funciona).
Me queda comprobar si el modo persistente funciona, pues desde que he detectado ese error ando brujuleando para solucionar el arranque normal, ya que no soy el único en esta casa que lo usa y sí sería el único con Ubuntu.
Así, necesito ayuda para, al menos, revertir el PC a la situación anterior (imagino que será arreglando el grub, y no sé cómo hacerlo).
Gracias de antemano.
NOTA: si hay un post muy similar, indicádmelo, pero no lo he encontrado. Y disculpas si es así.

Imagen de furtaxi
+1
0
-1

Tal como lo has hecho, entiendo que la partición que contiene el arranque, se ha quedado en el USB. De ésta forma, si no está enchufado ... no inicia,

De todas formas, si hay remedio.

No conectes el USB. Arranca con el Live CD, abres éste foro, te vas a preguntas frecuentes, y allí tienes como "Recuperar grub". Te valdrá para crear uno nuevo en el disco duro.

Así, si inicias desde el disco, usará el /boot de éste, y si lo haces desde el USB, pues desde aquél.

Fíjate que no necesitas, para nada, modificar el grub que ya tienes en el pendrive, sólo crear uno nuevo en el disco duro.

La única duda que tengo, es si sólo puso el arranque en el USB, o si colocó allí todo el raiz (/), anulando el del HDD. Nos informas de lo que ocurre.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de Jose Magno
+1
0
-1

Gracias por contestar.
Antes de hacer lo que comentas (y por mi desconocimiento casi total del grub), cuando "recupere el grub", imagino que respetará la configuración "de acceso" a windows, ¿no? (usuarios administrador, el mio, el invitado, etc...).
He pensado irme a un punto de restauración y quitarme de líos pero quizá era interesante poner mi problema aquí.

Heme aquí de nuevo con nuevas: en la documentación para recuperar el grub, usando dos formas para localizarlo, en ambas me pide buscarlo ("find /boot/grub/stage1" o "find /grub/stage1"), por lo que entiendo que debo ahora enchufar la memoria.
Debo entender entonces que, una vez identificado el grub, lo modificará de acuerdo a mis propósitos, ¿no?

+1
0
-1
Imagen de furtaxi
+1
0
-1

Te creará un grub nuevo, por lo que te buscará todos los sistemas operativos que encuentre. Por éso te digo que NO enchufes el USB, porque lo añadiría también.

Y el grub, sólo maneja el arranque del sistema, no "toca" ninguna otra cosa.

O sea, que no tiene nada que ver con cuentas de usuario y demás. éso, se carga cuando el grub acaba su labor, y entra el Sistema Operativo seleccionado.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de Jose Magno
+1
0
-1

Hola.
Nos hemos cruzado un post tuyo con una edición del mio anterior.
Lo dicho: he probado desde la ventana terminal (grub) y "no encuentra" el grub o da error (Error 15: File not found).

+1
0
-1
Imagen de Efrainek
+1
0
-1

hazlo como te explico furtaxi entra en la documentación e imprime recuperar grub, después quitas la usb y reinicias en modo live-cd y haces los pasos correctos de instalación de grub.

No recuerdo todos los pasos pero es algo mas omenos así

entras en lice-cd
creas punto de montaje y montas la particion primaria
instalas el grub y le das actualizar

creo que algo así va, ve la guia ubuntu en la documentación para todos los detalles y comandos.

+1
0
-1

El conocimiento es la raíz del valor, la ignorancia es la raíz del miedo -Efrainek-

http://efrainek.wordpress.com/
Caminando con Xubuntu, SliTaz y algo más

Imagen de Jose Magno
+1
0
-1

Muchas gracias pero al final, he usado un poco la lógica y os explico lo que he hecho:
Lo primero ha sido entrar en el recovery (de fábrica) y tratar de ir a un punto de restauración. Nada. No ha hecho nada.
Lo segundo ha sido (también con el recovery de fábrica) tratar de arreglar problemas de arranuqe. Y que si quieres arroz, Catalina.
Lo tercero, usar el auto super grub disk desde windows. Y ha funcionado. Me queda eliminar la entrada de ese programa del menu boot (se supone que te pregunta si lo quieres eliminar, pero no lo ha hecho).
Nota: con la memoria enchufada, no detecta (como parece lógico) el Ubuntu 10.4 instalado... así que partimos de cero otra vez!!
Me recomendáis algún tutorial claro para crear un USB Live?

+1
0
-1
Imagen de leninG
+1
0
-1

ma pues, si inicias un live cd, te mentes a sistema -> administración y allí esta crear live usb o bien creador de discos de arranque y desde allí seleccionas la usb y listo tenés tu live usb. si es un ubuntu ya instalado por ejemplo el 10.4 te vas a la misma ruta y te pide que selecciones una imagen.iso de un live cd de ubuntu y seleccionas la usb abajo y te la hace también. Al iniciar desde live usb o cd te va a cargar todo el sistema desde allí podés probar que todo te funcione antes de instalar definitivamente, incluso podes descargar e instalar driver para probarlos en modo live usb o cd y ya sabiendo que drivers te van a hacer falta procedes a instalar todo.

+1
0
-1