Intalación de FindThatWord

Imagen de foxsak
0 puntos

Hola, de antemano gracias por la colaboración y apoyo que me puedan prestar para resolver esta situación.

He intentando instalar FinThatWord, pero al momento de instalar el paquete deb, me aparece el siguiente error: Error: La dependencia no se puede satisfacer: python-gnome2-extras (>= 2.19)

Siendo honesto, no tengo ni la más remota idea de a que se refiere, ni como solucionarlo, pues estoy demasiado acostumbrado a windows y a los programas, errores y problemas del mismo, pero en Gnu/linux llevo muy poco tiempo (1 mes) y estoy tratando de aprender las cosas básicas.

Nuevamente gracias por la colabaración y las sugerencias.

Por cierto, tengo una netbook AcerAspireOne 150 con Gnu/Linux Ubuntu Netbook Edition

Imagen de tRaCk3r
+1
0
-1

Necesitamos el contenido de tu source.list, pulsa ALT + F2 y escribe esto:

cat /etc/apt/sources.list > ~/sources.list

Cuando pulses Enter (o Ejecutar con el ratón), se generará en tu Escritorio un fichero de texto llamado sources.list.

Péganos aquí su contenido, lo puedes abrir con cualquier editor de textos plano como por ejemplo, gedit.

Lo necesitamos porque al parecer, hay un lío en los repositorios de los que se nutre tu sistema a la hora de instalar programas.

+1
0
-1

 


tRaCk3r
http://tetosoft.com
ubuntu user #007044
linux user #319025
PC number #309252
Imagen de foxsak
+1
0
-1

Gracias por la pronta respuesta, por cierto, ejecute el comando que indicaste y extrañamente no aparecía el archivo en el escritorio (tal vez sea porque tengo una partición diferente para el root y otra para el home, supongo aunque como dije antes, ni idea), pero bueno, igual aquí está, espero que corresponda a lo que pediste:

# deb cdrom:[Ubuntu-Netbook 10.04 _Lucid Lynx_ - Release i386 (20100429.4)]/ lucid main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://co.archive.ubuntu.com/ubuntu/ lucid main restricted
deb-src http://co.archive.ubuntu.com/ubuntu/ lucid main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://co.archive.ubuntu.com/ubuntu/ lucid-updates main restricted
deb-src http://co.archive.ubuntu.com/ubuntu/ lucid-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://co.archive.ubuntu.com/ubuntu/ lucid universe
deb-src http://co.archive.ubuntu.com/ubuntu/ lucid universe
deb http://co.archive.ubuntu.com/ubuntu/ lucid-updates universe
deb-src http://co.archive.ubuntu.com/ubuntu/ lucid-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://co.archive.ubuntu.com/ubuntu/ lucid multiverse
deb-src http://co.archive.ubuntu.com/ubuntu/ lucid multiverse
deb http://co.archive.ubuntu.com/ubuntu/ lucid-updates multiverse
deb-src http://co.archive.ubuntu.com/ubuntu/ lucid-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://co.archive.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse
# deb-src http://co.archive.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu lucid partner
# deb-src http://archive.canonical.com/ubuntu lucid partner

deb http://security.ubuntu.com/ubuntu lucid-security main restricted
deb-src http://security.ubuntu.com/ubuntu lucid-security main restricted
deb http://security.ubuntu.com/ubuntu lucid-security universe
deb-src http://security.ubuntu.com/ubuntu lucid-security universe
deb http://security.ubuntu.com/ubuntu lucid-security multiverse
deb-src http://security.ubuntu.com/ubuntu lucid-security multiverse

+1
0
-1
Imagen de tRaCk3r
+1
0
-1

Parece ser correcto, prueba con:

sudo aptitude install -f
+1
0
-1

 


tRaCk3r
http://tetosoft.com
ubuntu user #007044
linux user #319025
PC number #309252
Imagen de foxsak
+1
0
-1

Bueno, ejecute el comando que indicaste en una consola, pero sin embargo, sigo sin poder intalar el paquete. Me aparece el mismo problema

+1
0
-1
Imagen de tRaCk3r
+1
0
-1

¿No hay errores nuevos?

Prueba:

sudo aptitude upgrade
+1
0
-1

 


tRaCk3r
http://tetosoft.com
ubuntu user #007044
linux user #319025
PC number #309252
Imagen de foxsak
+1
0
-1

Gracias por la ayuda, pero realice el upgrade y me indicaba que no habia nada para actualizar, y no, no aparecen errores nuevos, sigue apareciendo el mismo mensaje: Error: La dependencia no se puede satisfacer: python-gnome2-extras (>= 2.19)

+1
0
-1
Imagen de foxsak
+1
0
-1

Gracias por la ayuda, pero realice el upgrade y me indicaba que no habia nada para actualizar, y no, no aparecen errores nuevos, sigue apareciendo el mismo mensaje: Error: La dependencia no se puede satisfacer: python-gnome2-extras (>= 2.19)

Agrego: en la pestaña de archivos incluidos encontré esto, no se si servirá para saber que pasa.

Package: findthatword
Version: 0.1-1
Architecture: all
Maintainer: Ieuan Jones
Installed-Size: 256
Depends: python (>= 2.4), python-gtk2 (>= 2.10), python-glade2 (>= 2.13), python-gnome2-extras (>= 2.19)
Section: education
Priority: optional
Homepage: http://findthatword.sourceforge.net/
Description: A wordsearch creation program
FindThatWord is a full featured wordsearch creation program for
teachers, parents and those who enjoy creating puzzles. It supports
clues, hidden messages, autoresizing, puzzle narrative and can export to
various formats.

+1
0
-1
Imagen de tRaCk3r
+1
0
-1

¿Que ocurre si haces?:

sudo aptitude install python-gnome2-extras
+1
0
-1

 


tRaCk3r
http://tetosoft.com
ubuntu user #007044
linux user #319025
PC number #309252
Imagen de foxsak
+1
0
-1

Entre las lineas en la consola, aparece:

No se encontró ninguna versión candidata para python-gnome2-extras
No se encontró ninguna versión candidata para python-gnome2-extras
No se instalará, actualizará o eliminará ningún paquete.

+1
0
-1
Imagen de Goyo
+1
0
-1

El paquete python-gnome2-extras ya no existe en Lucid, por lo tanto ese paquete ya no vale (y no parece haber otro por ningún lado).

Puedes descargar el código fuente y ejecutar findthatword.py. Las dependencias que realmente hacen falta casi seguro que ya las tienes instaladas. Hay un archivo README con más detalles.

+1
0
-1
Imagen de foxsak
+1
0
-1

Gracias por responder y tratar de ayudarme para resolver este problema.
Gracias a tRaCk3r por el interes y gracias a Goyo por sacarme de la duda del porque no funcionaba el instalador, de igual forma teniendo en cuenta que soy principiante en gnu/linux no entendí muy bien a lo que te referias con el findthatword.py, pero bueno, tal vez conozcan algún programa similar en gnu/linux que pueda usar, ya que tengo instalado el crossword forge en wine, pero es muy lento, y se que una aplicación para linux sería más eficiente. gracias

+1
0
-1
Imagen de Goyo
+1
0
-1

Me refiero al archivo con ese nombre que está incluido en el código fuente de FindThatWord, no tiene nada que ver con GNU/Linux.

+1
0
-1
Imagen de foxsak
+1
0
-1

Gracias por la explicación, suponía que sería algo como esto, pero como no tengo mucha experiencia, ni idea. Aunque sigo en las mismas, porque aunque viera el código no sabría que tendría que hacer ahora. Buscaré algún tutorial por internet a ver si logro hacerlo.

+1
0
-1
Imagen de Goyo
+1
0
-1

Yo no encontré ningún tutorial, pero sólo tienes que hacer lo que te he dicho. No entiendo cuál es exactamente el problema, si lo explicas tal vez te pueda ayudar.

+1
0
-1
Imagen de tRaCk3r
+1
0
-1

Creo que lo que te sugiere Goyo es compilar el programa desde los fuentes.

Para ello, primero hay que tener los fuentes, abre un terminal y escribe:

mkdir tmp
cd tmp
wget http://sourceforge.net/projects/findthatword/files/findthatword/0.1/findthatword-0.1.tar.gz/download
tar zxvf findthatword-0.1.tar.gz
cd findthatword/src
chmod +x FindThatWord.py
./findthatword.py

Y con esto se inicia el programa.

+1
0
-1

 


tRaCk3r
http://tetosoft.com
ubuntu user #007044
linux user #319025
PC number #309252
Imagen de Goyo
+1
0
-1

Salvo que no hay que compilar nada.

+1
0
-1
Imagen de tRaCk3r
+1
0
-1

Exacto, comencé el post sin probar y fui desarrollando según hacía, después no repasé y se quedó lo de compilar.

+1
0
-1

 


tRaCk3r
http://tetosoft.com
ubuntu user #007044
linux user #319025
PC number #309252
Imagen de foxsak
+1
0
-1

Por fin pude ejecutar el findthatword, con los comando que me proporcionó tRaCk3r pude ejecutar el programa. ahora, a darle uso.

+1
0
-1
Imagen de Dieglock
+1
0
-1

Hola.

Busco instalar el FindThatWord en Ubuntu 11.10 y el Ubuntu Software Center me dice "Dependency is not satisfiable: phyton-genome2-extras (>=2.19).

Tengo Aptitude instalado y no corre ninguna actualización.

Cuando corro esto:
cd tmp
wget http://sourceforge.net/projects/findthatword/files/findthatword/0.1/find...
tar zxvf findthatword-0.1.tar.gz
cd findthatword/src
chmod +x FindThatWord.py
./findthatword.py

Se conecta a sourceforge pero dice que no hay ningún archivo llamado findthatword-0.1.tar.gz

Traté de correrlo con distinto paquete, con el que yo bajé de sourceforge vía Chrome, que es findthatword_0.1-1_all.deb y el resultado es el mismo.

¿Alguien sabe si hay algo más por hacer? La verdad, sí necesito el programa para crear sopas y crucigramas y es la única opción que he encontrado en Ubuntu para el Eclipse Crossword de Windows (que no logro hacer correr con Wine). Se nota que soy medio nuevo en Ubuntu, pero feliz de estar aprendiendo.

GRACIAS.

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

En este año que se fue se implementó Gnome 3 y las librerías gráficas GTK 3, entonces ese paquete python-gnome2-extras (no python-genome2-extras, una cosa es como pronuncias "gnome" y otra como se llaman los paquetes) ya no esta disponible más los archivos de desarrollo de ese paquete. (python-gnome2-extras-dev).

No se de donde o que repositorio (si agregaste un extra) estas buscando FindThatWord, en Ubuntu 11.10 no existe, o al menos yo no lo encuentro en mi Centro de software, al parecer ese programa esta descontinuado en esta versión de Ubuntu.

Si no encuentras el codigo fuente en sourceforge, las direcciones al archivo cambian, lo que quieres descargar, lo descargas desde aquí: http://sourceforge.net/projects/findthatword/files/findthatword/0.1/find...

Y desde su web oficial sugiere que este proyecto no ha tenido continuidad desde el 2009.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro