CableModem USB con Ubuntu

Hace tiempo que estoy interesado en aprender Linux, y me he tirado a la piscina con esta distribución. Después de la instalación he visto que no se conecta a internet. En el Device Manager reconoce mi cablemodem (Thompsom/RCA DCM245) que está conectado por USB... pero no se conecta a internet, no sé que debo hacer.

Es curioso que a través del LiveCD sí se conecta y funciona de maravilla.

Espero vuestra ayuda y os doy las gracias de antemano.

Imagen de pampero76
+1
0
-1

Prueba a cargar el módulo usbnet escribiendo en una terminal de root lo siguiente:
modprobe usbnet

Después nos cuentas.

+1
0
-1
Imagen de Anónimo
+1
0
-1

Lo acabo de probar y me dice que usbnet no es un módulo que reconozca el sistema. He ido a Synaptic y tampoco aparece en la lista... ni ninguno que empiece por usb*.

Aunque desde la LiveCD si hago un lsmod aparece esta línea:

Modulo: usbcore
Tamaño: 93780
Usado por: ehci_hcd,usb_storage,usbhid,usbnet,usblp,ohci_hcd,uhci_hcd

Se me ocurre que tal vez usbnet no sea en sí un módulo sino un programa que usa el módulo usbcore... éste debe ser el módulo que tengo que cargar... ¿cómo lo hago si no está en la lista de Synaptic y tampoco lo reconoce el modprobe?

Aunque no ha funcionado parece que vamos por buen camino...

+1
0
-1
Imagen de Anónimo
+1
0
-1

Yo estoy en las mismas y no logro hacer que Ubuntu me de acceso a internet mediante mi cablemodem el cual lo tengo conectado por USB.

Un amigo me dijo que utilice esto

dhcpclient eth1

Y con eso queda, he de probarlo y les comento que paso.

+1
0
-1
Imagen de Anónimo
+1
0
-1

Vale... ya he cargado (uno a uno) los módulos usbcore,ehci_hcd,usb_storage,usbhid,usbnet,usblp,ohci_hcd,uhci_hcd. Está claro que son estos los que tenía que cargar... pero ¿cómo consigo que se carguen por defecto al arrancar? ¿Qué fichero tengo que modificar (por favor ser detallados)? y otra cosa... aun después arrancarlos... internet sigue sin funcionar. Creo que tengo que modificar algo con el ifconfig... pero no sé lo que es... qué más cosas tengo que hacer?

gracias

+1
0
-1
Imagen de Anónimo
+1
0
-1

Pues ya logre echarlo a andar:

modprobe usbnet
dhclient eth1

Listo

+1
0
-1
Imagen de ebrainte
+1
0
-1

Equipo > configuracion de sistema > red > añadir y fijate que te aparesca 1 placa de res si solo tenes el modem usb, y 2 placas de red si tenes una usb y una placa de red ethernet, cuando haces click en agregar, seguis todos los pasos. Volves a dar click en agregar y voslves a seguir lo pasos para que te aparescan 2 placas de red detectadas. Ahora das a click en aceptar en la ventana "Red" y te tendria que estar funcionando el modem.

Salu2.-

+1
0
-1