COMO:Xgl en Dapper

+1
0
-1

Aquí teneis una guia extraida de https://wiki.ubuntu.com/XglHowto para aquellos que querais disfrutar de las Xgl en vuestro dapper:

Lo primero es tener ubuntu actualizada a dapper. Para ello aseguraos que en el fichero /etc/apt/sources.list en todas las líneas que corresponden a los repositorios de ubuntu ponga dapper en lugar de breezy(u hoary o warty si andais muy anticuados XD).

Esto se ejecutara en un terminal:

$sudo aptitude update && sudo aptitude dist-upgrade

Si quereis limpiar los paquetes que habeis descargado:

$sudo aptitude clean

Bien ya hemos actualizado ubuntu a la version dapper mas reciente, pasemos a instalar las Xgl:

$sudo aptitude install libgl1-mesa libglitz1 libglitz-glx1 xserver-xgl compiz-gnome
$sudo ln -sf /usr/bin/Xgl /etc/X11/X

Con esto cambiamos el link simbolico que hay en /etx/X11/X para que apunte a Xgl en lugar de a Xorg.
IMPOTANTE ANTES DE SEGUIR:(LEER COMENTARIO (1) AL FINAL DEL COMO)

A continuación nos vamos a una consola: Ctrl+Alt+1

Tecleamos lo siguiente para reiniciar gdm:

$sudo /etc/init.d/gdm restart

Si todo ha ido bien ( a mi aun no me funciona en mi ADM64) deberia arrancar GDM.

Para activar Compiz cuando arranque GNOME y asi poder usar el escritorio cubico entre otras cosas:
Escribir en un terminal:

$echo "compiz --replace gconf decoration wobbly fade minimize cube rotate zoom scale move resize place switcher" >> ~/.gnomerc
$echo "nohup gnome-window-decorator &" >> ~/.gnomerc

(1)QUE HACER SI FALLA
En caso de que no funcione id a una consola (Ctrl+Alt+1)

Escribid esto para recuperar las Xorg:

$sudo ln -sf /usr/bin/Xorg /etc/X11/X

Espero que os sirva de ayuda!

Salu2!

Comentarios

Imagen de Anónimo

sudo aptitude install libgl1-mesa libglitz1 libglitz-glx1 xserver-xgl compiz-gnome

No se puede encontrar ningún paquete cuyo nombre o descripción coincida con "libglitz1"
No se puede encontrar ningún paquete cuyo nombre o descripción coincida con "libglitz-glx1"
No se puede encontrar ningún paquete cuyo nombre o descripción coincida con "xserver-xgl"
No se puede encontrar ningún paquete cuyo nombre o descripción coincida con "compiz-gnome"
No se instalará, actualizará o eliminará ningún paquete.
0 paquetes actualizados, 0 nuevos instalados, 0 para eliminar y 0 sin actualizar.
Necesito descargar 0B de ficheros. Después de desempaquetar se usarán 0B.
Escribiendo información de estado extendido... Hecho

Imagen de Anónimo

Soy un iodiota.. no habia activado los repositorios!
ahora ya lo tengo instalado y esta genial!!!
:P

Imagen de Anónimo

Funciona perfectamente, pero no van las transparencias alguien me puede decir que pasa?

Imagen de dariorodt

¿Qué tarjeta de video tienes? Leí por ahí que Xgl necesita una tajeta de cierto poder para las transparencias. Ah! otra cosa... si tu tajeta es ATI las instrucciones son otras...

Lee esto: https://wiki.ubuntu.com/xglati

Imagen de Anónimo

hola como estan alguien me puede decir como puedo instalr el XGL ya que ejecuto el comando apt-get install compiz xserver-xgl libgl1-mesa xserver-xorg libglitz-glx1 compiz-gnome pero me dice que el paquete compiz no se encuntra quiero saber si este esta por defecto en los repositorios porque ya tengo Ubuntu instalado y actualizado por completo hasta el dia de la fecha.... bueno por ahi leei algo de activar los repositorio ,,,, como se debe eso o a que se refire con eso ,,,,,,

Imagen de Anónimo

Tengo un problemon.

Lo he instalado todo como indicais y al iniciar me sale todo como rallado, lo efectos van bien, pero rallados, que hago??

Imagen de Anónimo

BUENO YO NO TENGO LO ULTIMO DE LA TECNOLOGIA,MI PREGUNTA ES, SIES NECESARIO TENER UNA TARJETA GRAFICA DE ULTIMA GENERACION,PUES EN MI TARJETA MADRE VINO TODO INTEGRADO EN UNO, Y HE VISTO POR AHI LOS EFECTOS DE LAS XGL Y PUES BIEN, YO TAMBIEN QUIERO DISFRUTARLOS, MUCHAS GRACIAS, Y POR SI MI PC ES UN AMD 1200 CON 256 EN RAM Y 16 BITS PARA GRAFICOS, MUCHAS GRACIAS

Imagen de Anónimo

He probado y me ha cascado y he tenido q reinstalar todo, queria saber si funciona con un ibook G4 porq no quiero volver a reinstalarlo todo.

Gracias

Imagen de edalg

Hola, he hecho todo lo que dice sin problemas, però ahora tengo un problema, me va lentisimo todo.

Ejemplo: Al mover una ventana se mueve "a trozos". Al minimizar una mentana lo hace lentamente.

Hay alguna solución para volver a lo anterior?, al Xorg, hice lo que pone arriva de todo en (1) y nada.

Imagen de alede

Buena acabo de instalar dapper y no puedo instalar Xgl-Compiz, estan los repositorios, no se que hacer.

Cuando pongo en una terminal
$sudo aptitude install libgl1-mesa libglitz1 libglitz-glx1 xserver-xgl compiz-gnome
me dice que mno se instalara ningun paquete xserver-xgl compiz-gnome porque no ha sido encontrado. A las librerías si las bajo y la instalo, por favor ayuda, porque lo quiero hacer andar.

Imagen de Anónimo

si tu kernel es para amd64 chequeate esto

Imagen de Anónimo

esta mal: el chequeate esto iria a este link:

http://crysol.inf-cr.uclm.es/node/240

X)

Imagen de Haldir

hice estos pasos en mi dapper y a la perfeccion, lo unico malo es que cuando ando navegando me va muy lento el firefox cuando utilizo el scroll del mouse ya sea para subir o bajar, igual estuve checando ke ya no tengo aceleracion 3d cuando antes de instalar el xgl tenia aceleración, es normal esto???

Imagen de Corey_0

Hola, yo tengo un problema de lo mas rarito...

Instalo los drivers de la grafica, y me pone en la consola, con "glxinfo" que tengo aceleracion.
Luego instalo el GLX, y funciona bien y tal.
Pongo en consola "glxinfo" y mira tu por donde, me dice que ya no tengo aceleracion grafica! Que puedo hacer???????

GRACIAS DE ANTEMANO!!

--------------------------------------------------------------------------------------------
AMD Athlon X2 64 3800+@5200+
Asrock 939Dual SataII
nVidia GeForCe 7600GT
1024 DDR 400Mhz

AMD Athlon X2 64 3800+@5200+
Asrock 939Dual SataII
nVidia GeForCe 7600GT
1024 DDR 400Mhz

Imagen de Anónimo

Hola, yo lo he instalado como indicais y lo efectos me van bien, pero se me ve todo como rallado.

¿que puedo hacer?Tambien me gustaria saber como volver a tenerlo como antes

Imagen de Anónimo

Yo también lo veía rayado... tenía la profundidad de color en 16 bits.. Lo pasé a 24 y anduvo de perlas!

Ojalá te ayude mi comentario.

Imagen de NnEo0

a mi tambien me aparece todo rayado como hago para cambiar la profundidad de 16 bits a 24 si no puedo ver nada, tendria q habrir un terminal y q sentencias pongo?? podrian ayudarme?... gracias

Imagen de NnEo0

ya cambie la profundidad editanco el archivo xorg.conf de /etc/X11, lo cambio de 16 a 24, guardo, reinicio la sesion y sigue sin correr, me sale todo rayado...
Mi tarjeta es una Diamond Stealth III de 32 bits, y el controlador es el savage...
q puedo hacer para q me funcione bien el xgl
:)
Ayuda

Imagen de NnEo0

a mi tambien me aparece todo rayado como hago para cambiar la profundidad de 16 bits a 24 si no puedo ver nada, tendria q habrir un terminal y q sentencias pongo?? podrian ayudarme?... gracias

Imagen de NnEo0

a mi tambien me aparece todo rayado como hago para cambiar la profundidad de 16 bits a 24 si no puedo ver nada, tendria q habrir un terminal y q sentencias pongo?? podrian ayudarme?... gracias

Imagen de ardon

he seguido los pasos y creo q con exito. escribo las dos ultimas ordenes, y no me devuelve ninguna respuesta. ni positiva ni negativa. he reiniciado el ordenador, he mirado en la lista de sesiones por si aparecia... nada. sigo teniendo gnome como el primer dia, sin ningun cambio...

se supone q debe notarse algo? tengo q configurar algo mas? xq estoy bastante rallado...