Problemas con iptables

Imagen de maverik35
0 puntos

Me puse a probar la seguridad de mi red y utilice iptables.
La cuestion es que utilice una redireccion de puertos y utilice la tabla nat (-t nat) redireccionando el puerto 80....
Para esto antes habia habilitado el forward (echo 1 > /proc/sys/net/ipv4/ip_forward)..
haber, lo voy a poner mas claro:
1. habilito el forwarding como les mencione.
2. Enveneno arps (arpspoof)
3. Habilito las iptables con la tabla nat y redirecciono los https, puerto 443 y protocolo tcp
La cosa es que cuando mato los procesos de arpspoof, ya no me conecto a internet. Tengo que reiniciar...
Ahora, lo que hice fue, ignorantemente, hacer un iptables -F, y siguio igual, solo que ahora, cada vez que enveneno, se corta la comunicacion de la otra pc, aun y que se este habilitado el forwarding...Despues hice un iptables-restore y sigui igual..Igual, ignorantemente.
la cosa es que despues del flush a iptables, se complico, y aun reiniciando, me puedo conectar a internet, pero al envenenar arps, se corta el acceso a internet, con el ip
_forward habilitado...
Lei de iptables y al listar las cadenas de iptables con iptables -L, me da lo que se deberia estar cuando recien se carga un Linux, y se que la tabla por defecto es FILTER...
Alguna idea, para despues de utilizar iptables vuelva a la tabla por defecto?..Sin usar el iptables-restore?...Y como reestablezco mi envenenamiento?..Funcionaba bien hasta que le di el flush...Ahora tengo que reiniciar la pc cada vez que termino de trabajar con arpspoof y
y el forwarding se corta la comunicacion de la otra pc...
Como reestableceria las iptables?
Gracias....