Problemas con Barry

Imagen de vaisen
0 puntos

Hola buenas! Pues lo dicho, he intentado instalar el programa Barry para sincronizar mi blackberry pero he topado con el siguiente problema.No puedo instalar el paquete necesario opensync-plugin-barry.Esto es lo que me sale:

opensync-plugin-barry:
Depende: libopensync0 (>=0.22) but it is not installable
Depende: libopensync0 (<0.30) but it is not installable

He estado buscando a alguien que tubiera el mismo problema pero no he encontrado nada.

Gracias

Imagen de Goyo
+1
0
-1

Ya me gustaría saber cómo has conseguido eso porque opensync-plugin-barry no está en Maverick.
Puedes probar con este repositorio.

https://launchpad.net/~doctormo/+archive/barry-snapshot

+1
0
-1
Imagen de vaisen
+1
0
-1

Vale ya añadi el repositorio.Me sigue saliendo en synaptic pero cuando le doy a marcar para instalar y aplicar me dice exactamente lo mismo:

Los siguiente paquetes tienen dependecias no resolubles

+1
0
-1
Imagen de Goyo
+1
0
-1

Me he fijado mejor y en la página pone que los paquetes no se han podido construir, excepto opensync. Esto significa que no hay ahí ningún paquete binario relativo a barry que puedas instalar.

Por otro lado esto es cada vez más confuso. Dices "me dice exactamente lo mismo" pero al citar el mensaje de error pones cosas distintas. "Los siguiente paquetes tienen dependecias no resolubles" ¿los paquetes que tienen dependencies no resolubles son opensync-plugin-barry? ¿Las dependencias no resolubles son libopensync0 (>=0.22) y libopensync0 (<0.30)? ¿Por qué opensync-plugin-barry es necesario para instalar barry? ¿De dónde ha salido el paquete opensync-plugin-barry que estás tratando de instalar (esto ya lo pregunté antes)?

+1
0
-1
Imagen de vaisen
+1
0
-1

ok voy a intentar que lo entiendas bien: Basandome en un post de como instalar BARRY,llegue al paso de instalar los paquetes libbarry-dev, opensync-plugin-barry, barrybackup-gui,etc...

Consegui instalar todos excepto el nombrado opensync-plugin-barry.Entre en synaptic e intente instalarlos manualmente uno a uno.Cuando fui a marcar el paquete opensync-plugin-barry me sale el error:

No se pudieron marcar todos los paquetes para la instalacion o actualizacion.

Los siguientes paquetes tienen dependencias no resolubles.Asegurese de que estan añadidos y activados todos los repositorios ncesarios en las preferencias.(y justo debajo aparece esto:

opensync-plugin-barry:
Depende: libopensync0 (>=0.22) but it is not installable
Depende: libopensync0 (<0.30) but it is not installable

Esta algo mas claro?

Lo siento si te cree confusion

+1
0
-1
Imagen de Goyo
+1
0
-1

Un poco más claro. ¿Qué versión de Ubuntu tienes? Como decía antes, opensync-plugin-barry ya no está en Maverick, no tendría que aparecer en Synaptic. Si aparece es porque usas otra versión o bien has instalado algún repositorio adicional (además del que yo te dije, que tampoco tiene ese paquete).

+1
0
-1
Imagen de vaisen
+1
0
-1

Mi version es la Maverick Meercat.Y en cuanto a los repositorios, añadi los que me dijistes nada mas.Anteriormente añadi los PPA de samsung para el backlight y el de chrome.. y poco mas.

Que solucion le ves al tema?

+1
0
-1
Imagen de Goyo
+1
0
-1

Pues no sé. Realmente me gustaría saber por qué aparece ese paquete en Synaptic. En los repositorios oficiales de Maverick no está, en el de Barry Snapshots tampoco, ni en el PPA for Samsung Netbooks, en el de Chrome supongo que tampoco. No he podido encontrar ningún repositorio para Maverick que tenga ese paquete, así que no entiendo cómo es que está ahí.

En los repositorios oficiales de Lucid hay una versión:
opensync-plugin-barry (0.15-1ubuntu2) en Lucid
http://packages.ubuntu.com/lucid/opensync-plugin-barry

Las dependencias no son exactamente iguales que las que te pide a ti:
libopensync0 (<< 0.30)

En todo caso creo que puedes instalar libopensync de este repositorio:
https://launchpad.net/~opensync/+archive/opensync-0.22/+packages

+1
0
-1
Imagen de vaisen
+1
0
-1

Conseguido!Añadiendo el repositorio pude instalar el mil veces nombrado paquete!Gracias Goyo!Ahora solo me falta conseguir instalar definitivamente Barry.No sabras algo sobre eso tambien?

Muchisimas gracias!

+1
0
-1
Imagen de kozio
+1
0
-1

**/Moderado/**

Las preguntas en su propio hilo por favor. Gracias.

+1
0
-1