No consigo hacer funcionar mi red

Imagen de avix
0 puntos

Wenas.
Llevo toda la noche leyendo en los foros y los como's para arrancar mi red desde Ubuntu, y ya no se que más intentar.
Resulta que tengo una pequeña red de la siguiente forma:
Un XP con acceso a internet por teléfono, haciendo de puerta de enlace del mio, y tiene dhcp activado. En mi ordenador tengo instalado el xp, y ahora ubuntu.

Bien, desde xp, no tengo problema en contectarme. He conectado un ibook al router, y el xp que hace de pasarela le ha asignado una ip sin problema, tambien...

Ahora, desde Ubuntu no consigo ver de ninguna manera el otro ordenador. He probado de todo lo que he podido ver en los foros.
Ahora mismo tengo a eth0 configurado con dhcp, y lo puedo ver bien configurado en /etc/network/interfaces. Tambien veo la tarjeta de red desde ifconfig.
Tampoco veo nada raro en /etc/resolv.conf, pero de todas formas, aun no me preocupa, ya que ni siquiera puedo hacer un ping al servidor (192.168.0.1)

Cuando pongo sudo dhclient, despues de un rato termina diciendo lo siguiente:
No DHCPOFFERS received.

Ya no se que mas probar, porque:
* el hardware esta bien (ya que funciona con xp)
* Ubuntu vee la tarjeta de red (ya que aparece eth0 con ifconfig)
* El xp de pasarela asigna ip's...
que puedo hacer? reinstalar ubuntu?

tambien lo he intentado con ip fija, pero tampoco me ha funcionado.

A ver si alguien me podría echar una mano con la conexión, que estoy un poco desesperado :(

Gracias.

Salu2!

Imagen de avix
+1
0
-1

Hola, os anexo datos para concretar un poco:
ifconfig:

eth0 Link encap:Ethernet HWaddr 00:0B:6A:CB:28:E2
inet6 addr: fe80::20b:6aff:fecb:28e2/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:17 Base address:0xee00

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1364 errors:0 dropped:0 overruns:0 frame:0
TX packets:1364 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:122125 (119.2 KiB) TX bytes:122125 (119.2 KiB)

interfaces:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# This is a list of hotpluggable network interfaces.
# They will be activated automatically by the hotplug subsystem.
mapping hotplug
script grep
map eth0

# The primary network interface

iface eth0 inet dhcp

auto eth0

He visto en un post que hablaban de cambiar el /boot/grub/menu.lst y añadir la orden noapic. Curiosamente, he probado esto. Sigue sin funcionar, pero al memos al hacer in ping a la pasarela (192.168.0.1), no me dice lo de Not Reachable o algo así... ¿Para que sirve esta orden?

Bueno, a ver si me podriais echar una mano, porfa. Sigo sin ver la luz ;)

+1
0
-1