Mi ordenador no reconoce el modulo X-Fi I/O

Imagen de Figorin
0 puntos

Pues eso, recientemente instalé el ubuntu studio 10.10 y después de varios días de investigación con "San google" y por este foro hay un problema que me gustaría me solucionase alguien. Mi tarjeta es la Soundblaster X-Fi Elite Pro. Ya he conseguido que el equipo la reconozca y he instalado los paquetes alsa. Tengo sonido, pero no consigo que mi ordenador detecte el módulo externo I/O que viene con la tarjeta. El módulo consta de toda clase de puertos para todo tipo de conectores para la grabación y edición de sonido (MIDI,etc.), así como reguladores de efectos y de volumén.
Además la tarjeta viene con un software (no sé si es necesario pero supongo que sí) que en entorno windows se instala al meter el cd, pero no en ubuntu studio. ¿Cómo lo instalo? ¿Es necesario instalarlo para poder explotar las utilidades de mi tarjeta? ¿Es necesario para que me funcione el módulo (lo que de verdad me interesa)?. Gracias de antemano y un saludo.

Imagen de Pablo_F
+1
0
-1

Hola,

No estoy seguro de si podré ayudarte pero puedes dar la salida de terminal de estos comandos?

aplay -l
aplay -L
cat /proc/asound/modules

Saludos, Pablo

+1
0
-1

"Los analfabetos del siglo XXI no serán aquellos que no sepan leer y escribir, sino aquellos que no sean capaces de aprender, olvidar lo aprendido y aprender de nuevo" (Alvin Toffler)

Imagen de Figorin
+1
0
-1

Lamento contestar tan tarde a ta amable respuesta. Cuando meto "aplay -l" me sale:
**** Lista de PLAYBACK dispositivos hardware ****
tarjeta 0: XFi [Creative X-Fi], dispositivo 0: ctxfi [Front/WaveIn]
Subdispositivos: 8/8
Subdispositivo #0: subdevice #0
Subdispositivo #1: subdevice #1
Subdispositivo #2: subdevice #2
Subdispositivo #3: subdevice #3
Subdispositivo #4: subdevice #4
Subdispositivo #5: subdevice #5
Subdispositivo #6: subdevice #6
Subdispositivo #7: subdevice #7
tarjeta 0: XFi [Creative X-Fi], dispositivo 1: ctxfi [Surround]
Subdispositivos: 8/8
Subdispositivo #0: subdevice #0
Subdispositivo #1: subdevice #1
Subdispositivo #2: subdevice #2
Subdispositivo #3: subdevice #3
Subdispositivo #4: subdevice #4
Subdispositivo #5: subdevice #5
Subdispositivo #6: subdevice #6
Subdispositivo #7: subdevice #7
tarjeta 0: XFi [Creative X-Fi], dispositivo 2: ctxfi [Center/LFE]
Subdispositivos: 8/8
Subdispositivo #0: subdevice #0
Subdispositivo #1: subdevice #1
Subdispositivo #2: subdevice #2
Subdispositivo #3: subdevice #3
Subdispositivo #4: subdevice #4
Subdispositivo #5: subdevice #5
Subdispositivo #6: subdevice #6
Subdispositivo #7: subdevice #7
tarjeta 0: XFi [Creative X-Fi], dispositivo 3: ctxfi [Side]
Subdispositivos: 8/8
Subdispositivo #0: subdevice #0
Subdispositivo #1: subdevice #1
Subdispositivo #2: subdevice #2
Subdispositivo #3: subdevice #3
Subdispositivo #4: subdevice #4
Subdispositivo #5: subdevice #5
Subdispositivo #6: subdevice #6
Subdispositivo #7: subdevice #7
tarjeta 0: XFi [Creative X-Fi], dispositivo 4: ctxfi [IEC958 Non-audio]
Subdispositivos: 1/1
Subdispositivo #0: subdevice #0

Cuando meto "aplay -L":
default
pulse
Playback/recording through the PulseAudio sound server
front:CARD=XFi,DEV=0
Creative X-Fi, Front/WaveIn
Front speakers
rear:CARD=XFi,DEV=0
Creative X-Fi, Surround
Rear speakers
center_lfe:CARD=XFi,DEV=0
Creative X-Fi, Center/LFE
Center and Subwoofer speakers
side:CARD=XFi,DEV=0
Creative X-Fi, Side
Side speakers
surround40:CARD=XFi,DEV=0
Creative X-Fi, Front/WaveIn
4.0 Surround output to Front and Rear speakers
surround41:CARD=XFi,DEV=0
Creative X-Fi, Front/WaveIn
4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=XFi,DEV=0
Creative X-Fi, Front/WaveIn
5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=XFi,DEV=0
Creative X-Fi, Front/WaveIn
5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=XFi,DEV=0
Creative X-Fi, Front/WaveIn
7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=XFi,DEV=0
Creative X-Fi, IEC958 Non-audio
IEC958 (S/PDIF) Digital Audio Output
dmix:CARD=XFi,DEV=0
Creative X-Fi, Front/WaveIn
Direct sample mixing device
dmix:CARD=XFi,DEV=1
Creative X-Fi, Surround
Direct sample mixing device
dmix:CARD=XFi,DEV=2
Creative X-Fi, Center/LFE
Direct sample mixing device
dmix:CARD=XFi,DEV=3
Creative X-Fi, Side
Direct sample mixing device
dmix:CARD=XFi,DEV=4
Creative X-Fi, IEC958 Non-audio
Direct sample mixing device
dsnoop:CARD=XFi,DEV=0
Creative X-Fi, Front/WaveIn
Direct sample snooping device
dsnoop:CARD=XFi,DEV=1
Creative X-Fi, Surround
Direct sample snooping device
dsnoop:CARD=XFi,DEV=2
Creative X-Fi, Center/LFE
Direct sample snooping device
dsnoop:CARD=XFi,DEV=3
Creative X-Fi, Side
Direct sample snooping device
dsnoop:CARD=XFi,DEV=4
Creative X-Fi, IEC958 Non-audio
Direct sample snooping device
hw:CARD=XFi,DEV=0
Creative X-Fi, Front/WaveIn
Direct hardware device without any conversions
hw:CARD=XFi,DEV=1
Creative X-Fi, Surround
Direct hardware device without any conversions
hw:CARD=XFi,DEV=2
Creative X-Fi, Center/LFE
Direct hardware device without any conversions
hw:CARD=XFi,DEV=3
Creative X-Fi, Side
Direct hardware device without any conversions
hw:CARD=XFi,DEV=4
Creative X-Fi, IEC958 Non-audio
Direct hardware device without any conversions
plughw:CARD=XFi,DEV=0
Creative X-Fi, Front/WaveIn
Hardware device with all software conversions
plughw:CARD=XFi,DEV=1
Creative X-Fi, Surround
Hardware device with all software conversions
plughw:CARD=XFi,DEV=2
Creative X-Fi, Center/LFE
Hardware device with all software conversions
plughw:CARD=XFi,DEV=3
Creative X-Fi, Side
Hardware device with all software conversions
plughw:CARD=XFi,DEV=4
Creative X-Fi, IEC958 Non-audio
Hardware device with all software conversions
Y, por último, cuando meto "cat/proc/asound/modules" me sale esto:

0 snd_ctxfi

Lo siento, pero no entiendo gran cosa. Si con esta información puedes ayudarme sería la hostia. Como ya dije, el sistema reconoce mi tarjeta de sonido, por lo que lo más importante ya lo tengo. Sin embargo, a la hora de grabar voz o algún instrumento, se me hace casi imprescindible disponer de los puertos de conexión del módulo externo. En fin, en todo caso gracias por responder.

+1
0
-1