Optimizar VLC para ver TV digital HD (ISDB-T)

Imagen de vmannarelli
0 puntos

Tengo instalado en mi Ubuntu 10.04 un sintonizador ISDB-T USB MyGica S870 y funciona correctamente (le instale los drivers y firmware).
Usando el VLC sintonizo los canales en HD 1920x1080 y se ven entre cortado y la imagen pixeleada. Eso no sucede cuando sintonizo un canal 720x480 los cuales se ven muy bien y de manera fluida.
Que podre hacer para ver los canales 1920x1080 de manera mas fluida?
Alguna opcion en la configuracion del VLC?

Imagen de vmannarelli
+1
0
-1

El sintonizador S870 corre fluido con canales HD (1920x1080) cuando lo uso en Windows Vista con TotalMedia en la misma laptop que tengo instalado Ubuntu 10.04.
Eso quiere decir que Vista es mejor para manejar este sintonizador que Ubuntu 10.04?
Que puede estar pasando? Yo quiero usar mi S870 en mi Ubuntu!

+1
0
-1
Imagen de xexu91
+1
0
-1

Lo dudo bastante, mira a ver si te falta algun controlador:
Administracion/controladores de hardware

+1
0
-1
Imagen de santiago 14
+1
0
-1

puedes dar los datos de tu placa grafica?

+1
0
-1
Imagen de vmannarelli
+1
0
-1

Graphics:
• Mobile Intel® Graphics Media Accelerator X3100 with 8MB-256MB
dynamically allocated shared graphics memory

Processor and Chipset
• Intel Pentium Dual-Core processor T2370 / 1.73GHz, 1 MB L2, 533MHz FSB
• Mobile Intel GL960 Express Chipset

Memory
• Configured with 2 x 1024MB PC5300 DDR2 SDRAM (both memory slots
may be occupied).

+1
0
-1
Imagen de vmannarelli
+1
0
-1

Los canales HD de 1920 son los que se ven muy entrecortados pero el sonido si se escucha con claridad y fluidez.
Los demas canales en 720x480 se ven bien.
En el terminal se ve:
main video output warning: late picture skipped
repetido miles de veces
ayuda!

+1
0
-1
Imagen de santiago 14
+1
0
-1

fijate si se soluciona haciendo esto

en VLC: Herramientas>Preferencias>Entrada y codecs>usar aceleración GPU (experimental)> cerrar y volver a abrir el vlc (con VLC 1.1.4)

+1
0
-1
Imagen de vmannarelli
+1
0
-1

Veo que tengo el VLC antiguo que viene en Ubuntu 10.04.
Me parece que no es un problema del reproductor, sino mas bien del manejo del dispositivo (S870). Lo digo porque con otros reproductores tambien tengo problemas (ejemplo xine, MeTV).

Cuando utilizo el dispositivo en Window$ Vi$ta con TotalMedia (sw que viene en el CD de instalacion) me corre bien fluido y sin problemas, por lo que podriamos descartar que el procesador o video de mi laptop sean insuficientes para reproducir.
Viendo varios resultados en google hay muchas personas que utilizan el S870 sin problemas en Linux.

Cuando entro a Sistema > Administracion > Controladores de HW me aparace "Firmaware para tarjetas DVB" activado y usado actualmente.

Con dmesg me aparece:

[13258.700097] usb 2-5: new high speed USB device using ehci_hcd and address 3
[13258.833216] usb 2-5: configuration #1 chosen from 1 choice
[13258.938641] WARNING: You're using an experimental version of the DVB stack. As the driver
[13258.938644] is backported to an older kernel, it doesn't offer enough quality for
[13258.938646] its usage in production.
[13258.938647] Use it with care.
[13258.994850] dib0700: loaded with support for 14 different device-types
[13258.995080] dvb-usb: found a 'DiBcom STK8096GP reference design' in cold state, will try to load a firmware
[13258.995087] usb 2-5: firmware: requesting dvb-usb-dib0700-1.20.fw
[13259.020060] dvb-usb: downloading firmware from file 'dvb-usb-dib0700-1.20.fw'
[13259.242852] dib0700: firmware started successfully.
[13259.744239] dvb-usb: found a 'DiBcom STK8096GP reference design' in warm state.
[13259.744347] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
[13259.744560] DVB: registering new adapter (DiBcom STK8096GP reference design)
[13259.991343] DVB: registering adapter 0 frontend 0 (DiBcom 8000 ISDB-T)...
[13260.201577] DiB0090: successfully identified
[13260.201785] input: IR-receiver inside an USB DVB receiver as /devices/pci0000:00/0000:00:1d.7/usb2/2-5/input/input11
[13260.201918] dvb-usb: schedule remote query interval to 50 msecs.
[13260.201926] dvb-usb: DiBcom STK8096GP reference design successfully initialized and connected.
[13260.203664] usbcore: registered new interface driver dvb_usb_dib0700

Podria ser un tema del DMA del dispositivo? Este problema solo sucede con resoluciones de 1920x1080 y no con las de 720x480.
Ayudenme muchachos! Viendo TV HD en mi Ubuntu seria completamente feliz!

+1
0
-1
Imagen de santiago 14
+1
0
-1

fíjate si te sucede lo mismo usando el programa "Mi TV" (búscalo en el centro de software)

te pasa lo mismo con el HD básico (1280 x 720)?

+1
0
-1
Imagen de vmannarelli
+1
0
-1

Con Me TV no hay audio y los canales en 1920x1080 se ven pixeleados por lapsos. Con xine se ve pixeleado tambien pero se podria decir que el desempeño es mejor, hay mas fluidez pero aun no es desempeño normal.

En mi zona no hay canales en 1280, hay en 720x480 y esos si se ven bien. Solo los 1920x1080 son los que me traen problemas.

Estuve leyendo en un foro que Linux no maneja el multicore en este caso por eso se ve mal cuando se exige 1920x1080. Este es el link:
http://www.tdt-latinoamerica.tv/foro/mygica-s870-sobre-linux-ubuntu-t564...

En Vi$ta si se ve bien, fluido... en Ubuntu tambien tendria que verse asi tambien :(

+1
0
-1