¿Problemas con tu Tarjeta ATI? ¿Drivers Libres o Propietarios? [Soluciones Acá]

Imagen de 1antares1
0 puntos

[ ..::SOLUCIONES UBUNTU::.. ]

_______________________________________________________________________________________

Mi Comunidad Ubuntera, creo que muchos recuerdan la receta que publiqué hace ya algunos meses sobre:

"Instalación de Drivers de ATI [Tarjetas Soportadas - HD] -Drivers Propietarios-"

Tema:

http://www.ubuntu-es.org/node/141017

Se encuentra un poco des-actualizado y con algunos que otros detalles que faltaron por corregir, que podría confundir a muchos usuarios que inician su mundo en Ubuntu y tienen inconvenientes en instalar un Driver ATI que se hace muy fácil y rápido con las soluciones que propondré por experiencia personal con Ubuntu desde ya hace mucho tiempo.

No crearé ninguna guía o tutorial, ya que algunos de acá, podría tener Tarjetas antiguas o Chipsets arcaicos, como también Tarjetas que relucen ahora como los que son, el HD para adelante y pués, tendría que hacer 2 guías en la que con el tiempo se volverá obsoleto.

Constantemente estoy en la instalación y actualización de Drivers ATI para mi Tarjeta HD 4670, sea bajando el driver de su web (Recomendado), el FGLRX del Repositorio o agregando un Launchap.

_______________________________________________________________________________________

Invito a todos lo de ésta comunidad, que si tienen algún problema, duda por aclarar o inconveniente con la instalación y manejo de drivers, éste es su espacio.

Éste Tema estará abierto para aquellos que posean conocimientos básicos en el inicio de Ubuntu y estén con dudas con los Drivers para su Tarjeta Gráfica.

Acá les dejo algunos requisitos antes de publicar sus cuestiones:

-Publicar Modelo de la Tarjeta [Si es HD, publicar Versión. Y sino, también.].
-Versión de Ubuntu,
-Problemas presentes detallados [Que hizo antes... Como está ahora.... Como funciona su Sistema...]
-¿Sabe que es un .run?

_______________________________________________________________________________________

Trataré de resolver todos sus inconvenientes acá con la mayor paciencia y atención posible.

Estoy en creación de una guía muy práctica en .pdf para publicarla acá, pero aún los estudios me frenan tiempo y a inicios de Diciembre, estaré plenamente con el trabajo de ésta y otras Guías para ustedes, con mayor información de facilidad y eficacia para todos y todas acá.


- Comenzamos y se los dejo a ustedes....... 
- Espero sus Dificultades y les otorgaré las mayores soluciones posibles.

Saludos!

Imagen de UTatico
+1
0
-1

Hola 1antares1, he visto lo que has puesto como tutorial, pero no lo he podido seguir al pie de la letra ya que pues los repositorios cambian de acuerdo a la version... yo he trabajado ya hace arto con ubuntu pero no he metido las narices con cosas tan extrañas...

Antes tenia una NVDIA que se dañó, me regalaron ahora una ATI y pues aunque instalé los driver y todo fue bien, noto que el desempeño en general es muy lento... como si fueran lento los frames o algo así cuando desplazo maximizo o minimizo o lo que sea, en movimiento no es fluido, he intentado buscar la solucion pero creo que la desesperacion ya ni me deja buscar bien jajajajaj.

Podrias ayudarme con esto porfa, ya publique un post pero me mandaron este, entonces pues recurro a ti.

Gracias.

+1
0
-1
Imagen de almursi
+1
0
-1

buenas, no soy antares :), pero quizá pueda echarte una mano, más que nada porque tengo curiosidad por el rendimiento de esa tarjeta. El catalyst 11.8 (la versión anterior a la actual en la página de soporte de amd, porque el 11.9 no lo recomiendo) con otras tarjetas está dando buen resultado y de echo en oneiric es posible que vaya de serie, así que te aconsejaría que pruebes a instalarlo de manera manual. Puedes mirar este post: repositorio local, y seguir los pasos al menos hasta el cuarto. Una vez que te ha generado los paquetes los puedes instalar de diferentes maneras, el repositorio local es sólo una, y la más sencilla es con el comando "# sudo dpkg -i nombrearchivo.deb".
Por otro lado, una recomendación genérica con las ati es desactivar en el centro de control la espera a la actualización vertical (y de paso probar a desactivar la sección "Libre de fragmentación", en caso de que esté activo).
Por lo que he leído de la hd 6450 no es que sea para tirar cohetes, pero tendría que mover con soltura el escritorio a unas resoluciones medianas. Una utilidad para ver el rendimiento 3D es glxgears, que debe darte más de 1800 FPS cada cinco segundos para que los efectos 3d del escritorio funcionen bien.
Saludos cordiales.

+1
0
-1
Imagen de UTatico
+1
0
-1

Hola, en cuanto al driver, tengo instalada la version 11.8, he mirado las configuraciones y desactive lo que me dijiste... y luego hize la prueba y arroja esto:

16648 frames in 5.0 seconds = 3328.870 FPS
17075 frames in 5.0 seconds = 3414.944 FPS
16734 frames in 5.0 seconds = 3346.643 FPS
16974 frames in 5.0 seconds = 3394.782 FPS
16300 frames in 5.0 seconds = 3259.872 FPS
16497 frames in 5.0 seconds = 3299.336 FPS
16128 frames in 5.0 seconds = 3225.556 FPS
16087 frames in 5.0 seconds = 3217.283 FPS
13736 frames in 5.0 seconds = 2745.466 FPS
14953 frames in 5.0 seconds = 2990.505 FPS

sin embargo, sigo teniendo una experiencia poco fluida en el escritorio de ubuntu, he mirado por todo lado y pues hay varias personas a las que les pasa lo mismo, pero no llegan a una solución...

+1
0
-1
Imagen de almursi
+1
0
-1

buenas, gracias por sacar la prueba de glrxgears. Diría que aún podrías probar a forzar el rendimiento en otras opciones (incluso bajando la resolución del monitor) y ver qué tal anda, pero si el dato de 1800 (que leí de otro post) es correcto, teóricamente debería andarte bien con esos 3000. Quizá los que tengáis la familia 6000 tendréis que esperar un poco hasta que el controlador para linux saque jugo a la tarjeta. En tu caso (por ser una tarjeta moderna) probaría el 11.9 bajando el run de la web de amd, porque el comportamiento podría ser mejor que con las tarjetas antiguas (parece que hay un controlador opengl 3.3 y otro 4.1), pero eso sí, con los paquetes del 11.8 listos para instalar desde la consola en caso de que te dé problemas.

Aparte, una cosa que a mí me ha funcionado (supongo que al usar el escritorio clásico -sin efectos-) es deshabilitar el zeitgeist en "Aplicaciones al inicio" porque daba problemas con el totem (los que usen unity quizá no puedan, o no tengan ese problema).

Edito: He podido probar una 6570 y el rendimiento de glxgears es muy semejante (aunque el bus es pcie 1.1, como mínimo a la mitad de ancho del banda que puede usar la tarjeta, y eso debe de influir en el resultado). Creo recordar que antares también comenta que unity se ha integrado en ubuntu 11.04 con muchos flecos pendientes (empezando por el mal soporte de la industria gráfica) pero en el 11.10 que sale en pocos días todo debe estar bastante más maduro.

Saludos cordiales.

+1
0
-1
Imagen de VicFreaK
+1
0
-1

buena noche a todos los ubuntuser

necesito la siguiente ayuda de su parte y el problema es el siguiente:

me olvide de windows 7 y todo lo que tenia que ver con windows desde el lanzamiento final de Ubuntu 11.4 natty narwhal ya que esperaba con ansias esa versión, la instale todo bien sin problemas, instale programas, actualizaciones, repositorios a fondo, todo lo recomendado, y todo como un sueño, como lo esperaba hasta que llegue a la instalación de la tarjeta de vídeo que no se porque la deje de ultima, bueno paso lo siguiente:

instale los driver que me dio el ubuntu, creo que le llaman driver libre, todo bien pero el wine que corría algunas cosas no me las mostraba, como que mala imagen, lo desinstale y conseguí este tutorial el cual seguí al pie de la letra http://foros.softonic.com/documentacion-linux/configurar-ati-hd-3850-baj...

el driver arranco bien para lo esperado, el wine reprodujo mas cosas como WOW, luego quise añadir la resolucion de mi monitor el cual es 1600x900 pero había fallos que la perdía al reiniciar, cuando configure el xorg.conf me dio un crash al inicio y no pude iniciar el ubuntu, asi que lo borre y lo instale de nuevo,

instale todo y la tarjeta nuevamente bajo el tutorial pero esta vez al reiniciar no inicio y se quedo en pantalla negra, ya que no soportaba el UNITY, por gráfico seguro borre el driver y logre entrar de manera normal, instale el CATAlyst 11.4 pero = el wine no me da imagen de wow y ahora no me sale el gestor de controladores,

volvi a aplicar http://foros.softonic.com/documentacion-linux/configurar-ati-hd-3850-baj... pero cada vez que aplico la parte del Section "Device" no arranca sino por grafico seguro, esta vez no aplique eso pero ahora la resolucion 1600x900 aparece mal como encogida y bordes negros a los lados, como una pelicula pero sigue diciendo que esta a 1600x900.

por favor alguno me ayuda con tutorial exacto para la instalacion del driver,
ojo: el driver lo descargue de la pagina oficial para linux 32bit

de antemano agradecere enormemente su ayuda, ya que no quiero volver a Microsoft windows jamaz,

+1
0
-1
Imagen de furtaxi
+1
0
-1

Nada más que felicitarte, por abrir el hilo, estar pendiente de él, y contestar con tanto detalle a cada pregunta.

Personas como tú hacen grande a éste foro.

Y lo mismo digo de los demás participantes en el hilo, encomiable labor.

Un saludo,
Roberto.

P.D.: Yo no participo, porque soy más de Nvidia...

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de monogato
+1
0
-1

Pensaba actualizar al catalyst 11.9 el 11.8 con una instalación limpia y eso a ver si me iban los vídeos más fluidos pero he visto que almursi no lo recomienda, ¿y eso? También he desactivado esperar actualización vertical. La verdad es que no sé exactamente qué es lo que hace y como afecta a la calidad y al rendimiento. ¿Por qué es recomendable desactivarlo?

+1
0
-1

“todo es un asco, así que más vale encontrar una razón para sonreír” (HOUSE, THE BEST).

Imagen de almursi
+1
0
-1

buenas, el 11.9 siempre lo puedes probar, aunque a mí personalmente no me ha gustado (unas veces es por que aún tienen errores de instalación, que son corregidos cuando llegan a los repositorios, o por rendimiento). La explicación es que las nuevas tarjetas usan opengl 4.1, y es posible que aún lo estén depurando, pero los que usamos el opengl 3.3 nos podemos encontrar con fallos de lo que en inglés llaman "regression", es decir, de errores provocados por las nuevas funciones, así que si no tienes una tarjeta de última generación casi es preferible mantener el último controlador que te funcione bien (sin que eso impida probar los nuevos, pero sin ninguna urgencia). En cuanto a la actualización vertical suele ser una recomendación habitual en las guías de instalación del ubuntu 11.04 que he encontrado por internet, pero dado que no soy muy ducho en el tema esperemos que haya alguien que lo pueda explicar en condiciones :). Saludos cordiales.

+1
0
-1
Imagen de VicFreaK
+1
0
-1

creen que oneiric ocelot vendra mejor para las tarjetas ATI? o sera el mismo problema de instalacion? es que estoy pensando comprar una Nvidia si va a seguir asi, ya e intentado todo este tema desde el comienzo y no logro hacer una instalacion que quede perfecta :S para la tarjeta radeon 3850 HD T_T

+1
0
-1
Imagen de almursi
+1
0
-1

buenas, no lo sé :), quizá coincidamos en la idea, pero Nvidia resulta que también anda un poco loca últimamente, por lo que antes hay que echarle un ojo a la experiencia de los que están usando las últimas tarjetas, no vaya a ser que caigamos de la sartén a las brasas :). De tu problema no he dicho nada porque configurar los monitores siempre me ha resultado un tanto complicado. Hay un archivo al que le puedes echar un vistazo, lo más cómodo con el visor de sucesos del sistema, el gnome-system-log: /var/log/Xorg.0.log
Es bastante largo, pero puedes buscar entradas parecidas a estas:

[ 25410.625] (II) fglrx(0): Connected Display0: CRT1
[ 25410.625] (II) fglrx(0): Display0 EDID data ----
...
[ 25410.625] (II) fglrx(0): End of Display0 EDID data ---
...
[ 25410.828] (II) fglrx(0): Output CRT1 connected

En mi caso, todos los problemas se arreglaron cuando conecté el monitor a la salida principal (el CRT1), porque sólo entonces era capaz de reconocerlo correctamente, extraer el EDID y realizar las pruebas del modeline automáticamente, sin necesidad de tocar el xorg.conf (de hecho en ese caso cuanto más vacío está es mejor :) ). En tu caso, si es incapaz de reconocer el monitor, entonces tienes que editar el xorg.conf para añadir los modeline que soporta y/o restringir la resolución del monitor a una que no te dé problemas, que me suena está descrito en este hilo, y que a mí me funcionó mientras tenía el monitor conectado a CRT2.

Edito: He comprobado que en otras tarjetas más modernas (esta incidencia es de las primeras radeon HD) la salida VGA se convierte en CRT1 si no tienes nada conectado al DVI, por lo que el problema sólo se presenta si realmente se conecta un monitor vga antiguo sin soporte para el EDID, no por el tipo de conexión que se usa.

Saludos cordiales.

+1
0
-1
Imagen de monogato
+1
0
-1

una cosa, ¿alguien puede decirme a que version del catalyst corresponde el paquete fglrx-installer - 2:8.850-0ubuntu1~xup2 ?

P.D: Anyway, he instalado la version del catalyst 11.9 en ubuntu 11.04 64 bits con una radeon hd 5700 y sin problemas. No noto nada peor pero tampoco nada mejor, supongo que aún así algo tendrá mejor que la 11.8. ¿No?

+1
0
-1

“todo es un asco, así que más vale encontrar una razón para sonreír” (HOUSE, THE BEST).

Imagen de almursi
+1
0
-1

buenas, mira en
https://launchpad.net/ubuntu/+source/fglrx-installer/2:8.850-0ubuntu1
El catalyst 11.5.
Todo depende de la tarjeta que se tenga, cuanto más moderna más posibilidades de que hayan habilitado alguna función (pero diría que, sin necesidad de haber cambiado nada, siempre tienen que actualizar los códigos de reconocimiento de las nuevas tarjetas que sacan al mercado, por ejemplo). En el 11.9 hablan de "New stream release", es decir, de nuevas versiones de los programas. Saludos cordiales.

+1
0
-1
Imagen de monogato
+1
0
-1

gracias :)

+1
0
-1

“todo es un asco, así que más vale encontrar una razón para sonreír” (HOUSE, THE BEST).

Imagen de eduardomasat
+1
0
-1

Hola! soy nuevo en la página!, es una alegría contar con un foro de estas caracteristicas. Mi problema es el siguiente: tengo una acer aspire 5551-2988 con amd athlon II p320 y una ati radeon HD 4250, al instalar ubuntu 11.04 como aplicación para windows (porque no conozco mucho sobre como administrar las particiones), agregarle el software privativo e instalar los controladores de video, las ventanas se mueven de manera pixelada, las reacciones son lentas etc, y si no los instalo, tengo problemas al mirar videos como en youtube, por ejemplo, donde las respuestas son lentas y la calidad no es del todo buena. Qué debo hacer? será que mi notebook no es adecuada para este ubuntu?. Gracias por todo.

+1
0
-1
Imagen de almursi
+1
0
-1

buenas, para empezar te irá mejor si inicias con el escritorio clásico (en cuanto actualices el controlador puedes probar unity con mejores garantías). Seguramente te baste con buscar en este hilo cómo añadir los repositorios ppa y actualizar el controlador de manera automática, que es el método más sencillo (y después comprobar el rendimiento del opengl con glxgears).

Edito: Corrijo, el de los ppa me dicen que sigue dando guerra, así que toca actualizar de modo manual.

Saludos cordiales.

+1
0
-1
Imagen de AdrianMS
+1
0
-1

Hola.
Mi versión de Ubuntu es 11.4 de 32 bits y tengo una Ati HD6790. Ya le instale los drivers privativos y el Catalyst 11.5, pero tengo un problema cuando reproduzco vídeos, aun cuando doy foco a otra ventana que esta por encima de la de vlc (eh probado con varios reproductores pero es lo mismo) el video se sigue viendo.
Desde ya muchas gracias!.

+1
0
-1
Imagen de almursi
+1
0
-1

Buenas, es un bug de esa versión del catalyst, con uno más actualizado desaparece (o con esperar una semana y actualizar al ubuntu 11.10 también). Saludos cordiales.

+1
0
-1
Imagen de rubensa
+1
0
-1

Buenas noches,
he llegado aquí por que furtaxi amablemente me ha recomendado este hilo para solucionar mi problema. Respondiendo a las cuestiones imprescindibles:

1) Tengo una RADEON HD6450 y me ha fallado al instalar ubuntu 11.4

2) La instalación en live cd funciona y se visuliza perfectamente fluida el live cd con la resolución adecuada 1440 x 900 para un monitor de 19" .

3) El problema surge al finalizar la instalación y reiniciar por primera vez, en ese momento la pantalla de login parpadea en un color morado sin más, y es imposible logearse. De aquí no paso, por lo que ni siquiera he podido instalar los controladores privaticos ( en la sesión live cd, no me aparece ninguno como disponible)

4) Se que un .run es un archivo autoejecutable, al estilo de los .exe o de los .rpm de otras distribuciones de linux ( yo vengo de opensuse), pero no he trabajado nunca con ellos. Llevo usando sistemas linux mas de 4 años pero siempre como usuario que no investiga. Una vez que se instala bien, no paso del openoffice y del firefox.

Leyendo la documentación que me han facilitado tambien un compañero del foro, he visto esto:

Require Natty/11.04 and Modesetting Only

These cards should work with Ubuntu Natty/11.04, however you will need a more recent version of Mesa (7.11.x) than Natty's default (7.10.x) to get 3D acceleration.

PALM RadeonHD 6310/6250
TURKS RadeonHD 6570/6670
CAICOS RadeonHD 6450

Por lo que me apuntan a que quizas 11.10 solucione el problema, sin embargo tambien me recomiendan ( y seguramente con razón) que sea prudente y no me precipite en instalar un versión aún no testeada en masa.

+1
0
-1
Imagen de almursi
+1
0
-1

buenas, estas tarjetas te aseguro que funcionan en ubuntu 11.04, y la versión de mesa 7.11 quizá sirva más exactamente para mejorar el rendimiento (esperemos). Es posible que el controlador que se ha instalado (seguramente el radeon libre) sea incapaz de reconocer la tarjeta, puesto que algunas de éstas aparecieron en el mercado en abril/mayo de este año, he incluso el catalyst 11.6 (de junio) sigue teniendo un soporte muy básico de la familia 6000. Diría que si posees conexión de red (caso de que tengas un router adsl se configura automáticamente), desde el login de consola (Ctrl-Alt-F1) podrías ejecutar el run e instalar el catalyst 11.8 manualmente, aunque lo más sencillo sería instalar ubuntu 11.10 en cuanto esté disponible, si no te sientes cómodo manejando la consola. Los pasos a seguir son semejantes a los que explicamos por aquí, tan sólo falla la asistencia del entorno gráfico, aunque utilidades como mc (basta "sudo apt-get mc"), suelen ayudar bastante (pero vamos, si te animas te puedo resumir los pasos necesarios...). Saludos cordiales.

+1
0
-1
Imagen de monogato
+1
0
-1

Buenas de nuevo. Con el tema de la salida de Ubuntu 11.10, ¿qué tal está el tema del catalyst? ¿Te instala directamente la última versión? ¿Te instala una experimental como la última vez? ¿O te instala una antigua? Y en ese caso, ¿se puede actualizar manualmente con normalidad?

+1
0
-1

“todo es un asco, así que más vale encontrar una razón para sonreír” (HOUSE, THE BEST).

Imagen de almursi
+1
0
-1

buenas, aquí está:
https://launchpad.net/ubuntu/+source/fglrx-installer
Diría que no es que elijan uno experimental a propósito, sino quizá traten de poner el último disponible que dé tiempo a depurarlo un poco (lo que es el paquete .deb y los guiones de instalación). El ubuntu 11.04 coincidió con el lanzamiento de nuevas tarjetas de amd, así que llevaba un controlador experimental porque era eso lo que había... ya te lo avisan:

dependen únicamente de la capacidad de respuesta del fabricante. Ubuntu no puede arreglar ni mejorar esos controladores

Saludos cordiales.

+1
0
-1
Imagen de monogato
+1
0
-1

Tenía entendido que el problema era que el driver de ese momento no soportaba la nueva versión de x.org y tuvieron que arreglárselas como pudieron. Anyway, la versión esa parece que no es la última (ni una más nueva aún) pero pone que es una "pre-release". ¿Habrá vuelto a pasar?

+1
0
-1

“todo es un asco, así que más vale encontrar una razón para sonreír” (HOUSE, THE BEST).

Imagen de almursi
+1
0
-1

buenas, ni idea :), llevaba más de un año sin dar una vuelta por los foros y esos detalles los desconozco. El pre-release es la etiqueta que usan para señalar la beta de ubuntu, pero cuando hace unas horas que acaban de lanzar la versión no tengas prisas :), que ya aparecerá el "(pre-release freeze)" pero de ubuntu 12.04. El catalyst 11.8 es el que lleva y probándolo con tarjetas viejas y nuevas se ve bastante bien (quizá los que usen el escritorio 3D tengan más quejas de rendimiento -que esperemos se vayan arreglando-, pero no es mi caso). Saludos cordiales.

+1
0
-1
Imagen de monogato
+1
0
-1

ok, gracias. Supongo que para empezar iré poco a poco siguiendo el ritmo de los repositorios cuando instale la nueva versión (desde cero, por supuesto). Ya que el 11.8 no tiene el bug maldito al menos. :) Estaría bien poder saber que nuevas características van saliendo con cada nueva versión para ver si merece la pena arriesgarse. La verdad, no me terminaba de convencer el rendimiento con el 11.8, lo mismo es cosa mía o que ya me he acostumbrado pero lo noto ahora mejor.

+1
0
-1

“todo es un asco, así que más vale encontrar una razón para sonreír” (HOUSE, THE BEST).

Imagen de Rompe Nuca
+1
0
-1

el problema es el siguiente te driver parece estar instalado ya que tengo un Catalyst control center aunque es viejo por la disposición y utilidades del mismo en info me dice que tengo instalado el ultimo controlador el 11.8 .Pero en controladores adicionales me dice que no tengo instalado dicho driver y cuando lo quiero instalar me da un error, mi configuracion es la siguiente radeon hd 6950, 8g de ram, y un phenom II 965, mi vercion de unbuntu es la 11.10 de 64 bits, se agradece una respuesta si dejo todo asi o algo anda mal.

+1
0
-1
Imagen de DINAMIK
+1
0
-1

la herramienta de drivers de ubuntu se llama jockey, si vos cargas el driver privativo por tu cuenta, el tipo no lo reconoce. me paso en hardy.

tambien me pasan esas cosas con ubuntu tweak, si haces las cosas por atras las GUI a veces no las levantan.

si queres dejar todo prolijo, podes borrar el fglrx que instalaste a mano. agregar el ppa de x-swat/x-updates y en oneiric te va a dejar levantar el fglrx por jockey

+1
0
-1
Imagen de almursi
+1
0
-1

buenas, para saber qué tienes instalado lo más sencillo es abrir el synaptic y buscar "fglrx". Los dos paquetes que te interesan son el propio fglrx y el fglrx-amdcccle (centro de control), ambos la versión 2:8.881-0ubuntu4. Ese es el catalyst 11.8 del mes de agosto con las últimas correcciones. Puedes probar si reinstalándolos desde el synaptic se resuelva el problema y se restaura la conexión con jockey (se supone que eso lo parchearon en la versión 2:8.881-0ubuntu3, mientras el que has podido instalar bajándolo de la página de amd seguramente sea el 2:8.881-0ubuntu1). Saludos cordiales.

+1
0
-1
Imagen de 0angel007
+1
0
-1

Acabo de instalar ubuntu 11.10 y al intentar instalar driver desde controladores adicionales y me aparece un error y guarda un log en la carpeta /usr/share/ati, y dice algo de que ya hay una version de fglrx instalada pero yo no había instalado nada
ayuda!!!!

+1
0
-1
Imagen de almursi
+1
0
-1

buenas, parece que esta versión está dando algunos problemas con jockey (que es la aplicación de los controladores adicionales). Lo que comento hace un momento del synaptic puede valerte a ti también y ver qué tienes instalado (e instalarlos desde ahí si no lo están). Saludos cordiales.

+1
0
-1
Imagen de sergius.ferdinand
+1
0
-1

Hola que tal, lo que pasa es que tengo un problema con esta tarjeta de video, y es que no me la detecta.

Tengo Ubuntu 11.10, me lo baje ayer, por lo menos con este avanze mas que con el 11.04, que nisiquiera me dejaba hacer nada.

Bueno esta asi, cuando lo instale no me dejaba poner la mejor resolucion de mi monitor 1280x1024, solo tenia acceso a la 1024x768.
Ok, instale el Catalyst y me aparecieron los iconos de catalyst en las aplicaciones, pero al momento de querer accesar sale lo siguiente:

Se produjo un problema al inicializar Catalyst Control Center Edición para Linux. Lo siguiente pudo ser la causa.

No hay un controlador de gráficos AMD instalado o el controlador AMD no funciona adecuadamente.
Por favor inatale el controlador AMD de manera adecuada para su hardware AMD, o configure utilizando aticonfig.

Lo que alcanzo a comprender es que no tengo un controlador, y me hace pensar que el Catalyst no era el controlador, si no el menu para modificar el controlador.
Nose si estoy en lo correcto.

En fin, baje el driver de la pagina de ati para Linux, pero me sale como un archivo .run que nose como ejecutar, ya que el manual de ati esta en ingles.

La otra es que, instale el "Administrador de opciones compizconfig" y me sale la lista de efectos, pero claro, no me funcionan!!

Un dato mas, al instalar el Catalyst (que no me funciona) me dio acceso a las resoluciones mas altas, es decir, ya puedo poner resoluciones de 1440x900 o 1280x1024, y se ven un poco las transparencias de la lista de apps que tiene, ademas de que se mueve con mas suavidad, cosa que no hacia antes de poner el catalyst, pero igual no puedo hacer mucho mas..

Por ultimo, la lista de "Controladores adicionales" me aparece vacia, nose como agregar los de ati, ademas de que en el apartado de "Informacion del sistema" me aparecian todos los datos como, procesador, memoria, etc, pero donde dice "Graficos" dice Desconosido...

Es todo los datos que tengo, estoy barado y no se que hacer, espero me puedan ayudar C:

+1
0
-1
Imagen de almursi
+1
0
-1

buenas, mira un poco atrás:
http://www.ubuntu-es.org/node/144699#comment-452613
El controlador sólo trabaja con radeon hd actualmente. Saludos cordiales.

+1
0
-1
Imagen de sergius.ferdinand
+1
0
-1

Pues el catalyst que puse es el 11.4, creo que es de los mas recientes, creo... Y pues gracias a lo que me mostraste ya comprendi como ejecutar el .run , ya lo ise pero no me dio buenos resultados, me sale lo siguiente:

sergio@sergio-linux:~/Escritorio$ sudo sh ./ati.run --buildpkg Ubuntu/maverick
[sudo] password for sergio:
Created directory fglrx-install.NNSWYg
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.593...........................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
==================================================
ATI Technologies Linux Driver Installer/Packager
==================================================
Generating package: Ubuntu/maverick
Error: Distro Version entered incorrectly or not supported, use --listpkg to identify valid distro versions
Error: Distro Version entered incorrectly or not supported, use --listpkg to identify valid distro versions
Removing temporary directory: fglrx-install.NNSWYg
sergio@sergio-linux:~/Escritorio$

Aun no logro hacerlo funcionar completamente, que me podrian recomendar?

+1
0
-1
Imagen de almursi
+1
0
-1

por txantxar hace 2 semanas
Hola!
LLevo unos dos años con Ubuntu y desde entonces todavía no he conseguido instalar los driver de ATI. Tengo una Ati Radeon mobility X1400 y acabo de instalar el Ubuntu 11.04 Natty.
[...]
por almursi hace 2 semanas
buenas, echa un vistazo aquí:
http://wiki.cchtml.com/index.php/Hardware
El catalyst tan sólo soporta las tarjetas HD en este momento, pero puedes buscar por el foro cómo se las apañan otros usuarios con el legacy.[...]

buenas, lo que te pasaba era un enlace a un post de la página anterior, no al primero, así que no ha salido bien. El fglrx sólo funciona con tarjetas radeon HD (2xxx - 6xxx). Para la tuya te dicen:

For example, you can use Catalyst 9-3 if you're running Ubuntu 8.04 or Debian Lenny/5.0. Open source support is good and 3D is still improving.

Es decir, que te apañes con los controladores libres y te olvides de florituras 3D :) (porque el soporte a Ubuntu 8.04 diría que está cercano a caducar ya, y con pocas cosas modernas que uses no tendrás soporte en esa versión).

En cuanto a esos errores de instalación que cuentas olvídalos, aunque consiguieras arreglarlo seguiría sin funcionarte. Una opción es probar otros entornos de escritorio más simples, como el xfce de xubuntu, que no necesita de aceleración 3D, o quizá el unity 2D en ubuntu. Es cosa de probarlo y quedarte con el que te vaya mejor.

Saludos cordiales.

+1
0
-1
Imagen de sergius.ferdinand
+1
0
-1

Eso, quiere decir que las tarjetas como Radeon X1600 solo funcionan con Catalyst 9.3?
Pero esa Catalyst es obsoleto con Ubuntu 10.11? Lo ideal seria regresar a Ubuntu 8.04 para poder usar los graficos 3D?

Es todo esto correcto? Si es asi, pff... Ubuntu me a decepsionado totalmente, apesar de no ser tan recientes, esta tarjeta grafica es capaz de levantar aun un juego como Assassin's Creed Brotherhood, Splinter Cell Conviction, Resident 5, GTA IV, etc etc... No puedo creer que pueda jugar todo eso en Windows 7, y ni siquiera sea capaz de levantarse en Ubuntu :/... El soporte no me sirve, creo que tendre que regresarme a Windows u__u'...

Espero y salga algo positivo, me quedan un par de dias de esperanza :3

+1
0
-1
Imagen de sergius.ferdinand
+1
0
-1

Ya solo me queda reinstalar completamente el OS otra vez, y probar instalando en limpio el catalyst 9.3, que al parecer es aqui donde rige el problema..
Aunque por el comentario de abajo, las esperanzas se redujeron al minimo, no esperaba tener que seguir de lleno con windows 7 u__u'..

Espero y pase algo positivo para no sufrir una decepcion parte de Ubuntu y su anti-soporte para tarjetas de video ati anteriores :C.. Eso o esperar Windows 8 (:

+1
0
-1
Imagen de almursi
+1
0
-1

buenas, las quejas habría que remitirlas a amd y su decisión de descatalogar estas tarjetas, porque ubuntu aquí ni pincha ni corta nada. En realidad con los controladores libres es posible conseguir alguna aceleración, en algunas tarjetas, eso lo pruebas con glxgears. Y si a w$ no les han quitado el soporte seguramente sea por temas de contratos, en cualquier caso ahí los que usáis hardware antiguo sois bichos raros, porque w$ es el sistema por excelencia que fuerza la obsolescencia de los aparatos, mientras linux se caracteriza por todo lo contrario. Saludos cordiales.

+1
0
-1
Imagen de almursi
+1
0
-1

doble post

+1
0
-1
Imagen de sergius.ferdinand
+1
0
-1

No habra otra forma que no sea por catalyst para levantar una radeon X1600? algun otro acelerador?

+1
0
-1
Imagen de monogato
+1
0
-1

Te lo ha dicho, con el controlador que viene por defecto.

+1
0
-1

“todo es un asco, así que más vale encontrar una razón para sonreír” (HOUSE, THE BEST).

Imagen de sergius.ferdinand
+1
0
-1

Como no es posible, tendre que desachar este ubuntu :C... Ahora le intentare con Android :3

+1
0
-1
Imagen de monogato
+1
0
-1

Al fin he actualizado al horrible ubuntu 11.10 (ahora desearía no haberlo hecho, pero ya que me he metido en faena no voy a volver atrás). He instalado gnome-shell, porque el Unity es una M, pero no es compatible con el catalyst 11.8. El clásico que es el que más me interesa si que funciona más o menos pero seguro que funcionaría mejor con el 11.9 al igual que el gnome shell que si bien dicen que sigue sin ir bien del todo al menos podría probarlo. El tema es, ¿hay alguna diferencia entre los drivers bien instalados manualmente y los que proporciona el repositorio? Y otra cosa, ¿qué es eso del fglrx-updates que ni siquiera se instala bien pero te borra el normal y que es la misma versión pero con "actualizaciones post-lanzamiento"?

+1
0
-1

“todo es un asco, así que más vale encontrar una razón para sonreír” (HOUSE, THE BEST).

Imagen de almursi
+1
0
-1

buenas, el catalyst 11.9 bajado de amd a mi daba algunos errores de instalación, pero en 11.04, así que quizá estén mejor los guiones de instalación del paquete deb para 11.10 (muy posiblemente). Puedes probarlo y contarnos que tal te va :). La diferencia entre los de amd y el repositorio es depuración de errores en la instalación/desinstalación (y si incluyen alguna modificación de los binarios es de forma muy excepcional, puesto que ese tema es competencia de amd).

En los repositorios estables está ahora mismo el update4, y si cargas el driver de los repositorios experimentales en realidad asumes que puedes encontrar errores, y que están disponibles precisamente para depurarlos, notificar problemas, y que lleguen sin errores al repositorio estable. Todos tienen su "changelog", puedes ver la historia de los parches y correcciones incluidas. Si el update6 te da problemas en el synaptic puedes marcar la opción "forzar versión" sobre el paquete que te interese para usar lo que hay en el repositorio estable.

Saludos cordiales.

+1
0
-1
Imagen de monogato
+1
0
-1

Para eso instalo el último estable manualmente. Muy bueno saber que la diferencia está sólo en la instalación, así si se instala bien sabré que no tengo de qué preocuparme. Gracias.

+1
0
-1

“todo es un asco, así que más vale encontrar una razón para sonreír” (HOUSE, THE BEST).

Imagen de 1antares1
+1
0
-1

Jeje! Dios..... 62 respuestas. Tan perdido que estaba. Ésta tesis me tiene..... :S Tanto que quisiera seguir colaborando constantemente o con mayor atención en tratar de solventar los detalles y dudas, sobretodo de los iniciados en el mundo de GNU/Linux con Ubuntu, y actualmente ando en defensa del proyecto socio-tecnológico, pero bueeeh.... Sin más preámbulo y primeramente, quiero indicarle mi emoción y agradecimiento tanto a los usuarios pacientes con inconvenientes, resueltos o no, y sobretodo al usuario Almursi por integrarse en la colaboración afablemente. Un "infiltrado" para bien jeje!. Que bien.

No me leí sus mensajes completos, pero seguro pudo resolver muchos problemas de muchos usuarios que han empezado con Ubuntu. Un agradecimiento por su tiempo, espero verlo siempre por éstos lares, cuando me inactivo por un tiempo.

Gracias Furtaxi por tu párrafo y mensaje. Pués, la unión hace la fuerza, y que más que ofrecer unos 30 minutos, al menos semanal para la gran comunidad hispana (que éste blog debería ser renovado para ofrecer mejor visualización de contenidos multimedias y perfiles de usuarios) para colaborar y ser colaborado. Una distro que presenta innovaciones, y mayormente gratis y debemos agradecer, y uno de los que podemos empezar, es ayudar a los usuarios con problemas al usar Ubuntu, como lo fuimos alguna vez por aquí o por otros lados. Es la única manera de hacerle saber a las personas a nivel mundial de que existen alternativas "Libres" en el mundo, además de sistemas propietarios, caros, pesados y restrictivos.

Bueno, pude echar un ojo aquí a ver quien estaba molesto por aquí, esperando 2 semanas una respuesta jeje! Pués, al parecer todos quedaron encantados y solventados con Almursi.

Igualmente (si es que no vi que lo hicieron antes), daré algunos tips o respuestas de algunas dudas frecuentes que se presentan actualmente con Ubuntu 11.10, que a gráfica ATI se refiere.

--> Si quieren disfrutar de Gnome-3 con su Shell (Gnome-Shell), es preferiblemente usar Ubuntu 11.10. Ya que usan librerías GTK 3 de serie, donde instalar Gnome-Shell, no se cargarán librerías del GTK 2, ni creará incompatibilidades como muchos presentaban en Ubuntu 11.04. Será como instalar sólo el Shell.

--> Si desean seguir usando Gnome 2.32, usen Ubuntu 11.04 (Gnome-Clásico), Ubuntu 10.10, o incluso, Ubuntu 10.04, que les queda mucho soporte. Gnome 2.32, ya no presenta soporte oficial, al menos, en éstas versiones nombradas, si. Pero lo nuevo y soportado por sus desarrolladores principales es Unity con Gnome 3 o KDE.

--> No intenten instalar Gnome 2.32 en Ubuntu 11.10, ni tampoco Gnome-Shell en Ubuntu 11.04. Crearán incompatibilidades, muy pocas veces funciona (con suerte), y con inconvenientes, la mayoría fallan. Son librerías totalmente distintas. Colocan uno y eliminan al otro. Como instalar KDE 3 en Kubuntu 11.10 o KDE 4 en Kubuntu 7.04. Además de que en Ubuntu 11.04, sólo existen paquetes para Gnome 3.0, y no 3.2. (Según mi búsqueda).

--> Si desean usar Gnome-Shell con gráfica ATI, usen Driver Libre (por ahora). Para poder usar Gnome-shell con la mayor potencia de la gráfica, hay que esperar a la versión 11.10 (Del Driver Catalyst para GNU/Linux desde su web), que al parecer traerá listo el parche para poder ser usado en Gnome-Shell, sin problemas de visualización y Aceleración 3D. Recuerden que Gnome-Shell, si o si, hace falta Aceleración 3D, cosa que Unity 2D no. (Incluso, ya no se diferencia Unity 3D del 2D. El 2D Funciona perfecto y muy liviano).

--> Ubuntu 11.10 y 11.04, pueden ser usados perfectamente con el Driver Propietario (FGLRX - Catalyst), si a Unity se refiere.

Igualmente, pueden usar KDE (o Kubuntu 11.10), con ATI.

Encarecidamente, recomiendo que traten de usar Drivers Propietarios, ya que a pesar de sus intermediarios y problemas extraños, ofrece la mejor potencia para nuestras tarjetas gráficas y conoce mejor nuestro chip, que el driver libre que está hecho a punta de Ingenería inversa (Gran trabajo, por cierto), y evita que se recaliente, o dispare temperaturas que el driver no sepa manejar.

Y muchos dirán ¿Qué es eso de Gnome y KDE? Simplemente, entornos de escritorios.

Unity y Gnome-Shell, son Shells (Capas o entornos visuales, superpuestos y estrictamente personalizados), que van a base del entorno gráfico, sea Gnome 3 Base o el Plasma-Shell de KDE.

Igualmente, podrán verse una diferencia clara acá de entornos de escritorios, con imágenes y sus ventajas y desventajas:

Por último, si desean hacer uso del Driver de ATI privativo (FGLRX), sólo búsquenlo en "Controladores Restringidos" o en el Centro de Software "FGLRX", y listo! Lo instalan con 1 clic.

Generan el archivo de configuración (aunque ya no es necesario, pero es mejor tenerlo y sabemos que estará allí cuando algún día, mes o año, lo necesitaremos. Pero sigue presentando como un 5% de importancia en el sistema. Pero ATI lo necesita al menos para iniciar -según versiones muy anteriores de Ubuntu), y listo.

sudo aticonfig --initial -f

Ahora si, un saludo cordial. Cualquier duda, inconveniente o crítica, avisen! Comenten! Sean libres para bien. ;)

Si no reciben una respuesta (de mi parte) en días, seguro estaré ocupado en estudios. Igualmente, trataré de conectarme ésta semana. ;)

+1
0
-1

30 de Marzo 2008 - [Gabi & José] | Numeoli

Sólo hay 2 clases de personas. Las que piensan que hay 2 clases de personas y las que no.

Imagen de almursi
+1
0
-1

buenas 1antares1, lo cierto es que me preguntaba por dónde andabas :). Gracias por tus aportaciones (y constancia). Saludos cordiales.

+1
0
-1
Imagen de maurocorvalan
+1
0
-1

Hola instale Ubuntu 11.10 y desde Synaptic quiero instalar los drivers para mi targeta ATI y me encuentro con FGRLX y FGRLX UPDATE.Cual es la diferencia entre ellos ?
Gracias ..

+1
0
-1

Árbol sin raíces no aguanta parado ningún temporal...

Imagen de almursi
+1
0
-1

buenas, el "updates" lleva el update6 del que hablamos más arriba, pero el plan que tengan en ubuntu no lo sé, pero por lo pronto parece que te dejan elegir si quieres probar el paquete con los cambios de última hora sin necesidad de añadir un repositorio experimental adicional. Saludos cordiales.

+1
0
-1
Imagen de monogato
+1
0
-1

welcome back 1antares1! Me encanta gnome-shell, o mejor dicho, me encantará cuando esté un poco más depurado. Por lo pronto no es tan bueno como gnome 2 pero es lo mejor que puedes tener con ubuntu 11.10. Al tema, has dicho que no se puede usar gnome-shell con el driver privativo, pues según mi experiencia personal con el 11.8 (el que viene en los repositorios oficiales) no pero con el 11.9 (instalado manualmente) sí. No de forma perfecta. pero mejor eso que usar el libre.

+1
0
-1

“todo es un asco, así que más vale encontrar una razón para sonreír” (HOUSE, THE BEST).

Imagen de DvidC
+1
0
-1

hola, soy muy nuevo en esto, me gustaria saber porque no puedo usar unity 3d.
mi targeta es una ati 9200 pro. he instalado ubuntu 11.10, lo tengo limpio con drivers libres y cuando compruevo si tengo renderizacion 3d, me dice que si.
no se si tengo que instalar los privativos, si fuese el caso, me gustaria saber de algun tutorial sencillo o mas bien para torpes como yo. UN SALUDO Y GRACIAS DE ANTEMANO

+1
0
-1
Imagen de almursi
+1
0
-1

buenas, prueba con este comando en consola:

/usr/lib/nux/unity_support_test -p

Y si tienes alguna duda copias la salida y la pegas por aquí. Si todo te sale a "Yes" debería funcionarte, pero con ese modelo me temo que tienes que conformarte con el controlador libre.

p.d.: cuidado con el bloqueo de mayúsculas, no se puede usar en ningún foro

Saludos cordiales.

+1
0
-1

Páginas