(Solucionado) Wifi con wicd en Atheros. No funciona.

Imagen de koalera
0 puntos

Decidí cambiarme a ubuntu hace poco, así que no tengo demasiados conocimientos de nada, instalé el ubuntu 9.10 y descubrí que no era capaz de conectarme a internet por wifi (aunque si por cable).
Cambié el network-manager por wicd siguiendo las recomendaciones de varios foros y no se me solucionó el problema. Ahora, wicd intenta conectarse pero se queda parado en "Obteniendo direccion IP" y acaba diciendo que es "Imposible obtener dirección IP". Empiezo a desesperarme, estoy probando de todo, pero no hay manera.
Tengo un Amilo Pa1510 con una tarjeta Atheros. Los drivers que tengo instalados son ath5k.
Tenia entendido que mi tarjeta wifi era una ar5005g, pero del lspci saco esto:

*-network:0
description: Wireless interface
product: AR2413 802.11bg NIC
vendor: Atheros Communications Inc.
physical id: 3

No sé si hace falta más información, porque no tengo ni idea de qué es lo que falla...
Veo que mi problema se parece a esto:
http://www.ubuntu-es.org/?q=node/122022
pero no sé qué es eso de los módulos, ni cual tendría que poner yo.
Muchas gracias a todo el que pueda echar una mano.

Imagen de koalera
+1
0
-1

Bueno, nadie me respondió pero igualmente conseguí solucionar el problema. Para los que estén dándole vueltas a lo mismo, lo que hice fue instalar el controlador madwifi. No me hizo falta ni poner el wicd, con el madwifi funciona ya el network-manager y a mi me va bastante bien, se conecta automaticamente al iniciar el pc y no puedo quejarme de velocidad ni nada.
El tutorial podéis encontrarlo aqui.

+1
0
-1