Problemas con tarjeta de audio, cámara y tapa en Asus a52j [Solucionado]

Imagen de Akane
0 puntos

Como digo en el título del tema, estoy teniendo varios problemas para hacer funcionar bien la Ubuntu 10.10 en mi nuevo Asus A52J según el mismo portátil, ó Asus K52Jc según la página de Asus.

Ya había creado un tema sobre problemas con las 2 tarjetas gráficas q trae. Una vez un poco "ignorado" este problema para poder continuar he descubierto otros.

He encontrado temas en foros con problemas parecidos, pero ninguno resuelto, a ver si me podéis echar una mano.

1.- La tarjeta de audio, q es integrada del procesador, un Core i5, no me detecta la salida de auriculares ni la entrada de un micrófono externo. Si enchufo unos auriculares, me sigue sonando por los altavoces, con el micrófono pasa igual, enchufo el externo y sólo sigue pillando el integrado.No me aparece la opción de conmutar la salida en las opciones de audio. Es decir, que no pilla en ningún momento los conectores de entrada/salida audio, es como si no los tuviera.

2.- La cámara web me la pilla, pero me invierte la imagen en vertical (cabeza abajo).

3.- No puedo cerrar la tapa cuando lo tengo en funcionamiento porque se queda bloqueado.

Realmente los problemas 2 y 3 no es q me impidan el uso normal de mi pc, pero es incómodo, estaría más apurada en resolver el del audio.

Muchas gracias a todo aquel q me pueda echar una mano.

Un saludo.

Imagen de AlejandroHG
+1
0
-1

Hola Akane, tenía los mismos problemas que tú y conseguí solucionar alguno, a ver si te puedo echar una mano.

Lo primero decirte que tengo el kernel 2.6.35-24, no sé si esto influye, pero yo que tú actualizaría de no tenerlo por si acaso.

Después, para el tema del sonido, abre un terminal y escribe:

sudo gedit /etc/modprobe.d/alsa-base.conf

Y dentro copia lo siguiente al final:

options snd-hda-intel model=hp-laptop

Reinicia y listo, ya va bien.

Con respecto a la cámara, abre una terminal y copia lo siguiente:

sudo add-apt-repository ppa:libv4l/ppa && sudo apt-get update && sudo apt-get upgrade

Un saludo.

+1
0
-1
Imagen de Akane
+1
0
-1

Muchas gracias por responder, probaré con tus sugerencias a ver si va y ya cuento que ocurre. Y perdón por tardar en contestar, es que estoy con exámenes y no me he puesto mucho con el ordenador.

Aprovecho para decir que el problema de la tapa, al ser el más sencillo, sí lo he podido solucionar, si a alguien más le pasa, para arreglarlo sólo hay que ir a: Preferencias -> Gestor de energía

Una vez ahí en todas las pestañas en la sección de "al cerrar la tapa del portátil", cambiarlo por oscurecer la pantalla. A mí simplemente con eso se me dejó de bloquear, espero q les sirva a los q tengan el mismo problema.

Un saludo.

+1
0
-1
Imagen de Akane
+1
0
-1

Muchísimas gracias, ahora sí me van las 2 cosas, yo y mis vecinos te lo agradecemos :) (lo de mis vecinos x lo de los cascos, la cámara les daría un tanto igual :P).

PD: Bueno... en realidad perfecto no me va todavía, ahora me ha dejado de pillar el micrófono integrado y sólo me lo pilla externo, pero al ser algo menos importante ya lo miraré con calma.

Un saludo y muchas gracias de nuevo!!

+1
0
-1
Imagen de AlejandroHG
+1
0
-1

Con respecto a lo de la tapa, tu forma de eliminar el problema es muy sencilla, la verdad, eso me gusta.

Sin embargo, no eliminamos el problema principal, que se da porque ocurre algo que está mal cuando se suspende el equipo; buscando he encontrado esto; ahora bien, NO lo he probado, y al considerar que tu solución vale, igual lo de toquetear no apetece tanto, pero en principio aseguran que soluciona el problema, para el que quiera probar, aquí queda:

SUSPENDER: necesitas crear un nuevo archivo con estos comandos:

sudo gedit /etc/pm/sleep.d/20_custom-ehci_hcd

#!/bin/sh
# File: "/etc/pm/sleep.d/20_custom-ehci_hcd".
case "${1}" in
hibernate|suspend)
# Unbind ehci_hcd for first device 0000:00:1a.0:
echo -n "0000:00:1a.0" | tee /sys/bus/pci/drivers/ehci_hcd/unbind
# Unbind ehci_hcd for second device 0000:00:1d.0:
echo -n "0000:00:1d.0" | tee /sys/bus/pci/drivers/ehci_hcd/unbind
;;
resume|thaw)
# Bind ehci_hcd for first device 0000:00:1a.0:
echo -n "0000:00:1a.0" | tee /sys/bus/pci/drivers/ehci_hcd/bind
# Bind ehci_hcd for second device 0000:00:1d.0:
echo -n "0000:00:1d.0" | tee /sys/bus/pci/drivers/ehci_hcd/bind
;;
esac
sudo chmod +x /etc/pm/sleep.d/20_custom-ehci_hcd

A ver si puedo ponerme luego con el tema del micro integrado, que ahora estoy de exámanes :D

Un saludo.

+1
0
-1
Imagen de AlejandroHG
+1
0
-1

Lo que pone sudo, la primera y la última instrucción, se ejecuta en terminal, lo otro va en el archivo, y ya suspende cuando bajas la tapa, así que puedes hacerlo con total confianza ;)

Un saludo.

PD: Ah por cierto, ¿qué más decías que te pasaba?

+1
0
-1
Imagen de Akane
+1
0
-1

Muchas gracias por tu ayuda :)

Perdona si tardo mucho en contestar, si eres estudiante tb estarás sufriendo los exámenes.

Con lo de la suspensión del equipo era que se quedaba bloqueada la ubuntu, y había q apagar el equipo (a lo bruto, con el botón) y luego volverlo a encender. ¿Te referías a eso?

Un saludo y muchas gracias.

+1
0
-1
Imagen de AlejandroHG
+1
0
-1

Por defecto tiene puesto cuando cierras la tapa suspender y se quedaba pillado.

Si pones esto, ya puedes cerrar y luego abrir y hace lo que debe, espera a que pulses una tecla para volver a entrar y bien, y ya puedes "apagar" cerrando la tapa ;)

Y sí, tengo examenes! muchos! todos! xD

Un saludo

+1
0
-1
Imagen de Akane
+1
0
-1

He probado lo que me pusiste para lo de la suspensión, pero se me sigue bloqueando, lo que esta vez en lugar de quedarse la pantalla en negro, se me queda con la pantalla de carga de Ubuntu.

Aún así muchas gracias :) ese es un tema menor dado que no tengo costumbre de poner el portátil en suspensión.

A ver si me pongo yo tb con lo del micro, q como ahora he estado mirando otra cosa q no me va lo tengo algo aparcado.

Mil gracias por tu ayuda.

+1
0
-1
Imagen de AlejandroHG
+1
0
-1

Bien Akane, resulta que se ha arreglado el conflicto de gráficas; al parecer este era debido a un programa llamado Optimus de Nvidia que no estaba soportado; pero alguien ha creado uno para linux, bumblebee; sigue las instrucciones ahí dadas, son claras y sencillas; una pasada, la batería aumenta su vida una barbaridad:

http://www.codigo12.com/2011/08/02/howto-configurando-bumblebee-nvidia-o...

Un saludo.

PD: "He probado lo que me pusiste para lo de la suspensión, pero se me sigue bloqueando, lo que esta vez en lugar de quedarse la pantalla en negro, se me queda con la pantalla de carga de Ubuntu."

-> Eso es porque se está suspendiendo y abres, prueba a cerrarla, dejarla un par de minutos, vuelva a abrir y dale a un biotón, ya verás ;)

+1
0
-1
Imagen de Akane
+1
0
-1

Muchas gracias por la ayuda :)

Perdona por tardar en contestar, pero más vale tarde que nunca, ¿no?

Estoy todavía con lo del conflicto de gráficas a ver si lo consigo arreglar (lo había dejado totalmente apartado) pero parece que la solución del enlace no me termina de ir. Ahora que estos días tengo tiempo creo que lo mejor será simplemente instalar una versión más nueva de Ubuntu.

¡Muchísimas gracias por la ayuda! Un saludo.

+1
0
-1
Imagen de AlejandroHG
+1
0
-1

Hola Akane, qué tal.

Mira, yo ahora lo que te recomiendo es que te pongas la 11.10 pero más que nada porque va más fina para mi gusto y el Unity está mejorado, y para las gráficas el ironhide, que soluciona lo de las gráficas de una forma sencilla y dirigida, con luego su iconito y todo.

http://community.linuxmint.com/tutorial/view/610

Ahí viene cómo instalarlo, es sencillo y cómodo. Y luego funciona bien :)

Un saludo.

+1
0
-1
Imagen de AlejandroHG
+1
0
-1

Cuéntame qué tal ;)

+1
0
-1
Imagen de AlejandroHG
+1
0
-1

Por cierto, en el Skype parece que se me ve la cam al revés, ¿te ocurre esto? Un saludo.

+1
0
-1