instalcion de wpa_supplicant

+1
+1
-1

Hola a todos, este articulo, tratara de como instalar wpa_suplicant en ubuntu 10.04 lts (mi distro).
Hace poco tiempo actualice mi ubuntu, sin mirar los paquetes, llevaba varias semanas sin actualicar y lo drei necesaario,
lo que sucedio fue, que desde esta actualizacion no puedo acceder al WIFI de mis vecinos, los cuales, muy amablemente
los dejan abierto.

Despues de varios intentos fallidos de conectarme, abri el visor de sucesos y en la etiqueta "syslog" podia ver toda la
secuencia de conesion. Estos fueron algunos de los fallos que encontre:

wpa_supplicant[1171]: Association request to the driver failed
***************************
dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 9
dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 15
dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 12
dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 14
dhclient: No DHCPOFFERS received.
dhclient: No working leases in persistent database - sleeping.
***************************
kernel: [ 4918.182933] type=1503 audit(1293906839.770:18): operation="open" pid=6401 parent=6381 profile="/sbin/dhclient3" requested_mask="r::" denied_mask="r::" fsuid=0 ouid=0 name="/var/lib/wicd/dhclient.conf"
***************************
NetworkManager: nm_setting_802_1x_get_pkcs11_engine_path: assertion `NM_IS_SETTING_802_1X (setting)' failed
Unmanaged Device found; state CONNECTED forced. (see http://bugs.launchpad.net/bugs/191889)

Todos esto "fallos" no los visualizaba antes de la actualizacion. Estos son los paquetes que actualice:

Start-Date: 2010-12-24 12:41:59
Install: linux-image-2.6.32-27-generic (2.6.32-27.49), linux-headers-2.6.32-27-generic (2.6.32-27.49), linux-headers-2.6.32-27 (2.6.32-27.49)
Upgrade: libsmbclient (3.4.7~dfsg-1ubuntu3.1, 3.4.7~dfsg-1ubuntu3.2),
lib32bz2-1.0 (1.0.5-4, 1.0.5-4ubuntu0.1),
dmsetup (1.02.39-1ubuntu4, 1.02.39-1ubuntu4.1),
python-packagekit (0.5.7-0ubuntu2.1, 0.5.7-0ubuntu2.2),
libkrb5-3 (1.8.1+dfsg-2ubuntu0.2, 1.8.1+dfsg-2ubuntu0.4),
libpurple0 (2.6.6-1ubuntu4, 2.6.6-1ubuntu4.2),
libk5crypto3 (1.8.1+dfsg-2ubuntu0.2, 1.8.1+dfsg-2ubuntu0.4),
apt-transport-https (0.7.25.3ubuntu9.1, 0.7.25.3ubuntu9.3),
libpackagekit-qt-12 (0.5.7-0ubuntu2.1, 0.5.7-0ubuntu2.2),
dnsmasq-base (2.52-1, 2.52-1ubuntu0.1),
bzip2 (1.0.5-4, 1.0.5-4ubuntu0.1),
filezilla (3.3.1-1ubuntu1, 3.3.1-1ubuntu2),
libc-bin (2.11.1-0ubuntu7.2, 2.11.1-0ubuntu7.6),
libgutenprint2 (5.2.5-0ubuntu1, 5.2.5-0ubuntu1.1),
erlang-crypto (13.b.3-dfsg-2ubuntu2, 13.b.3-dfsg-2ubuntu2.1),
libcupsppdc1 (1.4.3-1ubuntu1.2, 1.4.3-1ubuntu1.3),
ttf-thai-tlwg (0.4.13-4, 0.4.13-4ubuntu0.1),
libqt4-qt3support (4.6.2-0ubuntu5, 4.6.2-0ubuntu5.1),
libwebkit-1.0-common (1.2.0-1, 1.2.5-0ubuntu0.10.04.1),
libpurple-bin (2.6.6-1ubuntu4, 2.6.6-1ubuntu4.2),
bind9-host (9.7.0.dfsg.P1-1, 9.7.0.dfsg.P1-1ubuntu0.1),
libcupsimage2 (1.4.3-1ubuntu1.2, 1.4.3-1ubuntu1.3),
python-mako (0.2.5-2ubuntu1, 0.2.5-2ubuntu1.3),
python-avahi (0.6.25-1ubuntu6, 0.6.25-1ubuntu6.1),
nspluginwrapper (1.2.2-0ubuntu6, 1.2.2-0ubuntu6.10.04.1),
libcupscgi1 (1.4.3-1ubuntu1.2, 1.4.3-1ubuntu1.3),
libgudev-1.0-0 (151-12, 151-12.3),
poppler-utils (0.12.4-0ubuntu5, 0.12.4-0ubuntu5.1),
libcomerr2 (1.41.11-1ubuntu2, 1.41.11-1ubuntu2.1),
erlang-xmerl (13.b.3-dfsg-2ubuntu2, 13.b.3-dfsg-2ubuntu2.1),
smbclient (3.4.7~dfsg-1ubuntu3.1, 3.4.7~dfsg-1ubuntu3.2),
libcupsdriver1 (1.4.3-1ubuntu1.2, 1.4.3-1ubuntu1.3),
linux-image-2.6.32-24-generic (2.6.32-24.41, 2.6.32-24.43),
cheese (2.30.1-0ubuntu1, 2.30.1-0ubuntu2),
libmagickcore2 (6.5.7.8-1ubuntu1, 6.5.7.8-1ubuntu1.1),
gdebi (0.6.0ubuntu1, 0.6.0ubuntu2),
libxml2-utils (2.7.6.dfsg-1ubuntu1, 2.7.6.dfsg-1ubuntu1.1),
dnsutils (9.7.0.dfsg.P1-1, 9.7.0.dfsg.P1-1ubuntu0.1),
mysql-server (5.1.41-3ubuntu12.7, 5.1.41-3ubuntu12.8),
comerr-dev (2.1-1.41.11-1ubuntu2, 2.1-1.41.11-1ubuntu2.1),
wine1.2 (1.1.42-0ubuntu4, 1.2-0ubuntu6~lucid5),
libbz2-1.0 (1.0.5-4, 1.0.5-4ubuntu0.1),
update-inetd (4.35, 4.35ubuntu0.1),
gnome-settings-daemon (2.30.1-0ubuntu1, 2.30.1-0ubuntu1.1),
libqt4-test (4.6.2-0ubuntu5, 4.6.2-0ubuntu5.1),
libqt4-script (4.6.2-0ubuntu5, 4.6.2-0ubuntu5.1),
libqt4-designer (4.6.2-0ubuntu5, 4.6.2-0ubuntu5.1),
erlang-syntax-tools (13.b.3-dfsg-2ubuntu2, 13.b.3-dfsg-2ubuntu2.1),
xserver-xorg-core (1.7.6-2ubuntu7.3, 1.7.6-2ubuntu7.4),
libqt4-network (4.6.2-0ubuntu5, 4.6.2-0ubuntu5.1),
libqt4-dbus (4.6.2-0ubuntu5, 4.6.2-0ubuntu5.1),
bogofilter-bdb (1.2.1-0ubuntu1, 1.2.1-0ubuntu1.1),
libavahi-glib-dev (0.6.25-1ubuntu6, 0.6.25-1ubuntu6.1),
python-imaging (1.1.7-1, 1.1.7-1ubuntu0.1),
xserver-common (1.7.6-2ubuntu7.3, 1.7.6-2ubuntu7.4),
libapparmor-perl (2.5-0ubuntu3, 2.5.1-0ubuntu0.10.04.1),
empathy-common (2.30.2-0ubuntu1, 2.30.3-0ubuntu1),
libmagickwand2 (6.5.7.8-1ubuntu1, 6.5.7.8-1ubuntu1.1),
phonon (4.6.2-0ubuntu5, 4.6.2-0ubuntu5.1),
libdevmapper1.02.1 (1.02.39-1ubuntu4, 1.02.39-1ubuntu4.1),
libcheese-gtk18 (2.30.1-0ubuntu1, 2.30.1-0ubuntu2),
gnome-terminal (2.29.6-0ubuntu5, 2.30.2-0ubuntu1),
hpijs (3.10.2-2ubuntu2, 3.10.2-2ubuntu2.1),
linux-generic (2.6.32.24.25, 2.6.32.27.29),
smbfs (3.4.7~dfsg-1ubuntu3.1, 3.4.7~dfsg-1ubuntu3.2),
python-software-properties (0.75.10, 0.75.10.1),
cups-client (1.4.3-1ubuntu1.2, 1.4.3-1ubuntu1.3),
mobile-broadband-provider-info (20100407-1, 20100716-1ubuntu0.1),
screen (4.0.3-14ubuntu1, 4.0.3-14ubuntu1.2),
libdns64 (9.7.0.dfsg.P1-1, 9.7.0.dfsg.P1-1ubuntu0.1),
hplip (3.10.2-2ubuntu2, 3.10.2-2ubuntu2.1),
libwbclient0 (3.4.7~dfsg-1ubuntu3.1, 3.4.7~dfsg-1ubuntu3.2),
icedtea-6-jre-cacao (6b18-1.8.1-0ubuntu1, 6b20-1.9.2-0ubuntu1~10.04.1),
empathy (2.30.2-0ubuntu1, 2.30.3-0ubuntu1),
libnspr4-0d (4.8.4-0ubuntu1, 4.8.6-0ubuntu0.10.04.2),
usb-creator-gtk (0.2.22, 0.2.22.1),
gdebi-core (0.6.0ubuntu1, 0.6.0ubuntu2),
libavahi-glib1 (0.6.25-1ubuntu6, 0.6.25-1ubuntu6.1),
libkrb5-dev (1.8.1+dfsg-2ubuntu0.2, 1.8.1+dfsg-2ubuntu0.4),
libcouchdb-glib-1.0-2 (0.6.3-0ubuntu1, 0.6.3-0ubuntu2),
mysql-server-core-5.1 (5.1.41-3ubuntu12.7, 5.1.41-3ubuntu12.8),
plymouth-label (0.8.2-2ubuntu2, 0.8.2-2ubuntu2.1),
libavahi-client-dev (0.6.25-1ubuntu6, 0.6.25-1ubuntu6.1),
openjdk-6-jre-lib (6b18-1.8.1-0ubuntu1, 6b20-1.9.2-0ubuntu1~10.04.1),
libfreetype6 (2.3.11-1ubuntu2.2, 2.3.11-1ubuntu2.4),
firefox-branding (3.6.8+build1+nobinonly-0ubuntu0.10.04.1,
3.6.13+build3+nobinonly-0ubuntu0.10.04.1),
e2fsprogs (1.41.11-1ubuntu2, 1.41.11-1ubuntu2.1),
plymouth-theme-ubuntu-logo (0.8.2-2ubuntu2, 0.8.2-2ubuntu2.1),
libqt4-opengl (4.6.2-0ubuntu5, 4.6.2-0ubuntu5.1),
grub-pc (1.98-1ubuntu7, 1.98-1ubuntu9),
libmagickcore2-extra (6.5.7.8-1ubuntu1, 6.5.7.8-1ubuntu1.1),
libmysqlclient16 (5.1.41-3ubuntu12.7, 5.1.41-3ubuntu12.8),
libisccc60 (9.7.0.dfsg.P1-1, 9.7.0.dfsg.P1-1ubuntu0.1),
avahi-utils (0.6.25-1ubuntu6, 0.6.25-1ubuntu6.1),
libc6-i386 (2.11.1-0ubuntu7.2, 2.11.1-0ubuntu7.6),
libgssrpc4 (1.8.1+dfsg-2ubuntu0.2, 1.8.1+dfsg-2ubuntu0.4),
apt-utils (0.7.25.3ubuntu9.1, 0.7.25.3ubuntu9.3),
libqt4-xmlpatterns (4.6.2-0ubuntu5, 4.6.2-0ubuntu5.1),
update-manager (0.134.10, 0.134.11),
indicator-sound (0.2.3-0ubuntu1, 0.2.6-0ubuntu1),
erlang-runtime-tools (13.b.3-dfsg-2ubuntu2,
13.b.3-dfsg-2ubuntu2.1),
update-manager-core (0.134.10, 0.134.11),
openjdk-6-jre-headless (6b18-1.8.1-0ubuntu1,
6b20-1.9.2-0ubuntu1~10.04.1),
libavahi-common-data (0.6.25-1ubuntu6, 0.6.25-1ubuntu6.1),
libavahi-core6 (0.6.25-1ubuntu6, 0.6.25-1ubuntu6.1),
samba-common (3.4.7~dfsg-1ubuntu3.1, 3.4.7~dfsg-1ubuntu3.2),
app-install-data-partner (12.10.04.3, 12.10.04.4),
udev (151-12, 151-12.3),
python-aptdaemon (0.11+bzr345-0ubuntu4, 0.11+bzr345-0ubuntu4.1),
libqt4-help (4.6.2-0ubuntu5, 4.6.2-0ubuntu5.1),
apt (0.7.25.3ubuntu9.1, 0.7.25.3ubuntu9.3),
firefox (3.6.8+build1+nobinonly-0ubuntu0.10.04.1, 3.6.13+build3+nobinonly-0ubuntu0.10.04.1),
libpango1.0-common (1.28.0-0ubuntu2, 1.28.0-0ubuntu2.1),
python-desktopcouch (0.6.4-0ubuntu3, 0.6.4-0ubuntu3.1),
apparmor-utils (2.5-0ubuntu3, 2.5.1-0ubuntu0.10.04.1),
cups-common (1.4.3-1ubuntu1.2, 1.4.3-1ubuntu1.3),
libhpmud0 (3.10.2-2ubuntu2, 3.10.2-2ubuntu2.1),
liblwres60 (9.7.0.dfsg.P1-1, 9.7.0.dfsg.P1-1ubuntu0.1),
bogofilter-common (1.2.1-0ubuntu1, 1.2.1-0ubuntu1.1),
linux-headers-2.6.32-24 (2.6.32-24.41, 2.6.32-24.43),
libcups2 (1.4.3-1ubuntu1.2, 1.4.3-1ubuntu1.3),
gdm (2.30.2.is.2.30.0-0ubuntu3, 2.30.2.is.2.30.0-0ubuntu4),
libqtcore4 (4.6.2-0ubuntu5, 4.6.2-0ubuntu5.1),
libavahi-ui0 (0.6.25-1ubuntu6, 0.6.25-1ubuntu6.1),
libkrb5support0 (1.8.1+dfsg-2ubuntu0.2, 1.8.1+dfsg-2ubuntu0.4),
sudo (1.7.2p1-1ubuntu5.1, 1.7.2p1-1ubuntu5.2),
mysql-client-core-5.1 (5.1.41-3ubuntu12.7, 5.1.41-3ubuntu12.8),
cups-driver-gutenprint (5.2.5-0ubuntu1, 5.2.5-0ubuntu1.1),
libssl-dev (0.9.8k-7ubuntu8, 0.9.8k-7ubuntu8.5),
ttf-symbol-replacement (1.1.42-0ubuntu4, 1.2-0ubuntu6~lucid5),
xulrunner-1.9.2 (1.9.2.8+build1+nobinonly-0ubuntu0.10.04.1, 1.9.2.13+build3+nobinonly-0ubuntu0.10.04.1),
tzdata-java (2010k-0ubuntu0.10.04, 2010o-0ubuntu0.10.04),
icoutils (0.26.0-4ubuntu1, 0.29.1-0ubuntu1~lucid),
erlang-mnesia (13.b.3-dfsg-2ubuntu2, 13.b.3-dfsg-2ubuntu2.1),
libpoppler5 (0.12.4-0ubuntu5, 0.12.4-0ubuntu5.1),
software-properties-gtk (0.75.10, 0.75.10.1),
cheese-common (2.30.1-0ubuntu1, 2.30.1-0ubuntu2),
software-properties-kde (0.75.10, 0.75.10.1),
linux-headers-generic (2.6.32.24.25, 2.6.32.27.29),
dpkg (1.15.5.6ubuntu4.1, 1.15.5.6ubuntu4.4),
erlang-public-key (13.b.3-dfsg-2ubuntu2, 13.b.3-dfsg-2ubuntu2.1),
aptdaemon (0.11+bzr345-0ubuntu4, 0.11+bzr345-0ubuntu4.1),
libxml2 (2.7.6.dfsg-1ubuntu1, 2.7.6.dfsg-1ubuntu1.1),
libbind9-60 (9.7.0.dfsg.P1-1, 9.7.0.dfsg.P1-1ubuntu0.1),
linux-image-generic (2.6.32.24.25, 2.6.32.27.29),
gnome-terminal-data (2.29.6-0ubuntu5, 2.30.2-0ubuntu1),
cups (1.4.3-1ubuntu1.2, 1.4.3-1ubuntu1.3),
libpoppler-glib4 (0.12.4-0ubuntu5, 0.12.4-0ubuntu5.1),
bogofilter (1.2.1-0ubuntu1, 1.2.1-0ubuntu1.1),
libxml2-dev (2.7.6.dfsg-1ubuntu1, 2.7.6.dfsg-1ubuntu1.1),
libqt4-sql (4.6.2-0ubuntu5, 4.6.2-0ubuntu5.1),
flashplugin-installer (10.1.82.76ubuntu0.10.04.2, 10.1.102.65ubuntu0.10.04.1),
libqt4-svg (4.6.2-0ubuntu5, 4.6.2-0ubuntu5.1),
python-aptdaemon-gtk (0.11+bzr345-0ubuntu4, 0.11+bzr345-0ubuntu4.1),
python-desktopcouch-records (0.6.4-0ubuntu3, 0.6.4-0ubuntu3.1),
wine (1.1.42-0ubuntu4, 1.2-0ubuntu6~lucid5),
tar (1.22-2, 1.22-2ubuntu1),
libpango1.0-dev (1.28.0-0ubuntu2, 1.28.0-0ubuntu2.1),
libfreetype6-dev (2.3.11-1ubuntu2.2, 2.3.11-1ubuntu2.4),
dpkg-dev (1.15.5.6ubuntu4.1, 1.15.5.6ubuntu4.4),
gwibber-service (2.30.1-0ubuntu1, 2.30.3-0ubuntu1),
libphonon4 (4.6.2-0ubuntu5, 4.6.2-0ubuntu5.1),
e2fslibs (1.41.11-1ubuntu2, 1.41.11-1ubuntu2.1),
libqt4-xml (4.6.2-0ubuntu5, 4.6.2-0ubuntu5.1),
packagekit (0.5.7-0ubuntu2.1, 0.5.7-0ubuntu2.2),
fglrx-modaliases (8.723.1-0ubuntu4, 8.723.1-0ubuntu5),
mysql-client (5.1.41-3ubuntu12.7, 5.1.41-3ubuntu12.8),
filezilla-common (3.3.1-1ubuntu1, 3.3.1-1ubuntu2),
cups-bsd (1.4.3-1ubuntu1.2, 1.4.3-1ubuntu1.3),
libqt4-assistant (4.6.2-0ubuntu5, 4.6.2-0ubuntu5.1),
gdebi-kde (0.6.0ubuntu1, 0.6.0ubuntu2),
desktopcouch (0.6.4-0ubuntu3, 0.6.4-0ubuntu3.1),
erlang-inets (13.b.3-dfsg-2ubuntu2, 13.b.3-dfsg-2ubuntu2.1),
libkadm5clnt-mit7 (1.8.1+dfsg-2ubuntu0.2, 1.8.1+dfsg-2ubuntu0.4),
libapparmor1 (2.5-0ubuntu3, 2.5.1-0ubuntu0.10.04.1),
libudev0 (151-12, 151-12.3),
update-manager-kde (0.134.10, 0.134.11),
libpq-dev (8.4.4-0ubuntu10.04, 8.4.5-0ubuntu10.04),
libplymouth2 (0.8.2-2ubuntu2, 0.8.2-2ubuntu2.1),
libwebkit-1.0-2 (1.2.0-1, 1.2.5-0ubuntu0.10.04.1),
libisccfg60 (9.7.0.dfsg.P1-1, 9.7.0.dfsg.P1-1ubuntu0.1),
usb-creator-common (0.2.22, 0.2.22.1),
libkadm5srv-mit7 (1.8.1+dfsg-2ubuntu0.2, 1.8.1+dfsg-2ubuntu0.4),
libc6-dev (2.11.1-0ubuntu7.2, 2.11.1-0ubuntu7.6),
libqtgui4 (4.6.2-0ubuntu5, 4.6.2-0ubuntu5.1),
plymouth-x11 (0.8.2-2ubuntu2, 0.8.2-2ubuntu2.1),
apparmor (2.5-0ubuntu3, 2.5.1-0ubuntu0.10.04.1),
tzdata (2010k-0ubuntu0.10.04, 2010o-0ubuntu0.10.04),
libpackagekit-glib2-12 (0.5.7-0ubuntu2.1, 0.5.7-0ubuntu2.2),
avahi-daemon (0.6.25-1ubuntu6, 0.6.25-1ubuntu6.1),
plymouth-theme-ubuntu-text (0.8.2-2ubuntu2, 0.8.2-2ubuntu2.1),
libavahi-client3 (0.6.25-1ubuntu6, 0.6.25-1ubuntu6.1),
libgksu2-0 (2.0.13~pre1-1ubuntu4, 2.0.13~pre1-1ubuntu4.1),
libssl0.9.8 (0.9.8k-7ubuntu8, 0.9.8k-7ubuntu8.5),
libpq5 (8.4.4-0ubuntu10.04, 8.4.5-0ubuntu10.04),
man-db (2.5.7-2, 2.5.7-2ubuntu1),
python-papyon (0.4.8-0ubuntu1, 0.4.8-0ubuntu2),
libqt4-webkit (4.6.2-0ubuntu5, 4.6.2-0ubuntu5.1),
imagemagick (6.5.7.8-1ubuntu1, 6.5.7.8-1ubuntu1.1),
openssl (0.9.8k-7ubuntu8, 0.9.8k-7ubuntu8.5),
erlang-ssl (13.b.3-dfsg-2ubuntu2, 13.b.3-dfsg-2ubuntu2.1),
libpango1.0-0 (1.28.0-0ubuntu2, 1.28.0-0ubuntu2.1),
rsyslog (4.2.0-2ubuntu8, 4.2.0-2ubuntu8.1),
libkdb5-4 (1.8.1+dfsg-2ubuntu0.2, 1.8.1+dfsg-2ubuntu0.4),
libss2 (1.41.11-1ubuntu2, 1.41.11-1ubuntu2.1),
linux-libc-dev (2.6.32-24.41, 2.6.32-27.49),
libdesktopcouch-glib-1.0-2 (0.6.3-0ubuntu1, 0.6.3-0ubuntu2),
samba-common-bin (3.4.7~dfsg-1ubuntu3.1, 3.4.7~dfsg-1ubuntu3.2),
libwww-perl (5.834-1, 5.834-1ubuntu0.1),
libqt4-sql-mysql (4.6.2-0ubuntu5, 4.6.2-0ubuntu5.1),
winbind (3.4.7~dfsg-1ubuntu3.1, 3.4.7~dfsg-1ubuntu3.2),
grub-common (1.98-1ubuntu7, 1.98-1ubuntu9),
krb5-multidev (1.8.1+dfsg-2ubuntu0.2, 1.8.1+dfsg-2ubuntu0.4),
ureadahead (0.100.0-4.1.2, 0.100.0-4.1.3),
libqt4-scripttools (4.6.2-0ubuntu5, 4.6.2-0ubuntu5.1),
libisc60 (9.7.0.dfsg.P1-1, 9.7.0.dfsg.P1-1ubuntu0.1),
libgssapi-krb5-2 (1.8.1+dfsg-2ubuntu0.2, 1.8.1+dfsg-2ubuntu0.4),
libavahi-gobject0 (0.6.25-1ubuntu6, 0.6.25-1ubuntu6.1),
libcupsmime1 (1.4.3-1ubuntu1.2, 1.4.3-1ubuntu1.3),
libc-dev-bin (2.11.1-0ubuntu7.2, 2.11.1-0ubuntu7.6),
libavahi-common-dev (0.6.25-1ubuntu6, 0.6.25-1ubuntu6.1),
mountall (2.15, 2.15.3),
libc6 (2.11.1-0ubuntu7.2, 2.11.1-0ubuntu7.6),
gzip (1.3.12-9ubuntu1, 1.3.12-9ubuntu1.1),
python-lazr.restfulclient (0.9.11-1ubuntu1, 0.9.11-1ubuntu1.1),
avahi-autoipd (0.6.25-1ubuntu6, 0.6.25-1ubuntu6.1),
libaprutil1 (1.3.9+dfsg-3build1, 1.3.9+dfsg-3ubuntu0.10.04.1),
openjdk-6-jre (6b18-1.8.1-0ubuntu1, 6b20-1.9.2-0ubuntu1~10.04.1),
libavahi-common3 (0.6.25-1ubuntu6, 0.6.25-1ubuntu6.1),
mysql-common (5.1.41-3ubuntu12.7, 5.1.41-3ubuntu12.8),
icedtea6-plugin (6b18-1.8.1-0ubuntu1, 6b20-1.9.2-0ubuntu1~10.04.1),
mysql-server-5.1 (5.1.41-3ubuntu12.7, 5.1.41-3ubuntu12.8),
libnss3-1d (3.12.6-0ubuntu3, 3.12.8-0ubuntu0.10.04.1),
firefox-gnome-support (3.6.8+build1+nobinonly-0ubuntu0.10.04.1, 3.6.13+build3+nobinonly-0ubuntu0.10.04.1),
nautilus-sendto-empathy (2.30.2-0ubuntu1, 2.30.3-0ubuntu1),
python-libxml2 (2.7.6.dfsg-1ubuntu1, 2.7.6.dfsg-1ubuntu1.1),
plymouth (0.8.2-2ubuntu2, 0.8.2-2ubuntu2.1),
libgdiplus (2.4.2-1build1, 2.4.2-1ubuntu0.10.04.1),
mysql-client-5.1 (5.1.41-3ubuntu12.7, 5.1.41-3ubuntu12.8),
hplip-data (3.10.2-2ubuntu2, 3.10.2-2ubuntu2.1),
erlang-base (13.b.3-dfsg-2ubuntu2, 13.b.3-dfsg-2ubuntu2.1),
lftp (4.0.2-1, 4.0.2-1ubuntu0.1),
packagekit-backend-apt (0.5.7-0ubuntu2.1, 0.5.7-0ubuntu2.2)
End-Date: 2010-12-24 12:49:11

Si alguien sabe cual puede ser el problema, con esta informacion, porfavor dejarme algun comentario. Gracias

Lo primero saber que version de wpasupplicant tenemos:

apt-show-versions wpasupplicant
wpasupplicant/lucid uptodate 0.6.9-3ubuntu3

En caso de no tener instalado "apt-show-version", podemos hacelos con un simple "sudo aptitude install apt-show-version"

Luego con una simple busqueda en google podemos encontrar otra version, seleccionaremos la anterior a la que tenemos instlada, si
es que esta no funciona. Tambien podemos visitar: http://packages.ubuntu.com/es/karmic/wpasupplicant y desde aqui buscar lo que mas nos
convenga.

Una vez descargada en nuestra carpeta de descargas:

tar -zxvf wpasupplicant*******.tar.gz

o

sudo dpkg -i wpasupplicant********.deb

si el archivo tiene extension "-deb", en este caso solo tenemos que esperar y el solo hace todo.
Para los que quereis compilar vuestros programas, una vez decomprimido el archivo, accedemos a la carpeta que se nos creo para descargar el
contenido del archivo, y dentro encontraremos otra carpeta llamada wpasuplicant, accediendo a ella encontraremos un README, que a mi
me fue de mucha ayuda, mi problema fue que estaba en Ingles y no tengo mucho nivel. :-)

Antes de empezar la a trabajar, recomiendo, por experiencia propia, que ahorrareis tiempo comprobando las dependencias y versiones antes,
asi no tendremos que empezar una y otra vez, como me sucedio a mi. Estos son algunos tipos de drives y web para descarga, consulta, howto,....

Necesitamos tener:

Linux kernel 2.4.x or 2.6.x with Linux Wireless Extensions v15 or newer

Host AP driver for Prism2/2.5/3 (http://hostap.epitest.fi/)

Linuxant DriverLoader, with Windows NDIS driver (http://www.linuxant.com/driverloader/)

Agere Systems Inc. Linux Driver (http://www.agere.com/support/drivers/)

madwifi driver (http://sourceforge.net/projects/madwifi/)

ATMEL AT76C5XXx driver (http://atmelwlandriver.sourceforge.net/)

Linux ndiswrapper (http://ndiswrapper.sourceforge.net/)

Broadcom wl.o driver (http://www.linksys.com/support/gpl.asp)

Intel ipw2100 driver (http://sourceforge.net/projects/ipw2100/)

Intel ipw2200 driver (http://sourceforge.net/projects/ipw2200/)

A estas altura tenemos que saber que driver le va mejor a nuestra tarjeta, sino, uno generico tipo "WEXT".

Tambien unas cuantas librerias:

libpcap 0.7.2 (http://tcpdump.org/) ?
|--- OPCIONALES
libdnet 1.4 (http://libdnet.sourceforge.net/) ?

OpenSSL 0.9.7c and 0.9.7d, and 0.9.8 versions ?
|
GnuTLS |--- EAP-TLS, EAP-PEAP, and EAP-TTLS (necesarios para estos tipos de autenticacion)
|
internal TLSv1 implementation ? ?
|--- EAP-FAST (necesarios para estos tipos de autenticacion)
OpenSSL 0.9.8d _with_ openssl-0.9.8d-tls-extensions.patch ?

Para construis wpasupplicant, primero tenemos que crear el archivo ".config" en la direccion de descarga de wpasupplicant/wpasupplicant
en mi caso (/home/ruben/Descargas/wpa_supplicant-0.7.3/wpa_supplicant). Este archivo ha ce contener:

CONFIG_IEEE8021X_EAPOL=y ?
CONFIG_EAP_MD5=y |
CONFIG_EAP_MSCHAPV2=y |
CONFIG_EAP_TLS=y |
CONFIG_EAP_PEAP=y |
CONFIG_EAP_TTLS=y |
CONFIG_EAP_GTC=y |
CONFIG_EAP_OTP=y |---tipos de autenticacion, los que no usemos, podemos borrarlos.
CONFIG_EAP_SIM=y |
CONFIG_EAP_AKA=y |
CONFIG_EAP_PSK=y |
CONFIG_EAP_SAKE=y |
CONFIG_EAP_GPSK=y |
CONFIG_EAP_PAX=y |
CONFIG_EAP_LEAP=y |
CONFIG_EAP_IKEV2=y ?

CONFIG_PCSC=y |---incluir GSM SIM/USIM interface para GSM/UMTS algoritmo de autenticacion (for EAP-SIM/EAP-AKA) (opcinal)

CONFIG_DRIVER_HOSTAP=y ?
CONFIG_DRIVER_HERMES=y |
CONFIG_DRIVER_MADWIFI=y |
CONFIG_DRIVER_ATMEL=y |
CONFIG_DRIVER_WEXT=y |
CONFIG_DRIVER_RALINK=y |---drivers de tarjeta, podemos borrar los que no usemos
CONFIG_DRIVER_NDISWRAPPER=y |
CONFIG_DRIVER_BROADCOM=y |
CONFIG_DRIVER_IPW=y |
CONFIG_DRIVER_BSD=y |
CONFIG_DRIVER_NDIS=y ?

La primera vez que cree el archivo inclui todo, y claro a la hora de hacer "make" me faltaban archivos que instalar, versiones por actualizar,
dependencias de drivers,....Aconsejo incluir lo que tengamos que usar (usar filosofia linux).

Llegado este punto y situados en al carpeta wpasupplicant, ya podemos ejecutar:

make

Si todo sale bien:

sudo cp wpa_cli wpa_supplicant /usr/local/bin

Ahora tenemos que crear el archivo wpasupplicant.conf (otro calvario), ojo con la ruta donde lo poneis, todos los demas archivos que lo nombren,
han de apuntar a la misma ruta. Puede ser que ya lo tengamos, para buscarlo:

sudo find / -name wpasupplicant.conf

Ha de tener una forma similar a esta:

network={
ssid="nombre_red"
scan_ssid=1
key_mgmt=WPA-PSK--->(tipo aitenticacion que usemos)
psk="pass"

Para la configuracion de este archivo tenemos muchos manuales en la red, tambien en español. Si tenemos el archivo con una forma parecida a esta,
podemos hacer una prueba de nuestra configuracion con:

wpa_supplicant -i wlan0 -c /etc/wpa_supplicant.conf -d

Si todo va bien, podemos ejecutar el demonio en segundo plano con:

wpa_supplicant -i wlan0 -c /etc/wpa_supplicant.conf -B

En caso de tener configurados varios drivers en nuestro .config, tenemos que especificar cual usara con la opcion -D nombre_driver.
Estos son los que mostre al principo del tuto:

hostap = Host AP driver (Intersil Prism2/2.5/3) [default]
(this can also be used with Linuxant DriverLoader)
hermes = Agere Systems Inc. driver (Hermes-I/Hermes-II)
madwifi = MADWIFI 802.11 support (Atheros, etc.) (deprecated; use wext)
atmel = ATMEL AT76C5XXx (USB, PCMCIA)
wext = Linux wireless extensions (generic)
ralink = Ralink Client driver
ndiswrapper = Linux ndiswrapper (deprecated; use wext)
broadcom = Broadcom wl.o driver
ipw = Intel ipw2100/2200 driver (old; use wext with Linux 2.6.13 or newer)
wired = wpa_supplicant wired Ethernet driver
roboswitch = wpa_supplicant Broadcom switch driver
bsd = BSD 802.11 support (Atheros, etc.)
ndis = Windows NDIS driver

La forma mas facil de ejecitarlo en segundo plano y con depuracion seria:

wpa_supplicant -c/etc/wpa_supplicant.conf -iwlan0 -d

Con esto ya tenemos instalado wpasupplicant. Dejamos la explicacion de wpa_cli para mas tarde. un saludo