Activar Wireless en Ubuntu [Solucionado]

Imagen de proteus8
0 puntos

Hola a todos,
Estoy comenzando en el mundo de Ubuntu hace 3 dias que lo instale (Ubuntu 10.10)y necesito que me ayuden a activar mi wireless, tengo un notebook DELL VOSTRO 1320 mi tarjeta de red es una DELL WIRELESS 1397 WLAN MINI CARD, ya intente hacerla funcionar con varios métodos incluido NDISWREPPER, pero no he tenido buenos resultados.
Por favor ayúdenme,
no me gustaría tener que volver a windows.

el chip de mi tarjeta es BROADCOM bcm4310 USB CONTROLLER
desde ya muchas gracias

Imagen de Scorpyo82
+1
0
-1

Hola, si quieres ver si ubuntu detecta tu tarjeta has lo siguiente.

Abre una terminal y lista las tarjetas PCI así:

lspci

Busca tu targeta en el texto que te tira.

Luego, si te la detecta haz:

iwconfig

Y pega aquí lo que te sale.

Saludos.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.

Imagen de proteus8
+1
0
-1

hola Scorpyo82, gracias por responder

cuando ejecuto el comando lspci
me muestra el listado de dispositivos PCI y creo que estos son mis tarjetas de red la por cable y la inalambrica:

08:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)
0e:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)

Luego cuando ejecuto el comando
iwconfig me muestra lo siguiente:
lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11 Access Point: Not-Associated
Link Quality:5 Signal level:0 Noise level:0
Rx invalid nwid:0 invalid crypt:0 invalid misc:0

+1
0
-1
Imagen de Scorpyo82
+1
0
-1

hummm si que aparece, si.

Ahora, creo que te la está nombrando como eth1

Haz una cosa, abre una terminal y haz un barrido con esa tarjeta a ver si te encuentra redes, si es así, es que es la tarjeta wifi.

iwlist eth1 scanning

Si aparecen redes, entonces significa que está bien, y lo que falla es la interfaz o algo parecido.

Saludos.

Edito: Aparecerán redes si las hay claro.... jejeje enciende el router y a ver si te lo pilla.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.

Imagen de proteus8
+1
0
-1

si ejecuto el comando iwlist eth1 scanning
me sale esto:

eth1 Interface doesn't support scanning

+1
0
-1
Imagen de Scorpyo82
+1
0
-1

Humm, probaste a bajar los drivers para la tarjeta?

Conecta el ordenador por cable para que tenga internet y has lo siguiente, ve a Sistema, Administración, Controladores adicionales.

Al abrirlo escaneará el PC y buscará Hardware que necesite drivers de propietarios, luego el programa te avisará y te pedirá confirmación para descargar e instalar el driver.

A ver si tienes suerte y es eso.
Porque la verdad, ya estoy algo desconcertado.

Saludos.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.

Imagen de proteus8
+1
0
-1

Hice lo que me dijiste pero no funciona:
en Controladores adicionales.me muestra 2 opciones:
broadcom b43 wireless driver
controlador inalambrico broadcom STA
si activo uno el otro se deshabilita, intente con los dos pero no hay caso
con el primero al hacer un iwconfig me muestra lo siguiente.
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11bg ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off

y el segundo:

lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11 Access Point: Not-Associated
Link Quality:5 Signal level:0 Noise level:0
Rx invalid nwid:0 invalid crypt:0 invalid misc:0

+1
0
-1
Imagen de Scorpyo82
+1
0
-1

Claro, no puedes usar los dos drivers a la vez ya que es para lo mismo, para tu tarjeta wifi.

Pues parece que con el primero de los drivers te nombra la tarjeta como wlan0 y con la otra eth1.

Yo no sé si es normal, pero creo que lo común es que te la muestre como wlan0.
Además, el primer driver mide ruido y potencia de salida, mientras que el segundo no lo hace, con lo cual, o es más antiguo o no es el driver apropiado.

Prueba con el primer driver, reinicia y haz un:

sudo ifconfig wlan0 up
iwlist wlan0 scanning

El primer comando es para levantar la tarjeta por si está desactivada y el segundo para hacer un barrido.

Si no te funciona ya buscaremos más alternativas.

Suerte y saludos.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.

Imagen de proteus8
+1
0
-1

Hola Scorpyo82 , hice lo que dijiste,
Ahora me aparece como activa la tarjeta, pero si ejecuto un iwlist wlan0 scanning
me dice lo siguiente:
proteus8@Vostro-1320:~$ iwlist wlan0 scanning
wlan0 No scan results

pucha que lata!!
tendrá solución este caso?

+1
0
-1
Imagen de Scorpyo82
+1
0
-1

Es extraño, puesto que ya está claro que te la detecta y que soporta el comando iwlist scanning pero se ve que la tarjeta no hace mucho caso.

¿Probaste despues de reiniciar?
¿y con el gestor de redes?

A ver si alguien nos hecha una mano con este problemilla porque estar sin internet es una historia de las gordas.

Tambien podrías descargar los últimos drivers de tu tarjeta en la web de broadcom.

Saludos.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.

Imagen de evalckea
+1
0
-1

No se si ya resolviste tu problema, si aun no, te diré, yo lo he resuelto de manera muy simple, pero necesitas conectarte una vez vía Ethernet, o sea por cable, al hacer esto vas a sistema->Administración->controladores de Hardware en esta forma el equipo descargará los controladores privativos de Broadcom y te permitirá configurar tu tarjeta WiFi.

Saludos desde Colombia.
Efraim

+1
0
-1

Linux User 468545

Ubuntu User 21113 

Imagen de Scorpyo82
+1
0
-1

Bueno, pues no te molestes en buscar los controladores en dell, que ya lo he hecho yo y nada de nada, solo hay drivers para windows.

Otra cosa, esas tarjetas le fallan a mucha gente aún teniendo los driver instalados, pero el mismo mismo caso describe esta persona en el siguiente blog, y lo solucionó con unos pasos al parecer muy fáciles.
Espero que tengas suerte.

http://linux.sanvicentechicoloapan.com.mx/Tutoriales/ubuntu-910-y-broadcom-corporation-bcm4312-80211bg-rev-01.html

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.

Imagen de proteus8
+1
0
-1

:(
no me deja ingresar al Link, dice que la cuenta esta suspendida!!!
algun otro donde pueda ver como lo solucionaron..

+1
0
-1
Imagen de cabezon_jano
+1
0
-1

Hola,disculpa ¿el link q te puse es el q no te deja entrar por el tema de la cuenta suspendida? Extraño, yo entro con el Chromium y cero problema, probe el link ademas con el navegador Swiftfox y el Midori y cero rollo, en todo caso copio y pego lo q aparece en el link (gracias a www.guia-ubuntu.org):

Net Controller broadcom Corporation BCM4312 802.11B/G
Net Controller broadcom Corporation BCM4312 802.11B/G Es una tarjeta de red que no identifica las conexiones inalámbricas cuando se instala GNU/LINUX Ubuntu 9.10

Computadores que usan esta tarjeta

HP Mini 100
eMACHINES E725
Acer Aspire One D250-1614
HP Compaq 6715b
Dell Mini 10
Acer Extensa 5220
Compaq presario CQ40
Dell INSPIRON 1501

Solución

Hasta el momento se han encontrado dos posibles soluciones.

Primera
1.- Conectarse a internet por cable.

2.- Tipea en la consola:

lspci
Revisa que estés tengas la tarjeta en cuestión.

3.- De ser así, ve a Gestor de paquetes Synaptic, y descarga:

b43-fwcutter
4.- Reiniciar

(Teóricamente, la aplicación Sistema > Administración > Controladores de hardware debería hacer esto de manera gráfica, pero no suele hacerlo a la primera)

Segunda
1.- Conectarse a internet por cable.

2.- Ir a la Consola:

sudo apt-get install linux-headers-$(uname -r)
3.- Consola:

sudo dpkg-reconfigure bcmwl-kernel-source
4.-Ir a administración > Controladores de Hardware y activar la Broadcom STA.

5.- Reiniciar

+1
0
-1

"No confundas Coincidencia con Destino" Mr. Eko

Imagen de danieldaza
+1
0
-1

Gracias!! Tenía este problema luego de actualizar a ubuntu 15.04 y se solucionó con tu consejo Cabezón_jano.
Tengo una bangho Intel® Pentium(R) CPU B940 @ 2.00GHz × 2 que tiene instalado tmb un windows 7.
Gracias de nuevo.

+1
0
-1
Imagen de cabezon_jano
+1
0
-1

Hola, discupa q me entrometa, tal vez ya probaste lo q te voy a recomendar, pero me parece q en este link: http://www.guia-ubuntu.org/index.php?title=Net_Controller_broadcom_Corpo... esta la solucion a tu problema. Me sirvio en un Netbook Dell mini inspiron.

Desde Chilito, chauu

+1
0
-1

"No confundas Coincidencia con Destino" Mr. Eko

Imagen de Scorpyo82
+1
0
-1

Hola cabezon_jano
De entrometerte nada!

Es necesario que la gente se implique, si no, casi ningún hilo funcionaría rápido.

Cualquier posible solución es bienvenida.

Saludos.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.

Imagen de proteus8
+1
0
-1

Hola cabezon_jano, hola Scorpyo82 , gracias a ambos por intentar ayudarme, hice lo que me dijo cabezon_jano , me detecta la tarjeta aparece como activa, pero no scanea ninguna red, ya no se que hacer....

+1
0
-1
Imagen de cabezon_jano
+1
0
-1

Hola de nuevo, a mi me pasaba q no me reconocia ninguna red un Toshiba con tarjeta atheros, googleando me encontré con q lo q tenia q hacer era cambiar el Network Manager (el programa q gestiona tus redes, viene por defecto en Ubuntu, en mi caso el Ubuntu 10.04) por el WICD, se me arreglo el problema, ademas por lo q he leido el WICD hace mejor gestion de las redes inalambricas.

+1
0
-1

"No confundas Coincidencia con Destino" Mr. Eko

Imagen de proteus8
+1
0
-1

Siiiiiiiiiiiiiiiiiiiiiiiiiiiiiiii!!!! eh eh eh por fin funciono!!
Gracias cabezon_jano, gracias Scorpyo82 por su tiempo y ayuda...
por si a alguien mas le ocurre esto lo solucione con la segunda opción que me dijo cabezon_jano:

1.- Conectarse a internet por cable.

2.- Ir a la Consola:

sudo apt-get install linux-headers-$(uname -r)
3.- Consola:

sudo dpkg-reconfigure bcmwl-kernel-source
4.-Ir a administración > Controladores de Hardware y activar la Broadcom STA.

5.- Reiniciar

y después instalar WICD

Muchas gracias... y ahora a disfrutar de Ubuntu,
y ya no mas windows :-D

+1
0
-1
Imagen de cabezon_jano
+1
0
-1

Hola, muy feliz estoy de haber colaborado en la solucion de tu problema, espero q ahora puedas disfrutar a pleno de tu Ubuntu. Por ultimo, te recomiendo que instales el navegador Chromium, por lo menos a mi, me anda mucho mas rapido que Firefox.

Desde La Serena, Chile, Chauuuu

+1
0
-1

"No confundas Coincidencia con Destino" Mr. Eko

Imagen de amorenelchino
+1
0
-1

Muy buenas a todos! Estoy leyendo y leyendo, pero es que no encuentro soluciô...pues yo no me puedo conectar ni con cable...:-( no ha manera
Mi ethernet controller es broadcon corporation netlink BCM5784M
Y network BCM4312 802.11b/g
No se que hacer, pues no puedo descargarme nada...
Muchisimas gracias!!!

+1
0
-1
Imagen de Scorpyo82
+1
0
-1

Si te fijas en la página oficial de Broadcom podrás llegar hasta este enlace:
http://www.broadcom.com/support/license.php?file=570x/linux-3.124c.zip
Que es donde te ofrecen el driver para la tarjeta de red ethernet que tienes...

Ya con eso funcionando todo lo demás es más sencillo... es cuestión de ir actualizando y buscando los paquetes necesarios para activar la wireless también.

Un saludo.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.

Imagen de Scorpyo82
+1
0
-1

Enhorabuena!

Me alegro mucho de que lo solucionaras y compartieras los detalles de la solución de nuevo.

Eso evita que mucha gente se quede con dudas si está siguiendo el post.

Saludos.

PD: Debes de colocar [Solucionado] en el titulo para que se dé por zanjado.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.

Imagen de xeon.minotauro
+1
0
-1

Bueno antes que nada comento que hoy me acabo de iniciar en el mundo de Linux, y tenia el mismo problema en mi netbook hp 2133 con la tarjeta inalambrica, pues comento que segui los pasos descritos en este post y FUNCIONOOOOOOOOOO. Gracias por ayudar a la gente nueva y gracias por hacer este sitio tan completo.
Saludos

+1
0
-1

Saludos...

Imagen de horgumo
+1
0
-1

hola q tal tambien soy nueva en la comunidad y tengo el mismo problema.... segui los pasos pero no me funciono!!! please ayuda.
les comento ademas q hace algunas semanas o casi meses tenia el mismo problema y lo resolvi con la ejecucion de unos comando pero ahora q inente buscarlos no los encontre.
me parecio q con lo q mencionaron se resolveria pero no fue asi!!
ayuda

+1
0
-1
Imagen de Scorpyo82
+1
0
-1

Hola Horgumo.

Este tema está solucionado.
Asegúrate de que te encuentras en la misma situación que el usuario que colgó el hilo, es decir, misma versión de sistema, misma tarjeta, equipo... etc etc.

Si no es así, crea un hilo nuevo escribiendo lo que te ocurre y proporcionando todos los datos que puedas para que podamos ayudarte.

Un saludo y suerte.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.

Imagen de merlyna
+1
0
-1

Soy nueva en linux y me funcionó de maravilla, gracias :)

+1
0
-1
Imagen de aina69
+1
0
-1

Gracias por su ayuda realice al pie de la letra los pasos:
1.- Conectarse a internet por cable.

2.- Ir a la Consola:

sudo apt-get install linux-headers-$(uname -r)
3.- Consola:

sudo dpkg-reconfigure bcmwl-kernel-source
4.-Ir a administración > Controladores de Hardware y activar la Broadcom STA.

5.- Reiniciar

y después instalar WICD

Les comento que realice esto en un Macbook Air con S.O Xubuntu.

+1
0
-1

"Lo importante de un problema no es la solucion,
sino la fuerza que se obtiene al encontrarla "