Lentitud wifi con RTL8191SEVA, ¿se pueden cambiar los valores de "noise" (ruido) o algo para mejorarla?

Imagen de Scorpyo82
0 puntos

Hola a todos.
Vereis, tengo un problema con esta tarjeta que llevo arrastrando desde que me pasé a ubuntu a mediados del lanzamiento de ubuntu 10.04.... el caso es que es muy muy lenta la conexión si estoy a mas de 3 metros del router, por el contrario, con una tarjeta con chip ZyDAS 1211 con el driver zd1211rw - [phy1] antigua por puerto USB y mucho mas lejo y aún teniendo menos cobertura, obtengo el total del ancho de banda, mucho más que con otros OS.....

La cuestión, es que a pesar de poner drivers alternativos para esta tarjeta y cambiar configuraciones de la misma.... etc, no consigo que vaya adecuadamente y la pregunta es:

¿hay algún lugar en el árbol de directorios de Linux donde pueda ver el comportamiento de esa tarjeta (si hay ruido, si está lejos del AP, etc...) que yo pueda trastear o modificar para cambiar valores o anular cosas para ir descartando?

¿puedo cambiar valores de los drivers que tengo descargados y luego instalarlos?

A ver, no soy programador ni nada, pero con paciencia y vaselina el elefante se la met** a la hormiga... jejeje

Por supuesto, si alguien tiene la solución a esto pues la prefiero a tener que meterme en este lio.

Bueno, de antemano gracias y les dejo datos de la tarjeta según lshw

id: network
description: Wireless interface
product: RTL8191SEvB Wireless LAN Controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:07:00.0
logical name: wlan0
version: 10
serial: 70:f1:b4:61:3b:a6
width: 32 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration:
broadcast = yes
driver = rtl819xSE
driverversion = 0019.1207.2010
firmware = 63
latency = 0
link = no
multicast = yes
wireless = 802.11bg
resources:
irq : 17
ioport : 7000(size=256)
memory : d5100000-d5103fff

Imagen de Scorpyo82
+1
0
-1

Cualquier idea es bienvenida.
Saludos.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.

Imagen de Scorpyo82
+1
0
-1

A ver, buscando el problema en google no encontré nada de nada, como mucho, encontré a gente que le pasa lo mismo.

Pues bien, al final, experimentando encontré que al instalar los driver privativos de realtek, te deja dos archivos alojados en /etc/realtek/ que son:
RadioPower.sh
wireless-rtl-ac-dc-power.sh

Pues bién, estos dos archivos son script pero tienen su primera linea comentada de manera que no se ejecuten por defecto. (Esto está mal.... no están comentadas, simplemente son así)

Solo hay que descomentarla. (no hacer eso, seguir leyendo y ver la corrección)

Concejo: Hacer varios test de velocidad para comprobar que velocidad de descarga teneis.

Procedemos en una terminal y hacemos lo siguiente:

sudo nano /etc/realtek/RadioPower.sh (Nó hacer esto, hacer esto otro para quitar permisos de ejecución:
sudo chmod -x /etc/realtek/RadioPower.sh

)

(Saltar hasta el siguiente archivo y haced lo mismo.
Para ototrgar permisos de ejecución solo cambiar el signo - (menos) por un +)

Eliminais la primar almoadilla quedando así la primara linea:

! /bin/sh

Cuando lo halláis hecho apretar CTRL+o para guardar los cambios con el mismo nombre, así que pulsamos ENTER y para cerrar pulsamos CTRL+x.

Ahora haceis lo mismo para el otro archivo:

sudo nano /etc/realtek/wireless-rtl-ac-dc-power.sh

Eliminais la primar almoadilla quedando así la primara linea:

! /bin/sh

Cuando lo halláis hecho apretar CTRL+o para guardar los cambios con el mismo nombre, así que pulsamos ENTER y para cerrar pulsamos CTRL+x.

Reiniciar y hacer los mismos test en las mismas paginas y comprobad por ustedes mismos.

Ya os digo, esto lo he sacado yo solo, y no lo he contratado con nadie, lo he hecho en el Ubuntu que tengo instalado en mi portatil y en el que tengo instalado en un disco duro portatil para comprobar que es eso y no otra cosa lo que hace que funcione la wifi bien, y es así, en ambos me va mucho más rápido cuando estoy lejos del router.

Saludos y suerte.

Edito: Las lineas no están comentadas, están así para que puedan ejecutarse, y al quitarle la almoadilla no se ejecutan, el caso es que me va mejor, pero aun así no va perfecto. Lo dejo abierto de nuevo, por si alguien puede aportar algo mejor. Está corregido.. pero como no puedo tachar, pues he puesto entre paréntesis los cambios.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.