Problema al reiniciar por primera vez ubuntu tras instalarlo (RESUELTO)

Imagen de kahloh
0 puntos

Hola a todos, soy nuevo en Ubuntu (es más aun ni he empezado) el motivo de mi consulta es que al terminar de instalar Ubuntu 10.10, en el momento de reiniciar me salen una serie de errores y el pc expulsa el CD, el pc no se reinicia hasta que pulso enter, una vez se esta reiniciando se que la pantalla en negro con la “barrabaja parpadeante” y no responde el teclado. Antes de instalar Ubuntu tenia instalado Windows XP home edition en el momento de la primera instalación lo quite para tener solo Ubunto ya que estaba harto del XP. El PC no funciona, he instalado la versión 10.04 con el mismo resultado. Espero que sea un error solucionable.
Gracias de antemano.

Imagen de Scorpyo82
+1
0
-1

No entiendo muy bien el problema.

Lograste instalar Ubuntu, usando todo el disco, ¿pero no puedes iniciarlo?

¿es eso?

Yo creo que lo mejor es que arranques con un LiveCD de ubuntu, luego, abre una terminal (Aplicaciones, Terminal), y escribes dentro de esta el siguiente comando:

sudo fdisk -l

Copia y pega el texto que te sale aquí, para que veamos la estructura de tus discos duros.

Saludos.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.

Imagen de kahloh
+1
0
-1

Hola Scorpyo82 aqui esta lo que me pediste

ubuntu@ubuntu:~$ sudo fdisk -1
fdisk: opción incorrecta -- «1»

Usage:
fdisk [options] change partition table
fdisk [options] -l list partition table(s)
fdisk -s give partition size(s) in blocks

Options:
-b sector size (512, 1024, 2048 or 4096)
-c switch off DOS-compatible mode
-h print help
-u give sizes in sectors instead of cylinders
-v print version
-C specify the number of cylinders
-H specify the number of heads
-S specify the number of sectors per track

ubuntu@ubuntu:~$

+1
0
-1
Imagen de Scorpyo82
+1
0
-1

:D

Eso no es exactamente lo que te puse.... jejeje
Es una "L" en minuscula. "l" no un 1.
Hazlo de nuevo, estoy esperando :D

Saludos.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.

Imagen de kahloh
+1
0
-1

Disco /dev/sda: 251.0 GB, 251000193024 bytes
255 cabezas, 63 sectores/pista, 30515 cilindros
Unidades = cilindros de 16065 * 512 = 8225280 bytes
Tamaño de sector (lógico / físico): 512 bytes / 512 bytes
Tamaño E/S (mínimo/óptimo): 512 bytes / 512 bytes
Identificador de disco: 0x00048b7b

Dispositivo Inicio Comienzo Fin Bloques Id Sistema
/dev/sda1 * 1 29399 236145664 83 Linux
/dev/sda2 29400 30516 8969217 5 Extendida
/dev/sda5 29400 30516 8969216 82 Linux swap / Solaris

Disco /dev/sdb: 500.1 GB, 500107862016 bytes
255 cabezas, 63 sectores/pista, 60801 cilindros
Unidades = cilindros de 16065 * 512 = 8225280 bytes
Tamaño de sector (lógico / físico): 512 bytes / 512 bytes
Tamaño E/S (mínimo/óptimo): 512 bytes / 512 bytes
Identificador de disco: 0x0003e6ea

Dispositivo Inicio Comienzo Fin Bloques Id Sistema
/dev/sdb1 1 59272 476097536 83 Linux
/dev/sdb2 59272 60802 12285953 5 Extendida
/dev/sdb5 59272 60802 12285952 82 Linux swap / Solaris
ubuntu@ubuntu:~$

+1
0
-1
Imagen de Scorpyo82
+1
0
-1

Tienes dos discos, uno de 250 y otro de 500 y en los dos tienes extructura propia de una instalación de linux, es decir, tienes dos instalaciones de linux en tu PC.

¿entonces, no puede iniciar desde ninguna?

Estás desde un Live CD?

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.

Imagen de kahloh
+1
0
-1

No, no puedo iniciar desde ninguna, estoy utilizando el modo prueba de ubuntu sin instalar desde el cd

+1
0
-1
Imagen de Scorpyo82
+1
0
-1

¿Entonces no te sale el menú de grub?
Si es así, y los dos Sistemas Linux están instalados nuevos, podemos instalar Grub y recuperar los dos...

Desde el mismo LiveCD (que es un autentico salva vidas) montaremos tu partición de ubuntu del disco 1.

Abre una terminal y empezamos:

sudo mount /dev/sda1 /mnt
sudo mount --bind /etc /mnt/etc
sudo mount --bind /proc /mnt/proc

Ahora entramos como root a tu sistema así:

sudo chroot /mnt

Bien, ahora reinstalamos grub con los siguientes comandos en la misma terminal:

grub-install --recheck /dev/sda
update-grub2 

Luego reinicia, y debería de salir el grub, seguramente te detectará el otro sistema linux.

Suerte.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.

Imagen de kahloh
+1
0
-1

Creo que no ha funcionado

To run a command as administrator (user "root"), use "sudo ".
See "man sudo_root" for details.

ubuntu@ubuntu:~$ sudo mount /dev/sdal /mnt
mount: el dispositivo especial /dev/sdal no existe
ubuntu@ubuntu:~$ sudo mount /dev/sda1 /mnt
ubuntu@ubuntu:~$ sudo mount --bind /etc /mnt/etc
ubuntu@ubuntu:~$ sudo mount --bind /proc /mnt/proc
ubuntu@ubuntu:~$ sudo chroot /mnt
root@ubuntu:/# grub-install --recheck /dev/sda
/usr/sbin/grub-probe: error: cannot find a device for /boot/grub (is /dev mounted?).
No path or device is specified.
Try `/usr/sbin/grub-probe --help' for more information.
Auto-detection of a filesystem module failed.
Please specify the module with the option `--modules' explicitly.
root@ubuntu:/# update-grub2
/usr/sbin/grub-probe: error: cannot find a device for / (is /dev mounted?).
root@ubuntu:/#

+1
0
-1
Imagen de Scorpyo82
+1
0
-1

Perdón!
Fallo mío.

modifica esto:
Desde el mismo LiveCD (que es un autentico salva vidas) montaremos tu partición de ubuntu del disco 1.

Abre una terminal y empezamos:

sudo mount /dev/sda1 /mnt
sudo mount --bind /etc /mnt/etc ------cambiar por------> sudo mount --bind /dev /mnt/dev
sudo mount --bind /proc /mnt/proc

Ahora entramos como root a tu sistema así:

sudo chroot /m

nt

Bien, ahora reinstalamos grub con los siguientes comandos en la misma terminal:


grub-install --recheck /dev/sda
update-grub2

Luego reinicia, y debería de salir el grub, seguramente te detectará el otro sistema linux.

Suerte.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.

Imagen de kahloh
+1
0
-1

ubuntu@ubuntu:~$ sudo mount /dev/sda1 /mnt
mount: /dev/sda1 ya está montado o /mnt está ocupado
mount: según mtab, /dev/sda1 ya está montado en /mnt
ubuntu@ubuntu:~$ sudo mount --bind /dev /mnt/dev
ubuntu@ubuntu:~$ sudo mount --bind /proc /mnt/proc
ubuntu@ubuntu:~$ sudo chroot /mnt
root@ubuntu:/# grub-install --recheck /dev/sda
Installation finished. No error reported.
root@ubuntu:/# update-grub2
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-2.6.32-28-generic-pae
Found initrd image: /boot/initrd.img-2.6.32-28-generic-pae
Found memtest86+ image: /boot/memtest86+.bin
Cannot find list of partitions!
done
root@ubuntu:/#

+1
0
-1
Imagen de kahloh
+1
0
-1

Sigue igual :S

+1
0
-1
Imagen de Scorpyo82
+1
0
-1

Pues entra en la bios del pc, de a boot menú
Y mira si estás arrancando del disco de 500 Gb en lugar de el disco de 250 Gb.

Tienes que arrancar desde el de 250 que es en donde está el arranque de Linux.

A ver si es eso.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.

Imagen de kahloh
+1
0
-1

Funcionó :D parece mentira que fuera algo tan sencillo, en el instalador solo me aparecia el disco duro de 500 gb porque es el principal del pc, no pense en ningun momento que estaria en el disco de 250 gb, muchisimas gracias por tu ayuda, la verdad es que da gusto estar en linux solo por la ayuda que brinda la gente de este foro.
Un afectuoso saludo, y lo vuelvo a decir, muchas gracias por tu paciencia. Ahora voy a adentrarme en este nuevo universo que se me presenta.

+1
0
-1
Imagen de Scorpyo82
+1
0
-1

Me alegro!

Ahí que ver como son las cosas.... si llegamos a empezar por la cosa mas inverosímil...

Pero bueno, por lo menos vas viendo cosillas..

Un saludo.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.