Ya me arte....................... ATI.........-.-

Holas que tal, aver si de una vez por todas logro hacer andar mi ATI.
Les cuento, tengo una ATI Radeon 9550, en una celeron 2.4 (no pregunten xq celeron por favor) con Unbuntu 2.6.8.1, he instalado los drivers .run de ATI y hasta aqui todo bien, no me dieron error ni nada, los Frames p/s aumentaron un poco pero no considerablemente (no llegan ni ahi a las 700 p/s). Mi direct rendering aparece como: No y sigo teniendo los opengl como Mesa.
He Seguido ya creo que varios y varios tutoriales, formateado la makina unas 523 veces, y el direct rendering no quere decirme que si.....tambien he leido en tutoriales de, haciendola mas facil directamente bajar con apt-get los drivers xfree86-driver-fglrx o xorg-... segun lo que tengas, por cierto, no existen o almenos mi apt-get dice eso....
Otra duda que tengo es que en un tutorial de la pagina de ubuntu (si mal no recuerdo) decia que debias tener un monitor con mas de 60hz, eso ya me parecio cualquera, si en windows funcionan, q todos debemos tner un 17" pulgadas para arriba si o si usando linux e ati ?....bue, se notara que estoy medio enojado, de todas formas les pido ayuda xq realemnte ya no doy mas.....si les falta info se la pasare con gusto y hare lo posible para que me puedan ayudar...

desde ya gracias.........

Emiliano

Imagen de Anónimo
+1
0
-1

por cierto me olvide que uso XFree86 al contrario de Xorg

Emiliano

+1
0
-1
Imagen de TASADAR-F
+1
0
-1

Para instalarlo es tan facil como poner sudo aptitude install xfree86-driver-fglrx y cambiar la palabra en el xorgconf o el equivalente en el xfree86 "ati" por "fglrx".Es obligatorio para este proceso tener actualizado el kernel a la maxima version de las distribucion en breezy 2.6.12-10-386 y entrar con el . El problema que me encuentro con la mayoria de las personas es que han intentado instalar el driver original de ATI con poco exito y estropean el modulo que viene con ubuntu con la nueva version y con ello la forma sencilla.

HAY 2 MANERAS DE HACERLO

sudo modprobe -r fglrx (Para quitar la version mala del modulo)
despues hacer sudo modprobe fglrx (debe dar un error porque lo hemos eliminado)

y eliminar todos los paquetes sean de los repositorios o los oficiales de ati que se hallan instalado anteriormente relaccionados con el fglrx
sudo aptitude purge paquete o se puede usar synaptic

PRIMERA MANERA (Recomendada) Me ha funcionado perfectamente con unas 25 personas diferentes excepto con un AMD64 y breezy que me funciono la 2 manera
despues de quitar el modulo desinstalar y volver a instalar el paquete
linux-restricted-modules-2.6.12 en el caso de breezy en hoary sera parecido cambiando los numeros de la version.
sudo aptitude purge paquete (eliminar)
sudo aptitude install paquete (instalar)
Esto pondra el modulo fglrx con la version de ubuntu
haced sudo modprobe fglrx (no debe salir nada)
Esto quiere decir que hemos instalado el modulo correctamente.
instalar el driver fglrx de los repositorios de ubuntu tiene que estar activado el repositorio restricted

sudo aptitude install (xfree86-driver-fglrx o xorg-driver-fglrx)

Haced sudo aptitude search fglrx y observar que al principio de la linea del driver que habeis instalado sale una "i" si sale "iB" es que no se ha podido instalar por algun problema (mala version kernel, diferentes versiones modulo driver, mala version del driver, no se desinstalaron anteriormente otros paquetes del driver fglrx)

Si ha aparedido la "i" solo hay que cambiar el xorg.conf o equivalente la palabra de driver "ati" por "fglrx" y reiniciar.

2 MANERA instalar los paquetes oficiales de ATI solo la he tenido que usar con una persona de un AMD64 y funciono perfectamente

Elimimar el modulo fglrx como hemos comentado al principio muy importante.

Bajarse el programa creador de paquetes de la pagina de ATI y seguir los pasos de https://wiki.ubuntu.com/BinaryDriverHowto/ATI desde donde pone Using the drivers from ati.com.

Escribir los comandos de los recuadros tal cual . Lo mas importante es instalar el modulo con el module-assistant y los driver con sudo dpkg -i *.deb . Antes de poner reboot no olvidarse cambiar ati por "fglrx" en el xorg.conf o equivalente

+1
0
-1
Imagen de Muadiv
+1
0
-1

Disculpame, veo que estas bien empapado con el tema de las placas ati, yo instale ubuntu, instale automix, y no trae la opcion para instalar ati, baje e instale el easyubuntu, que si lo trae, le di instalar, y nunca funciono tampoco...

Me podes pasar cuales son los pasos de cero para instalar bien la placa ati (tengo una agp 9200 de 128mb), dado que esta noche voy a instalar de cero ubuntu para probar unos scripts que estuve armando y quiero lograr instalar la placa de video.
Una cosa mas, mi placa es AGP, y en todos lados veo que se instala pci... como hago para instalarla AGP ¿?

Un abrazo y muchas gracias.
Muadiv.

+1
0
-1

/-------------------->
|Muadiv
|ubuntu@muadiv.com.ar
|www.muadiv.com.ar
\-------------------->

Imagen de Anónimo
+1
0
-1

hola, mira este link, a mi me soluciono completamente:
http://www.genbeta.com/archivos/2005/04/29-aceleracion-3d-para-tarjetas-...
espero que te sirva

+1
0
-1
Imagen de jona_spdr
+1
0
-1

ayer mismo lo instale, pensaba k m iba a dar problemas (cmo en demas distros) pero no xD, es muy simple:

1º Buscas en synaptic los drivers fglrx y los instalas

2ºsudo fglrxconfig, y configuras segun t dice, si tienes dudas dale a intro y se elige la opcion por defecto.

3º sudo gedit /etc/modules, y añades dos lineas:
fglrx
agpgart

4º sudo gedit /etc/X11/xorg.conf, sustituyes donde veas ati por fglrx, guardas y reinicia.

5ª Por ultimo desde consola: glxinfo, buscas donde pone DirecRendering, si pone Yes, la aceleracion 3D ya funciona.

Todo esto esta sacado de http://www.ubuntu-es.org/node/14214, me salte varios pasos porke no los vi necesarios y asi fue, y lo de fglrxconfig no se si es necesario xo como en otras distros lo acia, pues lo ice y todo a la perfeccion. Suerte, x cierto yo tng una ATI Radeon 9600 Pro xo supongo k sera igual, aunke t digo k es la distro k menos problemas me a dao para la ati. Saludoss

+1
0
-1
Imagen de ChouK
+1
0
-1

Una y otra vez me sale "iB" :__

+1
0
-1
Imagen de Muadiv
+1
0
-1

Me podrias pasar tu msn para ver si puedo instalarlo ?= tengo una AMD con un sempron 2800+ (tengo ubuntu la version x86 comun, no la de 64bits)y la verdad que intento hace mas de 3 meses y todavia no lo logro... y veo que has ya lo has hecho andar... me puedes ayudar ???

Gracias

/-------------------->
|Muadiv
|ubuntu@muadiv.com.ar
|msn:muadiv@hotmail.com
|www.muadiv.com.ar
\-------------------->

+1
0
-1

/-------------------->
|Muadiv
|ubuntu@muadiv.com.ar
|www.muadiv.com.ar
\-------------------->

Imagen de Anónimo
+1
0
-1

Si no te aparecen los paquetes fglrx... me da que no tienes habilitados los repositorios "restricted" en sources.list. Es lo único que se me ocurre, porque estar, están. Edita el archivo o añadelos desde Synaptic, recarga e instala los "headers" del núcleo y driver-fglrx; debe ser suficente.

Y por otro lado... Xfree ¿por algo en especial?

Cuentanos si ha sido así ;-)

+1
0
-1
Imagen de Anónimo
+1
0
-1

probe lo que que dijo liso pero nadap, no puedo instalar nada de lo que me pasaste......y en cuanto a lo de editar el source.list se donde esta pero no se que tengo que ponerle, perdon pero soy medio nabo, hace poco que tengo linux....por otro lado :P, lo de xfree es porque asi venia ubuntu, pero estaba pensando en poner xorg...-.-

+1
0
-1
Imagen de Liso
+1
0
-1

Nas, yo ultimamente solo doy consejos para hacer desde ratón, no creo que decirte que edites a mano el sources.list sea muy util, asi que, empezamos:

Ves al synaptic ( creo que en el menu es adm. de paquetes ) desde ahí hay una opcion que es configurar repositorios, pues pinchas eso, y te sale un menu, pues por cada uno de los que te sale, dale a editar y seleccionas todos los posibles, si no te sale un menu con estas opciones, escribe, donde pone "main restricted", esto
"main restricted universe multiverse"
y aceptar.

Ahora tienes todos los paquetes no oficialmente mantenidos por ubuntu. recargas y le das a "marcar todos los cambios", aplicas y sigues los pasos.

Despues ejecuta el ubuntueasy ( o el otro si tienes breezy ) y yasta.

Por cierto, cuando instalas con el easyubuntu la grafica, te sale unos dialogos de confiugracion, cuando te diga que seleccioines el driver, elige "fglrx" en el desplegable.

Si tienes algun problema, pregunta por aqui :P.
--
Liso ^ TLOTB
Eadem Mutata Resurgo
Linux has you...

+1
0
-1

--
Liso ^ TLOTB
Eadem Mutata Resurgo
Linux has you...

Imagen de Liso
+1
0
-1

Si usas una breezy intenta usar el automatix que te lo instala automaticamente:

http://ubuntuforums.org/forumdisplay.php?f=77

Si usas dapper o alguna otra, prueba con el easyubuntu:

http://easyubuntu.freecontrib.org/

Ya contaras como te a ido.
--
Liso ^ TLOTB
Eadem Mutata Resurgo
Linux has you...

+1
0
-1

--
Liso ^ TLOTB
Eadem Mutata Resurgo
Linux has you...

Imagen de Serpiente
+1
0
-1

Buenas a todos, ante todo saludaros ya que es mi primer mensaje

La question es que tengo una Ati 9600 XT la cual no consigo hacer funcionar correctamente en mi ubuntu 5.10. He probado todos los metodos que he encontrado por el foro, me he recorrido ya todo google pero siempre obtengo el mismo resultado. Cuando reinicio la computadora despues de haber instalado los drivers, al iniciar la X se me queda la pantalla en negro. El monitor recibe señal y el pc parece que no este colgado. Me pasa siempre lo mismo, ya sea con los drivers de la web de ati como los del repositorio. Despues de canviar lo de "ati" por "fglrx" pues pasa eso.
Una observacion es que si comento la linea Load "dri", consigo cargar bien la X pero sin acceleracion 3D y al hacer glxinfo me sale que uso los MESA.

Alguna idea??? gracias :)

+1
0
-1
Imagen de BrownHok
+1
0
-1

ya instale el driver oficial de ATI y nada, tengo un INTEL 2.8 GHZ y Board D865GL INTEL y tarjeta grafica ATI 9200 SE socket AGP

+1
0
-1
Imagen de pabava
+1
0
-1

prueba esto:

sudo aptitude install linux-headers-version-de-tu-kernel

sudo aptitude install linux-restricted-modules-version-de-tu-kernel

sudo aptitude install xorg-driver-fglrx

modprobe agpgart
modprobe -r fglrx

sudo gedit /etc/X11/xorg.conf
busca la seccion de device y reemplaza por
Section "Device"
Identifier "ATI Technologies, Inc. Radeon 9200 SE (RV280)"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection

guarda y cierra

sudo gedit /etc/modules

y añades

agpgart
fglrx

ahora reinicia y verifica

glxgears -iacknowledgethatthistoolisnotabenchmark

prueba. A mi me dio 1078

+1
0
-1