[Disco duro] ACPI vs laptop mode (abierto)

Imagen de pcmaster
0 puntos

Tengo instalado Ubuntu 10.10 en un ultraportátil Asus eeepc 1201N.

En un momento determinado me di cuenta de que el portátil hacía un ruido que no debería: clic...clic...clic..... Enseguida me di cuenta de lo que estaba ocurriendo: el disco duro estaba realizando una operación de aparcado de cabezales cada 5 segundos, y según el estado SMART del disco ya llevaba ya varios miles de ellas. Sólo ocurre cuando está funcionando en modo batería, al conectar el alimentador los aparcados cesan.

Ya sé que los discos actuales soportan muchas operaciones de aparcado, pero ese ritmo lo considero excesivo. Smartmontools me indica que la administración de energía del disco tiene el valor 128.

Descubrí que instalando el paquete laptop-mode el valor de energía del disco pasa de 128 a 1, mucho más agresivo, pero tampoco se producen los aparcados continuos de cabezales. Interpreto que ene se estado realiza el aparcado cada vez que deja de acceder al disco, de forma inmediata, pero no cada 5 segundos.

Parece solucionado, ¿no? Sin embargo hay un problema: al instalar laptop-mode se desinstala ACPI, y ya no puede dejarse el equipo en modo suspendido, útil si vas a dejar de usar el portátil durante un rato.

¿Alguna idea?

Imagen de pachiargento
+1
0
-1

Miara es medio tedioso tener que desbilitar tras cada reinicio el hrparm que es el problema de fondo Yo intenete con todo ¡¡De momento esto es lo que hago hasta encontrar una solucion
Tenes que crear un lanzador a este comando sudo hdparm -B 254 /dev/sda y listo no mas cliks
Asus eeepc 1201 ha Saludos desde Argentina ¡¡

+1
0
-1
Imagen de Scorpyo82
+1
0
-1

Te aconsejo que desactives la opción de aparcado de cabezales por inactividad y veas que resultados te dá.

Ve a administración de energía que está en Sistema>preferencias>gestor de energia dale a la pestaña "Con batería" y desactiva la casilla

reducir la velocidad de rotación de los discos cuando sea posible

Y mira a ver que tal.

Un saludo.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.

Imagen de pcmaster
+1
0
-1

Hola,

Gracias por vuestras respuestas.

La casilla que citas ya está desactivada. Pero no surte efecto.

+1
0
-1
Imagen de Scorpyo82
+1
0
-1

Pues puede ser problema de compatibilidad con tu portatil o algo...

Seguro que se puede apañar, pero no sé decirte como.

Si encuentro algo te aviso.

Un saludo.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.