No logro montar disquetera usb

Imagen de bruce__128
0 puntos

Hola. El panorama es este....

Ubuntu 10.04LTS
Tengo una disquetera usb, la conecto y el SO la reconoce, pero no monta automaticamente como lo hacen los pendrive. Asi que la monto manualmente para lo cual hice lo siguiente:

Con la Utilidad de Discos me fije donde esta el dispositivo (/dev/sdb)
Cree la carpeta donde pienso montarlo (/media/floppy)
Tipeo (sudo mount /dev/sdb /media/floppy) y pareciera que la monta por el comportamiento del hardware
El resultado final es que no la monta y no puedo acceder al disquete. Aclaro que tanto el dispositivo como el disquete estan ok.
Tambien probe modificando el fstab (/dev/sdb /media/floppy msdos noauto,user,rw,nosuid,defaults 0 0), pero nada ocurre.

Alguien podra darme una manito?
Mil gracias de antemano.

Imagen de arriero
+1
0
-1

¿Has metido a tu usuario en el grupo floppy? Estamos hablando de hacer algo como esto:

$sudo adduser Tu_Usuario floppy >> Cambiar tu_usuario por el tuyo
+1
0
-1

Si reparas tu problema, añade(Solucionado)en el asunto de tu primer post, así es mas fácil para el que busca después.Mi Blog

Imagen de bruce__128
+1
0
-1

arriero,

acabo de agregar al usuario a floppy, intento montar pero tengo el mismo resultado...

gracias

+1
0
-1
Imagen de arriero
+1
0
-1

Sobre el tema de añadir un floppy usb estoy un poco perdido, simplemente por no necesitarlo, pero has usado la utilidad de discos haber si te falta activar algo mas (fuser)
Sistema>Administración>Utilidad de disco.
Haber si esto resuelve el problema o sale algún compañero que use una disquetera usb y da una idea. Un saludo.

+1
0
-1

Si reparas tu problema, añade(Solucionado)en el asunto de tu primer post, así es mas fácil para el que busca después.Mi Blog

Imagen de bruce__128
+1
0
-1

utilice la Utilidad de Disco para saber donde estaba la disquetera (/dev/sdb) pero de ahi en mas realmente no se si me falta activar algo...

gracias de todos modos arriero.

+1
0
-1
Imagen de arriero
+1
0
-1

He encontrado un par de soluciones en paginas inglesas, pero como no se si es tu problema. Te paso los enlaces a las paginas:
linuxquetion
webup8
Por favor he visto varias cosas, pero podrías hacer una prueba por mi, coloca un disquete que tenga algún archivo y una vez puesto en la diquetera lanza esta orden y pega el resultado en el siguiente post:

sudo fdisk -l

Me haces el favor de hechar un vistazo a los enlaces y después de esto me cuentas.

+1
0
-1

Si reparas tu problema, añade(Solucionado)en el asunto de tu primer post, así es mas fácil para el que busca después.Mi Blog

Imagen de bruce__128
+1
0
-1

arriero,
la ultima piedra dio en el blanco a medias.

uno de los links ya lo habia visto pero el otro no y de ahi saque algo que funciono (webup8):

"Update: alternatively (thanks to Benplanet), run the following command in a terminal:
sudo modprobe -r floppy
And then restart your computer."

despues de esto trate de montar la unidad y la monto de una.... ya veo el contenido del disco!!!
pero cuando quise grabar algo en el, no lo hace...
sacar cosas del disquete, si pude y lo hace con un simple copy-paste
como lo puedo solucionar?

gracias nuevamente

+1
0
-1
Imagen de arriero
+1
0
-1

Monta el floppy como te dice en el primer enlace:

sudo mount -t vfat /dev/sdx /media/floppy

Cambia la x por lo que te haya dado en el sudo fdisk -l
Repasa el primer enlace para el montaje y quita la linea del fstab, haber si al final entran en conflicto los dos montajes. Hacemos las pruebas con el montaje desde la terminal y si funciona aplica la linea en fstab corrigiendo lo necesario.
He encontrado esto sobre como reconoce fstab a los floppys usb cambia a discreción:

/dev/sdx /media/floppy auto sync,user,noauto,nosuid,exec,nodev 0 0

Cambia la x por como te reconoce el sudo fdisk -l a la disquetera

+1
0
-1

Si reparas tu problema, añade(Solucionado)en el asunto de tu primer post, así es mas fácil para el que busca después.Mi Blog

Imagen de bruce__128
+1
0
-1

en el fstab ahora tengo esta linea:

#/dev/sdc /media/floppy vfat rw,user,noauto 0 0

si la aplico... no lo monta
si la omito.... lo monta

Pero independientemente de esto, cuando logro montarlo, no me permite escribir en el disquete.
No me tira ningun error de escritura pero no me deja copiarlo....

+1
0
-1
Imagen de arriero
+1
0
-1

Si lo tienes así, no lo montara jamas, # la almohadilla en Linux sirve para que el sistema pase de esa linea, quita la almohadilla.
Monta como te deje arriba si esta en auto en vez de vfat montara cualquier tipo de sistema de archivos vfat,msdos,Ext-x. Un saludo.
Edito:
Has añadido el directorio floppy en /media compañero para que se monte en ese lugar.

+1
0
-1

Si reparas tu problema, añade(Solucionado)en el asunto de tu primer post, así es mas fácil para el que busca después.Mi Blog

Imagen de bruce__128
+1
0
-1

si, lo del # lo sabia, por eso dije que si lo aplico (o sea, quito el #), no lo monta.
pero si lo omito (dejo el #), puedo montarlo sin problemas.

el directorio /media/floppy existe

+1
0
-1
Imagen de arriero
+1
0
-1

Yo creo que es problema mas de configuración y permisos mas que otra cosa, si te deja montarlo pero no tocarlos es mas problemas de permisos, pero añadiendo la linea de arriba al fstab no deberías tener problemas de permisos. Probamos y seguimos buscando

+1
0
-1

Si reparas tu problema, añade(Solucionado)en el asunto de tu primer post, así es mas fácil para el que busca después.Mi Blog

Imagen de arriero
+1
0
-1

Echa un vistazo a este hilo y repasa entero el hilo, te dará una idea de cual podría ser el problema.
Repasa el tema de permisos para floppy y mira si tienes el paquete pmount instalado.

+1
0
-1

Si reparas tu problema, añade(Solucionado)en el asunto de tu primer post, así es mas fácil para el que busca después.Mi Blog

Imagen de bruce__128
+1
0
-1

no tenia el pmount instalado..... ahora si

el tema es asi:

si en el fstab dejo la linea
/dev/sdb /media/floppy auto user,noauto 0 0
y trato de montarlo..... no ocurre nada

si en cambio omito esa linea, desde el terminal y haciendo
sudo mount /dev/sdb /media/floppy
lo monta sin problemas.

ahora el problema me ocurre cuando quiero escribir el discquete. Me fije y no tengo permisos de escritura, pero tampoco puedo cambiarlos (ni desde root).
Trate de cambiar el permiso antes de montar y lo cambia....pero cuando monto, los permisos de escritura desaparecen.

+1
0
-1
Imagen de arriero
+1
0
-1

Repasemos los pasos:
1.- ¿Tienes añadido al grupo floppy a tu usuario? Creo que si, sí quieres asegurarte, puedes usar algunos pasos de este tutorial. Usa el 2º punto para buscar el grupo, etc.
2.- ¿Tienes permisos suficientes en la carpeta /media/floppy ? repasamos con el anterior post. Si quieres podrías mirar en las propiedades del directorio.
3.- ¿Hemos configurado bien el archivo fstab? Creo que por lo que me pones te faltan cosas.

/dev/sdb /media/floppy auto user,noauto 0 0

Si lo comparas con el que te dejo debajo.

Forma de probar lo que hagas en fstab, sin reiniciar la maquina, es tecleando la siguiente orden:

sudo mount -a

Te deje este archivo de montaje sacado directamente de un howto de ubuntuforums:

/dev/sdx /media/floppy auto sync,user,noauto,nosuid,exec,nodev 0 0

Usalo haber que resulta.

+1
0
-1

Si reparas tu problema, añade(Solucionado)en el asunto de tu primer post, así es mas fácil para el que busca después.Mi Blog

Imagen de bruce__128
+1
0
-1

antes de montar la carpeta /media/floppy esta asi:

drwxrwxrwx 2 root root 4096 2011-03-01 07:49 floppy

despues de montar (sudo mount /dev/sdb /media/floppy), me queda asi:

drwxr-xr-x 2 root root 7168 1969-12-31 21:00 floppy

No se porque cambian los permisos. Y no encuentro la manera de cambiarlos.....

+1
0
-1