Instalé Ubuntu Desktop en mi Mac y ahora no puedo volver al OSX

Imagen de Karlinor
0 puntos

Hola,

Junto con saludarlos cordialmente, me presento, mi nombre es Daniel Cruz y soy de Chile. Soy dueño de un Ibook G4 version 1.33Ghz.

Bueno, la cosa es que, en mi Ibook me dió por instalar Ubuntu Live para poder jugar una serie de juegos además de poder, simplemente, probar.
Cuento corto, me costó poder averiguar que para el Ibook se necesita una versión de Linux específica, asi que, luego de una serie de intentos fallidos y discos quemados que tuve que tirar a la basura, lo pude instalar.
La versión que tengo instalada es la 10.04 si no me equivoco, Gnome para ser específico (como dije, soy usuario nuevo, estoy lejos de entender las diferencias entre los distintos tipos).
La cosa es que, luego de quemar el cd con la version correcta e intentar instalar, el instalador me decía que el DD estaba lleno, siendo que tenía 27Gb vacíos. Asi que, como no pude hacerlo del modo habitual, me atreví a hacer click en la opción de "particionar disco manualmente". Después de un par de intentos, pude hacerlo. Volví al inicio del instalador, y ¡ahora si!, me salía el disco particionado y me indicaba claramente que en uno de ellos se encontraba el OSX. Bueno, al ver esto pensé "ok, todo va bien" y seguí instalandolo. Al instalarlo, el Linux me corrió sin problemas, pero cuando quería poder pasar al OSX me surgió el pequeño gran problema: no puedo volver al OSX (supuestamente al instalarlo, automáticamente al iniciar, te debería dar dos opciones de S.O.). Lo volví a apagar e intenté todos las formas de inicio que tiene Mac para empezar desde el OSX o desde el D.D., pero nada, siempre llegaba a Linux.

¿Cómo puedo solucionar esto?, hasta ahora me gusta el Linux, pero también soy fanático de Mac, la idea era tener un poco de los dos mundos!.

De antemano muchas gracias (perdón por publicar esto en dos foros, pero no sé en cual debería ir)

Imagen de elnetotaca
+1
0
-1

pero eres la segunda persona a la que le voy a dar la misma respuesta este día!

copia y pega este comando en la terminal;
esta en aplicaciones>>accesorios>>Terminal

sudo fdisk -l

ahí vamos a ver si aún tienes tu osx, o al menos la partición

+1
0
-1

unzip; strip; touch; finger; mount; fsck; more; yes; unmount; sleep
Es lo que hago a diario....... En Linux mal pensados!

Imagen de apradoc
+1
0
-1

Estimado elnetotaca, en mi caso si desaparecí todo rastro de la tabla anterior y lo que obtengo es esto:

AVISO: GPT (Tabla de partición GUID) detectado en '/dev/sda'! La utilidad fdisk no soporta GPT. Use GNU Parted.


Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 cabezas, 63 sectores/pista, 60801 cilindros, 976773168 sectores en total
Unidades = sectores de 1 * 512 = 512 bytes
Tamaño de sector (lógico / físico): 512 bytes / 512 bytes
Tamaño E/S (mínimo/óptimo): 512 bytes / 512 bytes
Identificador del disco: 0x00000000

Dispositivo Inicio    Comienzo      Fin      Bloques  Id  Sistema
/dev/sda1               1          33          16+  ee  GPT
/dev/sda2              34        1987         977   ef  EFI (FAT-12/16/32)
/dev/sda3   *        1988   968535191   484266602   83  Linux
/dev/sda4       968535192   976773118     4118963+  82  Linux swap / Solaris

Podria seguir así para probar la plataforma Kaltura CE 4, pero luego debo devolver la máquina a su estado inicial.
Que me recomiendas, que no sea el suicidio o rezar? XD

+1
0
-1

@apradoc

Imagen de apradoc
+1
0
-1

Por otra parte al solicitarle a Gparted que me explorara que sistemas se encuentran en el disco me arrojó el siguiente resultado.

Se encontraron datos
Sistema de archivos
#1: ntfs (0MiB)

Luego al solicitarle ver el sistema me advierte:

Advertencia: el área del sistema de archivos detectado se solapa con, al menos, otra partición existente.
Se recomienda que no use ningún sistema de archivos solapado para evitar interferencias con datos existentes.
¿Quiere intentar desactivar los siguientes puntos de montaje?
/dev/sda1 mounted on 

Seguidamente creo que lo desactivaré y reintentaré una nueva instalación de ubuntu 11.10... y te digo que pasa Ñ'/

+1
0
-1

@apradoc

Imagen de Karlinor
+1
0
-1

Muchas gracias!
Esto es lo que me sale:

/dev/hda
# type name length base ( size ) system
/dev/hda1 Apple_partition_map Apple 63 @ 1 ( 31.5k) Partition map
/dev/hda2 Apple_Bootstrap untitled 2048 @ 36984832 ( 1.0M) NewWorld bootblock
/dev/hda3 Apple_Bootstrap Apple_HFS_Untitled_1 36721504 @ 262208 ( 17.5G) NewWorld bootblock
/dev/hda4 Apple_UNIX_SVR2 untitled 39350272 @ 36986880 ( 18.8G) Linux native
/dev/hda5 Apple_UNIX_SVR2 swap 1802240 @ 76337152 (880.0M) Linux swap
/dev/hda6 Apple_Free Extra 262144 @ 64 (128.0M) Free space
/dev/hda7 Apple_Free Extra 1120 @ 36983712 (560.0k) Free space
/dev/hda8 Apple_Free Extra 768 @ 78139392 (384.0k) Free space

Block size=512, Number of Blocks=78140160
DeviceType=0x0, DeviceId=0x0

No se mucho que significa, pero espero sirva!

+1
0
-1
Imagen de elnetotaca
+1
0
-1

ese comando muestra todas las particiones que tienes en tu disco duro.
lo hicimos porque yo tenía la duda si habías borrado las particiones OSX y con ello el sistema OSX, pero al parecer aún las tienes, lo que necesitas hacer es recuperar el grub;

http://www.guia-ubuntu.org/index.php?title=Recuperar_GRUB
ahí hay info como hacerlo

+1
0
-1

unzip; strip; touch; finger; mount; fsck; more; yes; unmount; sleep
Es lo que hago a diario....... En Linux mal pensados!

Imagen de Karlinor
+1
0
-1

Bueno, primero que nada gracias por su invaluable ayuda.

He seguido los pasos que en el link que indicas salen y todo bien hasta el grub-install, porque me sale este problema (error): /usr/share/lupin-support/grub-mkimage: 33: grub-probe: not found
/usr/sbin/grub-install: 31: grub-install.real: not found

¿por que sera?.

Saludos y gracias nuevamente!

+1
0
-1
Imagen de Karlinor
+1
0
-1

Hola,

Bueno, tengo una suposición con respecto a porque no me podría funcionar lo que en el link dicen (solo una suposición). Creo que puede ser debido a que no lee el cd (si bien el lector suena cuando lo esta leyendo, el SO no me indica absolutamente nada del cd, no tengo como abrir su conenido) y por eso no puedo instalar el Grub que ahi se encuentra.

La otra cosa es que, en la carpeta del Boot/Grub, debería haber un Menu.lst que en mi caso no se encuentra.

No se si sirva, pero en una de esas...

Saludos!

+1
0
-1
Imagen de Blackleker
+1
0
-1

El menu.lst no te aparece porque tienes el grub 2 el archivo de configuración del grub2 esta en /boot/grub/grub.cfg intenta con este comando sudo update-grub2 y coloca acá lo que sale

http://www.guia-ubuntu.org/index.php?title=GRUB

+1
0
-1
Imagen de elnetotaca
+1
0
-1

si, necesitas el menu.lst, lo que te dará acceso a tu osx, TU vas por buen camino, eres nuevo pero estas comprendiendo el funcionamiento basico de el sistema, en hora buena, sigamosle hechando ganas!

abre una terminal y digita esto;
sudo update-grub2

+1
0
-1

unzip; strip; touch; finger; mount; fsck; more; yes; unmount; sleep
Es lo que hago a diario....... En Linux mal pensados!

Imagen de elnetotaca
+1
0
-1

olvidate del sudo update-grub2

sigue estos pasos;
bajate este programa;
http://www.supergrubdisk.org/2011/02/20/rescatux-0-23-released/

1º arranca la pc desde Super Grub Disk eliges "Arrancar GNU/linux directamente" y te arranca tu versión de linux

2º Te vas a la terminal y escribes lo siguiente:

sudo grub-mkconfig (después que termine esto:)

sudo grub-install /dev/sda (después que termine esto:)

sudo update-grub

reiniciar.

y listo y a correr.

+1
0
-1

unzip; strip; touch; finger; mount; fsck; more; yes; unmount; sleep
Es lo que hago a diario....... En Linux mal pensados!

Imagen de elnetotaca
+1
0
-1

aqui te dejo un video donde puedes ver paso a paso como ellos lo hacen;

http://www.youtube.com/watch?v=0PyUh4BC28Y

+1
0
-1

unzip; strip; touch; finger; mount; fsck; more; yes; unmount; sleep
Es lo que hago a diario....... En Linux mal pensados!

Imagen de Karlinor
+1
0
-1

Hola,

primero que nada, gracias nuevamente por el interes en ayudar.
Elnetotaca: muchas gracias por tus comentarios, efectivamente soy nuevo en esto y de a poco voy aprendiendo.

Intente con todas las formas que uds me dieron y los problemas fueron los siguientes:

con el de elnetotaca: baje el archivo, pero no entendi a que se referia con iniciar el pc desde el archivo y luego seleccionar GNU/Linux para arrancar. Asi que, simplemente inicie el terminal y puse lo que me dijo.
Con el paso 1 (sudo grub-mkconfig) ningun problema,
con el paso 2 me tira el siguiente error: /usr/sbin/grub-install: 31: grub-install.real: not found.

Con el de Blackleker, el problema lo tengo con el udpate del grub2. Me da el siguiente error:
sudo: udpate-grub2: command not found

Esas son las malas noticias hasta ahora, mas rato probare con lo que sale en el video.
Igual todavia acepto recomendaciones

+1
0
-1
Imagen de Thedemon007
+1
0
-1

creo que has escrito el comando mal sudo: udpate-grub2: command not found tiene dos puntos (:) es asi: sudo udpate-grub2

+1
0
-1
Imagen de Goyo
+1
0
-1

Me temo que la mayor parte de la información disponible sobre grub está muy orientada a arqutecturas x86 o x86-64y en powerpc es diferente. Los paquetes relacionados con grub para powerpc llevan todavía la versión 0.97 y en efecto no parece haber ningún programa update-grub ni update-grub2 ni son los mismos paquetes.

http://packages.ubuntu.com/search?suite=maverick&arch=powerpc&searchon=names&keywords=grub

También algunas cosas que se leen por ahí sugieren que en powerpc no se usa grub sino algo llamado yaboot (o tal vez ambas cosas?).
https://wiki.ubuntu.com/PowerPCFAQ#Yaboot%20Configuration
Y efectivamente parece haber un problema con la lectura de CDs:
https://wiki.ubuntu.com/PowerPCKnownIssues#Ubuntu%2010.04%20Lucid%20Lynx

Los enlaces que te pongo sobre powerpc parecen algo anticuados pero pueden ser un punto de partida. Necesitas buscar información específica sobre esta arquitectura. Todavía debe haber bastantes usuarios por ahí y en algún sitio se deben juntar, y de hecho se siguen haciendo versiones no oficiales de Ubuntu, pero por aquí hace mucho que no veo ninguna consulta sobre esto.

+1
0
-1
Imagen de Thedemon007
+1
0
-1

Hola Goyo como has hecho para colocar los enlaces asi??? que codigo html utilizaste es que yo siempre posteo un enlace asi https://wiki.ubuntu.com/ y para que los demas lo puedan usar tienes que copiarlo y pegarlo en la barra de direcciones encambio el tuyo na mas se le da clic y ya

Edito: ya logre colocar los enlaces bien

+1
0
-1
Imagen de elnetotaca
+1
0
-1

si, tu problema se vuelve un tanto mas complicado con las mac pcs.
pero aqui puedes bajar este archivo;
lo que tienes que hacer es
1-bajarlo y descomprimirlo(lo puedes hacer en ubuntu)
2-quema el .iso en un cd o dvd
3-arranca la pc con el cd/dvd que contiene el .iso
ahí sigue las instrucciones.
http://sourceforge.net/projects/refit/files/rEFIt/0.14/rEFIt-0.14.cdr.gz...

+1
0
-1

unzip; strip; touch; finger; mount; fsck; more; yes; unmount; sleep
Es lo que hago a diario....... En Linux mal pensados!

Imagen de Karlinor
+1
0
-1

elnetotaca, gracias nuevamente por todo.

Te cuento cual es mi problema ahora (uno tras otro, estoy un poco cansado ya jaja), hice todo lo que me dijiste y al momento de iniciar el pc desde el cd, para hacerlo, espere que me saliera la pantalla como del Bios que te da la opcion de partir desde el cd (apretando la letra c desde la misma pantalla) o desde el linux (en el caso de poner la opcion l). Cuento corto, apreté c y nada, me vuelve a la misma pantalla para elegir entre estas dos opciones, una y otra vez.
Otra cosa, el archivo que me adjuntaste para bajar, no me sale .Iso, si no, .cdr.

Saludos!

+1
0
-1