(Solucionado)Error en Flashplugin-nonfree y/o Flashplugin-installer

Imagen de EvaEvaEva
6 puntos

En Ubuntu 10.04 de 64 bits

No puedo instalar Falshplugin-nonfree. El error que da es el siguiente:

Detalles del fallo:

flashplugin-installer
flashplugin-nonfree
adobereader-deu
E: Sub-process /urs/bin/dpkg returned an error code (1)
Un paquete no se pudo instalar. Tratando de recuperarlo:
Configurando flashplugin-installer (10.2.153.1ubuntu0.10.04.1) ...
Installing from local file /var/cache/flashplugin-installer/adobe flashplugin_10.2.153.1.orig.tar.gz
Flash Plugin installed.
nspluginwrapper: no appropiate viewer found for /usr/lib/flashplugin-installer/libflashplayer.so
dpkg: error al procesar flashplugin-installer (--configure):
el subproceso instalado el escript post-installation devolvió el código de salida de error 1
dpkg: problemas de dependencias impiden la configuración de flashplugin-nonfree:
flashplugin-nonfree depende de flashplugin-installer; sin embargo:
El paquete 'flashplugin-installer' no está configurado todavía.
dpkg: error al procesar flashplugin-nonfree (--configure):
problemas de dependencias - se deja sin configurar
Se encontraron errores al procesar:
flashplugin-installer
flashplugin-nonfree

¿Alguna manera de solucionarlo?
Gracias.

Imagen de EnriqueK
+1
0
-1

No los instales, mas bien entra a Synaptic y borra todo lo que tengas de flash , inclusive a flashplugin-installer , flashplugin-nonfree y en general todo lo que temgas de flash y lo mismo haces para eliminar todo lo que tengas de gnash, luego ejecuta los siguientes comandos en el orden indicado
wget -c http://download.macromedia.com/pub/labs/flashplayer10/flashplayer_square...
sudo tar -zxvf flashplayer_square_p2_64bit_linux_092710.tar.gz --directory /usr/lib/mozilla/plugins
rm flashplayer_square_p2_64bit_linux_092710.tar.gz

+1
0
-1
Imagen de EvaEvaEva
+1
0
-1

Con lo que me indicas veo que lo que se hace es colocar el fichero libflashplayer.so de 64 bits en /usr/lib/mozilla/plugins y ese ya lo había puesto.

También lo tengo puesto en /usr/lib/firefox/plugins y /usr/lib/opera/plugins y por eso aunque me daba error en flashplugin-installer y en flshplugin-nonfree me funcionaban bien los dos navegadores, Mozilla y Opera.

Lo que he hecho simplemente es desinstalar flashplugin-installer y flshplugin-nonfree que parece ser que son para 32 bits y al tener Ubuntu 10.04 de 64 bits el que funciona correctamente es libflashplayer.so de 64 bits

Gracias.

Un saludo.

+1
0
-1