Modem Huawei E173s -6

Imagen de Sandra Cuore
0 puntos

Que tal, desde Uruguay a todos.
Hace 2 meses que no puedo dar con la configuración de este modem, aqui la empresa que lo usa es CLARO, por lo tanto me he recorrido todos los centros de atencion al usuario y me han dicho que no tienen la configuracion para Ubuntu 10.10.
Si alguien la tiene, le agradeceria me la pasara.
Yo tengo algunas pero no me han servido porque ubuntu solo la detecta como unidad de almacenamiento ya que posee ranura para msd. Sin embargo no he tenido suerte.
Un saludo afectuoso a nuestros hermanos de habla hispana ;)
Gracias

Imagen de Sandra Cuore
+1
0
-1

- Conectamos el módem a un puerto USB
- Abrimos una Terminal y ejecutamos el comando lsusb
Aplicaciones -> Accesorios-> Terminal
Code:
user@NOTEBOOK:~$ lsusb
Dará como resultado algo como esto:
Code:
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 003: ID 138a:0001 DigitalPersona, Inc Fingeprint Reader
Bus 003 Device 002: ID 03f0:171d Hewlett-Packard Wireless (Bluetooth + WLAN) Interface [Integrated Module]
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 012: ID 12d1:1c0b Huawei Technologies Co., Ltd.
Bus 002 Device 002: ID 174f:1107 Syntek
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
ma
La linea que nos interesa es:
Code:
Bus 002 Device 012: ID 12d1:1c0b Huawei Technologies Co., Ltd.
Ahora vamos a crear un archivo con gedit que se llamará E173s, para esto en la terminal ejecutamos:
Code:
user@NOTEBOOK:~$ sudo gedit /etc/usb_modeswitch.d/E173s
Se abrirá el editor de texto con un archivo vacío, dentro compiamos lo siguiente (copiar y pegar, o hacerlo "a mano"):
Code:
#########
# Huawei E173s

DefaultVendor= 0x12d1
DefaultProduct= 0x1c0b

TargetVendor= 0x12d1
TargetProduct= 0x1c05

CheckSuccess=20

MessageEndpoint= 0x0f
MessageContent="55534243000000000000000000000011060000000100000000000000000000"
Guardamos el archivo y cerramos el editor de texto gedit.

Luego ejecutamos lo siguiente en la terminal:
Code:
user@NOTEBOOK:~$ sudo usb_modeswitch -c /etc/usb_modeswitch.d/E173s
Ahora debería aparecer en la terminal algo como esto:
Code:
matias@SK-NOTEBOOK:~$ sudo usb_modeswitch -c /etc/usb_modeswitch.d/E173s

Looking for target devices ...
No devices in target mode or class found
Looking for default devices ...
Found devices in default mode or class (1)
Accessing device 005 on bus 002 ...
Using endpoints 0x0f (out) and 0x8f (in)
Using endpoints 0x0f (out) and 0x8f (in)
Inquiring device details; driver will be detached ...
Looking for active driver ...
OK, driver found ("usb-storage")
OK, driver "usb-storage" detached

SCSI inquiry data (for identification)
-------------------------
Vendor String: HUAWEI
Model String: Mass Storage
Revision String: 2.31
-------------------------

USB description data (for identification)
-------------------------
Manufacturer: HUAWEI
Product: HUAWEI Mobile
Serial No.: not provided
-------------------------
Setting up communication with interface 0 ...
Using endpoint 0x0f for message sending ...
Trying to send message 1 to endpoint 0x0f ...
OK, message successfully sent
Resetting response endpoint 0x8f
Error resetting endpoint: -71
Resetting message endpoint 0x0f
Error resetting endpoint: -19
Device is gone, skipping any further commands

Checking for mode switch (max. 20 times, once per second) ...
Original device is gone already, not checking
Searching for target devices ...
Searching for target devices ...
Searching for target devices ...
Found correct target device

Mode switch succeeded. Bye.
LISTO. YA DEBERÍA ESTAR RECONOCIDO NUESTRO MÓDEM.
Lo verificamos ejecutando en la terminal:
Code:
user@NOTEBOOK:~$ lsusb
entre las lineas que aparecen debería aparecer una como esta:
Code:
Bus 002 Device 012: ID 12d1:1c05 Huawei Technologies Co., Ltd.
Por último nos queda modificar el archivo 40-usb_modeswitch.rules para que el modem sea correctamente reconocido cada vez que lo conectemos al puerto USB. Lo hacemos de esta manera:
En la terminal ejecutamos:
Code:
user@NOTEBOOK:~$ sudo gedit /lib/udev/rules.d/40-usb_modeswitch.rules
Abajo de esta linea:
Code:
# Huawei E173
ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="1557", RUN+="usb_modeswitch '%b/%k'"
Creamos una nueva que se va a llamar "#E173s", debe quedar así:
Code:
# Huawei E173s
ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="1c0b", RUN+="usb_modeswitch '%b/%k'"

+1
0
-1

Sandra Cuore / Montevideo - Uruguay

Imagen de luisitorres
+1
0
-1

Hola!
Antes que nada quiero aclarar que soy novata en ubuntu 10.10 y quiero instalar un modem E173s-6.
He seguido los pasos, pero me ha surgido un problema cuando ejecuto la terminal:
sudo usb_modeswitch -c /etc/usb_modeswitch.d/E173s
Ya que vos indicaste que debe aparecer "algo como esto", bueno a mi me apareció esto:
Looking for target devices ...
No devices in target mode or class found
Looking for default devices ...
Found devices in default mode or class (1)
Accessing device 004 on bus 002 ...
Using endpoints 0x0f (out) and 0x8f (in)
Using endpoints 0x0f (out) and 0x8f (in)
Inquiring device details; driver will be detached ...
Looking for active driver ...
OK, driver found ("usb-storage")
OK, driver "usb-storage" detached

SCSI inquiry data (for identification)
-------------------------
Vendor String: HUAWEI
Model String: Mass Storage
Revision String: 2.31
-------------------------

USB description data (for identification)
-------------------------
Manufacturer: HUAWEI
Product: HUAWEI Mobile
Serial No.: not provided
-------------------------
Setting up communication with interface 0 ...
Using endpoint 0x0f for message sending ...
Trying to send message 1 to endpoint 0x0f ...
OK, message successfully sent
Resetting response endpoint 0x8f
Resetting message endpoint 0x0f

Checking for mode switch (max. 20 times, once per second) ...
Waiting for original device to vanish ...
Waiting for original device to vanish ...
Waiting for original device to vanish ...
Waiting for original device to vanish ...
Waiting for original device to vanish ...
Waiting for original device to vanish ...
Waiting for original device to vanish ...
Waiting for original device to vanish ...
Waiting for original device to vanish ...
Waiting for original device to vanish ...
Waiting for original device to vanish ...
Waiting for original device to vanish ...
Waiting for original device to vanish ...
Waiting for original device to vanish ...
Waiting for original device to vanish ...
Waiting for original device to vanish ...
Waiting for original device to vanish ...
Waiting for original device to vanish ...
Waiting for original device to vanish ...
Waiting for original device to vanish ...
Original device still present after the timeout

Mode switch most likely failed. Bye.
Aún no me reconoce el modem, por lo tanto no lo puedo usar.
Desde ya muchas gracias.

+1
0
-1
Imagen de ogunsett
+1
0
-1

Yo hice lo mismo y me paso lo mismo, luego encontré el problema y esta en la linea donde dice:

sudo gedit /etc/usb_modeswitch.d/E173s

crea un archivo llamado E173s entonces lo renombre a 12d1:1c0b y en ese caso fue detectado correctamente.

+1
0
-1
Imagen de bean
+1
0
-1

no ha informado solucionado según como le fue con las instrucciones modificadas dadas; pero, a quien pueda interesar, Ubuntu 11.04 NN reconoce de inmediato el dispositivo modem Huawei e173, después de hacer las configuraciones correctas en conexiones de red, habiendo desconectado la cableada previamente.
Saludos.

+1
0
-1