[Resuelto] Problema al actualizar Ubuntu 10.10: no es posible configurar el paquete `linux-image-2.6.35-25-generic'

Imagen de nicomagliaro
0 puntos

Hola Gente:
Les cuento que mi problema empezo con la actualizacion a ubuntu maverick 10.10 en el cual cada vez q ejecuto actualizaciones me tira el sigiente error:

Configurando linux-image-2.6.35-25-generic (2.6.35-25.44) ...
Internal Error: Could not find image (/boot/vmlinuz-2.6.35-25-generic)
dpkg: error al procesar linux-image-2.6.35-25-generic (--configure):
el subproceso script post-installation instalado devolvió el código de salida de error 2
dpkg: problemas de dependencias impiden la configuración de linux-image-generic:
linux-image-generic depende de linux-image-2.6.35-25-generic; sin embargo:
El paquete `linux-image-2.6.35-25-generic' no está configurado todavía.
dpkg: error al procesar linux-image-generic (--configure):
problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de linux-generic:
linux-generic depende de linux-image-generic (= 2.6.35.25.32); sin embargo:
El paquete `linux-image-generic' no está configurado todavía.
dpkg: error al procesar linux-generic (--configure):
problemas de dependencias - se deja sin configurar
Configurando gdm (2.30.5-0ubuntu4.1) ...
No se ha escrito ningún informe de Apport porque el mensaje de error indica que es un error proveniente de un fallo anterior. No se ha escrito ningún informe de Apport porque el mensaje de error indica que es un error proveniente de un fallo anterior. Configurando libdrm2 (2.4.22-2ubuntu1) ...
Se encontraron errores al procesar:
linux-image-2.6.35-25-generic
linux-image-generic
linux-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)

Ya he intentado con sudo apt-get install -f pero hasta ahora nada a conseguido sulucionar el problema (siempre salta el problema de configuracion por lo que no puede instalarse el linux-generic). Aunque algo extraño es que anque siempre me tira la salida de este error en la actualizacion del kernel, los demas paquetes a actualizar o instalar, lo hacen sin problemas aunque el error siga siendo recurrente.
saludos y agradesco cualquier ayuda

Imagen de elnetotaca
+1
0
-1

dpkg --configure --pending
y dime que te sale en la terminal
es probable que te persista el error, pero ya se como arreglarlo, solo quiero estar seguro, hay que correr esa linea de comando, a ver si se puede solucionar automaticamente.

+1
0
-1

unzip; strip; touch; finger; mount; fsck; more; yes; unmount; sleep
Es lo que hago a diario....... En Linux mal pensados!

Imagen de elnetotaca
+1
0
-1

te desaparecistes del mapa, no se sabe si te sirvió mi respuesta o nó.

si te persiste el error solo dime que te dice la terminal luego de ejecutar
sudo apt-get update

saludos

+1
0
-1

unzip; strip; touch; finger; mount; fsck; more; yes; unmount; sleep
Es lo que hago a diario....... En Linux mal pensados!

Imagen de nicomagliaro
+1
0
-1

Mil disculpas elnoteataca por el cuelgue, es que estuve con mucho laburo estos ultimos dias ademas de que no me llegaron las alertas de respuesta a mi mail.
Prometo estar mas atento de ahora en mas.

hice los que me escribiste y estos son los resultados:

nicolas@nicolas-laptop:~$ sudo dpkg --configure --pending
[sudo] password for nicolas:
Configurando linux-image-2.6.35-25-generic (2.6.35-25.44) ...
Internal Error: Could not find image (/boot/vmlinuz-2.6.35-25-generic)
dpkg: error al procesar linux-image-2.6.35-25-generic (--configure):
el subproceso instalado el script post-installation devolvió el código de salida de error 2
Se encontraron errores al procesar:
linux-image-2.6.35-25-generic

Este es el output de la actualizacion de los repos

nicolas@nicolas-laptop:~$ sudo apt-get update
Obj http://archive.canonical.com maverick Release.gpg
Obj http://ar.archive.ubuntu.com maverick Release.gpg
Obj http://security.ubuntu.com maverick-security Release.gpg
Ign http://archive.canonical.com/ubuntu/ maverick/partner Translation-en
Ign http://archive.canonical.com/ubuntu/ maverick/partner Translation-es
Ign http://ar.archive.ubuntu.com/ubuntu/ maverick/main Translation-en
Obj http://archive.canonical.com maverick Release
Obj http://ar.archive.ubuntu.com/ubuntu/ maverick/main Translation-es
Obj http://archive.canonical.com maverick/partner Sources
Obj http://archive.canonical.com maverick/partner i386 Packages
Ign http://security.ubuntu.com/ubuntu/ maverick-security/main Translation-en
Ign http://ar.archive.ubuntu.com/ubuntu/ maverick/multiverse Translation-en
Obj http://ar.archive.ubuntu.com/ubuntu/ maverick/multiverse Translation-es
Ign http://security.ubuntu.com/ubuntu/ maverick-security/main Translation-es
Ign http://ar.archive.ubuntu.com/ubuntu/ maverick/restricted Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/multiverse Translation-en
Obj http://ar.archive.ubuntu.com/ubuntu/ maverick/restricted Translation-es
Ign http://security.ubuntu.com/ubuntu/ maverick-security/multiverse Translation-es
Ign http://security.ubuntu.com/ubuntu/ maverick-security/restricted Translation-en
Ign http://ar.archive.ubuntu.com/ubuntu/ maverick/universe Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/restricted Translation-es
Ign http://security.ubuntu.com/ubuntu/ maverick-security/universe Translation-en
Obj http://ar.archive.ubuntu.com/ubuntu/ maverick/universe Translation-es
Ign http://security.ubuntu.com/ubuntu/ maverick-security/universe Translation-es
Obj http://ar.archive.ubuntu.com maverick-updates Release.gpg
Obj http://security.ubuntu.com maverick-security Release
Ign http://ar.archive.ubuntu.com/ubuntu/ maverick-updates/main Translation-en
Obj http://security.ubuntu.com maverick-security/main i386 Packages
Obj http://security.ubuntu.com maverick-security/universe i386 Packages
Ign http://ar.archive.ubuntu.com/ubuntu/ maverick-updates/main Translation-es
Obj http://security.ubuntu.com maverick-security/restricted i386 Packages
Ign http://ar.archive.ubuntu.com/ubuntu/ maverick-updates/multiverse Translation-en
Obj http://security.ubuntu.com maverick-security/multiverse i386 Packages
Ign http://ar.archive.ubuntu.com/ubuntu/ maverick-updates/multiverse Translation-es
Ign http://ar.archive.ubuntu.com/ubuntu/ maverick-updates/restricted Translation-en
Ign http://ar.archive.ubuntu.com/ubuntu/ maverick-updates/restricted Translation-es
Ign http://ar.archive.ubuntu.com/ubuntu/ maverick-updates/universe Translation-en
Ign http://ar.archive.ubuntu.com/ubuntu/ maverick-updates/universe Translation-es
Obj http://ar.archive.ubuntu.com maverick-proposed Release.gpg
Ign http://ar.archive.ubuntu.com/ubuntu/ maverick-proposed/main Translation-en
Obj http://ar.archive.ubuntu.com/ubuntu/ maverick-proposed/main Translation-es
Ign http://ar.archive.ubuntu.com/ubuntu/ maverick-proposed/multiverse Translation-en
Obj http://ar.archive.ubuntu.com/ubuntu/ maverick-proposed/multiverse Translation-es
Ign http://ar.archive.ubuntu.com/ubuntu/ maverick-proposed/restricted Translation-en
Obj http://ar.archive.ubuntu.com/ubuntu/ maverick-proposed/restricted Translation-es
Ign http://ar.archive.ubuntu.com/ubuntu/ maverick-proposed/universe Translation-en
Obj http://ar.archive.ubuntu.com/ubuntu/ maverick-proposed/universe Translation-es
Obj http://ar.archive.ubuntu.com maverick-backports Release.gpg
Ign http://ar.archive.ubuntu.com/ubuntu/ maverick-backports/main Translation-en
Ign http://ar.archive.ubuntu.com/ubuntu/ maverick-backports/main Translation-es
Ign http://ar.archive.ubuntu.com/ubuntu/ maverick-backports/multiverse Translation-en
Ign http://ar.archive.ubuntu.com/ubuntu/ maverick-backports/multiverse Translation-es
Ign http://ar.archive.ubuntu.com/ubuntu/ maverick-backports/restricted Translation-en
Ign http://ar.archive.ubuntu.com/ubuntu/ maverick-backports/restricted Translation-es
Ign http://ar.archive.ubuntu.com/ubuntu/ maverick-backports/universe Translation-en
Ign http://ar.archive.ubuntu.com/ubuntu/ maverick-backports/universe Translation-es
Obj http://ar.archive.ubuntu.com maverick Release
Obj http://ar.archive.ubuntu.com maverick-updates Release
Obj http://ar.archive.ubuntu.com maverick-proposed Release
Obj http://ar.archive.ubuntu.com maverick-backports Release
Obj http://ar.archive.ubuntu.com maverick/main i386 Packages
Obj http://ar.archive.ubuntu.com maverick/universe i386 Packages
Obj http://ar.archive.ubuntu.com maverick/restricted i386 Packages
Obj http://ar.archive.ubuntu.com maverick/multiverse i386 Packages
Obj http://ar.archive.ubuntu.com maverick-updates/main i386 Packages
Obj http://ar.archive.ubuntu.com maverick-updates/universe i386 Packages
Obj http://ar.archive.ubuntu.com maverick-updates/restricted i386 Packages
Obj http://ar.archive.ubuntu.com maverick-updates/multiverse i386 Packages
Obj http://ar.archive.ubuntu.com maverick-proposed/main i386 Packages
Obj http://ar.archive.ubuntu.com maverick-proposed/universe i386 Packages
Obj http://ar.archive.ubuntu.com maverick-proposed/restricted i386 Packages
Obj http://ar.archive.ubuntu.com maverick-proposed/multiverse i386 Packages
Obj http://ar.archive.ubuntu.com maverick-backports/main i386 Packages
Obj http://ar.archive.ubuntu.com maverick-backports/universe i386 Packages
Obj http://ar.archive.ubuntu.com maverick-backports/restricted i386 Packages
Obj http://ar.archive.ubuntu.com maverick-backports/multiverse i386 Packages
Leyendo lista de paquetes... Hecho

Bueno espero que podamos llegar a una solucion

+1
0
-1
Imagen de nicomagliaro
+1
0
-1

Espero que esta informacion complemente la anterior. Es extrano pero como veras pude hacer una actualizacion del kernel 2.6.35-28 sin embargo me sigue tirando el mismo error:
Configurando linux-image-2.6.35-25-generic (2.6.35-25.44) ...
Internal Error: Could not find image (/boot/vmlinuz-2.6.35-25-generic)
dpkg: error al procesar linux-image-2.6.35-25-generic (--configure):
Es como que quiere configurar una imagen del kernel antigua. Otros programas los puedo instalar sin problemas aunque siempre me vuelve a salir el mismo error

nicolas@nicolas-laptop:~$ uname -r
2.6.35-28-generic

nicolas@nicolas-laptop:~$ ls -l /boot/
total 34964
-rw-r--r-- 1 root root 705861 2010-12-02 04:07 abi-2.6.35-24-generic
-rw-r--r-- 1 root root 706021 2011-03-18 21:36 abi-2.6.35-28-generic
-rw-r--r-- 1 root root 128614 2010-12-02 04:07 config-2.6.35-24-generic
-rw-r--r-- 1 root root 128604 2011-03-18 21:36 config-2.6.35-28-generic
drwxr-xr-x 3 root root 6144 2011-04-07 09:10 grub
-rw-r--r-- 1 root root 10759717 2011-03-11 13:54 initrd.img-2.6.35-24-generic
-rw-r--r-- 1 root root 10770348 2011-04-07 09:09 initrd.img-2.6.35-28-generic
drwx------ 2 root root 1024 2010-08-03 08:30 lost+found
-rw-r--r-- 1 root root 165084 2010-09-24 14:14 memtest86+.bin
-rw-r--r-- 1 root root 167264 2010-09-24 14:14 memtest86+_multiboot.bin
-rw-r--r-- 1 root root 1831358 2010-12-02 04:07 System.map-2.6.35-24-generic
-rw-r--r-- 1 root root 1832012 2011-03-18 21:36 System.map-2.6.35-28-generic
-rw-r--r-- 1 root root 1192 2010-12-02 04:10 vmcoreinfo-2.6.35-24-generic
-rw-r--r-- 1 root root 1192 2011-03-18 21:39 vmcoreinfo-2.6.35-28-generic
-rw-r--r-- 1 root root 4294032 2010-12-02 04:07 vmlinuz-2.6.35-24-generic
-rw-r--r-- 1 root root 4295344 2011-03-18 21:36 vmlinuz-2.6.35-28-generic
saludo2

+1
0
-1
Imagen de elnetotaca
+1
0
-1

ejecuta en la terminal;

sudo dpkg --remove linux-image-2.6.35-25-generic

sudo apt-get update
sudo apt-get upgrade

con eso te tiene que reparar el problema, si te persiste el problema postealo aqui.
Saludos.

+1
0
-1

unzip; strip; touch; finger; mount; fsck; more; yes; unmount; sleep
Es lo que hago a diario....... En Linux mal pensados!

Imagen de nicomagliaro
+1
0
-1

Bueno diste en la tecla, ya me actualiza perfecto. Creo que estamos para cerrar el hilo como resuelto
Muchas gracias elnetotaca

+1
0
-1
Imagen de elnetotaca
+1
0
-1

pasa buen día.
Saludos.

+1
0
-1

unzip; strip; touch; finger; mount; fsck; more; yes; unmount; sleep
Es lo que hago a diario....... En Linux mal pensados!