Problemas con el gestor de Actualizaciones

Imagen de Beckett999
0 puntos

Hola,

me gustaría compartir un problema que estoy teniendo para ver si alguien puede tirarme alguna idea o darma una mano... y así de pas tal vez aprenda un poco más a manejar Ubuntu.

El problema es el siguiente: desde que instalé Ubuntu 10.10 - Maverick Meerkat no logro realizar las actualizaciones periódicas desde el Gestor de Actualizaciones. Al poner comprobar, este detecta que hay actualizaciones disponibes y las lista, pero al poner Instalar cominza el proceso y siempre indefectiblemente se detiene saltando un cartel que dice:

Se requiere la instalación de paquetes no confiables

La acción puede necesitar la instalación de paquetes de fuentes no autenticadas.

Descubrí que sí puedo instalar las actualizaciones desde Synaptic, pero me gustaría saber por qué el gestor de actualizaciones no funciona bien.

Desde ya muchas gracias!!

Francisco

Imagen de Jose Luis 1320
+1
0
-1

El servidor de donde uno o más repositorios se encuentran activos no estan autenticados con su llave pública, depende mucho de que repositorios tienes activos dentro de /etc/apt/sources.list

Primero intenta hacer desde Terminal (Aplicaciones> Accesorios> Terminal)

sudo apt-get update

en lo que devuelve en la pantalla de tu consola "terminal" debe venir (al final) en que repositorio no esta obteniendo la llave publica que te falta para que en las Actualizaciones se descarguen los paquetes sin contratiempos.

Un saludo.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de Xachox
+1
0
-1

Hola a todos!
Como ya no tenia bastante con los problemas de audio y video, ahora también
se ha sumado el gestor de actualizaciones.
Quisiera compartir una captura de pantalla para que se entendiera mejor pero no se como
"subirla" aquí. Intentaré explicarlo en palabras:
Ahora cuando arranco el Centro de software de Ubuntu y selecciono cualquier
aplicación para instalar me sale esto:
Falló al bloquear el gestor de paquetes
Compruebe si está actualmente ejecutando otra herramientas de gestión de software,
por ejemplo Synaptic o aptitude. Solamente se puede usar una herramienta cada vez.

No estoy usando ninguna otra herramienta de ese tipo, y por lo tanto no tengo ni idea de que
puede estar pasando.
Alguien podría ayudarme y así poder continuar perdiendo el tiempo en intentar encontrar solución
a los prablemas deaudio y video que tengo??
Gracias de antemano.

+1
0
-1

Imagen de Jose Luis 1320
+1
0
-1

segundo, no te quejes y ponte a resolver los problemas.

y tercero, lee las normas del foro.

cuarto, El problema es con el gestor de actualizaciones o el centro de software?

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de Xachox
+1
0
-1

Perdone usted don Jose Luis.
-Pensaba que no era correcto abrir otro hilo si la duda trataba de lo mismo que otro
ya existente.
-No me estoy quejando, solamente consulto lo que a mi me ocurre.
-Resolvería todo sin molestar a nadie, si tuviera los conocimientos para hacerlo.
-Pensaba que esta página trataba de eso ya que no todos somos unos expertos (como otros).
-El problema ocurre en ambos (gestor y centro).
-Al igual te has tomado mi escrito como na queja por lo de perder el tiempo, lo cuál me dice
que has leido el mensaje pero sin entenderlo, ya que he seguido muchos foros y "tutoriales"
para arreglar el tema AVI y que no me de problemas y en tres versiones distintas de
Ubuntu (9.04, 10.04 y 10.10). En todas funciona un tiempo y luego se va, vuelve y se va (sonido)
mientras que en todas lo que si siempre se ha entrecortado es el video.
-La pérdida de tiempo hacía referencia al tiempo pasado para buscar solución y a lo nada conseguido.
-La forma de responderme no invita ciertamente a un cosenso y a un aprendizaje.
Disculpa la pérdida de tiempo con mis asuntos.
Saludos

+1
0
-1

Imagen de Jose Luis 1320
+1
0
-1

Y gracias por aclararlo, en fin yo tambien me disculpo si me he leido agresivo y frío, en fin que bueno que hayas leido tutoriales para tratar de solucionar tus problemas eso por sí solo vale mucho... pero en fin no siempre se va a solucionar todo, habra veces en que los problemas persistirán... Yo por ejemplo en Ubuntu tenía demasiados problemas con el sonido al igual que tu; hice y deshice cuanto pude, con ALSA con OSS y el problema en fin siguió presentándose en uno y otro controlador de sonido... pero en fin lo ultimo que hice fue el haber instalado una instantanea de los drivers de ALSA antes de que lanzaran los de la version 1.0.24 con un script y funciona, digamos bien... hay veces que tengo que forzar el reinicio de ALSA al iniciar sesión pero de ahí en fuera funciona perfecto.

Ahora uso Debian 6, Y la verdad de problemas de audio... no los he tenido y es la misma tarjeta de sonido problemática dentro de Ubuntu.

Saludos.

Edito: sobre los AVI, ahi si ya no tengo tengo idea de que es lo que suceda ni como solucionarlo pues no veo videos con ese formato frecuentemente.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de furtaxi
+1
0
-1

Se requiere la instalación de paquetes no confiables

La acción puede necesitar la instalación de paquetes de fuentes no autenticadas.

Entiendo que pueden ser dos cosas:

Cosa 1: Te está pidiendo que aceptes. Puede que la ventana esté oculta, o que el terminal sea demasiado pequeño para mostrar el mensaje. Revisa lo primero, y aumenta el tamaño del terminal antes de lanzar el comando.

Cosa 2: Debes activar los repositorios nonfree. Tienen paquetes que pueden ser necesarios, pero de los que se carece de código fuente, o están mantenidos por personal ajeno a Ubuntu. Por ello, se te avisa, ya que tu sistema será un poco menos libre.

Sistema-Administración- Gestor de paquetes Synaptic-> menú repositorios. Asegúrate que están marcadas las cuatro primeras casillas.

(También puedes llegar aquí con el Centro de Software de Ubuntu->Editar->orígenes de software)

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de Beckett999
+1
0
-1

Hola, en principio mcuhas gracias por tomarse el tiempo y responder a mis consultas.

Jose Luis, cuando corro sudo apt-get upgrade lo que obtengo al final como mjes de error es:

W: Error de GPG: http://ar.archive.ubuntu.com maverick-updates Release: Las siguientes firms fueron inválidas: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key
W: Se produjo un error durante la verificación de las firmas. El repositorio no está actualizado y se utilizarán los ficheros de índice antiguos. El error GPG es: http://ar.archive.ubuntu.com maverick-security Release: Las siguientes firms fueron inválidas: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key

W: Imposible obtener http://ar.archive.ubuntu.com/ubuntu/dists/maverick-security/Release

W: Algunos archivos de índice no se han podido descargar, se han ignorado,
o se ha utilizado unos antiguos en su lugar.

Leyendo este foro aprendí hace rato que puedo usar las ódenes

sudo apt-get update y
sudo apt-get updrade

y tambén puedo bajar las actualizaciones desde Synaptic, pero me gustaría entender cuál es el problema y poder solucionarlo para ejecutar normalmente las actualizaciones desde el Gestor y dado que también esto me ha traído problemas con en Centro de Software al tratar de instalar algunos programas nuevos.

furtaxi, la ventana de error que tira el Gestor de actualizaciones con el texto que citaste solo tiene un botón (que ahora no recuerdo -y no puedo ver-, pero supongo que es Aceptar) y al apretarlo cierra el Gestor sin instalar nada.
En cuanto al tema de los repositorios supuse en un principio que el preoblema provenía de ahi (y aun supongo que tiene algo que ver) así que ya probé activando más origenes y las primeras 4 casillas de la pestaña Sofrware de Ubuntu están marcadas.

Gracias por sus respuestas, espero haber pintado un poco mejor los detalles del problema. Aguardo sus respuestas, si es que pueden aportarme algo más.

Saludos!

Francisco

+1
0
-1
Imagen de furtaxi
+1
0
-1

http://www.ubuntu-es.org/node/131555#comment-376164

Cambia el número de la clave, copiando y pegando el de tu error en vez del que pone el post, si son diferentes, creo que con ello, se soluciona.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de Beckett999
+1
0
-1

Hola furtaxi, gracias por tu respuesta. Probé lo que se indica como posible solución en el post que me sugeriste, pero ante el primer comando

sudo gpg --keyserver wwwkeys.eu.pgp.net --recv-keys 40976EAF437D05B5
(el número de clave de mi problema es el mismo que en el post)

surge

gpg: AVISO: propiedad insegura del archivo de configuración `/home/francisco/.gnupg/gpg.conf'
gpg: llamadas a programas externos desactivadas por permisos inseguros de ficheros.
gpg: error de comunicación con el servidor de claves: Error general
gpg: recepción del servidor de claves fallida: Error general

con ese mensaje de error por todos lados no creo que la cosa esté avanzando bien =S Además, intenté seguir con el procedimiento con los siguientes comandos, pero no se puede.

+1
0
-1
Imagen de Beckett999
+1
0
-1

Hola,

perdón que siga molestando, pero alguien me podría explicar por favor qué son las llaves públicas y de dónde se manejan, que me gustaría entenderlo?

Aunque creo que con sus consejos solucioné algunos pasos y estoy más cerca, mi problema sigue más o menos en el mismo estado, desde el Gestor de Actualizaciones no puedo instalarlas, pero si desde el Synaptic (dandole Continuar a las advertencias de que lo que va a descargar e instalar no esta confirmado que sea seguro) o usando update & upgrade desde una terminal.

Gracias!

Francisco

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

O igual alguien que sepa explicarte mejor que es una llave publica lo hará, pero te recomiendo que leas esta página: http://es.wikipedia.org/wiki/Criptograf%C3%ADa_asim%C3%A9trica

y en esta (te recomiendo más esta): http://delta.cs.cinvestav.mx/~gmorales/CriptoConf/node12.html

para que te empiezes a formar una idea de que es una llave pública...

Igual y si cambias tu repositorio tal vez dejes de tener el problema.

Saludos!.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de Beckett999
+1
0
-1

Gracias Jose Luis.

Cambiar el repositorio es algo que ya hice varias veces, eligiendo el más cercano, uno de más confianza, dejando que elija el mejor, etc. pero no cambió nada. Voy a ver esto que me mandaste. De todas formas puede ser que este pequeño problema sea un eror y no tenga una solución definitiva.

+1
0
-1
Imagen de Munuera
+1
0
-1

Hola,

Me pasa lo mismo que a ti y no paro de mirar por la red, pero no consigo solucionarlo. ¿Al final tu lo consiguiste? Si fue así. ¿Cómo lo hiciste?

Gracias de antemano

+1
0
-1
Imagen de cuentos
+1
0
-1

se pide no invadir hilos, y por que se hace un "desbarajuste" y no se sabe a quine se le esta contestando, ahora bien mnuera, el problema es que agregaste repositorios para descargar algun programa, pero el sistema de seguridad de linux no deja por que tienes quer agregar unas "llaves" para que linux/ubuntu los puerda tomar como seguros y dejar descargar de eloos los programas, desde la terminal (consola) ejecuta sudo apt-get update, y te va arrojar que no tiene la key de ciertos repositorios, fijate bien cuales son y si tu estas seguro de estos repositorios tendrias que agregar la llave. aqui una guia para que veas como agregar las llaves: http://blog.pcollaog.cl/2009/04/26/agregar-llaves-de-repositorios-apt-en...

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos