[COMO] Cambiar resolución de TTY luego de instalar controlador privativo (10.10)

Imagen de heavynetol
0 puntos

Algunas veces nos encontramos que luego de instalar el driver privativo de nuestras tarjetas gráficas, la resolución de las TTY tiene el tamaño de un pulgar por caracter.

Para solucionar dicho problema, les presento este [HOWTO], a fin de solucionarlo

1. Necesitamos los siguientes paquetes:

sudo apt-get install v86d hwinfo 

2. Buscamos el ID de nuestra resolución favorita:

sudo hwinfo --framebuffer | grep "Mode" 

aparecerá algo como esto:

Model: "NVIDIA NV34 Board - p162-2nz"
....
  Mode 0x0317: 1024x768 (+2048), 16 bits
  Mode 0x0318: 1024x768 (+4096), 24 bits
  Mode 0x031a: 1280x1024 (+2560), 16 bits
  Mode 0x031b: 1280x1024 (+5120), 24 bits
....
  Mode 0x0352: 2048x1536 (+8192), 24 bits

Los números en hexadecimal son los iD (Identificadores), en mi caso elegí 0x0318: que corresponde a la resolución 1024x768.

3. Ahora debemos decirle al kernel que resolución usará cuando inicie.

sudo gedit  /etc/default/grub

En éste archivo buscamos las siguientes líneas:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
...
#GRUB_GFXMODE=640×480

y lo cambiamos por la resolución que escogimos.
Nota: Se debe estar seguro de que el monitor soporta la última resolución listada por "hwinfo", en mi caso no funcionó, y opté por 1024x728. OBSERVENSE LOS CAMBIOS EN EL TEXTO.

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=1027x768-24,mtrr=3,scroll=ywrap"
GRUB_CMDLINE_LINUX="vga=0x0318"
...
GRUB_GFXMODE=1024x768

Guardamos.

4. Editamos otro archivo:

sudo gedit /etc/initramfs-tools/modules

y agregamos este texto al final

uvesafb mode_option=1024x768-24 mtrr=3 scroll=ywrap

Guardamos.

5. Necesitaremos crear otro archivo:

 echo FRAMEBUFFER=y | sudo tee /etc/initramfs-tools/conf.d/splash

6. Todo listo, solo necesitamos actualizar las configuraciones:

sudo update-grub2
sudo update-initramfs -u

7. Paso final reiniciar. y a disfrutar.

Imagen de Diegotime
+1
0
-1

Al reiniciar luego de hacer los cambios a mi me sale solo texto, luego al encender luego del grub se queda la pantalla con ese color por defecto del grub y luego aparece el mouse y el escritorio, sin el logo de ubuntu, y al apagar solo me aparecen los puntitos.

+1
0
-1