Aporte para la Broadcom BCM4311 despues de la Actualizacion de Ubuntu 10.10 a Ubuntu 11.04

Imagen de h3llBug
0 puntos

Hola a todos:

Espero les sirva este pequeño aporte, ayer actualize de Ubuntu 10.10 a Ubuntu 11.04, la verdad que como Diseñador Grafico que soy me agrado la interface y demas monerias que le han puesto. Peeeeerooooo!!

Cual fue mi sorpresa el dia de hoy al querer conectarme por WiFi no podia, primero me moleste, estaba hechando pestes por no traer el soporte adecuado y demas cosas por el estilo, me puse a investigar y no encontraba gran cosa, incluse pense en regresar a la antigua version que me funcionaba de maravilla incluso podia poner la tarjeta en modo monitor y hacer auditorias sin problemas.

Despues de estar dando y dando vueltas al asunto, me puse a buscar la manera de arreglarlo, y al final pude hecharla a andar de la siguiente manera:

1 Desinstale todo lo anterior relacionado con la tarjeta, (bcmwl..., b43, bb43-fwcutter,) TODO!!

2 Reinicie el equipo.

3Entre al CD de Ubuntu 11.04 y fui a pool/restricted/b/bcmwl/ ejecute bcmwl-kernel-source_5.100.82.38+bdcom-0ubuntu3_i386.deb se abrio el centro de software y le di a instalar.

4 En el mismo centro de software busque b43 y seleccione el primero: Paquete instalador para el firmware del controlador b43 (firmware-b43-installer). Antes de instalar le di en detalles y tambien seleccione Imagen generica de Linux. Ahora si instalar.

5 Fui a Sistema/Administracion/Controladores Adicionales. Me indico que estaba instalado y listo para usarse

6 Active el WiFi con la tecla Funcion y F2 (en mi caso) y ahora funciona correctamente para acceder a internet.

Nota 1: Cuando la reinicien tal vez aparezca desactivada, para no volver a hacer todo el proceso, ingresen a terminal y prueben los siguientes comandos: Primero prueben el ifconfig wlan0 up, si no anda con ese entonces prueben el sudo modprobe b43 como menciona el compañero WillKi en su post de ¡T
http://www.taringa.net/posts/linux/10486165/Solucin-del-Wireless-en-Ubun...

Pues bueno espero que les sirva de algo, me despido

Nota 2: Mi Laptop es una Dell Inspirion 1501, y mi tarjeta inalambrica es la Broadcom BCM4311, no estoy seguro si funcione en otros equipos, es solo cuestion de prueba-error y relajarse un poco; jeje.

Nota 3: Se me olvidaba, para conseguir parchar la tarjeta entren a la pagina oficial del aircrack-ng, bueno aqui el link http://aircrack-ng.org/doku.php?id=compat-wireless&DokuWiki=ec74a4667fee...

Imagen de Grecoo
+1
0
-1

Tuve exactamente el mismo problema, mi tarjeta es la misma, mi computadora es una Compaq Presario F500, aun que tienen casi las mismas características.
Bueno, nada mas, muchísimas gracias por el aporte, que me fue muy útil.
Saludos

+1
0
-1
Imagen de Babilonnia
+1
0
-1

Tengo el mismo problema con mi tarjeta Broadcom depues de instalar ubuntu 11.04. Tengo una laptop Dell Inspiron 1521

¿Alguien puede decirme cómo se desinstala "todo lo que tenga que ver con la tarjeta" y que es todo'

Esto es lo que me sale cuando le doy lspci | grep Broadcom en la terminal.
03:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
0b:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)

Lo agradeceré mucho!

Que les sea leve el calor.

+1
0
-1
Imagen de h3llBug
+1
0
-1

Que bueno que te haya servido de algo Grecco.

Babilonia, en mi caso yo desinstalo en el Centro de Software, pongo el nombre de lo que busco en este caso, con tan solo escribir b43 te aparece todo lo relacionado al driver b43, fwcutter; escribes broadcom y te aparece el bcmwl y algun otro paquete que tengas relacionado con broadcom. Tambien puedes ir a Sistema/Administracion/Controladores adicionales y ahi desintalas el controlador, Pudiera ser que tambien necesites activar el controlador.

Despues de eso reinicias el equipo y procedes con lo que anteriormente explique.

+1
0
-1
Imagen de Babilonnia
+1
0
-1

Gracias. hl3Bug. Hice todo eso y después seguí tus instrucciones y nada.
:(

+1
0
-1
Imagen de Babilonnia
+1
0
-1

Ou.
Lo hice de nuevo. Y ya funciona.
Graaaacias!

+1
0
-1
Imagen de edwinzur
+1
0
-1

Hola..... al igual que todos ustedes..... instale la nueva versión 11.04, y tuve el mismo problema, no me funcionaba el wireless, por lo cual nuevamente tuve que reinstalar la versión la 10.10 pues me es indispensable el wireless. Tengo un Dell Inspiron E1405 y al igual que a Babilonnia me sale con el comando lspci | grep Broadcom asi

2:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
0c:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)

Será probable que me funcione...... ??? me arriesgo a actualizar de nuevo 11.04???
Gracias...!

+1
0
-1
Imagen de edwinzur
+1
0
-1

Hola...!
Les cuento que realize todo lo indicado.......desinstalar todo lo relacionado con el driver b43, broadcom y reinstalar segun las intrucciones al inicio. Como a todos ustedes, me funcionó, pero como siempre al reiniciar el sistema, no reconocia de nuevo el wireless y lo tenia que activar en cada sesion mediante la terminal con el comando sudo modprobe b43
Trabajando encontre la solucion para que se active definitivamente y si tienes varios usuarios, todos van a poder disfrutar del wireless. la solucion es la siguiente
1. Inicia la terminal
2. Registrate como supreusuario con el comando sudo su
3. Cargan el directorio etc con el comando cd /etc
4. Estando en este punto lanzamos en la terminal el editor de textos escribiendo editor de textos
5. En el editor de textos presionamos al mismo tiempo las teclas Ctrl + R con los cual nos aparece un dialogo preguntando "archivo a insertar desde"
6. escribes rc.local y nos abre de inmediato:

r#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

exit 0

7. Debe modificar este archivo insertando el comando sudo modprobe b43 entre las lineas

# By default this script does nothing.

exit 0

de forma que finalmente quede asi

r#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

sudo modprobe b43

exit 0

8. Una vez modificado el archivo, presionas al mismo tiempo Ctrl + O para guardar el archivo, el programa te pregunta el nombre a guardar, borras lo que se encuentre por defecto y escribres rc.local , te pregunta si quieres sobreescribir, le indicas que si
9. sales del editor de textos presionando al mismo tiempo Ctrl + x
10. haciendo esto te devuelve al terminal, simplemente sales de la terminal reinicia el sistema y verás como se activa automaticamente el wireless al iniciar la sesion.

Espero les ayude y les funcione.....! estoy usando un Dell Inspiron E1405 con las tarjetas
2:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
0c:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)
Ubuntu 11.04

+1
0
-1
Imagen de Grecoo
+1
0
-1

Volvi a tener un problemita con la placa. Reinstale Ubuntu para instalarlo de cero. Al instalarlo volvi a hacer todo esto y funciono. Bueno, ahora cuando reinicie volvia a lo mismo que antes, no me reconoce la tarjeta.
Ahora voy a seguir buscando a ver si encuentro alguna solucion por ahi.
De ultima me pasare a..no se....windows!
Nah, chiste, pero sumandole lo de Unity ya van varias que no me gustan.
Saludos

+1
0
-1
Imagen de steev_666
+1
0
-1

Igual ya he tratado con todos los medios, instalando y reinstalando paquetes, inclusive intente con NDISWRAPER y nada por el momento ando con LAN pero el wifi nadamas no logro hacerlo andar, alguien mas save alguna otra opcion o forzarlo a cargar en el kernel!?

+1
0
-1

MB: Asus Croshair Formula IV ROG

Mem: 4 Gb Kingston HiperX 2000 Mhz 9-9-9-24

Procesador: AMD 1090T BE @ 4.0 (en proceso de mas overclokeo :D)

T/Video: Ati All-In-Wonder x1900 256Mb @ (600CoreX1200Mem)

T/Sonido: Sb Audigy 2 ex +

Imagen de PeDrO139
+1
0
-1

hola yo tengo el mismo problema con mi dell inspiron 1501, y lo que puso h3llBug funciono, pero cuando reinicie no me reconoció de nuevo la tarjeta. seguiré buscando alguna solución...

+1
0
-1
Imagen de fjbouzada1
+1
0
-1

Pues eso. Yo tengo todo instalado y sólo me funciona la primera vez, al volver a encender a empezar de nuevo. Yo no tengo el CD sino que me conecto con cable para reinstalar los drivers de la tarjeta. Esto empieza a ser desesperante. Supongo que en algún momento en el gestor de actualizaciones darán una solución definitiva.
Saudos.

+1
0
-1
Imagen de Babilonnia
+1
0
-1

Me pasó lo mismo, después de reinciar, el wireless no funciona.

+1
0
-1
Imagen de PeDrO139
+1
0
-1

alguien sabe algo sobre Ndiswrapper?
me encontré en algunos foros que solucionaron este problema con ese programa, pero la verdad no se como funciona y como se usa.

incluso encontré el driver para windows que puede ser usado con ese programa http://ftp.us.dell.com/network/R151517.EXE pero yo no le entendí del todo así que prefiero esperar a ver si algún usuario más avanzado lo quiere intentar.

espero nos ayuden con eso!

+1
0
-1
Imagen de vivilu_w
+1
0
-1

Hola!

Yo tengo el mismo problema, mi computador es un Dell Inspiron 1501 y la tarjeta es BCM4311.

Ya segui los pasos y me funciona el wireless mientras que no reinicie el ordenador. Tambien ya intente con Ndiswrapper, funciona el wireless pero me bloquea el ethernet y no lo puedo volver a activar. Y prefiero tener red por cable que la wireless, aunque lo ideal es tener ambas asi que si alguien encuentra la solucion lo agradeceria mucho. :)

Gracias

Vivi

+1
0
-1
Imagen de Williamqui
+1
0
-1

yo tengo un problemita ya hice todo lo que dijiste para activarlo y si me funciona pero cada vez que apago mi PC cuando la vuelvo a encender tongo que desinstar el wireless y reinstalarlo habra alguna solucion a eso ?

+1
0
-1
Imagen de Williamqui
+1
0
-1

e encotrado una media solucion para mientras ai una solucion es la siguiente

http://www.taringa.net/posts/linux/10486165/Solucin-del-Wireless-en-Ubun...

entren alli esta la solucion para ke no les arte estar desistalando e instalando cada vez..... XD!!!!!!

+1
0
-1
Imagen de primy
+1
0
-1

Bueno les comento yo tengo una tarjeta Broadcom Corporation BCM4311 y la solución que me funciono fue instalar el paquete firmware-b43-installer.
Luego en aplicaciones al inicio añado la siguiente linea
sudo modprobe b43
Así cada vez que iniciemos se activara el wifi automáticamente.
Prueben y comenten que tal esta solución, haber si entre todos damos con algo.
Un saludo.

+1
0
-1

Tu familia es la que te ayuda sin pedir nada a cambio.

Imagen de achim_311
+1
0
-1

Pero como haces esto, no entiendo, si pudieres explicarlo,
Luego en aplicaciones al inicio añado la siguiente linea
sudo modprobe b43

Saludos.

+1
0
-1

-------------------------------------------------------------------------------------------
Free as in Freedom, Not as in free beer!!!
El Software Libre Es Cuestion de Libertad, No de Precio!!!

Imagen de h3llBug
+1
0
-1

Perdon por no haber podido contestar antes, la solucion que les da el compañero es buena, al agregar el firmware la hace andar mejor, y ciertamete el modprobe b43 tambien la deja funcionando, otra opcion es que descarguen el compat wireless y parchen la tarjeta. Perdon si no me extiendo en el tema pero estos dias ando algo lleno de trabajo, un saludo,perdon si no les funciono mi solucion.

+1
0
-1
Imagen de h3llBug
+1
0
-1

El compañero que les dio el link de taringa, pues no es nada mas que lo mismo solo que activando el modulo para que ande la wifi, el modprobe 43 en cosola, tambien deberia funcionar con ifconfig wlan0 up, o al menos tengo esa teoria, son las opciones que me han andado a mi

+1
0
-1
Imagen de Cesarcln
+1
0
-1

Hey me funciono. ya estoy en internet desde el inalambrico. tengo la misma laptop y tube el mismo problema.
pero con esto todo anda bien.. un saludo

+1
0
-1
Imagen de kuboode
+1
0
-1

Prueben con estos drivers, son 100% funcionales, solo instalar y nadas mas, porque se quiebran tanto la cabeza jeje, espero les sirva que es lo mas seguro

http://www.taringa.net/posts/linux/11328286/solucion-a-drivers-broadcom-...

http://kuboosoft.blogspot.com/2011/06/solucion-drivers-broadcom-ubuntu-1...

+1
0
-1
Imagen de achim_311
+1
0
-1

Le dedique un poco de tiempo para solucionar el problema, en mi caso a mi me funciono y probé a re-iniciar la maquina varias veces antes de poner la solución que me funciono, pero antes que nada si a funcionado la tarjeta inalámbrica al colocar en la terminal el comando sudo modprobe b43 si es asi, estos dos pasos son lo que me solucionaron el problema:

1. Editar el archivo /etc/modules y al final o antes de la ultima linea colocar b43

sudo gedit /etc/modules

2. Editar el archivo /etc/rc.local y antes de la linea exit 0 colocar modprobe b43

sudo gedit /etc/rc.local

Listo con esto basta, ahora re-iniciar la maquina y probar, espero que esto les solucione a todos este problema con la tarjeta inalámbrica, si todavía tiene este problema.

+1
0
-1

-------------------------------------------------------------------------------------------
Free as in Freedom, Not as in free beer!!!
El Software Libre Es Cuestion de Libertad, No de Precio!!!

Imagen de rioport
+1
0
-1

El paso 2 es innecesario, solo es necesario agregar el nombre del modulo a /etc/modules.
De una manera más sencilla así:

echo 'b43' | sudo tee -a /etc/modules
+1
0
-1

-- GC --

Imagen de achim_311
+1
0
-1

Cuando intente solo con el modulo a mi no me funciono, me funciono hasta que lo agrede en el rc.local, pero seria de probaran con el código que dio el amigo me parece mas fácil.

+1
0
-1

-------------------------------------------------------------------------------------------
Free as in Freedom, Not as in free beer!!!
El Software Libre Es Cuestion de Libertad, No de Precio!!!

Imagen de FIREBIRDDELL
+1
0
-1

Bueno despues de leer en muchos foros y ver que nos dabamos de topes con la pared, por que no nos jala el wifi en ubuntu 11.04, el compañero hellbug y edwinzug realmente nos dan la solucion completa, pero nosotros tenemos que poner un poquito de cerebro para identificar como poder usarlo.

1 Desinstale todo lo anterior relacionado con la tarjeta, (bcmwl..., b43, bb43-fwcutter,) TODO!! Esto lo podemos hacer por medio de gestor de paquetes synaptics, le dan en busqueda B43 y te mostrara todos los instalados, en mi caso estan en verde, seleccionalos con clic derecho para desinstalarlos(no le des completamente)

2 Reinicie el equipo.

3Mete el CD de Ubuntu 11.04 en la unidad lectora y ve a pool/restricted/b/bcmwl/ ejecute bcmwl-kernel-source_5.100.82.38+bdcom-0ubuntu3_i386.deb se abrio el centro de software y le di a instalar. Si esto no funciona busca directamente el archivo en la carpeta y dale un clic para instalarlo directamente.

4 En el mismo centro de software escribe en busqueda b43 y selecciona el primero: Paquete instalador para el firmware del controlador b43 (firmware-b43-installer). Antes de instalar le di en detalles o informacion y tambien seleccione Imagen generica de Linux. Ahora si instalar.

5 Fui a aplicaciones/ Controladores Adicionales. Le di clic y me indico que estaba instalado y listo para usarse
En este paso nos vamos a la solucion de este link

http://aircrack-ng.org/doku.php?id=compat-wireless&DokuWiki=ec74a4667fee...
Esta pagina te manda primero a que busques el compat-wireless mas reciente, busca al final de la pagina y checa la fecha, el bueno es el que tiene la terminacion .tar.bz2 ya que existe otro con la misma fecha pero inicia con p.tar.bz2. para esto tienen dos opciones hacer el paso uno y donde dice

wget http://wireless.kernel.org/download/compat-wireless-2.6/compat-wireless-$(agregar aqui la fecha del compat y dejar este indicador --> -I ).tar.bz2 importante no borren el indicador I

si no pueden hacerlo asi, entonces bajen directamente el archivo compat-wireles con fecha mas reciente y pasen al siguiente paso de la pagina que es descomprimirlo

tar -jxf compat-wireless-$(nuevamente ponen la fecha aqui -I).tar.bz2

, en mi caso lo hizo automatico el gestor de archivos asi que la carpeta ya les podria aparecer descomprimida, sino, con este comando lo descomprime.

el paso siguiente es moverse en la terminal a el directorio de la carpeta compat-wireless

cd compat-wireless-$(recuerden la fecha del archivo que bajaron -I)

paso siguiente

wget http://patches.aircrack-ng.org/mac80211.compat08082009.wl_frag+ack_v1.patch

wget http://patches.aircrack-ng.org/channel-negative-one-maxim.patch

dejen que realice su trabajo y pasan al siguiente paso

patch -p1 < mac80211.compat08082009.wl_frag+ack_v1.patch

patch -p1 < channel-negative-one-maxim.patch

en este punto nuestro equipo ya estara preparado para que comience a trabajar nuestra wifi, asi que pasaremos al siguiente paso.

make

esperen a que termine su proceso y le dan al siguiente paso

sudo make install

esperen a que termine su proceso sean pacientes en este punto tarda varios minutos, le dan al siguiente paso

sudo make wlunload

aqui por favor no se espanten, al momento de aplicar el comando la red ethernet cableada se desconecta, asi que no cierren su navegador, si quieren volver a abrirlo despues del reinicio, solo denle en historial y abrir recientes o algo parecido, con eso abrira las paginas que estaban abiertas antes del reinicio.

por ultimo le dan en este comando

sudo modprobe (driver que usa tu equipo) en mi caso es una b43 o broadcom, chequen cada dato antes de iniciar.

si les marca error no se espanten, solo reinicien la maquina y cuando inicien nuevamente tendran la red cableada, la wifi no la reconocera, pero aqui entra el aporte de edwin que viene aqui abajo, no desesperen el camino es largo pero es seguro.

Despues de lo que hellbug hace tenemos que realizar este paso y reiniciar el equipo, ademas de activar nuestra wireless ya sea por la tecla Fn+F2 en mi caso, seleccionen la que aplique a su equipo.

La solucion es la siguiente
1. Inicia la terminal
2. Registrate como supreusuario con el comando sudo su
3. Cargan el directorio etc con el comando cd /etc
4. Estando en este punto lanzamos en la terminal el editor de textos escribiendo editor de textos
5. En el editor de textos presionamos al mismo tiempo las teclas Ctrl + R con los cual nos aparece un dialogo preguntando "archivo a insertar desde"
6. escribes rc.local y nos abre de inmediato:

r#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

exit 0

7. Debe modificar este archivo insertando el comando sudo modprobe b43 entre las lineas

# By default this script does nothing.

exit 0

de forma que finalmente quede asi

r#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

sudo modprobe b43

exit 0

8. Una vez modificado el archivo, presionas al mismo tiempo Ctrl + O para guardar el archivo, el programa te pregunta el nombre a guardar, borras lo que se encuentre por defecto y escribres rc.local , te pregunta si quieres sobreescribir, le indicas que si
9. sales del editor de textos presionando al mismo tiempo Ctrl + x 2 veces
10. haciendo esto te devuelve al terminal, simplemente sales de la terminal reinicia el sistema y verás como se activa automaticamente el wireless al iniciar la sesion.

Bueno amigos comparto este post verificado paso a paso y con aclaraciones que quiza los compañeros pasaron por alto, pero siempre con la finalidad de sumar esfuerzos, a mi me llevo unas semanas tener todo completo, pero la ayuda de hellbug y de edwinzug, mas algunas aclaraciones pequeñas mias de las paginas a utilizar, considero que les puede funcionar, ya que vienen infinidad de drivers cargados en las paginas que se utilizan, para los que tienen un kernel un poco mas viejito, vienen los comandos para que lo actualices a una version mas reciente que te permita meterle los comandos mencionados aqui.

Espero les ayude y les funcione.....! estoy usando un Dell Inspiron 1501 con las tarjetas
2:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
0c:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)
Ubuntu 11.04

GRACIAS A HELLBUG Y EDWINZUG POR LOS APORTES DADOS...!!!!

P.D1 Si reinician y no se enciende sola la wifi, presionen la tecla Fn + F2 en mi caso, localicen ese dato de sus equipos por que varia segun las marcas y modelos.

P.D2 Creo que posiblemente no todas las tarjetas sean broadcom, asi que chequen los firmware el nombre que le dan en el caso de las suyas y sustituyan en los comandos donde se usa el driver( por ejemplo sudo modprobe "b43", b43 es el nombre del driver, si usas atheros checa la version y colocale ath9k, aclaro es un ejemplo), donde sea necesario modificarlo traten de probar, pero siempre a la segura, con respaldo de su informacion.

+1
0
-1
Imagen de edwinzur
+1
0
-1

Muchísimas gracias por el reconocimiento y por compilar la solución completa....! ese es el gran poder del software libre........... TODO EL MUNDO puede contribuir a mejorar y solucionar...! :). De nuevo gracias.

+1
0
-1
Imagen de matutano
+1
0
-1

Muchísimas gracias, funciona a la perfección siguiendo los pasos de H3llBug!!! Después de tantos meses sin wifi casi me pongo a llorar como una nenaza de la alegría!!!
En lo único que no te hice caso es en lo del CD, instalé el bcmwl-kernel directamente desde Synaptic...
Gracias de nuevo.

Por cierto, Unity nunca me ha funcionado, y además Gnome no refresca bien la pantalla, la deja "sucia", deja rastros de otras ventanas y cosas así, aunque el vídeo se ve de maravilla, sólo me ocurre con las ventanas del sistema y el fondo de escritorio... Pero bueno, por lo demás, bien, y ahora con wifi y todo!!

+1
0
-1

Un saludo,

matutano

-------------------------------------------------------------------------------------------

(Ubuntu 11.04 amd64 - Dell Inspiron 1501 AMD Turion64x2)

Imagen de FIREBIRDDELL
+1
0
-1

bueno, pues que bien que te funciono, la verdad como no habia desconectado mi lap del cable, jamas imagine que no estaba jalando la tarjeta, hasta que me cambie de espacio fisico y requeri usar el wifi jajaja, en fin, es interesante ver que funciono para mas personas, ojala postearan mas que se interesen en resolver este problema en sus equipos. SALUDOS

+1
0
-1
Imagen de cabispaski
+1
0
-1

Primero muchas gracias a todos pues no podría utillizar Ubuntu sin vuestra ayuda.
Yo soy de esos que anda desde la Versión 9.04 con Ubunutu y estoy contentísimo pero nunca entendí como funciona esto, así que cada vez que tengo un problema busco y cuando encuentro una solucion a un problema similar me dedico a copiar las instrucciones y pegar en la terminal sin acabar de entender qué estoy haciendo.

Hará cosa de un mes que ando con el problema que al reiniciar el ordenador no me funcione el wifi y para q funcione, cada vez tenia que ir a Synaptic desintalar "bcmwl-kernel source", después abrir -controladores adicionales- y activar el controlador inalambrico broadcom STA.
No tenía solución hasta que he encontrado este POST
Esta vez no podia seguir las intrucciones ya que no tengo el cd con el que hice mi primera instalación de UBUNTU en 2009. Así que probando diferentes opciones de estos "post" he encontrado algo que a mi me ha funcionado aunque sea de suerte. Allá va:

MI SOLUCION:

1.- reiniciar ordenador, ir a Synaptic desintalar "bcmwl-kernel source", después abrir -controladores adicionales- y activar el controlador inalambrico broadcom STA. Ahora la WIFI debe estar funcionando.

2.- Editar el archivo /etc/modules y el archivo /etc/rc.local; para ello:
2.1.- abrimos terminal "sudo gedit /etc/modules" ; con esto se abrirá una ventana donde hay añadir
"b43" de la siguiente forma:
----------------------------------------------------------------------------------------------------------------------------------------------------------------
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

lp

b43
----------------------------------------------------------------------------------------------------------------------------------------------------------------
Una vez añadido el texto "b43" dos lineas bajo "lp" guardamos y cerramos.

2.2.- Volvemos a la terminal y ejecutamos "sudo gedit /etc/rc.local" para abrir la ventana editora donde
tendremos que añadir "modprobeb43" de la siguiente forma:
----------------------------------------------------------------------------------------------------------------------------------------------------------------
...
#
# By default this script does nothing.
modprobe b43
exit 0
----------------------------------------------------------------------------------------------------------------------------------------------------------------
Una vez añadido el texto "modprobe b43" le damos a guardar y cerramos las ventanas.

3.- abrimos synaptic y en el quick filter escribimos "broadcom"; seleccionamos las 3 últimas de las 4 opciones para instalar ("bcmwl-kernel-source"; "broadcom-sta-source" y "b43-fwcutter") y le damos a aplicar. Una vez aplicado se debe quedar "bcmwl-kernel source" y "b43-fwcutter en verde". Finalmente cerramos Synaptic.

YA ESTÁ, DESPUÉS DE ESTO NO HE VUELTO A TENER EL PROBLEMA, Y CADA VEZ QUE REINICIO EL WIFI SE CONECTA AUTOMATICAMENTE COMO SIEMPRE

+1
0
-1
Imagen de soletetwo
+1
0
-1

gracias actualice ubuntu 12 y con el mismo problema hice lo que tu pero con el cd ubuntu 10 y ya tengo internet mucha gracias

+1
0
-1
Imagen de Dave-Dee
+1
0
-1

He comprobado que la solución propuesta en este post consiste en restaurar la versión del controlador broadcom (bcmwl-kernel-source) de la versión 6.20.155+bdcom-0ubuntu0.0.1 a la versión anterior 5.100.82.112+bdcom-0ubuntu3. Ahora bien, ¿qué pasa si el gestor de actualizaciones te recupera la versión más reciente? volveríamos a tropezar con el mismo problema.

Para evitarlo, he ido al Gestor de Paquetes Synaptic, he buscado dicho paquete (por su nombre), lo he seleccionado, y en el menú "Paquetes" he marcado "Bloquear Versión". Supongo que así conjuro el problema. Ahora bien, si esto tiene malas consecuencias, me gustaría saberlo, porque mis conocimientos sólo llegan a nivel de usuario (muy leído, eso sí).

+1
0
-1

DV.D. (Dave Dee)