No arranca Ubuntu 10.10 (mounting /dev)

Imagen de Bataleon
0 puntos

Si, ya lo se. Miles de hilos y foros con esta cuestión. Buscar antes de preguntar. Pero la verdad que estos días se me estuvo secando el cerebro entre búsquedas, esperas y posibles soluciones. Y nada. Estoy en el último tramo de la búsqueda antes de reinstalar todo, lo que sería muy engorroso (si vieras lo fachero que estaba mi Ubuntu).

Bueno, transcribo las últimas lineas de donde queda el booteo. Bastante conocidas:

"Killed.
Mount: mounting /deb on /root/dev failed: No such file or directory
Mount: mounting /sys on /root/sys failed: No such file or directory
Mount: mounting /proc on /root/proc failed: No such file or directory
Target filesystem doesn't hace requested /sbin/init.
No init found. Try passing init=bootarg
BusyBox V1.15.3 (Ubuntu 1:1.15.3-1 Ubuntu5) Built-in shell (ash)
Enter 'Help' for a list of built-in Commands
(initramfs) _"

¿El motivo? no se bien. Pero puede ser porque mi compu calienta bastante, se haya colgado, y tuve que apagarla forzadamente. Conozco que esto suele derivar en este problema (incluso me pasó lo mismo hace un tiempo por apagarla mientras actualizaba, pero como tenía Ubuntu instalado hacía poco, no tuve problemas en reinstalarlo, esta vez quisiera no llegar a eso).

El fdisk -l:
Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x86e90da6

Device Boot Start End Blocks Id System
/dev/sda1 * 1 47416 380866547+ 7 HPFS/NTFS
/dev/sda2 47416 60801 107517420 f W95 Ext'd (LBA)
/dev/sda5 47416 60801 107517388+ 7 HPFS/NTFS

Ahí dice que Bootea desde el sda1, pero Ubunu está instalado en el sda5. El NTFS de 102 GB.

¿Que soluciones probé?
* Entré con un USB Live al Ubuntu en Cero. Abro el Gparted y la partición donde está el booteo tiene un puntito rojo, de problema (como muestra la imagen anterior). Pongo Check, y me tira error.

* Desde consola, Sudo fsck -f /dev/sda5 (o sda1, o sda) me da error.

* Sudo Mount /dev/sda5/mnt
Sudo grub-install -root-directory=mnt/sda

Me da error en la 2ª linea.

* sudo mount /dev/sda5 /mnt
sudo mount --bind /dev /mnt/dev
sudo mount --bind /dev /proc /mnt/proc
sudo chroot
sudo su
grub-install --recheck /dev/sda
sudo update-grub2

Me da error en el comando chroot, y de ahí en adelante me da error en los otros. O sea, llego a montar las unidades nada mas.

* Rescatux
No puedo montarlo en el usb, porque tengo el Universal USB Installer, y me pide que indique que SO voy a poner. Pero es una Live, y no le encuentro la forma.

Bueno. Quisiera saber que es lo que estoy haciendo mal, o si ya existe alguna solución definitiva, porque vi muchos, muchos foros con este tema, sin solucionar. Sé que depende de cada Pc, las particiones y la distro instalada. Pero espero que con los datos que puse, se pueda encontrar una solución. Porque con el problema de temperatura que tengo, es probable que esto vuelva a pasar.
De paso, mientras andaba bien, cuando estaba en suspensión, no volvía el entorno gráfico. Andaba todo, porque funcionaban las combinaciones de teclado, pero tenía que forzar el reinicio.

De mas está decir que les voy a agradecer muy profundamente a quienes me ayuden. Ya quiero dejar de darle plata al diablo (no por comprar el SO, sólo por usarlo). Y extraño mi cilindro girando, mis reconocimientos de movimientos de mouse, y esa magia del Open Source.

Espero asistencia.

Mauricio.

Imagen de Bataleon
+1
0
-1

Imagen de AgD
+1
0
-1

El error que te esta dando dice que fsck no tiene ninguna herramienta para reparar sistemas de archivos NTFS.

Recuerda que deberás de instalar ntfsfix, y como es posible que otros programas busquen fsck.ntfs tal vez debas crear un enlace simbólico. Los comandos serían:

sudo apt-get install ntfsfix
sudo ln -s /usr/bin/ntfsfix /bin/fsck.ntfs

+1
0
-1

make install . es
Noticias, apuntes y pequeños tutoriales sobre GNU/Linux
Imagen de AgD
+1
0
-1

Debes pasar un fsck al disco.

¿Que error te da cuando intentas ejecutar fsck -aVC /dev/tu-disco desde un LiveCD?

+1
0
-1

make install . es
Noticias, apuntes y pequeños tutoriales sobre GNU/Linux
Imagen de Bataleon
+1
0
-1

Con los discos montados. Para sda5, sda1 y sda:

fsck from util-linux-ng 2.17.2
fsck: fsck.ntfs: not found
fsck: Error 2 while executing fsck.ntfs for /dev/sda5

Con los discos desmontados:
Para /sda:

fsck.ext2: Bad magic number in super-block while trying to open /dev/sda
/dev/sda:
The superblock could not be read or does not describe a correct ext2
filesystem. If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193

+1
0
-1
Imagen de AgD
+1
0
-1

No has puesto los comándos que has ejecutado, para lanzar fsck. Así que presupongo que en el primer paso usaste fsck.ntfs y en el segundo fsck.ext2. Antes de empezar, unas aclaraciones:

  1. Un fsck siempre se debe ejecutar con los discos desmontados. Si lo haces con los discos montados corres el riesgo de empeorar la situación.
  2. El fsck debe ser invocado correctamente. Si el sistemas de ficheros es ntfs, no podrás invocar a fsck.ext2, fsck.vfat. Por tanto no tiene sentido que invoques fsck.ext2 en una partición ntfs
  3. fsck trabaja sobre particiones. Y no sobre el disco duro. No puedes invocar fsck sobre /dev/sda, debe ser /dev/sdaX

Conclusión
Debes pasar una utilidad de reparación a la partición con linux; en tu caso y según tu mismo has indicado /dev/sda5, la cual esta con ¡¡NTFS!!

Puesto que uno de los mensajes indica que no tienes ninguna utilidad para reparar particiones NTFS, debes instalar-lo:
sudo apt-get install ntfsprogs

Y posteriormente ejecutar:
ntfsfix /dev/sda5

Si quieres, puedes crear un enlace simbólico en /sbin con fsck.ntfs que apunte hacia /sbin/ntfsfix

PD: Tener un entorno Linux instalado en una partición NTFS es des-aconsejable. Tendrás constantes problemas.

+1
0
-1

make install . es
Noticias, apuntes y pequeños tutoriales sobre GNU/Linux
Imagen de Bataleon
+1
0
-1

Te desilucionaré.

Terminé formateando la partición del Sistema e instalé Windows y Ubuntu de 0. Ahora estoy tratando de ponerlo mas o menos como lo tenía.

Los mensajes que te había puesto que devolvía fsck, eran sólo poniendo fsck como me lo habías dicho.
El ntfsfix decía que ya estaba todo listo, pero el problema seguía igual.

Acomodé mejor las particiones, e instalé Ubuntu en un Fat32, espero haber hecho bien. Gracias por el consejo.

Esto me devuelve ahora el fdisk -l:

Dispositivo Inicio Comienzo Fin Bloques Id Sistema
/dev/sda1 * 1 47416 380866547+ 7 HPFS/NTFS
/dev/sda2 47416 60802 107518925+ f W95 Ext'd (LBA)
/dev/sda5 47416 53938 52388075+ 7 HPFS/NTFS
/dev/sda6 53938 60516 52833280 83 Linux
/dev/sda7 60516 60802 2295808 82 Linux swap / Solaris

Donde el sda5 tiene a Windows y sda6 a Ubuntu.
Pero cuando entro a "Equipo", además de "Sistema de archivos" (donde obviamente, están los arhivos de Ubuntu), en una de las particiones, están los mismos archivos. O sea, como que están duplicados los Archivos del Sistema de Ubuntu. Pero bueno, quizás en la instalación hice algo mal. Después arreglaré eso.

Muchisimas gracias por tu ayuda. Porque mas allá de las ventajas en utilidad y funcionamiento, esto, la comunidad, es lo que hace la diferencia.

+1
0
-1
Imagen de furtaxi
+1
0
-1

Ubuntu tiene sus propios formatos de disco, y utilizar los de Microsoft, sea FAT32 o NTFS, sólo te dará problema tras problema.

Recuerda: Si estás en GNU/Linux, usa lo de GNU/Linux.

ext4, es un excelente formato, y no tienes porqué usar otro.

Entre otras cosas, con FAT32, tendrás problemas en manejar archivos o particiones de varios Gb.

Ya que acabas de reinstalar, y no tienes datos... hazlo otra vez, que acabas antes, y usas tres particiones para GNU/Linux:

/ ext4, primaria, para el sistema, entre 6 y 16 Gb (mejor 16, ya que los archivos temporales irán ahí dentro)

2 Gb de intercambio

/home, ext4, primaria o lógica, que es indiferente, aunque mejor priimaria, del tamaño máximo que puedas, para tus datos.

NO necesitas hacerle nada a Windows. Sólo reinstala Ubuntu, ya encontrará él al de Microsoft, y lo pondrá en el GRUB.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de Norielmtz
+1
0
-1

Tengo el mismo problema la dif. es que despues de entrar a grub me salen 5 opciones y no arranca mas que las pruebas de memoria, no puedo entrar a la terminal mediante el recovery mode porque me sale el mismo error, tampoco puedo formatear pues se traba, no se que hacer.

+1
0
-1

"El misterio es la cosa más bella que podemos experimentar. Es la fuente de todo arte y ciencia verdaderos".
AE

Imagen de mbd
+1
0
-1

hola tengo un solo ordena utiliso xubuntu 10.04.2 y necesito mi ordena cuanto antes me pasa lo mismo pero a mi no me va sudo ni apt get ..... no puedo poner fotos por me conecto por psp e introducido de todo deves todo con el cd dentro deves en cuando me aparece la ventana de obciones como cuando instalas linux e dado a todas ya sea probarlo instalarlo no va te dice elige el lenguaje lo elijo y nad se keda en negro gracias por leer mi comentario y necesito urgente mi ordena

+1
0
-1