problema con aceleracion grafica nvidia

Hola, vereis llevo ya con ubuntu un tiempo y he intentado varias veces instalar la aceleracion grafica de mi geforce 5500. He siguido tropecientos manuales, q para el caso venian a decir todos lo mismo, he instalado nvidia-glx, he modificado el xorg.conf etc etc pero siempre se me queda la pantalla en negro al querer iniciar en modo grafico.

Cuando entro en modo recovery me dice ke la version del kernel-nvidia es la 1.0.7174 y que la del modulo X es 1.0.7667 sin embargo si intento instalar con aptitude la version 1.0.7667 me dice que ya esta incluida en linux-restricted-modules que ya tengo instalado.

El caso es que no consigo que me funcione correctamente, si alguien pudiera ayudarme estaria agradecido.

Imagen de Anónimo
+1
0
-1

Probaste con "dpkg-reconfigure xserver-xorg" y después elegir el controlador "NVIDIA" en lugar de "NV"???
Suerte,
Juan Martín

+1
0
-1
Imagen de tseliot
+1
0
-1

Creo que antes habias instalado el driver legacy. No es un problema.

Entra en Recovery Mode y escribe esto:

apt-get --purge remove nvidia-glx-legacy linux-restricted-modules-`uname -r`-legacy

apt-get --purge remove nvidia-glx linux-restricted-modules-`uname -r` nvidia-kernel-common

¡Atención! asegúrate de que no pongas ' en lugar de ` (que es el tipo de apóstrofo adecuado)

y luego instala el driver 7667 (yo tengo la misma tarjeta de vídeo que tú y te aseguro que ese driver funciona):

apt-get install nvidia-glx linux-restricted-modules-`uname -r` nvidia-kernel-common

Asegúrate de que hayas puesto el driver "nvidia" (en lugar de "nv") en tu xorg.conf y que hayas comentado "Load DRI" (como está indicado en las guías que habrás seguramente leído).

Luego escribe:
reboot

Y al arrancar de Ubuntu verás el entorno gráfico.

Si tienes otros problemas con la tarjeta intentaré aclararte tus dudas.

Saludos

Alberto

+1
0
-1