World of warcraft u otros juegos modo Opengl en tarjetas de video Intel - (Solucionado)

Imagen de samuaz
0 puntos

abro este post para todos aquellos que tenemos una tarjeta de video intel ya sea gma x3100 como la mia o cualquiera de sus variantes, personalmente en windows con esta tarjeta intel he juegado al wow con 20-30 fps con las opciones de video al minimo y emulando los shaders por software quitandole carga al gpu y enviandola al cpu, el problema esta en que en wine se puede jugar en modo directx pero los fps dejan mucho que desear, en modo opengl que seria lo ideal el wine se crashea saliendo la ventana que ha ocurrido algun error en wine y seguido frizeando el wow.

los fps en modo opengl son buenos, pero el juego se frizea a los segundos de iniciar con el personaje, hasta los momentos no he logrado solucionar dicho problema ni encontrado informacion que lleve a su fix, en todos los foros estado unidenses lo unico que responden es "intel es una mierda", "los drivers de intel son mierda", "comprate otro pc", "llora/cry".

si en windows es capaz de jugar al wow con una gma x3100 porque no en ubuntu con wine? por eso abro este post para todos aquellos que tenemos estas tarjetas y queremos jugar al wow o otro juego en ubuntu, para que nos ayudemos entre nosotros a solucionar el problema con el opengl.

tengo ubuntu 11.04, mi compu es una macbook 4,1 core2duo, 4gb de ram, y tarjeta de video integrada intel gma x3100/i965

hasta los momentos he probado editar el registro de wine etc pero nada no logro evitar ese crash el wine, al parecer el problema proviene en que el world of warcraft busca una librearia del opengl que no se encuentra en los drivers, intentare instalar los ultimos drivers desde el source de intelgrapchics

si alguien conoce una manera de solucionarlo o ha logrado jugar con tarjetas de video intel porfavor indiquenos que ha hecho

saludos

Imagen de LyingB
+1
0
-1

para empezar Wine no es Windows, sólo es una API que pretende hacer funcionar las aplicaciones de Windows en Linux, pero ya que la API de Windows es cerrada y cambia constantemente en ocasiones es no se obtienen buenos resultados.

Mira aquí para ver si puedes solucionar tu problema.

+1
0
-1


Agrega al final del título del post (solucionado) si has arreglado tu problema.

Imagen de samuaz
+1
0
-1

hola gracias por el link, ya los he visto todos los bugs y eso xD pero no consigo arreglarlo :S talvez algun forero sabe como solucionarlo sigo a la espera saludos

+1
0
-1
Imagen de samuaz
+1
+1
-1

ya lo solucione, para el que quiera hay que instalar driconf y activar el soporte S3TC en la pestaña calidad grafica y listo ya no les dara crash saludos

+1
+1
-1
Imagen de Juan XX
+1
0
-1

Que bien que lo solucionaste samuaz, me ayudaste mucho :D

+1
0
-1