xubuntu sin sonido exterior (Solucionado)

Imagen de exnihilo
0 puntos

Hola. Soy novato en Xubuntu, acabo de instalarlo hace un par de días y no logro configurar correctamente el audio. Mi ordenador es un HP Mini 100 con Xubuntu 10.04.2 Lucid Lynx Release i386; la tarjeta de audio una HDA Intel chip IDT ID 7667. He revisado el alsamixer y todo parece correcto (los controles de volumen están activados). Al reproducir un archivo de audio o un vídeo se puede escuchar el sonido conectando unos auriculares, pero no sin ellos: el altavoz externo del portátil no suena.

Estas son las salidas del lspci y del lsmod:

lspci

00:00.0 Host bridge: Intel Corporation N10 Family DMI Bridge
00:02.0 VGA compatible controller: Intel Corporation N10 Family Integrated Graphics Controller
00:02.1 Display controller: Intel Corporation N10 Family Integrated Graphics Controller
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 02)
00:1d.0 USB Controller: Intel Corporation N10/ICH7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation NM10 Family LPC Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation N10/ICH7 Family SATA AHCI Controller (rev 02)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 02)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 04)
01:00.1 Class ff00: Realtek Semiconductor Co., Ltd. Device 5288 (rev 01)
02:00.0 Network controller: RaLink RT3090 Wireless 802.11n 1T/1R PCIe

lsmod | grep snd

snd_hda_codec_idt 52042 0
snd_hda_intel 22069 7
snd_hda_codec 74201 2 snd_hda_codec_idt,snd_hda_intel
snd_hwdep 5412 1 snd_hda_codec
snd_pcm_oss 35308 0
snd_mixer_oss 13746 3 snd_pcm_oss
snd_pcm 70694 4 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_seq_dummy 1338 0
snd_seq_oss 26722 0
snd_seq_midi 4557 0
snd_rawmidi 19056 1 snd_seq_midi
snd_seq_midi_event 6003 2 snd_seq_oss,snd_seq_midi
snd_seq 47263 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 19098 3 snd_pcm,snd_seq
snd_seq_device 5700 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd 54244 20 snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore 6620 3 snd
snd_page_alloc 7076 2 snd_hda_intel,snd_pc

Espero que con estos datos sea suficiente para hacer un diagnóstico.
Saludos y gracias por anticipado.

-----------------------------------------------

Solucioné el problema siguiendo las instrucciones del mensaje número 9 del siguiente hilo:
http://ubuntuforums.org/showthread.php?s=e1b9857a6f8c1cface3e94a75601c02...