No puedo acceder a mi disco duro externo

Imagen de antonio80
0 puntos

Hola, soy muy novato en ubuntu y linux en general.
Desde hace un tiempo no sé por qué no puedo acceder a mi disco duro externo a través del usb. El mensaje de error que me sale es el siguiente:

"No se pudo montar Sistema de archivos de 80 GB
DBus error org.gtk.Private.RemoteVolumeMonitor.Failed: An operation is already pending"

Utilizo ubuntu 11.04, a ver si pueden ayudarme con instrucciones de novato y paso a paso. Cualquier detalle que necesiten díganmelo, Gracias.

Imagen de furtaxi
+1
0
-1

O eso creo.

Windows ha estado intentando reparar el disco, y es necesario reiniciar en Windows una vez más, para que lo marque como revisado. Ésa debe ser la operación pendiente.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de antonio80
+1
0
-1

Vaya, ahora no pero hace tres semanas si lo tenía instalado y por aquel entonces ya tenía este problema...

¿No hay alguna manera para montarlo sin tener que instalar de nuevo el windows?

+1
0
-1
Imagen de furtaxi
+1
0
-1

Lo enchufas, lo abres para que lea los directorios, lo expulsas, desconecta, repites la operación, y ya te lo deja bien.

Creo que había un comando por consola para poner la marca de revisado, pero google hoy está enfadado conmigo, no lo encuentro. :)

Si me sale, te lo posteo, pero acabas antes de la otra forma, sólo un par de inicios en Windows, y listos.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de antonio80
+1
0
-1

Ya no tengo windows instalado, a ver si podéis ayudarme a "montarlo" desde la terminal de ubuntu u otra manera. Gracias.

+1
0
-1
Imagen de antonio80
+1
0
-1

En este hilo en inglés, donde alguien tiene mi mismo problema, parece que dan una solución, pero no me deja crear la carpeta con el comando mkdir /media/tempdisk

¿alguna pista?

Esto es lo que me dice el comando /sbin/fdisk -l

sudo /sbin/fdisk -l

Disco /dev/sda: 200.0 GB, 200048565760 bytes
255 cabezas, 63 sectores/pista, 24321 cilindros
Unidades = cilindros de 16065 * 512 = 8225280 bytes
Tamaño de sector (lógico / físico): 512 bytes / 512 bytes
Tamaño E/S (mínimo/óptimo): 512 bytes / 512 bytes
Identificador de disco: 0x000243ad

Dispositivo Inicio    Comienzo      Fin      Bloques  Id  Sistema
/dev/sda1   *           1       24257   194835456   83  Linux
/dev/sda2           24257       24322      522241    5  Extendida
/dev/sda5           24257       24322      522240   82  Linux swap / Solaris

Disco /dev/sdb: 80.0 GB, 80025280000 bytes
255 cabezas, 63 sectores/pista, 9729 cilindros
Unidades = cilindros de 16065 * 512 = 8225280 bytes
Tamaño de sector (lógico / físico): 512 bytes / 512 bytes
Tamaño E/S (mínimo/óptimo): 512 bytes / 512 bytes
Identificador de disco: 0x7de73c7b

Dispositivo Inicio    Comienzo      Fin      Bloques  Id  Sistema
/dev/sdb1               1        9729    78139392    b  W95 FAT32
+1
0
-1
Imagen de furtaxi
+1
0
-1

mkdir /media/tempdisk

es una orden que trabaja sobre una carpeta del sistema, así que sólo root puede hacerlo. Lo correcto es:

sudo mkdir /media/tempdisk

Veo que es un error del que posteó la solución, no te sientas culpable... :)

sudo mkdir /media/tempdisk
sudo mount /dev/sdc1 /media/tempdisk -o force
sudo umount /dev/sdc1

(Recuerda cambiar sdc1 por lo que corresponda a tu disco, supongo que sdb1, si es el de 80 Gb, según tu fdisk))

Por cierto... lo tienes en FAT32... cuando puedas, lo formateas en NTFS, que es un poquito más moderno, y un pelín menos malo.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de antonio80
+1
0
-1

cuando escribo en la terminal

sudo mount /dev/sdb1 /media/tempdisk -o force

me devuelve el mensaje:

mount: debe especificar el tipo de sistema de archivos

y cuando escribo

sudo umount /dev/sdb1

me dice:

umount: /dev/sdb1: no montado

¿qué fallará?

+1
0
-1