Problemas y mas problemas, pk Ubuntu lia tanto

Weno amigos tal vez sea un poco drastico con el titulo pero es asi yo estoy con muxas gans de aprender linux, empeze a dar mis pasitos con Mandrake, suse y ahora despues de muxo con ubuntu, vamos al tema...

Un poco de historia.
--------------------
Ordenador P4 - 2.6.
Disco 120 Serial ATA (instalado windows xp, particionado en 2, C y D)
DVD, CDRW.
512MB DDR.

Pasos ke segui
--------------
- Me dejaron un disco de 10GB IDE ATA 100.
- Lo instale como IDE1 Master con el DVD y en el otro canal IDE2 el CDRW.

Procedi a la isntalcion de ubuntu en el disco ide, ubuntu detecto ke habia otro sistema y ke instalaria GRUB, hasta ahi ok.
Al hacer un reinicio automatico, ya ke ubuntu termianba de configurarse, en vez de aparecer GRUB directametne entraba en Windows (Disco Serial ATA) , bueno ok entramso en BIOS cambiamos el arranke para ke se inicia desde el Disco IDE de 10GB, todo perfecto.
- Procedo a la actualizacion de ubuntu via internet y hacer alguans cosillas, todo perfecto ke perfeccion Dios mio..

5 horas despues...
------------------
- Nio veo mi disco duro donde estaba windows... pues entro a un foro y a canales de mirc y me dicen como montarlo...
sudo mkdir /media/windows
sudo mount /dev/sda1 /media/windows -t ntfs -o umask=0222

ok todo perfectoo, weno ahora ahora configuramos para ke al iniciar se monte automaticamente el disco..
- Editamos el archivo
sudo gedit /etc/fstab

y añadimos en la ultima linea...
/dev/sda1 /media/windows ntfs umask=0222 0 0

Ok en teoria tood bien, guardamos y salimos, reiniciamos y a la aparece un mensaje...
-----------------------------------------------------
Mount: special device /dev/sda1 does not exist..
------------------------------------------------------

A la ingresamos a ubuntu y vemos ke no se monto la unidad... ke pasoo.....
En teoria deberia de haberlo leido.. y montado la unidad.

Nota: en el curro isntale ubuntu con disco IDE y tenia ubunut en un disco y dos discos mas y lso pude montar todos editando el archivo fstab....

Preguntas..
-----------
1 Ubuntu soporta discos duros Serial ATA en el arranke.
2 Como pude montar el disoc Serial ATA una vez iniciado el sistema, pk manualmente si lo pilla y no al iniciarce...??
3 La otra particion del disco Serial ATA, no pude montarlo pk no se como Ubuntu asigna lso nombres de las particiones..
$. Hay alguna utilidad para saber como Ubuntu asigna a cada disco instalado tanto las particiones (hda1, hda2, hdb1, sda1, etc)...

Muchas gracias de antemano y a er si alguien me echa una mano para poder aprender mas de este sistema operativo ke esta muy bien la Distro de Ubuntu peroo hay cosillas ke no logro adaptarme...

Imagen de Anónimo
+1
0
-1

Hola,

Prueba con fdisk -l para ver las particiones o instalate qtparted que es similar al partition magic.

Yo no consigo que arranque en el inicio, pero lo monto luego simplemente con un doble click o boton derecho y montar(Siempre y cuando te aparezca windows en Discos no debes tener problemas, ya que, por lo que dices si que has hecho mkdir /media/windows).

Te listo mi linea del fstab:

/dev/sda5 /mnt/windows/G vfat utf8,auto,users,rw,exec,dmask=000,fmask=111 0 0

Con esto lo monto como te comento arriba, eso si, al inicio tambien me dice que no existe el dispositivo.

Suerte y un saludo.

+1
0
-1
Imagen de alexd
+1
0
-1

Muchas gracias a todo ke ahora se ke a muxos le pasa lo mismo tratare de hacer lo ke me han comentado y ya os contare.... GRACIAS...
Aprender linux como sea....

+1
0
-1

Aprender linux como sea....

Imagen de inwe
+1
0
-1

No sé, quizás esté equivocado pero... ¿seguro que el disco nuevo está en /dev/sda1?

/dev/sda1 lo suele "generar" el hotplug cuando insertamos algún dispositivo por usb. Yo creo que si el disco nuevo es el master del primer ide, deberías mirar /dev/hda1, si es que realmente está insertado en ese sitio. Recuerda los discos y dispositivos ides usan hda, hdb, hdc y hdd.

Vaya, creo que me he confundido, el que no ves es el serial-ata. Si es así desconozco como funciona, ya que mi ordenador anda por el paleolítico inferior y aun no he visto un serial-ata XDD

Espero que haya resuelto tu duda :). Un saludo

+1
0
-1
Imagen de Anónimo
+1
0
-1

Hola,

Mi disco serial ata corresponde a sda5(no se porque es 5,pero lo es) y cuando inserto un pendrive lo reconoce como sdb1, y antes de tener el serial ata lo reconicia como sda1.

Un saludo.

+1
0
-1
Imagen de TheSen
+1
0
-1

Yo tuve problemas con mi particion de Windows, aunque de fácil solución. No he intentado montarla al arranque puesto que en la partición de Windows lo único que tengo es Windows y sus programas, mis documentos y todo lo demás lo tengo en otras particiones FAT32 que no dan problemas en Linux. Aunque no servirá mucho de ayuda lo que escriba ahora, espero que por lo menos sea informativo.

Las unidades sda en Linux, tradicionalmente, se utilizaban para las unidades SCSI (de hecho, con knoppix hay un problema en el arranque con mi controladora SATA y el error lo da cargando el SCSI que no tengo). Actualmente, en las unidades sda se cargan el USB, Firewire y los discos SATA. La numeración de estas unidades sigue el mismo sistema que en las hdx, es decir sda el primer dispositivo, sdb el segundo, y los numeros indicando el numero de partición. Por lo general, por lo que he probado, los discos SATA se ponen antes que los dispositivos USB y los Firewire. Es decir si tienes un disco SATA y un lector de tarjetas USB, sda será el SATA y el sdb el USB. Si tienes dos particiones, lo más seguro es que sda1 sea C: y sda2 sea D: (si son las dos primarias), si D: es una unidad lógica será sda5. De todas formas, como dijeron por aquí arriba, para ver una lista de particiones usa:

fdisk -l

que muestra una tabla con discos instalados, particiones, tipo de las particiones, etc.

La linea que dijiste

---------------------------------------------------------------------
/dev/sda1 /media/windows ntfs umask=0222 0 0
---------------------------------------------------------------------

quiere decir que quieres montar /dev/sda1 en el directorio /media/windows que tiene el formato ntfs. El umask se utiliza para quitar permisos, en concreto quitas el permiso de escritura a todos los usuarios. El ntfs no está plenamente soportado en linux, se puede leer pero no escribir (recientemente salió el captive ntfs que permite escribir pero no es muy estable de momento) por eso se utiliza el umask que se utiliza. Esa línea la dejaría:

/dev/sda1 /media/windows ntfs auto,users,umask=0222 0 0

auto: para que se monte automáticamente
users: para que los usuarios puedan montarla

Prueba a hacer eso, espero que te funcione. El tema puede dar para más conversación pero con esto creo que entenderás mejor tú problema, aunque no se si lo solucionará.

Un saludo

---------------------------------------
Mucho mundo por ver, muchas cosas por hacer

+1
0
-1

Mucho mundo por ver, muchas cosas por hacer

Imagen de Anónimo
+1
0
-1

Ehh tio muxas gracais de verdad se me han aclarado algunas dudas ke tenia, ahora tengo un problema ke tambien os expondre pero respecto a GRUB, como vereis como lo tengo montado hasta ahora me akeja otor problema y es ke el GRUB al iniciarce me da la opcion para poder escoger ke sistema operativo inciar, si le digo ke ejecute windows (Disco SERIAL ATA - en unidad C: ) se keda pillado..... y no funciona trate de editar el grub y decirle ke inicia asi boot (sda1,0), boot (hd0,0), boot (hd1,0) probe todas las configuraciones posibles... pero nada
Ya detallare mas sobre el tema pero ese es el problema ke akeja actualmente.... si podeis echarme una mao os agradeceria...

+1
0
-1