Actualización de “Eye of GNOME” [Solucionado]

Imagen de 19jp87
0 puntos

Hola, me gustaría actualizar el visor de imágenes Eye of GNOME que viene con Ubuntu 10.04 (versión 2.30.0), para lo cual ingresé a la página oficial del programa donde está disponible para descargar la última versión estable 3.0.2. Descargué el archivo, un .tar.bz2, lo descomprimí y lo volví a comprimir, pero en .tar.gz para poder construir el .deb usando "alien". Abrí el .deb creado e instalé el nuevo Eye of GNOME, pero al tratar de abrirlo me dice que no está instalado (tipeando eog en la consola), al mismo tiempo que en el Centro de Software y en Synaptic me dice que sí está instalado (el mismo eog, versión 3.0.2). Por lo cual tuve que desinstalar eog, momento en que se me ofrecía la solución de volver a la versión anterior, la que viene con Lucid Lynx. Entonces quisiera saber si es posible actualizarlo o no.

Imagen de RagonichaFulva
+1
0
-1

Yo creo que has hecho algo muy raro...

El tar.bz2 es el código fuente, no un paquete precompilado para convertir con alien. Mira la documentación de esta web que ALIEN y las formas de paquetes para instalar están muy bien explicados.

En este caso, sólo has de compilar el código. Simplemente desinstala eog (que ya lo has hecho), descomprime el .tar.bz2, entra en la carpeta creada y compila el código. Antes de ello, eso sí, revisa el fichero "install" (no "install.sh") que te explica cómo instalar.

Un saludo.

+1
0
-1

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."

Imagen de 19jp87
+1
0
-1

Hola, gracias por la respuesta, aunque ha salido todo mal. Si hago lo que me dices, al seguir las instrucciones del fichero INSTALL y escribir ./configure llega un momento en que me aparece:

configure: error: Your intltool is too old.  You need intltool 0.40.0 or later.

Entonces no me funciona el siguiente paso que es escribir ‘make’.

Intenté otra forma, que fue la de descargarme directamente el .deb desde pkgs.org, pero al abrirlo y tratar de instalarlo me aparece:

Error: La dependencia no se puede satisfacer: libcairo-gobject2 (>= 1.10.0)

Por cierto, tampoco pude desinstalar el eog que ya tenía, porque me ofrecía como "solución" desinstalar ubuntu-desktop y claro está que no iba a aceptar esa solución.

Con todo ese atado mejor dejo el eog que ya tengo.
Saludos.

+1
0
-1
Imagen de rioport
+1
0
-1

Yo lo intente por el hecho de poder ver archivos SVG sin que se vean como imágenes raster, pero la ultima versión compatible es la 2.31.1. ¿Por qué? por el tema de las librerías. O migras a la nueva versión de Ubuntu que lo contenga o te conformas con lo que hay, es el precio de la estabilidad.

+1
0
-1

-- GC --

Imagen de RagonichaFulva
+1
0
-1

Para instalar el nuevo eog has de aprender a compilar.

En la documentación de esta página hay un artículo que te enseña cómo hacerlo.

Respecto a las dependencias, te aparecen en el archivo INSTALL que te mencioné que leyeras.

Sólo has de instalarlas con APT antes de compilar:

sudo apt-get install dependencia1 dependencia2 dependencia3...

tras instalarlas, podrías compilar.

Si bajaste el .deb has de hacer lo mismo:

sudo apt-get install libcairo-gobject2

y luego instalar el.deb. Aunque tengas eog en el sistema te lo actualizará. Para ello, Ubuntu usará el Centro de Software, pero yo preferiría usar usar el programa Gdebi, que va más rápido y ya te dice las dependencias, etc. El centro de software lo veo aún un poco verde en este apartado.

sudo apt-get install gdebi

Compilar es a la vez la forma más agradecida y menos agradecida de instalar paquetes en Ubuntu y otras distros. La instalación es mejor, puesto que el compilado es a medida de tu máquina, pero es más laborioso.

En un inicio te sugiero empezar con paquetes precompilados (.deb) y poco a poco que adquieras conocimientos más avanzados para probar cosas más complejas (saber qué son las dependencias, cómo modificar el archivo de orígenes de software, compilar, etc.). La mayoría de esas competencias las adquirirás con la documentación de esta web, que además no es una lectura muy extensa.

+1
0
-1

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."

Imagen de 19jp87
+1
0
-1

Y qué crees que fue lo que hice. Esa tal librería de libcairo-gobject2 no existe en los repositorios de Ubuntu 10.04, en launchpad sale que está para Ubuntu 10.10 en adelante. Y al intentarlo por medio de la compilación pude satisfacer la primera dependencia que me aparece, pero al hacer eso te empieza a pedir más dependencias todavía hasta llegar el momento en que no se pueden satisfacer todas.
“rioport” respondió a mi duda, es por un tema de librerías. Antes tuve Ubuntu 10.10 y 11.04, pero preferí el 10.04 por estabilidad.

+1
0
-1
Imagen de RagonichaFulva
+1
0
-1

Pues ignoro lo que hiciste, ya que no mencionaste los detalles de tus procedimientos. La lógica en estos foros dicta que se aplique el principio de la navaja de occam y luego ya nos complicamos más adelante.

Podrías intentar forzar la instalación de dicha librería, aunque no sé si te merece la pena o el esfuerzo.

+1
0
-1

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."

Imagen de Jose Luis 1320
+1
0
-1

Es para gnome 3, requiere de librerías GTK 3.0 y en Ubuntu 10.04, jamás las vas a tener por que usa gnome 2.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de RagonichaFulva
+1
0
-1

Es cierto. Inviable. No funcionaría por las propias dependencias de la librería.

+1
0
-1

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."

Imagen de 19jp87
+1
0
-1

Gracias a los dos por sus respuestas. Tenía esa sospecha cuando lo compilé, porque me pedía algo de GTK, era eso.

Saludos.

+1
0
-1