Disco duro usb que no monta

Imagen de vallesin
0 puntos

Me han pasado un disco duro usb que no lleva alimentación a la corriente eléctrica , solo usb , el dueño me dijo que en windows no aparece al conectarlo , en ubuntu sucede igual , me a pedido si puedo recuperar el hd o la info aunque este quede inservible.

¿que puedo empezar a hacer? con el comando lsusb el hd si que aparece listado

Imagen de 11.10Elcelote
+1
0
-1

deja y le pregunto a mi bola de cristal!

a ver que version de ubuntu tienes???
que tipo de disco duro es??

+1
0
-1
Imagen de vallesin
+1
0
-1

Uso ubuntu 11.04 , tipo de disco duro?? pues un hd de 3,5 western digital , no se que mas decirte de él porque no es mio xD , pensé que no seria muy importante , supongo que de capacidad serán 500gb.

1 saludo

+1
0
-1
Imagen de 11.10Elcelote
+1
0
-1

1 solo saludo?
bueno, has esto;

conecta tu disco duro externo, y abrete la terminal, y teclea;
sudo fdisk -l

lsusb

pega aqui el resultado.

Luego, sin desconectar el disco duro externo, teclea esto en la terminal;
sudo gedit /etc/fstab

y pega aqui el contenido

salu2

+1
0
-1
Imagen de Tucu
+1
0
-1

Hola tengo un disco externo Western Digital de 1Tb que no se reconoce en Windows ni en Ubuntu.
He probado las sugerencias haciendo el comando;
sudo fdisk -l

Al aplicar el comando anterior aparecen todas las particiones del disco interno y otro disco externo que si me funciona bien pero no aparece el que no funciona

Entonces decidi probar, aunque no se que es lo que hace, con el comando:
lsusb

Al hacer esto aparece una lista de todas las cosas conectadas al ordenador y figura el disco que no funciona
Ejemplo:

Bus 002 Device 008: ID: 1058:0730 Western Digital Technologies Inc.
Mis preguntas son 2 primero que significa la respuesta que obtengo al comando lsusb y la segunda que puedo hacer para solucionar el problema
Muchas gracias

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

Estimado compañero:

No invada hilos, abra un nuevo tema con su problemática, aquí unicamente le estan ayudando al autor de este hilo.

Gracias.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de vallesin
+1
0
-1

sudo fdisk -l

Disco /dev/sda: 160.0 GB, 160041885696 bytes
255 cabezas, 63 sectores/pista, 19457 cilindros
Unidades = cilindros de 16065 * 512 = 8225280 bytes
Tamaño de sector (lógico / físico): 512 bytes / 512 bytes
Tamaño E/S (mínimo/óptimo): 512 bytes / 512 bytes
Identificador de disco: 0x0007c989

Dispositivo Inicio Comienzo Fin Bloques Id Sistema
/dev/sda1 * 1 18693 150145024 83 Linux
/dev/sda2 18693 19458 6142977 5 Extendida
/dev/sda5 18693 19458 6142976 82 Linux swap / Solaris

lsusb

Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 006: ID 1058:1023 Western Digital Technologies, Inc.
Bus 002 Device 002: ID 04f2:b015 Chicony Electronics Co., Ltd VGA 24fps UVC Webcam
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

sudo gedit /etc/fstab

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
#
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sda1 during installation
UUID=6bd4cf68-0a02-4660-a397-73db00846686 / ext4 errors=remount-ro 0 1
# swap was on /dev/sda5 during installation
UUID=6e2f39bd-377b-4fb7-a49e-5edd64154a4e none swap sw 0 0

Hay lo llevas compañero , gracias por la ayuda , ¿tiene solución?

+1
0
-1
Imagen de 11.10Elcelote
+1
0
-1

tienes instalado el Gparted??

si no, instalatelo asi;
sudo apt-get install gparted

abrelo, para ver los discos duros, y ver si desde ahí lo puedes montar, de lo contrario, intentaremos montarlo a mano.

+1
0
-1
Imagen de vallesin
+1
0
-1

En el gparted no aparece el hd , :(

+1
0
-1
Imagen de Goyo
+1
0
-1

Los discos deben de estar dañados, se puede intentar recuperar la información con testdisk.

+1
0
-1
Imagen de vallesin
+1
0
-1

En el gparted no sale en el listado de dispositivos :(

+1
0
-1
Imagen de vallesin
+1
0
-1

¿Nadie sabe que mas puedo hacer?

+1
0
-1
Imagen de 11.10Elcelote
+1
0
-1

has probado conectar el disco duro en un pc con win2??
si funciona en ese sistema operativo quiere decir que no esta dañado.

+1
0
-1
Imagen de vallesin
+1
0
-1

Lo he conectado y el administrador de particiones si que lo reconoce , pero en el explorador de archivos no sale , e intentado darle formato y nada.

Lo mismo desde ubuntu , aparece en el gestor de particiones pero no es posible hacer nada con el , ¿lo doy por muerto?

+1
0
-1
Imagen de rioport
+1
0
-1

Si es USB ¿Has probado a sacarlo de la carcasa en que viene? Quizá sea el circuito USB-SATA (No sé el nombre) es el que falla. Estando el disco fuera lo puedes conectar a algún puerto SATA que tengas libre o usar un conversor SATA a USB y probar si funciona el disco.

Un poco más de información:
1)Desconecta el disco, limpia el buffer de dmesg:

sudo dmesg -c

Saldrán muchas lineas de texto, lineas innecesarias así que no las pegues acá.
2)Conecta el disco, espera unos segundos y consulta el buffer de dmesg

dmesg

Y pega acá el resultado.

+1
0
-1

-- GC --

Imagen de jgonzalez679
+1
0
-1

Hola. No conozco ningún disco duro de 3.5 pulgadas que no necesite alimentación external. Creo que ahí está el error
Saludos

+1
0
-1
Imagen de rioport
+1
0
-1

Hay que leer un poco más, ¿Te diste cuenta quién creó el tema?

+1
0
-1

-- GC --

Imagen de vallesin
+1
0
-1

Despues de vaciar el buffer con el comando que me dijiste se llena con errores similares a este.

[21609.014477] sd 9:0:0:0: [sdc] Unhandled sense code
[21609.014481] sd 9:0:0:0: [sdc] Result: hostbyte=invalid driverbyte=DRIVER_SENSE
[21609.014485] sd 9:0:0:0: [sdc] Sense Key : Data Protect [current]
[21609.014491] sd 9:0:0:0: [sdc] Add. Sense: Logical unit access not authorized
[21609.014498] sd 9:0:0:0: [sdc] CDB: Read(10): 28 00 00 00 00 00 00 00 08 00
[21609.014510] end_request: critical target error, dev sdc, sector 0
[21609.015598] sd 9:0:0:0: [sdc] Unhandled sense code
[21609.015603] sd 9:0:0:0: [sdc] Result: hostbyte=invalid driverbyte=DRIVER_SENSE
[21609.015609] sd 9:0:0:0: [sdc] Sense Key : Data Protect [current]
[21609.015615] sd 9:0:0:0: [sdc] Add. Sense: Logical unit access not authorized
[21609.015623] sd 9:0:0:0: [sdc] CDB: Read(10): 28 00 00 00 00 00 00 00 08 00
[21609.015636] end_request: critical target error, dev sdc, sector 0

+1
0
-1
Imagen de brenlla
+1
0
-1

Me sucedía lo mismo, no me montaba los dispositivos USB tipo lápiz o disco duro.

Solución para mí fue abrir una consola y ejecutar
sudo modprobe usb_storage

+1
0
-1

GNU/Linux user #124.437 since 1997