(Solucionado) Problema Aircrack-ng Ubuntu 11.10

Imagen de Kalen94
0 puntos

Buenas a todos, veréis, hace apenas menos de una hora que he instalado el paquete de Aircrack-ng en Ubuntu 11.10, al intentar recibir paquetes de una red me sale arriba un mensaje diciendo "Fixed channel mon0 -1". Según he estado leyendo por internet este problema también estaba en las versiones de Ubuntu 10.10 y 11.04. He buscado la solución en mi versión pero no la encuentro, sólo encuentro la solución para las versiones 10.10 y 11.04. Según parece se debe a las distintas versiones del kernel.

Haber si alguien me puede ayudar.

Muchas gracias y un saludo.

Imagen de Kalen94
+1
0
-1

Al final ya lo he solucionado, para quien le sirva:

1.- Escribimos en la terminal sudo apt-get install linux-headers-$(uname -r) para saber nuestro kernel.

2.- Bajamos el paquete que corresponde a nuestra versión (3.02 en mi caso), http://wireless.kernel.org/en/users/Download/stable/ y lo descomprimimos en nuestra carpeta personal.

3.- Escribimos en la terminal, cd compat-wireless-3.0-2.

4.- Después, wget http://patches.aircrack-ng.org/channel-negative-one-maxim.patch

5.- Luego, sudo apt-get install patch

6.- Seguimos, patch ./net/wireless/chan.c channel-negative-one-maxim.patch

7.- make

8.- sudo make install

9.- sudo make unload

10.- Y finalmente, sudo reboot.

Espero haber ayudado.

Saludos.

+1
0
-1
Imagen de CRYSPYN
+1
0
-1

Gracias por compartir tus conocimientos. Lo he solucionado siguiendo los pasos que indicas. Un saludo

+1
0
-1
Imagen de avo
+1
0
-1

Gracias, entre otras cosas me ha servido para solucionar varios problemas que he tenido. En cuanto pueda haré un post para explicarlos.

Saludos.

+1
0
-1

Abo.

Imagen de erickr3
+1
0
-1

hola mi amigo me parece bueno el post y yo soy nuevo en ubuntu 11.10
pero cuando me pides que abra una consola 3.- Escribimos en la terminal, cd compat-wireless-3.0-2.
no encuentra la ruta sorry como no me ubico mucho aun te pido si puedes hacer un video con mirar se aprende siempre mejor de ante mano gracias

+1
0
-1
Imagen de nahym1000
+1
0
-1

tienes que ir navegando por las rutas! checa donde se descargo el archivo o donde lo descomprimiste en la terminal lo vas poniendo por ejemplo:
"cd Descargas"
"cd etc." o simplemente abres la terminal pones cd y despues arrastras la carpeta ala terrminal y se pondra la ruta solo das enter y sigues con los siguientes pasos

+1
0
-1
Imagen de Fercho_26
+1
0
-1

tengo una tarjeta con chispet ralink 3070 intente este metodo y no funciono ayuda por favor

+1
0
-1
Imagen de jorge1915
+1
0
-1

Disculpa cuando llego al paso 6 no entiendo como segui me podrias ayudar pasarme un video de youtube soy nuevo en esto gracias de ante mano..

+1
0
-1
Imagen de jorge1915
+1
0
-1

copia todos los pasos en tu crpeta personal lo guardar con el nombre que quieras luego le das clic izquierdo propiedades permisos (permitir ejecutar el archivo como un programa)
luego coloca en la tarminal el siguiente coamndo

./ y el nombre que le colocastes y lo ejecutara solo

+1
0
-1
Imagen de jorge1915
+1
0
-1

me genera un error cuando se esta instalando la make como hago para istalarlarla alguien me puede ayudar.. me genera este error..

cc1: algunos avisos se tratan como errores

make[3]: *** [/home/jorge/compat-wireless-2.6.39-1/net/wireless/util.o] Error 1
make[2]: *** [/home/jorge/compat-wireless-2.6.39-1/net/wireless] Error 2
make[1]: *** [_module_/home/jorge/compat-wireless-2.6.39-1] Error 2
make[1]: se sale del directorio «/usr/src/linux-headers-3.0.0-14-generic»
make: *** [modules] Error 2

+1
0
-1
Imagen de LyingB
+1
0
-1

Primero que nada te recuerdo que no debes invadir los hilos de otro usuario, si no abrir uno con tus dudas.

El problema es que has descargado los compat-wireless de la rama 2.6.x, mientras que estás usando un kernel de la rama 3.0.x. Tienes que descargar los compat-wireless de acuerdo con la versión que usas.

+1
0
-1


Agrega al final del título del post (solucionado) si has arreglado tu problema.

Imagen de Arturox08
+1
0
-1

Percátate que si hayas descargado el parche para tu respectivo Kernel, quizás es por eso el error que te manda, no te saldrá la versión exacta de tu kernel en la página de Compat-Wireless, pero por el ejemplo mi Kernel es el 3.0.9, y el paquete que te aparece en la página es del 3.0 pero el último número no es el mismo, igual será compatible con tu kernel, ¿si me entiendes? espero haberte ayudado.

+1
0
-1
Imagen de mispk2
+1
0
-1

Resulta que he instalado todo como decía y me he quedado sin wiffi, tengo linux-headers-3.0.0-14-generic y en la desesperacion me baje todos los paquetes de la pagina de http://wireless.kernel.org/en/users/Download/stable/ ... y eh probado de instalarlos uno por uno, resultado:NEGATIVO ahora no tengo wiffi y tengo que instalar otra vez mi ubuntu.
de todas maneras ole a quien les ha funcionado. si alguien tiene una sugerencia antes de que me someta a instalar ubuntu, bienvenido sea ya que me fastidia bastante tener que instalar todo otra vez.. gracias.

+1
0
-1

Adrian

Imagen de teclaelvis
+1
+1
-1

Adrian a mi me pasó exactamente lo mismo asi que para no reintalar mi ubuntu lo que hice fue desintalar el compat-wireless para ello hice lo siguiente desde la terminal:

cd compat-wireless (Es decir desde la terminal ve a la carpeta donde esta el compat wireless)
luego teclea en la terminal:
sudo make uninstall
y luego que ejecute teclea
sudo make unload

Despues reinicia y tendras tu preciada tarjeta de red activada nuevamente

+1
+1
-1
Imagen de nahym1000
+1
0
-1

hola hermano muchas gracias la verdad es que pense que habia quemado la tarjeta y ya iba a ir a comprar una nueva! gracias de nuevo salvaste mi bolsillo jaja

+1
0
-1
Imagen de m0m0o
+1
0
-1

funciona perfecto Kalen94, muchas gracias a ti y a los demas que aportan junto contigo su ayuda,

Saludos!

+1
0
-1
Imagen de alevilla13
+1
0
-1

amigo despues de hacer todos los procedimientos antes mencionados para el uso de aircrak, resulta que a la hora de reiniciar ya no detecto ninguna red es como si se hubiera desconectado la tarjeta de red, mi kernel es 3.0, te agradecerias me pudieras ayudar

+1
0
-1
Imagen de nahym1000
+1
0
-1

hola amigo lo que tienes que hacer es reisntalar el driver que ubuntu te instalo ya sea el privativo o uno de terceros puedes abrir controladores adicionales y ahi te dira que drivers puedes usar

suerte

+1
0
-1