Como no, Ati Radeon Mobility X1400 128Mb en 11.10

Imagen de lagogz
0 puntos

Buenos días.

Como ya comenté en otro tema que abrí hace unos días en el foro de actualizaciones, me había quedado en Feisty (o Hardy, no recierdo si había llegado a ella,jeje), con lo que casi me puedo volver a considerar novato.

La última vez q me puse con Ubuntu dejé el pc perfecto, y por supuesto es el mismo que tengo ahora.

El pc es un portátil Dell Inspiron 6400 , con procesador de doble nucleo, 2 Gb de memoria DDR2 y la @#.;-./ de mi tarjeta Ati Mobility Radeon X1400 de 128 mb.

El sistema que estoy intentando configurar es la Oneiric Ocelot o 11.10.

Me he leído y releído todos los manuales q me he encontrado, pero nanai. Explico lo q hice desde cero.

1- Instalé Ubunru 11.10.

2- Inicié el sistema, todo funcionó correctamente y Unity perfecto. Me dijo q había ciertas actualizaciones y le hice caso. Reinicié y Unity ya no funcionaba correctamente. En particular no aparecía ninguna aplicación en el botón "Ubuntu" o de listar las aplicaciones (el q está más arriba en l abarra lateral izquierda) y el centro de software no se abría. La verdad es q me dió igual pq uso Gnome, pero bueno, si alguien sabe el problema q me lo explique,plis (ya he intentado cosas pero nada).

3- Compruebo aceleración desde consola. Glxgears me muestra los engranajes y me saca q van más o menos a 350 frames. Los engranajes van perfectos, fluídos. Glxinfo me dice q Direct Rendering= yes.

4- Instalo Synaptic y compruebo si tengo instalado el driver fglrx, y me sorprendo de q no lo tengo instalado. Voy a herramientas de sistema/controladores adicionales y no me encuentra ninguno.

5- Me informo de como instalar el driver oficial (privativo) de Ati (en algunos casos creo q leí q no lo había compatible para mi tarjeta con la 11.10). Entonces me descargue 3, en 9.3 y 9.4 (creo q estos, los últimos vamos) que según la página de Ati no los soporta mi tarjeta, pero son los más parecidos, ya q fuí incapaz de encontrar el de la mía, y el 11.6 (creo q es 6, el último tambien).

6- Instalo buildessentials, dh-make,linux-kernel-headers,etc.... e intento crear los debs de los run. No me deja con ninguno de los 9.
sudo dpkg -i ./ati.....run --buildpkg Ubuntu/oneiric
Me dice q no son compatibles con la versión de Ubuntu.

7- Instalo los fglrx desde Synaptic y reinicio.

8- Me logueo y ya no tengo Gnome 3, me aparece la apariencia tradicional. En la pantalla de login selecciono Gnome, no Gnome Classic, pero me aparece el Classic. Consola, Glxgears y me muestra los engranajes, pero se mueven a saltos, mucho más lentos. Aún así me sigue dando 350 frames.

9- Hago un aticonfig y me dice q no hay tarjeta de vídeo compatible. Intento acceder al Catalyst y me dice o q no hay tarjeta de vídeo compatible o q los fglrx están mal configurados.

10. Lspci en consola y me saca q tengo la Ati, me pone algo así como lnc ATI Mobility Radeon X1400 128.

11. En herramientas de sistema sigue sin encontrar controladores adicionales.

12. Intento un Xorg -configure y ahí ya flipé del todo. No tengo /etc/X11/Xorg.conf. Y como no me funciona aticonfig --initial -f pues a joderse.

12. Lo intento con el driver 11.6 privativo de Ati. Desinstalo fglrx mediante synaptic. Creo los deb y los instalo. Reinicio y me sigue pasando lo mismo, Gnome Classic. Aticonfig sique sin rular pero Glxgears me saca el siguiente error:

"X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 135 (GLX)
Minor opcode of failed request: 19 (X_GLXQueryServerString)
Serial number of failed request: 12
Current serial number in output stream: 12"

13- Xorg -configure me saca lo siguiente:

"Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.

Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.

ddxSigGiveUp: Closing log"

Me imagino q este error me dá pq debo reiniciar y entrar desde consola, pero entonces, funcionan las X sin el archivo Xorg.conf???????

Y ahí me he quedado.

Alguien puede ayudarme a configurar la gráfica. Es lo único q me falta, y me jode, pq en Feisty lo hice a la primera, y creo q me daba como 1500 frames el Glxgears.

Un saludo.

Imagen de lagogz
+1
0
-1

Buenas de nuevo.

Lo q si creo q tenía instalado era xorg-video-radeon o algo así, puede ser q tenga q desinstalar esto antes de instalar los fglrx de las sources?

+1
0
-1
Imagen de almursi
+1
0
-1

buenas, pues te ha fallado lo esencial :), leer que el catalyst sólo soporta las radeon HD desde hace años y tu tarjeta la eliminaron en el 2009. Con el radeon libre debería trabajar, aunque probablemente sólo tengas buen resultado con unity 2D. En cuanto al (corrijo) punto 13, ese comando sólo te sirve cuando estás en la consola del modo de recuperación, porque si tienes activa consola gráfica no puedes probarlo. Saludos cordiales.

+1
0
-1
Imagen de lagogz
+1
0
-1

Ya me parecía a min. Joder con los de ATI, cagon tó.

De toda formas con el fglrx tampoco me va, o sea q... No sabrías indicarme si tengo q desinstalar algo antes de instalar los fglrx? y q pasa con el Xorg.conf, ya no se usa? pq no me aparece y aún así se inicia el X server?

Tanto Unity 3D como Gnome 3 me iban a la perfección antes de intentar configurar la aceleración 3D, q creo q ya la tenía ya q direct rendering estaba en yes, pero bueno.

Si consigo el último driver privativo creado por ATI para mi tarjeta, podría instalarlo en 11.10?

Un saludo.

+1
0
-1
Imagen de almursi
+1
0
-1

buenas, a lo último no es muy recomendable intentarlo, te va a dar más problemas que otra cosa y dudo que funcione. Si estás muy aburrido usa una partición aparte con una instalación que no te importe formatear si no te funciona. Saludos cordiales.

+1
0
-1
Imagen de lagogz
+1
0
-1

Buenas de nuevo.

He leído q gnome-shell no está soportado por el driver fglrx. Eso es cierto??????

Es q si es así vaya mierda.

Un saludo.

+1
0
-1
Imagen de DINAMIK
+1
0
-1

Hola

lo que te conviene hacer es usar el driver libre.

si podes volve a reinstalar oneiric, agrega el ppa de xorg. y vas a poder usar el galium que tiene un buen soporte.

saludos

+1
0
-1
Imagen de lagogz
+1
0
-1

Dinamik, y podrías indicarme q s eso del ppa y el galium?

Un saludo.

+1
0
-1
Imagen de lagogz
+1
0
-1

A ver, a ver, q creo q me estoy liando.

Justo después de instalar Ubuntu, al hacer un glxgears me sacaba esto:

350 frames in X seconds = 22000 FPS

Esto significa q me da 350 frames o 22.000, pq si es lo segundo ya esta de puta madre,no?

La X de segundos no recuerdo cuánto es, pero tampoco tiene sentido q me diese esto, ya q si son 350 frames cada 5 segundos por ejemplo, como van a ser 22.000 cad a segundo. Eso es imposible.

+1
0
-1
Imagen de almursi
+1
0
-1

buenas, te estás liando :). Esos valores son imposibles (igual que los dichosos "puntos básicos" de los periodistas, son "decimales" traducido al castellano). 350 / 5segundos = 70 fps/frames por segundo. Saludos cordiales.

+1
0
-1
Imagen de lagogz
+1
0
-1

Buenas de nuevo.

Al instalar el sistema limpio, no debería reconocerme la tarjeta e instalarme el driver fglrx? y de no ser así, alguien podría decirme como lo instalo.

No me sirve sudo apt-get install fglrx fglrx-acddme(o como sea) pq ya lo hice, y lo único que conseguí es q no me vaya Gnome 3.

Y por favor, el Xorg.con de /etc/X11 no existe. Lo he comprobado justo después de instalar el sistema limpio y no existe. Se ha cambiado el archivo de configuración de las X en esta versión de Ubuntu. D no ser así, tendría q instalar el driver fglrx y crearme yo el Xorg.conf, y de ser así q debería contener el Xorg.conf?

Lo q tengo instalado es algo así como xserver-xorg-radeon, y cuando voy a información del sistema, el driver q me pone es gallium no se qué.

Me sigue dando 50 FPS.

Un saludo y gracias.

+1
0
-1
Imagen de DINAMIK
+1
0
-1

En Ubuntu 9.10 hacia adelante, para los modelos discontinuos de ati la unica opcion es el driver libre. te recomiendo poner la ultima version de ubuntu,

y luego en terminal escribis:

sudo add-apt-repository ppa:xorg-edgers/ppa

eso te va a mantener el driver radeon, actualizado,
podes buscar como tunear un poco el xorg.conf para sacarle mas jugo, pero no le pidas mucho.

no tomes el glxgears como un benchmark, es muy mentiroso.
con el driver "radeon" vas a poder usar compiz y jugar

-------------------------------------------------------------------------

en concepto de lo tuyo, el xorg.conf en las ultimas versiones de ubuntu no es necesario. lo tiene incluido en el nucleo (si no me equivoco). busca como generar xorg.conf, hay mucha info. lo generas y lo modificas a gusto.

gallium es el driver libre para las ati. yo con ese driver pude jugar al regnum en una x1650, a 20 fps (con el privativo me da 35 fps)

+1
0
-1
Imagen de Arnao
+1
0
-1

me viene al pelo esto porque le voy a instalar a un amigo ubuntu 11.10 y su GPU es una ATI Technologies Inc Mobility Radeon X2300 y ya no la soporta el driver privativo con lo cual le tengo que poner el driver libre y no sabía como se hacía, pero me queda una duda, después de añadir el repositorio que comentas cual es el paquete que habría que instalar para activar el driver libre de ati?

Un saludo

+1
0
-1
Imagen de almursi
+1
0
-1

el xorg.conf en las ultimas versiones de ubuntu no es necesario

buenas, eso es cierto, generalmente sólo lo creas cuando quieres "tunearlo". De todos modos el esqueleto es tan básico como esto (que es tanto como no decir nada :) ):

Section "Device"
	Identifier	"Configured Video Device"
	Driver 		"radeon"
EndSection

Section "Monitor"
	Identifier	"Configured Monitor"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Monitor		"Configured Monitor"
EndSection

Lo que marco en negrita es donde seleccionas arrancar con el controlador libre.

Si no me equivoco en cuanto añades el repositorio, sencillamente tendrás disponibles nuevas versiones para xserver-xorg y video-radeon y la actualización es automática. Saludos cordiales.

+1
0
-1
Imagen de DINAMIK
+1
0
-1

en mi caso, lo que siempre me paso, es que ubuntu elige ponerte el driver libre por default, o sea que no vas a tener ke instalar nada mas que agregar el ppa del xorg para obtener la ultima version.

recuerden que para usar el driver libre, les combiene 11.04 o 11.10

pueden ver la info de video usando

glxinfo (si todo esta bien, el driver va a ser galium 0.4)

recuerden que el xorg.conf no se genera solo, pero ya con la configuracion estandar tienen un buen rendimiento. van a poder usar compiz y van a poder jugar varios juegos, por ejemplo regnum.

+1
0
-1
Imagen de Arnao
+1
0
-1

muchas gracias, por mi parte aclarado entonces

Un saludo

+1
0
-1