Ubuntu 11.10 no me reconoce wireless broadcom (solucionado)

Imagen de pitas91
0 puntos

Hola, soy nuevo en ubuntu y por lo que tenia entendido ubunto reconocía todos los periféricos, pero a la hora de iniciar ubuntu por primera vez no me reconoció wireless, y me metí a configuración y me sale que el firmware no existe, que debo hacer para que me reconozca wirelees?

Muchas gracias,

Imagen de centurix
+1
0
-1

No nos das muchas pistas.
El wifi es interno o externo?

si es interno abre una consola (terminal) y pega aquí el resultado del comando:

lspci -nn

si es por usb

lsusb
+1
0
-1

--
Elementary OS "Luna"
LRU #473102

:(){ :|:& };:

Imagen de pitas91
+1
0
-1

Gracias centurix, el wifi es interno del portatil, es un HP DV3 2157CL

00:00.0 Host bridge [0600]: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub [8086:2a40] (rev 07)
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)
00:02.1 Display controller [0380]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a43] (rev 07)
00:1a.0 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 [8086:2937] (rev 03)
00:1a.1 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 [8086:2938] (rev 03)
00:1a.7 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 [8086:293c] (rev 03)
00:1b.0 Audio device [0403]: Intel Corporation 82801I (ICH9 Family) HD Audio Controller [8086:293e] (rev 03)
00:1c.0 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 [8086:2940] (rev 03)
00:1c.2 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 [8086:2944] (rev 03)
00:1c.3 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 [8086:2946] (rev 03)
00:1c.5 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 [8086:294a] (rev 03)
00:1d.0 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 [8086:2934] (rev 03)
00:1d.1 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 [8086:2935] (rev 03)
00:1d.2 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 [8086:2936] (rev 03)
00:1d.7 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 [8086:293a] (rev 03)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev 93)
00:1f.0 ISA bridge [0601]: Intel Corporation ICH9M LPC Interface Controller [8086:2919] (rev 03)
00:1f.2 SATA controller [0106]: Intel Corporation ICH9M/M-E SATA AHCI Controller [8086:2929] (rev 03)
00:1f.3 SMBus [0c05]: Intel Corporation 82801I (ICH9 Family) SMBus Controller [8086:2930] (rev 03)
02:00.0 Network controller [0280]: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller [14e4:432b] (rev 01)
03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 02)

Esto fue lo que me retorna el comando,

Gracias

+1
0
-1
Imagen de centurix
+1
0
-1

Tu controladora wifi es la siguiente:

02:00.0 Network controller [0280]: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller [14e4:432b] (rev 01)

Y está soportada por el driver STA (privativo).

Haz click en el botón de inicio (arriba del launchpad) y escribe "controladores"

Una de las opciones que aparece es "Controladores adicionales" haz click sobre ella y dinos que pone.

En mi ordenador dice:
Controlador inalambrico Broadcom STA
This package contains Broadcom 802.11 Linux STA wireless driver for use with ... BCM4322 ....

Si te aparece instalado y no está activado actívalo.
Si no aparece instalado miramos por otro lado.

PD. comprueba que tienes activado en "Orígenes del software" el repositorio: Controladores privativos para dispositivos (restricted).

Un saludo

+1
0
-1

--
Elementary OS "Luna"
LRU #473102

:(){ :|:& };:

Imagen de pitas91
+1
0
-1

Listo centurix, hice lo que me dijiste y no me salia ningun controlador wifi, pero me salia un mensaje que necesitaba conectarse a internet, asi que me conecte por cable y descargo los controladores, ahora ya puedo conectarme por wifi, osea que ese era el problema, conectarse a internet.

Muchas gracias!!!

+1
0
-1
Imagen de ginsho
+1
0
-1

Hola!
Yo tengo el mismo problema que Pitas91. Tampoco me reconoce el wireless. En mi caso se trata de un ASUS Z9200, también con wifi interno.
Pero a mi, al abrir los "controladores adicionales", no me sale ninguna opción. Está vacío.

¿Cómo puedo seguir para habilitarlo?

He introducido el comando lspci en el terminal y esto es lo que me sale:

00:00.0 Host bridge [0600]: Silicon Integrated Systems [SiS] 760/M760 Host [1039:0760] (rev 03)
00:01.0 PCI bridge [0604]: Silicon Integrated Systems [SiS] SG86C202 [1039:0002]
00:02.0 ISA bridge [0601]: Silicon Integrated Systems [SiS] SiS964 [MuTIOL Media IO] [1039:0964] (rev 36)
00:02.5 IDE interface [0101]: Silicon Integrated Systems [SiS] 5513 [IDE] [1039:5513] (rev 01)
00:02.6 Modem [0703]: Silicon Integrated Systems [SiS] AC'97 Modem Controller [1039:7013] (rev a0)
00:02.7 Multimedia audio controller [0401]: Silicon Integrated Systems [SiS] SiS7012 AC'97 Sound Controller [1039:7012] (rev a0)
00:03.0 USB Controller [0c03]: Silicon Integrated Systems [SiS] USB 1.1 Controller [1039:7001] (rev 0f)
00:03.1 USB Controller [0c03]: Silicon Integrated Systems [SiS] USB 1.1 Controller [1039:7001] (rev 0f)
00:03.2 USB Controller [0c03]: Silicon Integrated Systems [SiS] USB 1.1 Controller [1039:7001] (rev 0f)
00:03.3 USB Controller [0c03]: Silicon Integrated Systems [SiS] USB 2.0 Controller [1039:7002]
00:09.0 Network controller [0280]: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller [14e4:4318] (rev 02)
00:0a.0 CardBus bridge [0607]: Ricoh Co Ltd RL5c476 II [1180:0476] (rev ac)
00:0a.1 CardBus bridge [0607]: Ricoh Co Ltd RL5c476 II [1180:0476] (rev ac)
00:0a.2 FireWire (IEEE 1394) [0c00]: Ricoh Co Ltd R5C552 IEEE 1394 Controller [1180:0552] (rev 04)
00:0b.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ [10ec:8139] (rev 10)
00:18.0 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration [1022:1100]
00:18.1 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map [1022:1101]
00:18.2 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller [1022:1102]
00:18.3 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control [1022:1103]
01:00.0 VGA compatible controller [0300]: Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter [1039:6330]

+1
0
-1
Imagen de ginsho
+1
0
-1

Lo apliqué como receta mágica sin saber muy bien lo que estaba haciendo.
Pero me ha funcionado.
Lo dejo ahí por si a alguien más le sirve:
http://nfolamp.wordpress.com/2011/10/15/ubuntu-11-10-getting-wireless-bcm4311-working/
Saludos!!

+1
0
-1
Imagen de juantel
+1
0
-1

Para una broadcom BCM4318 y en ubuntu 11.10, a mi me funciono lo siguiente:
En el terminal teclear el siguiente comando:
sudo apt-get install b43-fwcutter (enter)
Se instala y luego volver a teclear en el terminal lo que sigue:
sudo apt-get install firmware-b43-installer (enter)
Se instala y la tarjeta wifi comienza a funcionar de inmediato.
Saludos.

+1
0
-1
Imagen de juantel
+1
0
-1

Para una broadcom BCM4318 y en ubuntu 11.10, a mi me funciono lo siguiente:
En el terminal teclear el siguiente comando:
sudo apt-get install b43-fwcutter (enter)
Se instala y luego volver a teclear en el terminal lo que sigue:
sudo apt-get install firmware-b43-installer (enter)
Se instala y la tarjeta wifi comienza a funcionar de inmediato.
Saludos.

+1
0
-1
Imagen de juantel
+1
0
-1

Para una broadcom BCM4318 y en ubuntu 11.10, a mi me funciono lo siguiente:
En el terminal teclear el siguiente comando:
sudo apt-get install b43-fwcutter (enter)
Se instala y luego volver a teclear en el terminal lo que sigue:
sudo apt-get install firmware-b43-installer (enter)
Se instala y la tarjeta wifi comienza a funcionar de inmediato.
Saludos

+1
0
-1
Imagen de kevinlw
+1
0
-1

yo tambien tengo ubuntu 11.10 y no me va el wifi, he puesto lspci -nn y me ha salido 01:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8191SEvA Wireless LAN Controller [10ec:8171] (rev 10)
me he ido a Controladores adicionales, pero no me detecta nada, sale en blanco, asi que no se, alguien puede ayudarme...

+1
0
-1
Imagen de centurix
+1
0
-1

Deberías abrir un hilo nuevo y no secuestrar el hilo de otro usuario.

Desconozco el nivel de usuario que eres pero necesitas tirar de consola. Prueba con lo siguiente:

sudo apt-get install build-essential linux-source-2.6.31 linux-headers-generic
cd /usr/src
sudo tar -xvjf linux-source-2.6.31.tar.bz2
sudo ln -s /usr/src/linux-source-2.6.31 /usr/src/linux
cd ~
mkdir Realtek
cd Realtek
wget http://launchpadlibrarian.net/33927923/rtl8192se_linux_2.6.0010.1012.2009.tar.gz
tar -xvzf rtl8192se_linux_2.6.0010.1012.2009.tar.gz
cd rtl8192se_linux_2.6.0010.1012.2009
make
sudo su   
make install
modprobe r8192se_pci
iwconfig

linux-source-2.6.31 se refiere al kernel instalado, deberás sustituirlo por el tuyo. Para ver el kernel teclea en consola:

uname

Si buscas el driver de 64 bits:
http://launchpadlibrarian.net/34090404/rtl8192se_linux_2.6.0010.1012.200...

+1
0
-1

--
Elementary OS "Luna"
LRU #473102

:(){ :|:& };: