Alexandria y Gnome 3 (Solucionado)

Imagen de Crepuscular
0 puntos

Buenas.

Instalé Gnome 3 con Ubuntu Oneric.

El problema es que Alexandria no funciona, en la pagina del proyecto lo han indicado:
(Due to changes in the latest ruby-gnome2, packaged with Ubuntu 11.10 (oneiric), Alexandria no longer works on that platform. A new bugfix release is planned to fix this issue.
pero los gurus del foro tal vez sepan que hacer para seguir utilizandolo

Un saludo

Imagen de Jose Luis 1320
+1
0
-1

The reasons behind this are a little complex, and took me a while to work out, so I shall go through them.

In the course of developing GTK+3, the GTK+ developers decided to tidy up libraries of unrelated modules. So, for example, libgnome was refactored and classes like Gnome::Program were pulled out into Gtk::Application in the main libgtk library. Similarly, the functionality of libglade2 is now provided by Gtk::Builder. And use of libgconf2 is discouraged (without any simple drop-in replacement, as far as I can tell so far).

The Ruby/GNOME2 team, with limited resources, cannot keep supporting soon-to-be discontinued libraries. So, coming up to their recent 1.0.0 release, they marked libgnome2-ruby, libgconf2-ruby and libglade2-ruby (and many others) as deprecated. This means “considered obsolete but still available for use, though planned to be phased out”.

Debian dropped all the deprecated packages from Debian Testing in July 2011, since they are “unmaintained upstream”. This also meant that any packages which depended upon them had to be dropped, including Alexandria.

Ubuntu, which takes most of its software packages from Debian, followed suit in not including the deprecated Ruby/GNOME2 packages, and therefore also had to drop Alexandria in the 11.10 release.

por ahora Alexandría no va correr en Ubuntu 11.10 puesto que librerías dependientes de gnome 2 con las cuales funciona ya no están siendo soportadas y al final quedarán obsoletas, entonces se tiene que portar el programa a las librerías equivalentes de gnome 3.

¿Se puede hacer algo? Sí.

Usar una versión de Ubuntu antigua o usar Debian estable, que va seguir siendo estable por un buen rato todavía., mientras se arregla el soporte de gnome 3.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de Crepuscular
+1
0
-1

Hola, me respondo:

Buscando en launchpad he encontrado un PPA que lo tiene para Oneric
Instala alguna libreria de Ruby pero funciona

deb http://ppa.launchpad.net/alexandria-team/ppa/ubuntu oneiric main

PD: Gracias JoseLuis pero estoy con Gnome 3 y Alexandria funcionando sin volver atrás

Un saludo

+1
0
-1

 

 

***ese gran desconocido, el botón BUSCAR

 

Imagen de Jose Luis 1320
+1
0
-1

Que bueno que encontraste la solución, ahora agrega "solucionado" en el título del hilo. pestaña superior izquierda "Editar".

Saludos!.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro