problemas con windows 7 y ubuntu 11.10

Imagen de skullblack
0 puntos

Ante todo comentar que soy novato en el mundo linux, pero nunca me habia pasado esto que os cuento y no encuentro solución y me quiero meter de lleno en linux y asi no me es posible.
Tengo un disco duro con dos particiones en una parte tengo el windows7 y en otro es para tener documentos varios, me he descargado el linux ubuntu 11.10 para instalar y crear un dual boot, donde me de a elegir con que sistema operativo quiero iniciar la sesion, pero al instalar el ubuntu, sigo los pasos que me guia la instalación, en la cual señalo la primera opcion de instalacion que dice instalar ubuntu junto con otro sistema operativo y seguidamente me da la posibilidad de particionar la cantidad de disco que quiero para el ubuntu, en principio todo perfecto acaba la instalacion, y reinicio el ordenador no habiendo generado el dual boot y saliendo directamente el ubuntu, reinicio el ordenador metiendo el disco de windows para recuperar el mbr de windows 7 lo reparo, reinicio el ordenador y tampoco me sale el dual boot directamente se inicia el windows 7, y asi puedo estar instalando o reparando uno y otro sin poder conseguir el dual boot, necesito que alguien me oriente como puedo hacer o que es lo que estoy haciendo mal porque llevo varios dias con esto y no le encuentro solución.

Un saludo y gracias

Imagen de .doc
+1
0
-1

El MBR de Windows es excluyente (solo admite Windows), en cambio el GRUB de Linux admite el arranque dual. Por eso se recomienda instalar primero windows y después (en tu caso) el Ubuntu. Tu primer problema supongo que sería por una mala instalación del Grub, tu segundo problema fué, sencillamente, que el MBR no acepta el Ubuntu.

¿solución? hombre, volver a instalar en el orden conveniente (1º Windows, 2º Ubuntu) y elegir que el grub se te instale en la partición donde tienes el MBR (para que lo sustituya). Pero puede que haya una solución más rápida: bájate, en primer lugar, la ISO de supergrubDisk2 (lo encuentras con Google) y hazte en CD de inicio. Inicia tu PC con él y en la opción 'Detect any OS' selecciona el Ubuntu y arranca con él.

Una vez arrancado el Ubuntu, abre una consola y vete copiando esto (por hacerte el proceso completo)
sudo apt-get install os-prober
sudo os-prober
sudo update-grub
sudo grub-install /dev/sda

(se supone que tienes un solo disco duro, que Ubuntu llama /dev/sda (si no, pon el nombre que te diga Ubuntu, /dev/sdb, /dev/sdc, o lo que sea)

Y posiblemente te reconozca los dos S.O y se te restaure el grub. (Y el CD del Supergrub2 guárdalo, es una herramienta muy útil para arrancar los sistemas operativos que tengas 'BIEN' instalados en tu PC cuando surja algún problema y no los puedas iniciar 'normalmente')

+1
0
-1
Imagen de skullblack
+1
0
-1

muchas gracias agradezco tu ayuda probare todos los pasos que me has comentado y ya te dire.que tal me ha ido

+1
0
-1
Imagen de skullblack
+1
0
-1

Bueno, soy mas torpe de lo que pensaba, como te dije tenia instalados los dos sistemas operativos y me descargue el supergrubDisk2, seguidamente lo ejecuto desde un cd e inicio el ubuntu como sistema operativo siguiendo los comandos que m, e has comentado dandome en todos ellos ok luego cierro el terminal y reinicio el ordenador pero se inicia con el ubuntu sin darme la opción de elegir el sistema operativo con el que iniciar.
Viendo que esto no funcionaba, con el gparted quite la particion de linux y deje el hdd con el windows, como ya te comente tengo un disco duro con dos particiones c: y d:,entonces instalo de nuevo el windows en c: anteriormente formateada la unidad, una vez instalado instalo con el livecd el ubuntu cogiendo la primera opcion de instalar junto a otro sistema operativo, posteriormente la propia instalación me permite crear una partición para el ubuntu automaticamente todo siguiendo el asistente, seguidamente finaliza la instalación y me sigue iniciando el ubuntu, hasta que no meto el disco de instalacion de windows y reparo el mbr que entonces luego ya solo me inicia desde windows.
No se lo que hago mal, pero no entiendo nada. Te agradezco tu ayuda. No será por no intentarlo llevo todo el dia haciendo los pasos que me indicaste un montón de veces tantas que ya ni me acuerdo y nada.

+1
0
-1
Imagen de .doc
+1
0
-1

entra en ubuntu, abre una consola, escribe (o copia) esto...
sudo fdisk -l
y copia y pega el resultado aquí.

+1
0
-1
Imagen de skullblack
+1
0
-1

Aqui te dejo:

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 cabezas, 63 sectores/pista, 60801 cilindros, 976773168 sectores en total
Unidades = sectores de 1 * 512 = 512 bytes
Tamaño de sector (lógico / físico): 512 bytes / 512 bytes
Tamaño E/S (mínimo/óptimo): 512 bytes / 512 bytes
Identificador del disco: 0x000cd7c3

Dispositivo Inicio Comienzo Fin Bloques Id Sistema
/dev/sda1 * 2048 326440959 163219456 7 HPFS/NTFS/exFAT
/dev/sda2 326442960 781489842 227523441+ 7 HPFS/NTFS/exFAT
/dev/sda3 781490174 976771071 97640449 5 Extendida
/dev/sda5 781490176 968910847 93710336 83 Linux
/dev/sda6 968912896 976771071 3929088 82 Linux swap / Solaris

gracias por todo.

+1
0
-1
Imagen de .doc
+1
0
-1

no entiendo... aparentemente está perfecto (lo único que veo raro es que /dev/sda1 empiece en el sector 2048. ¿qué tienes hasta ese sector? ¿dev/sda1, que es la partición booteable, es la que contiene el sistema Windows, y la /sda2 es una partición D:\Datos?

¿seguro que con...
sudo update-grub
seguido de...
sudo grub-install /dev/sda
... no se te restaura el grub? (a recordar, el espacio hay entre install y /dev/sda... y que hay que ponerlo así: /dev/sda (o sea, hay que poner 'sda', que es el disco, y no la partición, que sería con un número)

+1
0
-1
Imagen de skullblack
+1
0
-1

si te digo la verdad desconozco porque empieza en 2048 como purdo hacer para que empiece desde 0. y el comando lo hago con el espacio porque al principio lo hacia sin espacio y me daba error y tambien pongo sda solo sin ningun numero. no entiendo nada.

+1
0
-1
Imagen de skullblack
+1
0
-1

Si lo instalaria con wubi tendría el mismo rendimiento que instalandolo como cdlive?

+1
0
-1
Imagen de skullblack
+1
0
-1

No entiendo nada, hoy he instalado el ubuntu 10.04 32 bits y todo perfecto, me ha creado el dual boot sin problemas, y no entiendo porque no funciona con el 11.10, no creo que tenga nada que ver, que esta ultima era la versión de 64 bits, ya que el windows 7 que tengo tambien es de 64 bits.

+1
0
-1
Imagen de .doc
+1
0
-1

llámalo 'fallos en el CD creado para el 11.10', o 'fallos en la versión 11.10'... o 'poltergeists'.

Hombre, la versión 10.04 es LTS, y es más 'madura' (aparte de que aún no tenía el entorno gnome3). Dejalo así hasta la 12.04, que también será LTS (o haz nuevos intentos, en realidad reinstalar varias veces es bueno para tener 'soltura' en el manejo de Ubuntu)

+1
0
-1
Imagen de skullblack
+1
0
-1

Entiendo, que si ahora actualizase a la versión 11.10, me sucederia lo mismo, que cuando instalaba la versión 11.10?

+1
0
-1
Imagen de .doc
+1
0
-1

me imagino que tendrías que actualizar 'escalonadamente' (10.10-11.04-11.10...). Yo, personalmente, no soy nada partidario de las actualizaciones (si no es una distro 'rolling release') porque se actualiza todo de golpe, y siempre (opino yo...) es un riesgo cuando hay cambios radicales y, cuando es así, prefiero reinstalar.

Pero siempre puedes probar otra vez, con otro CD de instalación, a ver qué pasa (en extremo, me imagino que si te creas, antes, una imagen de tu partición root ( / ), con Clonezilla, siempre podrás restaurarla y volver, quizás en menos de 5 minutos, a tu versión 10.04 anterior)

+1
0
-1
Imagen de rafaelmira
+1
0
-1

No se deja desinstalar ubunto muestra error

+1
0
-1
Imagen de .doc
+1
0
-1

no se a qué viene tu post, pero hay que comentar que lInux no se desinstala: se borra, y ya está.

(claro que si has instalado tu ubuntu dentro de Windows, con ese engendro llamado wubi, vete tu a saber... Pero si es así, el problema será de Windows, que es quien lo ha instalado)

+1
0
-1