Ubuntu no me reconoce Windows 7

Imagen de melfanatico
0 puntos

Hola estimados amigos linuxeros. Yo estoy dando mis primeros pasos en esto del mundo GNU, así que me voy encontrando con distintos problemas, los que paso a relatar.
En primer lugar comentar como en la historia, en mi PC tengo dos discos SATA, uno con windows 7 y otro solo con archivos varios. Mi idea es instalar en este segundo disco, con más capacidad, Ubuntu. Descargo la imagen, creo un usb para la instalación, ingreso al livecd, comienzo la instalación pero al momento de establecer las particiones donde se va a instalar el disco directamente no reconoce la existencia del disco donde tengo Windows. SI solo creo las particiones en el otro disco, no me crea el GRUB, con lo cual no puedo tener acceso a Windows y si reparo el arranque del mismo no tengo acceso a Ubuntu.
También probé instalar Wubi... y directamente me tira errores.
Uds. que opinan?
Saludos

Imagen de Gabriel_M
+1
0
-1

Desde la sesión live-cd
Abre una terminal.
Ejecuta:
sudo su
apt-get install gdisk
gdisk /dev/sda
p
q
gdisk /dev/sdb
p
q
Copia y pega las salidas en el post.

+1
0
-1
Imagen de melfanatico
+1
0
-1

Gracias Gabriel por la repuesta tan pronta.
Te comento que hice lo que me dijiste y me pasa lo siguiente

ubuntu@ubuntu:~$ sudo su
root@ubuntu:/home/ubuntu# apt-get install gdisk
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package gdisk
root@ubuntu:/home/ubuntu# gdisk /dev/sda
The program 'gdisk' is currently not installed. You can install it by typing:
apt-get install gdisk
You will have to enable the component called 'universe'
root@ubuntu:/home/ubuntu#

Capaz es una pavada pero no se como seguir, como dije mas arriba soy novato y linux es un mundo nuevo para mi.
Saludos

+1
0
-1

Probando, probando

Imagen de xpt
+1
0
-1

habilita los repositorios de Universe (en synaptic los puedes habilitar, sino sabes busca segun tu versión de ubuntu) y haz lo que te dijo Gabriel_M

+1
0
-1
Imagen de melfanatico
+1
0
-1

Gracias xpt. Active los repositores como me indicaste, pero ahora me tira otro error.

E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

No se como seguir.

Perdon por la ignorancia.
Saludos

+1
0
-1

Probando, probando

Imagen de melfanatico
+1
0
-1

Estimados Gabriel_m y xpt, ahora si pude ejecutar el gdisk, en realidad no se en que le erré ayer, porque hoy hice lo mismo, en fin. Estos son los resultados del gdisk.

ubuntu@ubuntu:~$ sudo su

root@ubuntu:/home/ubuntu# apt-get install gdisk
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
gdisk
0 upgraded, 1 newly installed, 0 to remove and 315 not upgraded.
Need to get 170 kB of archives.
After this operation, 397 kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu/ oneiric/universe gdisk i386 0.6.14-1 [170 kB]
Fetched 170 kB in 1s (89.6 kB/s)
Selecting previously deselected package gdisk.
(Reading database ... 132576 files and directories currently installed.)
Unpacking gdisk (from .../gdisk_0.6.14-1_i386.deb) ...
Processing triggers for man-db ...
Setting up gdisk (0.6.14-1) ...

root@ubuntu:/home/ubuntu# gdisk /dev/sda
GPT fdisk (gdisk) version 0.6.14

Partition table scan:
MBR: MBR only
BSD: not present
APM: not present
GPT: not present

***************************************************************
Found invalid GPT and valid MBR; converting MBR to GPT format.
THIS OPERATION IS POTENTIALLY DESTRUCTIVE! Exit by typing 'q' if
you don't want to convert your MBR partitions to GPT format!
***************************************************************

Command (? for help): p
Disk /dev/sda: 312581808 sectors, 149.1 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): 56B2BAA4-63DC-4028-9426-B7F9D5FCA9E3
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 312581774
Partitions will be aligned on 1-sector boundaries
Total free space is 5741 sectors (2.8 MiB)

Number Start (sector) End (sector) Size Code Name
1 63 312576062 149.0 GiB 0700 Linux/Windows data

Command (? for help): q

root@ubuntu:/home/ubuntu# gdisk /dev/sdb
GPT fdisk (gdisk) version 0.6.14

Partition table scan:
MBR: MBR only
BSD: not present
APM: not present
GPT: not present

***************************************************************
Found invalid GPT and valid MBR; converting MBR to GPT format.
THIS OPERATION IS POTENTIALLY DESTRUCTIVE! Exit by typing 'q' if
you don't want to convert your MBR partitions to GPT format!
***************************************************************

Warning! Main partition table overlaps the first partition by 15 blocks!
Try reducing the partition table size by 60 entries.
(Use the 's' item on the experts' menu.)

Command (? for help): p
Disk /dev/sdb: 976773168 sectors, 465.8 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): D20FA590-1FEA-439F-82A1-ECCD94A14E63
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 976773134
Partitions will be aligned on 1-sector boundaries
Total free space is 2015 sectors (1007.5 KiB)

Number Start (sector) End (sector) Size Code Name
1 19 976771119 465.8 GiB 4200 Windows LDM data

Command (? for help): q

Espero su respuesta.
Muchas gracias y saludos

+1
0
-1

Probando, probando

Imagen de Gabriel_M
+1
0
-1

.... principio, tus discos estan particionados con sistema mbr, y gdisk los reconoce.
Ahora habría que ver por qué no lo hace Ubuntu al instalar.
En una sesión live, ejecuta:
sudo su
fdisk -l (ele minúscula)
Copia y pega las salidas en el post.

+1
0
-1
Imagen de melfanatico
+1
0
-1

Estimado Gabriel_M
Los resultados del fdisk -l son:

ubuntu@ubuntu:~$ sudo su
root@ubuntu:/home/ubuntu# fdisk -l

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders, total 312581808 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xb7e61057

Device Boot Start End Blocks Id System
/dev/sda1 * 63 312576062 156288000 7 HPFS/NTFS/exFAT

Disk /dev/sdb: 500.1 GB, 500107862016 bytes
224 heads, 19 sectors/track, 229504 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x34825544

Device Boot Start End Blocks Id System
/dev/sdb1 19 976771119 488385550+ 42 SFS

Disk /dev/sdd: 8010 MB, 8010194944 bytes
32 heads, 63 sectors/track, 7760 cylinders, total 15644912 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x4d202e03

Device Boot Start End Blocks Id System
/dev/sdd1 * 63 15644159 7822048+ c W95 FAT32 (LBA)
///////////

Me sigue mostrando los dos discos y el pendrive desde donde arranca el live
Saludos

+1
0
-1

Probando, probando

Imagen de Gabriel_M
+1
0
-1

1- Desde windows, corre su scandisk y defrag, como se llamen, (no uso windows desde el primer xp) sobre ambos discos el de 160 gigas y el de 500 gigas.
2- Reinicia y desde windows reduce la partición del disco de 500 gigas, en al menos 40 gigas. Reinicia nuevamente y si todo esta correcto, reinicia con una sesión live con Ubuntu
3. Desde Ubuntu, inicia la instlación y al llegar a particionamiento elige manual, selecciona /dev/sdb y en el espacio libre instala en:
Una partición primaria, activa, sistema de archivos ext4, de unos 30 gigas, punto de montaje /
Una partición lógica, sistema de archivos intercambio, de 1 giga, montaje por defecto
Una partición lógica, sistema de archivos ext4, de los gigas restantes, punto de montaje
/home/tuusuario/datos
El grub en el mbr del disco /dev/sda
al iniciar del disco ejecuta en una terminal
sudo su
chmod -Rf 777 /home/tuusario/datos
en esta partición aloja tus archivos personales, para tenerlos a salvo en futuras instalaciones.

+1
0
-1
Imagen de melfanatico
+1
0
-1

Estimado Gabriel_M muchas gracias por tus respuestas, esta misma tarde voy a ver que es lo que pasa, si hago ese procedimiento.

Muchas gracias.

+1
0
-1

Probando, probando

Imagen de melfanatico
+1
0
-1

Gabriel_M, despues de realizar los pasos que me dijiste, cuando llego al momento de seleccionar las particiones me encuentro con el problema de que el disco donde esta windows no lo reconoce, tampoco la particion que se creo en el de 500 gb...
En la sesion live, use gparted y ahi pude redimensional el disco de 500, pero el de 160 (windows) me indica que tiene un error, dejo el link a la imagen. http://imageshack.us/photo/my-images/560/pantalla1v.png/
No se, vos que decis.

+1
0
-1

Probando, probando

Imagen de melfanatico
+1
0
-1

Como comentaba antes, hice la particion de 40 gb en windows, pero al momento de realizar la instalacion solo aparece como si fuera un disco entero, de 500 gb y el de 160 gb (sda, supongo) no figura...
http://imageshack.us/photo/my-images/39/pantalla2.png/

Saludos

+1
0
-1

Probando, probando

Imagen de Gabriel_M
+1
0
-1

1- El disco /dev/sda tiene errores, sin embargo, si lo reconoce, te lo pone abajo para instalar el grub.
2- Te escribí claramente:
1- Desde windows, corre su scandisk y defrag, como se llamen, (no uso windows desde el primer xp) sobre ambos discos el de 160 gigas y el de 500 gigas.
2- Reinicia y desde windows reduce la partición del disco de 500 gigas, en al menos 40 gigas.
Reinicia nuevamente y si todo esta correcto, reinicia con una sesión live con Ubuntu

Debes correr las aplicaciones Windows.
Debes reducir, sin crear nuevas particiones desde Windows
Debes reiniciar Windows y controlar nuevamente los discos.
Recien entonces iniciar Ubuntu.

+1
0
-1
Imagen de melfanatico
+1
0
-1

Estimado gabriel. Yo le hice el scandisk desde windows y no me tiro errores. Igual ahora voy a probar de nuevo.
Gracias

+1
0
-1

Probando, probando

Imagen de melfanatico
+1
0
-1

Estimado Gabriel_M.
Despues de pasar dos veces el scandisk en el disco de 160 Gb, y que no vea ningun error en windows, sigue mostrandome lo mismo el gparted me sigue mostrando un error en el mismo y la instalacion no lo reconoce...
Saludos

+1
0
-1

Probando, probando